Carbon Interface

From Lazarus wiki
Jump to: navigation, search
Logo OSX.png

This article applies to macOS only.

See also: Multiplatform Programming Guide

Deutsch (de) | English (en) | 日本語 (ja) |

Introduction

Carbon is a Mac OSX native API which descends from the old Mac OS APIs and is available since Mac OS X 10.0. One thing to note, however, is that Apple has restricted Carbon to 32 bit applications only. To write 64 bit applications one should use the Lazarus Cocoa Interface

Other Interfaces

Platform specific Tips

Interfaces Development Articles

See also

What you need

The Carbon widgetset is now the default widgetset under Mac OS X. For installation instructions see Installing Lazarus on Mac OS X.

Getting a "carbonproof" Lazarus

Carbon IDE version 0.9.25 running on Mac OS X 10.4
Note-icon.png

Note: If you installed even a vaguely recent Lazarus version, you can skip this and the next section since Lazarus installers since 0.9.25 include both the Carbon widgetset source and compiled units for the Carbon widgetset.

  • Start Lazarus. The IDE will start with a new project and an empty form. Save this project under a name of your choice. In the following examples we assume this to be /Users/<yourUsername>/pascal/test/project1.lpi

Compiling Carbon interface via Makefile

Since 0.9.25 carbon is the default widgetset for Mac OS X, so the below is not needed anymore.

If your are still using a Lazarus below 0.9.25, you have to type this in Terminal.app:

make lcl LCL_PLATFORM=carbon

Compiling the Lazarus IDE with the Carbon interface via Makefile

This requires Lazarus 0.9.25 or later.

Type in Terminal.app:

make all LCL_PLATFORM=carbon OPT="-k-framework -kCarbon -k-framework -kOpenGL"


On Leopard (OS X 10.5.x) you should type:

make all LCL_PLATFORM=carbon OPT="-k-framework -kCarbon -k-framework -kOpenGL -k'-dylib_file' \
    -k'/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib:/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib'"

As stated on Apple's developer pages: http://developer.apple.com/qa/qa2007/qa1567.html

Important notes about the Carbon IDE

  • You must run Lazarus via lazarus.app.
  • Make sure your editor is using a mono-font. You can check that on the Editor Options dialog. The "Monaco" font is a good suggestion.

Compiling the Carbon interface via Lazarus

We now assume your Lazarus directory is located at /Users/<yourUsername>/pascal/lazarus/

  • Start Lazarus.
  • Set Tools -> Options -> Environment -> Files -> Lazarus Directory to /Users/<yourUsername>/pascal/lazarus/
  • Set Tools -> Configure "Build Lazarus"> to

BuildLazarusOptionsCarbonIntf.png

For 0.9.24 add this to your 'Options':

-k-framework -kCarbon -k-framework -kOpenGL

This will prevent unresolved symbols (Carbon-symbols like _ActivateWindow) while linking lazarus.

  • Tools>Build Lazarus -- This will compile the Carbon Interface and put the .ppu files into /Users/<yourUsername>/pascal/lazarus/lcl/units/powerpc-darwin and /Users/<yourUsername>/pascal/lazarus/lcl/units/powerpc-darwin/carbon

Your first native Carbon app

Compiler Options

Set Project > Compiler Options > Paths > LCL Widget Type to carbon

You should now be able to compile the project without errors. It will create an executable project1, but you cannot focus it. The reason is that Mac OS X expects some hidden resource files.

Note for OS X 10.5: As discussed in this forum topic, on Leopard you have to add the following linker parameters to your project:

-dylib_file '/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib:/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib'

(This parameter is located at Project > Compiler Options > Linker > Pass additional options to the linker)


Creating the Apple resource files

Note-icon.png

Note: Since 0.9.25 Lazarus can create application bundles without compiling this tool on your own. The corresponding button is at Project > Project Options... > Create Application Bundle

The command line tool:

Open /Users/<yourUserName>/pascal/lazarus/components/macfiles/examples/createmacapplication.lpi in the IDE. Compile.

Open a Terminal of your choice. Type:

cd /Users/<yourUserName>/pascal/project1/
/Users/<yourUserName>/pascal/lazarus/components/macfiles/examples/createmacapplication project1
ln -s ../../../project1 project1.app/Contents/MacOS/project1

Now you can start the program from IDE (checked option Use Application Bundle for running and debugging (darwin only)) or via its Finder icon or in the native Mac OS X Terminal via "open project1.app"

Tip: There is also a script that creates an app bundle for a GTK executable at OS X Programming Tips. You can modify it to use with a Carbon executable (take out the 4 instructions that start the executable with X11). A slightly improved version of this script for Carbon apps is also available for downloading from here.

Application Bundle

See Application Bundle.


Hiding application from the Dock

There is no way to hide an application from the Dock at run-time, but the application can declare itself to be an agent. OSX doesn't show agents in the Dock or in the Force Quit Applications window. Agents are visible for utilities like Activity Monitor, unix command-line tools (i.e. top), as well as OSX API functions.


Warning-icon.png

Warning: Agents are never shown in application's menu. So the agent application should provide StatusBar (TTrayIcon) user interface, hotkeys so they can be switched off, or should be launched/terminated by other GUI application.

For example, startlazarus is an agent, launched by the Lazarus IDE when rebuilt.


To declare an application to be an agent, open the application's bundle Info.plist file:

  • add a property LSUIElement (or "Application is agent")
  • set LSUIElement property's value to True (or check with the checkbox)
  • save the Info.plist file.

infoplistinside.png

Cross-compiling Intel to PowerPC

With 0.9.26 Lazarus comes with precompiled units for both architectures Intel and PowerPC. Since there are still a lot of Mac PowerPC users, you might want to build an application for both archs, or even create a universal binary.

IDE Environment configuration

Before you're able to cross-compile, you must make sure, that the IDE Environment compiler settings are correct. Open Environment->Files, check out "Complier path" setting.

If you need to cross-compile an application or LCL (using Lazarus), you should define "fpc" binary as a compiler. fpc binary will select the proper compiler (ppc386 or ppcppc), depending on your current target selected.

crossppcidesettings.png

Of course, you specify the necessary compiler manually (ppc386 - for Intel, ppcppc - for PowerPC), but using "fpc" is more correct and easier

Project configuration

If you are using an Intel Mac and want to compile an application for PowerPC, you need to do the following

  • Go to projects Compiler options->Code
  • Select powerpc for Target CPU family.

Rebuild the application (if you have compiled an intel application it will be overwritten with powerpc app).

Define binary architecture

If you are not sure about the target CPU of the binary, you can use the command-line tool "lipo" to check it. Example:

$ lipo -info project1. 
Non-fat file: project1 is architecture: ppc

Getting PowerPC units

If you have Lazarus and FPC installed from .dmg file provided at Lazarus sourceforge, then you already should have all necessary units for PowerPC compilation.

If you don't use the provided .dmg files (i.e. using svn version), you might need to rebuild LCL units for powerpc target as well.

Open Tools -> Configure "Build Lazarus" -> Advanced Build Options.

  • Type powerpc into Target CPU field.
  • Select all components, except for IDE and Samples (since there's no need to rebuild them) for building.
  • It's recommended that you check 'Clean all' as well.

powerpcbuild.png

Press Build and wait for building process to complete. After that you need to recompile your project, making sure that the project's compiler project is configured for powerpc.

LCL building might fail if you don't have RTL/FCL units compiled for the powerpc arch. You'll need RTL/FCL sources to compile them.

  • Go to the rtl/fcl sources directory (the one where 'rtl' and 'packages' directories are contained')
  • Run the following line from the terminal

(making and installing rtl/fcl files tries to write into /usr/local dir, that might need root access. using sudo might be required)

make clean all install CPU_TARGET=powerpc   
  • Wait for the make process to complete, then rebuild the LCL and your project again.

Creating Universal binaries

Lazarus will create an application tuned for a single CPU, for OS X this is either a PowerPC or Intel CPU. You may want to distribute your application as a 'Universal Binary', allowing users that may have either a PowerPC or Intel computer to use the program. To do this, you need to compile two versions of your application: one with PowerPC as the target CPU and one as Intel. Next, you need to stitch these two executables together using the OS X program "lipo" (installed with the other OS X developer tools required by Lazarus). For example, consider two versions of the application 'myprogram'. One in the 'ppc' folder compiled for PowerPC and one in the 'intel' folder compiled for Intel CPUs. You can then combine these two to a univeral application by running this command:

 lipo -create ./ppc/myproj ./intel/myproj -output ./myproj

Now, copy the newly created application myproj inside your .app folder.

Cocoa controls in Carbon applications

Carbon is considered a legacy API by Apple. This means that newer features and controls in Mac OS X might not be available using Carbon API. Though it doesn't mean, that they cannot be used in Carbon application. It just requires additional work to access them. In C it means using Obj-C, but since Obj-C is not available in Pascal. In Lazarus you have to use the PasCocoa library.

The following capabilities require Cocoa:

  • TTrayIcon

To configure Cocoa support in Lazarus, complete the following steps depending on your Lazarus version:

Lazarus 0.9.29 or later

In these versions PasCocoa is already installed and configured and LCL-Carbon is compiled with Cocoa support by default, you just need to complete this steps:

1) If you have previously configured PasCocoa in your /etc/fpc.cfg file, remove this configuration now

2) Build LCL-Carbon if not already built

Lazarus 0.9.28 or earlier

1) Download and configure FPC for the PasCocoa library.

You'll find the instruction here. You only have to to download PasCocoa and configure your fpc.cfg file, as described. (You don't need to compile the PasCocoa samples or the Cocoa widgetset).

2) Now you need to recompile Carbon LCL with Cocoa support enabled.

Open Tools -> Configure "Build Lazarus"...->Advanced Build Options

Select LCL for Build+Clean Add "-dCarbonUseCocoa" to Options.

CarbonUseCocoa.png

After that click build

This should rebuild the LCL only. If you finished step 1 (downloading PasCocoa) successfully, then the LCL should compile with no problems.

After the LCL is rebuilt, you need to rebuild your project.

Don't forget, if you need Cocoa controls for CPU other than your Mac, you'll need to rebuild the LCL, specifying the proper CPU target.