Lazarus Faq

From Lazarus wiki
Jump to: navigation, search

العربية (ar) | Deutsch (de) | English (en) | Español (es) | Français (fr) | Magyar (hu) | Italiano (it) | 日本語 (ja) | 한국어 (ko) | Português (pt) | Русский (ru) | Slovenčina (sk) | ‪中文(中国大陆)‬ (zh_CN) | ‪中文(台灣)‬ (zh-TW)

Contents

General

What is Lazarus?

Lazarus is a cross-platform integrated development environment (IDE) that lets you create visual (GUI) and non-visual Object Pascal programs, and uses the Free Pascal compiler to generate your executable. Its aim is write once, compile anywhere: you should be able to just recompile your program source code with Lazarus running on another operating system (or a cross compiler) and get a program that runs on that operating system.

For more details see Overview of Free Pascal and Lazarus

Why are the generated binaries so big?

The binaries are big because they include a lot of debug information necessary for using gdb (GNU Debugger). A debugger is a program that is used to test your code. It uses the extra-information stored in your binary to test it. But once your program is working well, you may delete those infos and reduce the size of the binary.

Quick guide to Lazarus/FPC application size reduction

  • 1. Project|Compiler Options|Code|Smart Linkable (-CX) -> Checked
  • 2. Project|Compiler Options|Linking|Debugging| Uncheck all except Strip Symbols From Executable (-Xs)
  • 3. Project|Compiler Options|Linking|Link Style|Link Smart (-XX) -> Checked

Note: only do this if you don't need to run the debugger. For more details, see Size Matters

Alternative solution: Project|Compiler Options|Linking|Debugging| Leave generating debugging info enabled and enable use External gdb debug symbols. See the screenshot below:

BigExe.PNG

Lazarus executable size starts big, but grows very slowly, because of the way the LCL is designed, and its use of certain Free Pascal features (RTTI). Projects that don't use the LCL are much smaller (this is similar to some non-GUI C++ frameworks). This typically requires more manual coding though.

Do I need ppc386.cfg or fpc.cfg?

You only need fpc.cfg. This way the compiler knows where to find the libraries.

How do I compile Lazarus?

Do something like this:

$ cd lazarus
$ make clean all

How do I build other projects based upon the LCL without the IDE

If you want to compile projects automatically or from the command line, use lazbuild. This is a command line version of the IDE to build Lazarus projects and packages.

If you want to build LCL applications without the IDE and without lazbuild, add the following lines to the end of your fpc.cfg

# searchpath for other toolkits (Linux)
-Fu/usr/lib/fpc/$fpcversion/units/$fpctarget/{YourToolKit}

 # searchpath for other toolkits (Windows)
-Fu/{YourLazarusDirectory}/components/lazutils/lib/{platform}
-Fu/{YourLazarusDirectory}/lcl/units/{platform}
-Fu/{YourLazarusDirectory}/lcl/units/{platform}/{YourToolKit}
Where {YourToolKit} may be gtk2, gnome, qt or win32 and {platform} may be x86_64-linux and run:
ppc386 your.project.pp

Hint: Don't forget to install the development packages for your toolkit otherwise you might receive something like: Linker message: cannot find -l.

What version of FPC is required?

  • Lazarus 1.0.8 requires at least FPC 2.6.2.
  • Lazarus 1.0 requires at least FPC 2.6.0.

I can't compile Lazarus

  1. Check if the compiler is the correct version
  2. Check if the (fpc) libraries are from the same version
  3. Check if the compiler installation path has spaces in it. Make sure it doesn't!
  4. Check if you have a fpc.cfg and no old ppc386.cfg
  5. Check also the OS-dependent FAQs
  6. If you're still stuck, ask on the forum or Lazarus mailing list

How to embed a small file in the executable, without the need of a separate file? How to embed a resource?

Both Lazarus resource and Windows-type/FPC resources are supported. See Lazarus_Resources.

What is the meaning of the various file extensions used by Lazarus?

The Lazarus Tutorial#The Lazarus files explains some extensions by an example. Here is a brief list:

extension filetype description
.lpi Lazarus Project Information contains project-specific settings like compiler settings and needed packages. stored in XML
.lps Lazarus Program Session Personal data like cursor positions, source editor files, personal build modes. stored in XML
.lpr Lazarus Program Pascal source of main program.
.lfm Lazarus Form Form configuration information for all objects on a form (stored in a Lazarus-specific textual format, similar to Delphi fdm; the actions are described by Pascal source code in a corresponding *.pas file)
.pas
.pp
.p
Pascal code Pascal code typically for a form stored in a corresponding *.lfm file
.lrs Lazarus Resource Generated Lazarus Resource file; not to be confused with a Windows resource file.

This file can be created with lazres tool (in directory Lazarus/Tools) using commandline: lazres myfile.lrs myfile.lfm

.ppu Compiled unit Compiled source code created by the Free Pascal compiler for each unit and program.
.o Object file created by the compiler, every ppu file has a corresponding o file, needed by the linker.
.lpk Lazarus package information package-specific settings, like compiler settings and needed packages; stored in XML
.lrt Lazarus Resourcestring table Lazarus Resourcestring table created when saving a lfm file and i18n is enabled. It contains the TTranslateString properties of the lfm. Do not edit them, they are overwritten.
.rst Resourcestring table Resourcestring table created by the compiler for every unit with a resourcestring section. Do not edit them, they are overwritten.
.po gnu gettext messages When i18n is enabled the IDE creates/updated the .po files with the resourcestrings from the rst and lrt files.

Why are TForm.ClientWidth/ClientHeight the same as TForm.Width/Height

The TForm.Width/Height do no include the frame, because there was no way to retrieve the frame size on all platforms. Without a reliable way, the LCL would move the forms around on the screen or resize them endlessly.

Eventually it will be changed when there is a reliable way to get the size and position of a window with its frame on all platforms. To keep compatibility with older LCL forms, a version number and some extra methods will be added.

Errors

Platform specific errors/problems are also covered in sections below.

'Fatal: Circular unit reference between a and b'

A common thing happened to a new user when one wants to create two forms referencing each other's properties. The error above only happens to uses clause of interface section, thus it's OK to put it in implementation section. Example:

This one causes error:

unit a;
 
interface
 
uses b;
 
implementation
 
end.
unit b;
 
interface
 
uses a;
 
implementation
 
end.

But this one doesn't:

unit a;
 
interface
 
implementation
 
uses b;
 
end.
unit b;
 
interface
 
implementation
 
uses a;
 
end.

When I do var mytext: text; to declare a text file, I get "Unit1.pas(32,15) Error: Error in type definition". How can I fix this?

The TControl class has a Text property. In a method of a form, that has higher visibility, the Text type from the system unit. You can use the TextFile type, which is just an alias for the Text type or you can add the unit to the type definition.

var
  MyTextFile: TextFile;
  MyText: System.Text;

A similar name clash exists with assigning and closing a text file. TForm has a assign and a Close method. You can use AssignFile and CloseFile or add the unit name System.

I get an error when using Printer.BeginDoc

The unit Printers must be added to the uses section.

The Printer4Lazarus package must be added to your project requirement in the IDE under: Project|Project Inspector|Add|New Requirement|Package Name:

If the package Printer4Lazarus package is not in the list when opening the dropdown box it must be installed. The package is part of the Lazarus installation and can be found in: [lazarus installed directory]\components\printers

If you used the default installation directories [lazarus installed directory] is:

  • Windows: c:\lazarus
  • Linux: /usr/lib/lazarus

The same solution also applies to the exception you can get when referencing Printer.Printers

When I try to compile a project, I get an error message "Cannot find Unit ..."

Please see Unit_not_found_-_How_to_find_units

For information on the error "Cannot find unit interfaces", see the next section.

When I try to compile a project, I get an error message "Cannot find Unit interfaces"

When I try to compile a project, I get an error message "Cannot find Unit interfaces". How can I solve this?

It means the compiler can not find the file 'interfaces.ppu' or the file was found, but it is wrong or outdated (the .ppu file date code is older than the date code of the compiler itself). Testing the compiler option settings can help debug these issues, via Project: Compiler Options... (use the Test button at the bottom of the dialog). This test will also verify that the {TargetCPU} and {TargetOS} variables are set properly.

This unit can be found in {LazarusDir}\lcl\units\{TargetCPU}-{TargetOS}\{LCLWidgetSet}\interfaces.ppu. For example: /home/username/lazarus/lcl/units/i386-linux/gtk/interfaces.ppu.

It is normal to have multiple versions of interfaces.ppu (in the proper directories) to allow compiling with different widgets.

If you selected a different widgetset for your project than was used to build Lazarus, you may need to build the LCL for the selected widgetset.

If the interface.ppu file is in the folder matching the OS and CPU you selected in the project preferences, and you get this error, you are using a different compiler / rtl for compiling your project than you used for compiling your Lazarus IDE, or if the libraries need to be recompiled to give the .ppu files newer compilation dates. You can do one of the following

  • Rebuild the LCL (or Lazarus completely) with the compiler selected in the Environmnent Options. You can do this with Tools -> Build Lazarus. Before doing this, check the current settings in Tools -> Configure Build Lazarus.
  • Change the compiler in the Environment Options to the one you used to compile Lazarus. Look carefully also in the Environment Options to see if you are using the correct paths for the Lazarus Directory and the FPC sources directory. Check that there is only one version of the compiler configuration file fpc.cfg - it should reside in /etc/ for Linux/Unix systems or in the same directory as the fpc compiler for Windows systems. Try to run "fpc -vt bogus" to check which fpc.cfg is being used in your system. Rogue copies often creep in if you have updated your compiler to a new version; they may be found in your home directory or in the same directory as the one in which you built your new compiler. DELETE THESE!
  • You may also try to change the widgetset currently selected for the project. For example, the sample project "objectinspector" that comes with Lazarus is set to gtk by default. Compiling this project will surely give you "Can't find unit interfaces" in Windows platform. Changing widgetset to default(Win32) in Project | Compiler Options... | LCL Widget Type (various) should fix this issue.

When I compile a project, that uses a LCL unit, I get a linker error

Here is an example for such a linker error:

/path/to/lazarus/lcl/units/x86_64-linux/wsimglist.o: In function `REGISTERCUSTOMIMAGELIST':
/path/to/lazarus/lcl//widgetset/wsimglist.pp:266: undefined reference to `WSRegisterCustomImageList'
  • Make sure yor project uses the package LCL. You can check this in the project inspector.
  • Make sure unit "interfaces" is used as one of the first units of your program.

Note: These functions are implemented by the LCL backends. By adding the unit interfaces, you link a LCL backend into your program.

When I try to compile delphi projects under Lazarus, I get an error message

At the line :{$R *.DFM} How can I solve this problem?

Lazarus (or better Linux) doesn't know about resources, so you can't use them in the way Delphi/Win32 does. However Lazarus uses a method pretty compatible with this. You can still use your Delphi layouts (.dfm files) if you use the following steps:

  • You need a textual version of the .dfm files. D5 and higher are doing this by default. If you have older files: Alt+F12 to see the layout as text and paste/copy. When you have a text .dfm file, just copy it to a .lfm file.
  • Create a file with lazres (in lazarus/tools) lazres yourform.lrs yourform.lfm
  • Add the following initialization section to
initialization
{$I yourform.lrs}

Please keep in mind that not all properties in the dfm are supported yet by Lazarus, so you might get a crash.

Edit: Since FPC 2.4.0, Delphi style resources are supported, so you don't need to change anything. Even Lazarus SVN already uses it as default projects. Note: it's still advised that you use Lazarus' Delphi project converter as there might still be unsupported properties.

'Identifier not found LazarusResources'

When creating a form Lazarus automaticaly add some extra units to the uses section of your form unit. During the conversion of a delphi unit to a Lazarus unit this does not happen. So you need to add LResources to the Uses section of your form unit.

When accessing events of objects, e.g., the onclick event of a button, I get the following error. ERROR unit not found: stdCtrls

Make sure, in the Project -> Project Inspector, that your project depends on the package "LCL" and that you have installed the FPC sources.

Lazarus is the IDE and the visual components library LCL. All other stuff, like IO, Database, FCL and RTL are provided by FPC. The IDE needs the paths to all sources.

The FPC source path can be set via: Environment -> Environment Options -> Files -> FPC source directory

'Fatal: Internal error XXXXYYZZW'

An internal error is a compiler error that is not expected to happen (but is prepared to easily track down the problem if happens by giving code XXXXYYZZW). Every internal error is a bug, thus it's advised to report to the bugtracker (with small example that can demonstrate the internal error) when one gets it.

Debugger

See also GDB Debugger Tips.

How do I set up/configure for debugging

Setup the debugger

How can I inspect properties?

You have to use FPC 2.4 or newer.

If you compile your application using -gw (dwarf debug info), you should be able to inspect properties.

Note this is only true for properties that map directly to a variable (the "read" declaration points to a member, not a function).

If your property returns the value of a function it is very dangerous to evaluate/inspect it. It would require this function to be called, and very often it would change the values of some of your variables. This would mean it would alter the state of your application in the debugger, and any further code-execution, debugging or inspections would return incorrect results.

The optional ability to explicitly inspect the results of functions (with the risks described), and therefore calling code from the debugger is not yet implemented

Why does the debugger not show some Variables/Structures ("no such symbol"/"incomplete type")

For problems debugging:

  • properties
  • Array of ... (Dynamic Array)
  • Variables in Nested Procedures
  • "no such symbol in context"
  • "incomplete type"

Please see GDB Debugger Tips

How can I debug FCL components from packages with Lazarus

FCL components and classes are built without debug information by default and as a result, gdb cannot access component methods or properties. To build package components they must be rebuilt with a debug-line information "-gl" switch.

This example assumes you have a Linux distribution with /usr/local/ installation prefix and that the Database package fcl-db is what is needed to contain debug-line information. While the fcl-db is used in this example, you may issue this make command from ANY of the included packages.

Before you begin, you need to locate your FPC path by examining your FPC configuration file. The file (fpc.cfg) is located at /etc/fpc.cfg. Display the contents of fpc.cfg and find your fpc installation path. Look for a line starting with -Fu in the fpc.cfg:

-Fu/usr/local/lib/fpc/$fpcversion/units/$fpctarget/*

Make scripts are installing units into INSTALL_PATH/lib/fpc/$fpcversion/units/$fpctarget/, so you must be sure that /usr/local is the installation path, and should be assigned to INSTALL_PREFIX, otherwise the Make scripts will place units where they don't belong or the Make script will fail.

Step 1: Open a shell terminal
Step 2: cd /user/local/share/src/fpc-2.3.1/fpc/fcl-db/
Step 3: sudo make clean all install INSTALL_PREFIX=/usr/local OPT=-gl

Note: INSTALL_PREFIX parameter should be properly configured for units to be installed. In the sample below /usr/local is a default fpc path for Linux, but may vary on other OSes.

make clean all install INSTALL_PREFIX=/usr/local OPT=-gl

Finally, after rebuilding any FCL units you may want to rebuild LCL as well.

Problems with GDB on Mac OSX

Please see here for debugger issues under Mac

How can I use a log file for debugging?

Lazarus provides a basic log framework in the unit LazLogger. (For historical reasons some parts are also accessible through LclProc; this access might be removed in future)

By just including the unit you can use the following:

  • DebugLn: which works about the same as WriteLn, but accepts only strings.
  • DebugLnEnter/DebugLnExit: same as debugln, but increase/decrease indent.
  • DbgOut: which works about the same as Write, but accepts only strings.

All of them can be called with either:

  • A single string, or list of (up to 15) strings: DebugLn('Foo'); DbgOut('a','b');
  • An array of const: DebugLn(['Foo=', 1]);
  • Same arguments as Format(). String + array of const: DbgOut('a %d',[1]);

In normal circumstances, the output is written to stdout. No output is written if stdout is closed (for example when the application is {$AppType Gui}, or compiled with -WG on Windows (see Compiler options / Linking / Target OS specific options).

Debug output can also be written to file. The initialization code of the LCLProc unit checks Lazarus.exe's command line parameters for '--debug-log=<file>'. On finding this parameter any subsequent debug output is sent to <file>.

If no '--debug-log' command line parameter has been given, it next checks if an operating system environment variable xxx_debuglog exists, where xxx is the program file name without extension. For Lazarus this would be lazarus_debuglog. If such an environment variable exists, it uses the file specified in that environment variable as file to receive debug output. Example: if you do:

set lazarus_debuglog=c:\lazarus\debug.txt

debug output will be written to c:\lazarus\debug.txt.

For more features, see the unit.

How can I use a Log-file for debugging the IDE itself?

Lazarus itself uses this framework.

This means that you can run Lazarus with
--debug-log=lazarusdebuglog.txt

If this is not sufficient: in the IDE the extent of the information that is logged can be controlled with --debug-enable. See --help for a list of keywords, or install the package IdeLazLogger.

If you want output on a console (most useful for Windows), add {$APPTYPE console} to lazarus.pp ; Then rebuild Lazarus.

See also Console Mode Pascal#Run in IDE with redirected output

Contributing / Making Changes to Lazarus

I created a Patch to dock the IDE Messages form on the "Source Code Editor" form (at bottom)

Such patches will not be applied, because they only implement a small part of the needed docking. The goal is to create a complete dock manager and use that. A complete dock manager can dock all IDE windows and it allows to let the user define how to dock. For example dock the messages window above or below the source editor — or not at all. For instance,

+-------------------++--+
|menu               ||  |
+-------------------+|  |
+--++---------------+|  |
|PI|| Source Editor ||CE|
+--+|               ||  |
+--+|               ||  |
|  |+---------------++--+
|OI|+-------------------+
|  ||messages           |
+--++-------------------+

The dock manager can store the layout and restore it on next load. Preferably the dock manager can dock in pages too. The dock manager does not need to use drag and drop. All patches implementing docking without a dock manager makes it harder to implement a real dock manager and will be rejected.

An example for such a dock manager is the package anchordockdsgn,

I have fixed/improved Lazarus. How can I add my changes to the official Lazarus source?

Create a patch and send it to the developers. For details, see Creating A Patch.

How can I install more than one copy of Lazarus?

Please see Multiple_Lazarus

How can I become a Lazarus developer and access management in the SVN and bug-tracker?

First of all, you must learn about Lazarus, to prove your knowledge and skill. Start by reading the wiki articles, read the Lazarus source code, giving a look at the Lazarus Bug-Tracker, fix some bugs, and if you think you are ready, contact the developers on the mailing list.

Where is ... defined

Virtual key constants

Virtual key constants are defined in LCLType. Add LCLtype to your uses.

Using the IDE

How can I use "identifier completion"?

You can invoke identifier completion by pressing [ctrl][space]. Under the menu item Environment -> Editor Options -> Code Tools -> Automatic Features you can set how quick this should happen automatically.

Can I change the code editor font and colours?

Yes, see the menu item Tools -> Options and use the Editor/Display and Colors sections. On Windows you may find that the default Courier (and some other typefaces) are either too sharp or too soft, either selecting/deselecting 'Disable anti-aliasing'. TrueType fonts are an improvement, such as the free "Bitstream Vera Sans Mono" font available from [1]. (To install a new font, unzip and copy the files into a suitable folder. In Windows XP you will need to use the Fonts section of the Control Panel. In Windows 7 you may select all the font files, right-click and find an Install option in the pop-up menu)

Linux

How can I debug on Linux without the IDE?

First of all you need a debugger. gdb is the standard debugger under linux and there are several GUI-frontends available. One common frontend is ddd, which is part of most common distributions. To compile lazarus/lcl with debug-information you should then use the following commands to start a debug session:

$ make clean; make OPT=-dDEBUG
$ ddd lazarus

Be warned, however, that ddd is not as comfortable as, e.g., the Lazarus debugger, especially if it comes to view the contents of a variable you have to take into account that ddd/gdb are case sensitive whereas Pascal is case-insensitive. Therefore, you have to type all variable names in uppercase to see their contents. For more information see the fpc-manuals.

I can debug now but ddd does not find my sources or complains that they contain no code. What's that?

This is a path-related problem with either gdb or ddd. You can avoid this by

  • Use the "Change directory" command from the ddd menu and choose the directory where the sources are located. The drawback of this method is that you now can't use the source of the program you started with (e.g. lazarus). Thus it may be neccessary to change the directory multiple times.
  • In ddd goto [Edit] [gdb-settings] and set the search-path
  • Create a $(HOME)/.gdbinit file like:
     directory /your/path/to/lazarus
     directory /your/path/to/lazarus/lcl
     directory /your/path/to/lazarus/lcl/include

I receive an error during the linking that states /usr/bin/ld can't find -l<some lib>

For example:

 /usr/bin/ld: cannot find -lgdk

This means an external library was not found. In the above case under Linux it means the libgdk.so or libgdk.a was not found. Normally this means, you forgot to install the development package of this library. In the case of gdk the package is called under the Fedora Core distribution: 'gtk+-devel-1.2.10-33'.

Package Based Distributions 
You need to install the package that provides the lib<somelib>.so or lib<somelib>.a files. Dynamic libs under linux have the extension .so, while static libs have the extension .a. On some Linux distro's you have installed the package (rpm, deb) <packagename> which provides <some lib>, but you also need the development package (rpm, deb), normally called <packagename>-dev, which contains the .a (static lib) and/or the .so (dynamic lib).
Some distributions have commands to find which package contains a file:
Mandriva
[]$ urpmf lib<somelib>.so
will list all packages containing the file named lib<somelib>.so, you'll have to install those ending in -devel
Debian
install the apt-file utility (apt-get install apt-file) then
[]$ apt-file search lib<somelib>.so
will list all packages containing the file named lib<somelib>.so, you'll have to install those ending in -dev
SuSE

SuSE installs the gtk devel libs under /opt/gnome/lib (or /opt/gnome/lib64 for 64 bits), which is not in the standard lib path. Simply add it to your /etc/fpc.cfg. (-Fl/opt/gnome/lib).

Source Based Distributions and Manual Compilation (LFS) 
Make sure that there is a lib<somelib>.a in the path, and that it contains the right version. To let the linker find the dynamic library, create a symlink called lib<some lib>.so to lib<some lib><version>-x,y.so if necessary (and/or for static lib; lib<some lib>.a to lib<some lib><version>-x,y.a).
FreeBSD 
As source based distro's, and also make sure you have -Fl/usr/local/lib in your fpc.cfg and/or Lazarus library path. Keep in mind that GTK1.2 has "gtk12" as package name under FreeBSD. (same for glib) NOTE: This has changed as of late. Newest ports have gtk-12 and glib-12 as well. You might stumble on this problem, since FPC requires the "-less" ones, you will need to symlink them like this:
[]# cd /usr/local/lib && ln -s libglib-12.so libglib12.so
[]# cd /usr/X11R6/lib && ln -s libgtk-12.so libgtk12.so
[]# cd /usr/X11R6/lib && ln -s libgdk-12.so libgdk12.so
NetBSD 
As source based distro's, and also make sure you have -Fl/usr/pkg/lib in your fpc.cfg and/or Lazarus library path
Fedora : In the "add/remove software" panel search for: "gtk2-devel", "glibc-devel" ([see here]), "libx11-devel"

How can I convert a Kylix 2 project into a Lazarus project?

Nearly the same way as converting a Kylix project into a Delphi/VCL project.

The LCL (Lazarus Component Library) tries to be compatible to Delphi's VCL. Kylix's CLX tries to be QT compatible. Here are some general hints:

  • Rename all used CLX Q-units like QForms, QControls, QGraphics, ... into their VCL counterparts: Forms, Controls, Graphics, ...
  • Add LResources to the uses section of every form source
  • Rename or copy all .xfm files to .lfm files.
  • Rename or copy .dpr file to .lpr file.
  • Add "Interfaces" to the uses section in the .lpr file.
  • Remove {$R *.res} directive
  • Remove {$R *.xfm} directive
  • Add {$mode objfpc}{$H+} or {$mode delphi}{$H+} directive to .pas and .lpr files
  • Add an initialization section to the end of each form source and add an include directive for the .lrs file (Lazarus resource file):
initialization
{$I unit1.lrs}
The .lrs files can be created via the lazres tool in: (lazarusdir)/tools/lazres.
For example: ./lazres unit1.lrs unit1.lfm
  • Fix the differences. The LCL does not yet support every property of the VCL and the CLX is not fully VCL compatible.
  • To make it more platform independent, reduce unit libc (which is deprecated) references and substitute with native FPC units like baseunix/unix as much as possible. This will be necessary to support other targets than linux/x86 (including OS X, FreeBSD and Linux/x86_64)

When compiling lazarus the compiler can not find a unit. e.g.: gtkint.pp(17,16) Fatal: Can't find unit GLIB

1. Check a clean rebuild: do a 'make clean all'

2. Check if the compiler has the correct version (2.0.4 or higher)

3. Check if the compiler is using the right config file. The normal installation creates /etc/fpc.cfg. But fpc also searches for ~/.ppc386.cfg, ~/.fpc.cfg, /etc/ppc386.cfg and it uses only the first it finds.

Hint: You can see which config file is used with 'ppc386 -vt bogus'
Remove any ppc386.cfg as it is really obsolete.

4. Check if the config file (/etc/fpc.cfg) contains the right paths to your fpc libs. There must be three lines like this:

   -Fu/usr/lib/fpc/$fpcversion/units/$fpctarget
   -Fu/usr/lib/fpc/$fpcversion/units/$fpctarget/rtl
   -Fu/usr/lib/fpc/$fpcversion/units/$fpctarget/*
The first part of these paths (/usr/lib/fpc) depends on your system. On some systems this can be for example /usr/local/lib/fpc/... .
Hint: You can see your searchpaths with 'ppc386 -vt bogus'

5. Check that the config file (/etc/fpc.cfg) does not contain search paths to the lcl source files (.pp, .pas):

 forbidden: -Fu(lazarus_source_directory)/lcl
 forbidden: -Fu(lazarus_source_directory)/lcl/interfaces/gtk
If you want to add the lcl for all your fpc projects, make sure that the two paths look like the following and are placed after the above fpc lib paths:
 -Fu(lazarus_source_directory)/lcl/units/$fpctarget
 -Fu(lazarus_source_directory)/lcl/units/$fpctarget/gtk

6. Check if the missing unit (glib.ppu) exists in your fpc lib directory. For example the gtk.ppu can be found in /usr/lib/fpc/$fpcversion/units/i386-linux/gtk/. If it does not exists, the fpc lib is corrupt and should be reinstalled.

7. Check if the sources are in a NFS mounted directory. In some cases the NFS updates created files incorrectly. Please, try to move the sources into a non NFS directory and compile there.

8. If you are still not succeeded try to use samplecfg script as follows:

# cd /usr/lib/fpc/version/

# sudo ./samplecfg /usr/lib/fpc/\$version /etc

Note: Do not a slash ("/") after etc, because if you do, the system will create a folder /etc/fpc.cfg/fpc.cfg. In fact, we want samplecfg to make a file /etc/fpc.cfg, not the folder /etc/fpc.cfg.

I have installed the binary version, but when compiling a simple project, Lazarus gives: Fatal: Can't find unit CONTROLS

Probably you are using a newer fpc package, than that used for building the lazarus binaries. The best solution is to download the sources and compile lazarus manually. You can download the source snapshot or get the source via svn:

$ bash
$ svn checkout http://svn.freepascal.org/svn/lazarus/trunk lazarus
$ cd lazarus
$ make clean all

Make sure that Lazarus get the new source directory: Environment->General Options->Files->Lazarus Directory Top

Lazarus compiles, but linking fails with: libgdk-pixbuf not found

Install the gdk-pixbuf library for gtk1.x:

Where to find the gdk-pixbuf library:

RPMs: http://rpmfind.net/linux/rpm2html/search.php?query=gdk-pixbuf&submit=Search+...&system=&arch=

Debian packages: libgdk-pixbuf-dev

Sources: ftp://ftp.gnome.org/pub/gnome/unstable/sources/gdk-pixbuf/

Ubuntu 8.10:

If you are compiling Lazarus with GTK 2.0 you'll get a "libgdk-pixbuf2.0" not found error. Just install libgtk2.0-dev using apt on this way:

apt-get install libgtk2.0-dev

I have SuSE and I get /usr/bin/ld: cannot find -lgtk Error: Error while linking

Older SuSE versions (before SuSE 11) install the gtk devel libs under /opt/gnome/lib (or /opt/gnome/lib64 for 64 bits), which is not in the standard lib path. Simply add it to your /etc/fpc.cfg (-Fl/opt/gnome/lib).

Lazarus crashes with runtime error 211 after I installed a component

After I installed a component, Lazarus crashes with the following message:

Threading has been used before cthreads was initialized.
Make cthreads one of the first units in your uses clause.
Runtime error 211 at $0066E188

How can I fix this?

Your freshly installed component is using threads. FPC on *nix doesn't automatically include threading support, but it must be intialized. This initialization is done in the cthreads unit. Every application using the component needs to add this unit to the uses clause of the main program. Lazarus itself is no exception. This can be done in two ways:

1) Open the package. In the package editor click on Options. Under page Usage add to the custom options -dUseCThreads. Then rebuild the IDE. This way the cthreads unit will be automatically used by the IDE under unix and the cthreads are initialized.

2) In order to avoid modifying package, a fpc compiler option could be used directly. Open menu Tools->Configure "build Lazarus". Configure "build Lazarus" dialog will be shown, in field "Options:" type -Facthreads and then press "OK" button. The next step is to install the package. Lazarus will be built with option -Facthreads which means that it will treat main program as if unit cthreads where first in uses clause.

Hint: Maybe your old (non-crashing) Lazarus executable is stored as lazarus.old in the same directory as the crashing Lazarus executable.

See also Multithreaded_Application_Tutorial#Units_needed_for_a_multithreaded_application

When I run a program with threads I get runtime error 232

The complete error message is:

This binary has no thread support compiled in.
Recompile the application with a thread-driver in the program uses
clause before other units using thread.
Runtime error 232

Solution: Add cthreads as first unit to the uses clause of your main program, usually the .lpr-file.

I have Ubuntu Breezy/Mandriva KDE3 and my fonts in Lazarus IDE look too big

If Lazarus is compiled with Gtk1.2, the settings in Gnome Preferences/Font don't have any effect as they are related to Gtk2. You could try this solution: Create a file named .gtkrc.mine in your home directory (if it's not already there) and add these lines to it:

style "default-text" {
       fontset = "-*-arial-medium-r-normal--*-100-*-*-*-*-iso8859-1,\
                  -*-helvetica-medium-r-normal--*-100-*-*-*-*-*-*"
}

class "GtkWidget" style "default-text"

If this is not enough try and create also a .gtkrc symlink to .gtkrc.mine . It worked in this way under Xubuntu 7.10, Mandriva 2009.0 KDE3.

How can my gtk programs use custom rc files?

Option a) Name the rc file yourprogram.gtkrc and put it in the same directory where the executable is.

Option b) Use unit GtkInt and call GTKWidgetSet.SetRCFilename('your_preferred_rc_file'); Best done before Application.Initialize in the .lpr file with {$IFDEF LCLGtk}.

Option c) Use unit gtk2 and call gtk_rc_parse('your_rc_file')); and gtk_rc_reparse_all;.

I have Ubuntu and I cannot compile for Gtk2 due to missing libraries

Ubuntu has a problem with not creating all the symbolic links that you'll need even when the libraries are installed. Make sure that all missing libraries when trying to link for Gtk2 have their appropriate links. For instance, you might need to do:

cd /usr/lib
sudo ln -s libgdk-x11-2.0.so.0 libgtk-x11-2.0.so

Make sure that the [whatever].so symbolic links are created and point to the actual libraries.

How can I compile a program for Gtk2?

At the moment, the Gtk2 compiled IDE is a little unstable, but you can compile software for Gtk2 using the Gtk1 IDE.

To start with recompile LCL for Gtk2. Go to the menu "Tools"->"Configure Build Lazarus" and set LCL to clean+build and everything else to none.

Now click Ok and go to the menu "Tools"->"Build Lazarus"

Now you can compile your software with Gtk2 going on the Compiler options and changing the widgetset to Gtk2.

Lazarus runs differently with Linux vs. Windows. What do I need to know?

If you use readln(); and writeln(); for your input and output the console window (sometimes called terminal window) is not going to pop up as it does with Windows. You will need to access this window with View - Debug Windows - Terminal Output. Unlike with Windows you can not use backspace to correct typing errors. The 'Enter' key on the numeric keypad won't work either. Type carefully!

Because Linux is case sensitive you will need to take care that you pay attention to case when referencing or accessing files.

Windows

When I cycle/rebuild the compiler, I get

The name specified is not recognized as an internal or external command, operable program or batch file.>& was unexpected at this time

In the compiler directory there is an OS2 scriptfile named make.cmd. Different versions of Windows also see this as a script file, so remove it since what is needed for OS2 becomes a hindrance on Windows.

make[3]: ./ppc1.exe: Command not found

Somehow make has lost its path (reason unknown). Try to cycle with a basedir set like:

make cycle BASEDIR=your_fpc_source_dir_herecompiler

When I try to make Lazarus I get:

make.exe: * * * interfaces: No such file or directory (ENOENT). Stop.make.exe: * * * [interfaces_all] Error 2

You need to upgrade your make.

makefile:27: *** You need the GNU utils package to use this Makefile. Stop.

Make sure you didn't install FPC in a path with spaces in the name. The Makefile doesn't support it.

How can I give my program an XP look like Lazarus has?

Project -> Project Options -> Check 'Use manifest to enables themes'.

When I run Windows program created in Lazarus it starts with a DOS window

Specify the -WG argument (Windows GUI) on the command line of the compiler or in the Lazarus IDE check the Windows GUI check box on the compiler options dialog box (Project menu -> Compiler Options -> Linking -> target OS Specific options.

Mac OS X

Why does compiling a project fail with 'unknown section attribute: no_dead_strip'?

Dead code stripping is not supported by the assembler and linker before Xcode 1.5 (available for Mac OS X 10.3.9). Disable the compiler options

  • Code > Unit style > Smart linkable (-CX)
  • and Linking > Link Style > Link smart (-XX)

Debugging

Please see here for debugger issues under Mac

Licensing

Can I make commercial applications with Lazarus?

Yes, the LCL is licensed under the LGPL with an exception, which allows you to link to it statically without releasing the source of your application. Modifications and enhancements to the LCL must be distributed with source. Lazarus, the IDE, is licensed under the GPL. The LCL consists only of the code in the directory named "lcl", other code may not be covered by this statement.

Why are some components restricted from usage in commercial application?

Lazarus comes with additional components, that were developed by third parties. Those are under various other Licenses. If you wish to use them you need to see the License within the source files of those packages. Most of those 3rd party components are in the directory "components".

How do I know if a Component is part of the LCL?

All LCL units are in the directory "lcl". A list of units belonging to the LCL can be found here. If your code uses units not listed on this page, you may have used a component that is not part of the LCL.

Can I make commercial plug-ins for Lazarus?

Yes, the IDEIntf part of the IDE is licensed under the LGPL with the same exception, so that shared data structures in this part will not force you to license your plug-in or design-time package under the GPL. You are free to choose a plug-in of any license; we don't want to limit your choice. Therefore non-GPL compatible plug-ins are allowed. Note that it's not allowed to distribute a precompiled Lazarus with these non-GPL-compatible plugins included statically; however, we do not see this as a severe limitation, since recompiling Lazarus is easy.

Using the Forum

What is the correct way to ask questions in the forum?

First and most important: always mention which Lazarus version, Free Pascal version, Widgetset, CPU Architecture and Operating System (with full version) that you are using! Don't just say that you are using "the latest version"; please state the exact version number. For snapshots, the revision number and/or date are also important.

When asking a programming question, always try to include some source code which demonstrates the problem. Please surround your code with [code][/code] tags (or use the Insert code button in the forum post editor toolbar). You can attach complete programs as zip files if you want.

If you get an error on your code, always specify what the error is. Simply copying what the compiler / debugger / your program said should be enough in most cases. If the error happens at runtime, use -gl and disable function inlining when compiling so your program can generate a proper backtrace.

Often an image is also very useful. You can host images in http://imageshack.us/ and other similar websites and then post a link.

Try to provide both a high-level overview of the problem (what goal you want to achieve) as well as a more detailed view of the problem (how are you trying to achieve your goal. Often, there is a much easier way of getting things done that you may not know about.

Finally, make sure you have searched/read the relevant documentation (e.g. the FPC documentation and Lazarus wiki, see e.g. Lazarus Documentation. You should also search the forums: other people with may already have found solutions to similar problems. If you indicate you have already done a bit of homework, people will in general be much more willing to help.

For more tips about asking questions the smart way, read this: http://catb.org/esr/faqs/smart-questions.html

Version numbering

See the Version Numbering page for an explanation of the branching and version numbering of Lazarus.

Problems/issues with old Lazarus/FPC versions

Issues with old Lazarus/FPC versions and notes about upgrading are covered below.

Often, the best solution is to upgrade; please see the various Release Notes

Why is the linking so slow on Windows?

Note-icon.png

Note: This problem was fixed in FPC 2.2 and Lazarus 0.9.24. Please update your Lazarus if you can. For older versions read text below.

Generally speaking, compilation on Windows takes more time then other platforms because the GNU Linker utilized by Free Pascal is slow on this platform. This problem only affects Windows, and is only bad on relatively old computers (less then 1Ghz) and computers with little RAM (128MB or less).

Also, if you smartlink LCL the linking will be much slower. A study about this is located here: File size and smartlinking

Starting from FPC 2.2, an internal linker is used which decreases the linking time dramatically.

Old Lazarus does not support Windows-style resources; converting lrs resources

Older versions of FPC (and Lazarus based on it) don't support Windows (.rc/.res) resources, but only LRS files (Lazarus Resource files). See Lazarus_Resources Since 0.9.30 Lazarus can use fpc resources. That means you can delete the lrs files for forms and replace the include directives {$I unit1.lrs} with {$R *.lfm}.


See also

Personal tools