Lazarus Tutorial/de

From Free Pascal wiki
Jump to: navigation, search

Deutsch (de) English (en) español (es) suomi (fi) français (fr) magyar (hu) Bahasa Indonesia (id) italiano (it) 日本語 (ja) 한국어 (ko) македонски (mk) Nederlands (nl) português (pt) русский (ru) slovenčina (sk) shqip (sq) 中文(中国大陆)‎ (zh_CN) 中文(台灣)‎ (zh_TW)
Zurück zu den Zusätzlichen Informationen.

Dies ist der Anfang eines Lazarus Tutorials. Bitte fühlen Sie sich frei, Ihre Erfahrungen hinzuzufügen.

Überblick

Lazarus ist ein freies und Open-Source Entwicklungswerkzeug für den FreePascal Compiler, der ebenfalls frei und als Open Source verfügbar ist. Die Lazarus IDE (Integrated Development Environment - Screenshots) ist eine stabile und feature-reiche Entwicklungsumgebung für die Programmierung eigenständiger interaktiver (grafischer) und einfacher batchorientierter Konsolenanwendungen. Lazarus läuft gegenwärtig auf Linux, FreeBSD und Win32 und bietet einen anpassbaren Quelltext-Editor, interaktive Gestaltung von Bildschirmoberflächen, einen Package Manager, Debugger und die komplette GUI-Integration mit dem FreePascal Compiler (FPC).

Los gehts

(Dank an User:Kirkpatc)

Besorgen Sie sich, installieren Sie (siehe Installieren von Lazarus) und starten Sie Lazarus. Dadurch steht Ihnen auch der Free Pascal Compiler zur Verfügung.

Anmerkung: Zumindest unter Linux Ubuntu, ist der Befehl zum Starten von Lazarus aus einer Konsole "startlazarus". Ansonsten, wenn Sie es von einem Debian-Package installiert haben, sollten Sie einen Menüeintrag "Lazarus" unter Anwendungen / Programmentwicklung haben. (Problem: In Debian und Ubuntu wurden das Programm und das Package umbenannt zu "lazarus-ide", weil das "tct"-Package bereits ein Hilfsprogramm namens "lazarus" enthielt.)

Ihr erstes Lazarus Programm!

Wählen Sie aus dem Hauptmenü den Menüpunkt "Projekt --> Neues Projekt --> Anwendung". Eine neu GUI-Anwendung wird erstellt, siehe auch Form Tutorial. Mehrere Fenster erscheinen auf dem Desktop: das Hauptmenü am oberen Rand, der Objektinspektor links, der Lazarus Quelltexteditor nimmt den größten Teil des Desktops ein, und ein vorgefertigtes Fenster(Formular) namens "Form1" liegt auf dem Quelltexteditor. Auf dem Menü 'Fenster', unterhalb der Haupt-Menüzeile, ist eine Reihe von Tabs angezeigt. Falls der Tab 'Standard' nicht schon ausgewählt ist, dann wählen Sie ihn mit einem Mausklick aus. Jetzt suchen Sie das TButton-Symbol (rechteckiges Symbol mit 'OK') und aktivieren es durch einen Mausklick. Dann klicken Sie in das 'Form1' Fenster, irgendwo links der Mitte, und eine Schaltfläche namens 'Button1' wird dort eingesetzt. Klicken Sie erneut auf das Button-Symbol und dann in 'Form1' irgendwo rechts der Mitte: eine zweite Schaltfläche namens 'Button2' wird eingesetzt.

Wählen Sie jetzt 'Button1' aus. Der 'Objektinspektor' (links) zeigt die Eigenschaften des Objekts 'Button1' an. Ziemlich weit oben in der Liste steht die Eigenschaft 'Caption' mit dem angezeigten Wert 'Button1'. Klicken Sie in das Feld und ändern Sie 'Button1' zu 'Press'. Wenn Sie die ENTER-Taste drücken oder in ein anderes Feld klicken, ändert sich die Beschriftung des ersten Buttons auf 'Press'. Nun klicken Sie auf den Tab 'Ereignisse' im Objektinspektor, um verfügbare Ereignisse zu sehen, die mit dem Button verbunden werden können. Diese Ereignisse sind OnClick, OnEnter, OnExit, usw. Wählen Sie das Feld rechts von 'OnClick': eine kleinere Schaltfläche mit drei Punkten (... Ellipse) erscheint. Wenn Sie darauf klicken, springt die IDE automatisch in den Quelltext-Editor und der Cursor wird in folgendem Code platziert:

 procedure TForm1.Button1Click(Sender: TObject);
 begin
   {jetzt tippen Sie:}    Button1.caption := 'Press again';
   {der Editor hat die Procedure bereits komplettiert mit}
 end;

Drücken Sie F12, um das Fenster 'Form1' anstelle des Quelltext-Editors auszuwählen.

Jetzt bearbeiten Sie die Eigenschaften von 'Button2': klicken Sie in 'Form1' darauf, um seine Eigenschaften im Objektinspektor zu sehen. Ändern Sie das Attribut 'Caption' auf 'Exit' (an Stelle von 'Button2'.) Nun wählen Sie den Tab 'Ereignisse' und klicken in das Feld für 'OnClick'. Klicken Sie auf die '... Ellipse', und Sie werden in den Quelltext-Editor mitgenommen, in die Mitte einer anderen Prozedur:

 procedure TForm1.Button2Click(Sender: TObject);
 begin
   {jetzt tippen Sie:}   Close;
   {der Editor hat die Procedure bereits komplettiert mit} 
 end;

Sie sollten Ihre Arbeit jetzt (überhaupt: häufiger!!) speichern durch Auswahl von 'Projekt speichern unter...' mit 'ihr_gewählter_Datei_Name.pas'

Jetzt drücken Sie F12, um wieder das Fenster 'Form1' zu sehen. Sie sind jetzt bereit, die Kompilierung zu versuchen. Der einfachste Weg, dies zu tun, ist 'Start' aus dem Hauptmenü zu wählen, und dort wieder die 'Start' Option im Untermenü. Alternativ können Sie einfach F9 drücken. Dies wird zuerst kompilieren und dann, wenn alles gut geht, Ihr Programm linken und ausführen.

Verschiedene Textfenster werden erscheinen und einige Compiler-Meldungen werden geschrieben. Erscheint dann das Fenster 'Form1' ohne das Punktegitter, dann, "Hurra", sehen Sie das aktuelle Hauptfenster ihrer Anwendung. Es wartet darauf, dass die Buttons gedrückt werden.

Versuchen Sie auf den Button mit der Beschriftung 'Press' zu klicken. Sie werden bemerken, dass er sich zu 'Press again' ändert. Wenn Sie ihn erneut drücken, wird er immer noch 'Press again' sagen!!

Jetzt klicken Sie auf den Button mit 'Exit'. Das Fenster wird sich schließen und das Programm wird beendet. Das Entwurfs-Fenster 'Form1' mit dem Punktegitter wird wieder angezeigt, bereit, um weitere Bearbeitungsschritte zu akzeptieren.

Modifizieren Sie Ihr Programm

Öffnen Sie Ihr gespeichertes Projekt wieder. Im Fenster 'Form1' klicken Sie auf die 'Press' Schaltfläche (Button1), um sie auszuwählen. Springen Sie im Quelltext-Editor in die Procedure, die auf den Klick auf Button1 ('Press') reagiert: Wählen Sie dazu den Tab 'Ereignisse' im Objektinspektor aus, klicken in das Feld rechts von 'OnClick', klicken auf die '... Ellipse', und Sie sind an der entsprechenden Stelle im Quelltext-Editor angekommen.

Verändern Sie Ihren Code wie folgt, achten Sie dabei auf sauberes Setzen der ; und der begin ... end Strukturen (Sie können den Code auch hier markieren und per Copy-Paste in den Quelltext-Editor kopieren):

 procedure TForm1.Button1Click(Sender: TObject);
{Machen Sie Gebrauch von der Tag Eigenschaft, setzen Sie sie entweder auf 0 oder 1}
  begin
   if Button1.tag =0 then
   begin
     Button1.caption := 'Press again';
     Button1.tag := 1
   end else
   begin
     Button1.caption := 'Press';
     Button1.tag := 0
   end
 end;

Speichern Sie Ihre Arbeit, kompilieren und starten Sie neu (F9). Der linke Button wird jetzt zwischen zwei alternativen Botschaften hin- und herschalten.

Der Rest liegt an Ihnen!

Wenn Sie das Schreiben von Konsole- oder Text-basierten Pascal Programmen bevorzugen (zum Beispiel wenn Sie einem einfachen Pascal Programmierkurs folgen, oder Sie Programme schreiben müssen für die Verwendung im Batchmodus oder für die Systemprogrammierung), können Sie dennoch Lazarus benutzen zum Bearbeiten, Kompilieren und Starten Ihrer Programme. Es bildet eine ideale Umgebung für die Pascal Entwicklung. Siehe Console Mode Pascal.

Der Editor

Wenn Sie Lazarus zum ersten Mal starten, wird eine Reihe von separaten getrennten oder 'schwebenden' Fenstern auf Ihrem Desktop erscheinen.

Das erste, gleich oben auf dem Desktop, trägt den Titel Lazarus Editor vXXXXXX - project1 (welches anschließend modifiziert wird um den Namen Ihres gegenwärtig geöffneten Projekt widerzuspiegeln). Dies ist das Hauptsteuerungs Fenster für Ihr Projekt und enthält das Hauptmenü und die Komponentenpalette.

Laz de editor1.jpg

In der Zeile unter der Titelleiste befindet sich das Hauptmenü mit den üblichen Einträgen für Datei, Bearbeiten, Suche, Ansichtfunktionen und so weiter, mit einigen Auswahlen, die spezifisch für Lazarus sind. Darunter auf der Linken ist eine Gruppe von BitButtons (welche Sie rasch zu den jeweiligen Hauptmenü Optionen bringen) und auf der Rechten ist die Komponentenpalette.

Unter dem Lazarus Editor Fenster wird das Objektinspektor Fenster auf der Linken erscheinen, und der Lazarus Quelltext Editor auf der Rechten. Es gibt noch ein anderes kleineres Fenster, beschriftet mit Form1, über dem Lazarus Quelltext Editor Fenster. Wenn dieses nicht sogleich sichtbar ist, kann man es durch drücken der F12 Taste hervorholen, welche zwischen der Quelltext Editor Ansicht und der Formular Ansicht umschaltet. Das Formularfenster ist dasjenige, auf dem Sie das grafische Interface für Ihre Anwendung erstellen, während der Quelltext Editor das Fenster ist, welches den Pascal Code zeigt, der mit der Anwendung verbunden ist, welche Sie gerade entwickeln. Die Bedienung des Objektinspektors wird weiter unten detaillierter behandelt, während die Komponentenpalette beschrieben wird.

Wenn Sie ein neues Projekt starten (oder wenn Sie zuerst Lazarus starten), wird ein vorgegebenes Formular erstellt, welches zusammengesetzt ist aus einem Feld, in dem ein Punktegitter ist, welches Ihnen hilft, die verschiedenen Komponenten des Formulars zu positionieren, und einer Leiste am oberen Rand, welche die üblichen Minimieren, Maximieren und Beenden Buttons enthält. Wenn Sie mit Ihrer Maus irgendwo in diesem Feld klicken, werden Sie die Eigenschaften dieses Formulars sehen, angezeigt im Objektinspektor auf der linken Seite des Desktops.

Andere Fenster, die während Ihrer Arbeit sichtbar werden könnten: der Projektinspektor, welcher Details der Dateien enthält, die in Ihrem Projekt inbegriffen sind, und Ihnen erlaubt, Dateien hinzuzufügen oder zu löschen aus Ihrem Projekt, das Nachrichten Fenster, welches Compilermeldungen anzeigt, Fehler oder Fortschrittsberichte über Ihr Projekt; wenn Lazarus von einem Terminalfenster gestartet wird, bleibt das orginale Terminal sichtbar und detaillierte Compilermeldungen werden auch dort ausgegeben.


Das Hauptmenü

Die Hauptmenü Linie enthält die folgenden Einträge: Datei Bearbeiten Suche Ansicht Projekt Start Komponenten Werkzeuge Einstellungen Fenster Hilfe

Wie gewöhnlich, können die Optionen gewählt werden entweder durch Platzieren des Mauscursors über der Menü Option und klicken der linken Maustaste, oder durch Eingeben von Alt-F auf der Tastatur (sofern das Hauptmenü den Fokus hat: wenn nicht, dann drücken Sie TAB mehrmals um den Fokus durch die verschiedenen Fenster zu bewegen, bis das gewünschte Fenster mit seiner Titelleiste farbig hervorgehoben ist).

Die Online-Hilfe zu einzelnen Menüpunkten finden Sie hier.

Das Untermenü Datei

Laz de menu datei.jpg
  • Neue Unit: Erzeugt eine neue Unit-Datei (Pascal Quelle).
  • Neues Formular: Erzeugt ein neues Formular: sowohl das visuelle Bildschirmfenster als auch die verbundene Pascal-Quelltext-Datei.
  • Neu ...: Bietet ein Dialogfenster (Screenshot) mit einer Auswahl von neuen Dokumenttypen zum Erzeugen.
  • Öffnen ...: Bietet ein Dialogfenster, welches die Navigation durch das Dateisystem ermöglicht, um eine existierende Datei zu öffnen.
  • Wiederherstellen: Abbrechen der Editieränderungen und Wiederherstellen der Datei zu ihrem anfänglichen Status.
  • Wieder öffnen ...: Zuletzt geöffnete Dateien wieder öffnen.
  • Speichern: Speichert die aktuelle Datei unter Verwendung des originalen Dateinamens. Wenn es noch keinen Namen gibt, wird das System danach fragen (wie bei Speichern unter).
  • Speichern unter ...: Erlaubt Ihnen, ein Verzeichnis und den Dateinamen zu wählen, um die aktuelle Datei zu speichern.
  • Alles speichern: Speichert alle geöffneten Dateien.
  • Schließen: Schließt die aktuelle Datei, fragt, ob alle Änderungen gespeichert werden sollen.
  • Alle Editorfenster schließen: Schließt alle im Editor geöffneten Dateien. Fragt, ob Änderungen gespeichert werden sollen.
  • Verzeichnis säubern ...: Bietet einen Dialog mit einer Reihe von editierbaren Filtern, um Dateien aus dem gegenwärtigen Verzeichnis zu entfernen. Nützlich zum Entfernen von .bak Dateien und Überresten von früheren Delphi-Projekten.
  • Drucken ...: Druckt den Quelltext der aktiven Unit aus.
  • Neustart: Startet Lazarus neu.
  • Beenden: Beendet Lazarus, nachdem gefragt wurde, ob die bearbeiteten Dateien gespeichert werden sollen.

Das Untermenü Bearbeiten

Laz de menu bearb.jpg
  • Rückgängig: Widerruft die letzte Editieraktion, versetzt den Editor in den Status vor der letzten Aktion zurück.
  • Wiederholen: Setzt die letzte Aktion, die mit Rückgängig aufgehoben wurde, wieder ein.
  • Ausschneiden: Entfernt den markierten Text oder andere Objekte und fügt sie in die Zwischenablage ein.
  • Kopieren: Erstellt eine Kopie des markierten Texts, hinterlässt das Original an seinem Platz, und fügt die Kopie in die Zwischenablage ein.
  • Einfügen: Plaziert den Inhalt der Zwischenablage an der Cursorposition. Wenn Text an der Cursorposition markiert war, dann wird der Inhalt der Zwischenablage den Text überschreiben.
  • Block einrücken: Bewegt den markierten Text nach rechts um den Betrag, der in Einstellungen -> Editoreinstellungen -> Allgemein -> Blockeinzug spezifiziert ist. Dieses Feature ist nützlich zur Formatierung Ihres Pascal Quelltextes, um die grundlegende Blockstruktur zu zeigen.
  • Auswahl ausrücken: Entfernt eine Ebene der Einrückung, bewegt den Text nach links um den Betrag, der in Blockeinzug spezifiziert ist.
  • Auswahl einschließen ...: Bietet ein Dialogfenster mit einer Anzahl von Optionen für folgerichtiges Einschließen des markierten Textes (begin ... end; try ... except; try ... finally; repeat ... until; { ... } etc).
  • Auswahl kommentieren: Wandelt den markierten Text in einen Kommentar um durch Einfügen von // auf jeder Zeile.
  • Auswahl entkommentieren: Entfernt die Kommentarmarkierungen.
  • $IFDEF einfügen: Fügt eine $IFDEF Deklaration an der Cursorposition ein.
  • Auswahl sortieren ...: Sortiert die Zeilen (oder Wörter oder Paragraphen) alphabetisch; Optionen für aufsteigende oder absteigende Anordnung, mit oder ohne Beachtung der Groß- und Kleinschreibung. In der Mitte des Progamm-Quelltexts, macht es natürlich keinen Sinn, aber wenn Sie eine Liste haben, die Sie sortieren müssen, wird dieser Kniff es tun.
  • Auswahl großschreiben: Wandelt den markierten Text in Großbuchstaben um.
  • Auswahl kleinschreiben: Wandelt den markierten Text in Kleinbuchstaben um.
  • Tabulatoren in Auswahl in Leerzeichen umwandeln: Wandelt jeden Tabulator im markierten Text in die Anzahl Leerzeichen um, die spezifiziert sind durch Einstellungen -> Editoreinstellungen -> Allgemein -> Tabulatorsprung. Die Anzahl von Leerzeichen ist keine feste Anzahl, aber die Anzahl wird benötigt, um die verbleibende Breite des Tabulators zu füllen.
  • Zeilen in der Auswahl trennen: Wenn irgendeine Zeile im markierten Text länger als 80 Zeichen ist oder die Anzahl spezifiziert in Einstellungen -> Editoreinstellungen -> Anzeige -> Rechter Rand, dann wird die Zeile an einem Wortende umgebrochen und in der nächsten Zeile fortgesetzt.
  • Auswählen: Erlaubt die Auswahl von Textblöcken. Optionen enthalten Alles auswählen, Bis zu einer Klammer, Zeile auswählen etc.
  • Aus der Zeichentabelle einfügen: Erlaubt das Einfügen von Symbolen, die nicht auf der Tastatur sind, wie akzentuierte Zeichen, aufgelesen von einer pop-up Zeichentabelle.
  • Text einfügen: Zeigt ein pop-up Menü, welches das Einfügen von Standardtext erlaubt wie z.B. CVS Stichwörter (Autor, Datum, Kopf etc.) oder GPL Hinweise, Benutzername oder aktuelles Datum und Zeit.
  • Quelltext vervollständigen: Komplettiert den Code an der Cursorposition. Es ist kontextsensitiv und erspart Ihnen eine Menge Zeit. Zum Beispiel: Es komplettiert Klassen, durch Hinzufügen von privaten Variablen, Get und Set Eigenschaftszugriff Methoden und Hinzufügen von Methodenrümpfen. Bei Variablenzuweisungen (z.B. i:=3;) fügt es die Variablendeklaration hinzu. Bei forward defined Prozeduren fügt es die Prozedurrümpfe hinzu. bei Ereigniszuweisungen (OnClick:=) fügt es die Methodendefinitionen und den Methodenrumpf hinzu. Siehe Lazarus IDE Tools.
  • Prozedur extrahieren ...: Nutzt den markierten Text (eine Anweisung oder Serien von Anweisungen), um eine neue Prozedur zu erstellen.

Das Untermenü Suche

Laz de menu suche.jpg
  • Suchen ...: Ähnlich wie die Möglichkeit in beinahe allen graphischen Texteditoren: ein Dialogfenster erscheint, welches die Eingabe einer zu suchenden Zeichenkette erlaubt, mit Optionen wie Schreibweise beachten, nur ganze Worte, reguläre Ausdrücke und die Richtung der Suche.
  • Nächstes suchen, Vorheriges suchen: Erneute Suche nach der zuvor eingegebenen Zeichenkette, in der spezifizierten Richtung.
  • In Dateien suchen ...: Sucht nach Zeichenketten in Dateien: ein Dialogfenster mit Optionen: alle offenen Dateien, alle Dateien im Projekt, oder alle Verzeichnisse; Masken sind verfügbar für die Auswahl der Dateitypen.
  • Ersetzen ...: Ähnlich wie Suchen ...; zeigt ein Dialogfenster mit Platz, um die zu suchende Zeichenkette und den ersetzenden Text einzugeben, und Optionen für Schreibweise beachten, Richtung etc.
  • Inkrementielle Suche: Suche nach der Zeichenkette während Sie die zu suchende Zeichenkette eingeben. Beispiel: Nachdem Sie "Inkrementielle Suche" gewählt haben und zuerst "l" drücken, dann wird "l" hervorgehoben. Wenn Sie dann "a" drücken, wird der Editor das nächste "la" finden und so weiter.
  • Zu Zeile springen ...: Bewegt den Cursor zur spezifizierten Zeile in der Datei.
  • Zurückspringen: Schritt zurück in der Datei zum nächsten Lesezeichen (zuvor muss Add jump point to history verwendet worden sein). Springt auch zu Lesezeichen in anderen geöffneten Dateien.
  • Vorwärtsspringen: Schritt vorwärts zum nächsten Lesezeichen.
  • Sprungmarke speichern: Fügt Lesezeichen (Bookmark) oder Sprungpunkt zur Datei hinzu.
  • Sprungliste anzeigen ...: Anschauen der Liste der Lesezeichen in der Datei: Noch nicht implementiert.
  • Zum nächsten Fehler springen:
  • Zum vorherigen Fehler springen:
  • Freies Lesezeichen setzen:
  • Springe zum nächsten Lesezeichen:
  • Springe zum vorherigen Lesezeichen:
  • Anderes Ende des Quelltextblocks suchen: Wenn auf einem begin positioniert, findet es das zugehörige end und umgekehrt.
  • Zu Quelltextblockanfang gehen: Geht zum begin der Prozedur oder Funktion, in welcher der Cursor platziert ist.
  • Deklaration unter Cursor suchen: Findet den Ort, an dem der markierte Bezeichner deklariert ist. Dies kann in der selben Datei sein oder in einer anderen Datei, die bereits im Editor geöffnet ist. Wenn die Datei nicht geöffnet ist, wird sie geöffnet (wenn eine Prozedur oder Funktion deklariert ist, zum Beispiel in classesh.inc , wird diese im Editor geöffnet).
  • Datei unter Cursor öffnen: Öffnet die Datei, deren Name unter dem Cursor ausgewählt ist. Hilfreich zum Schauen in Include Dateien oder andere Dateien, die die im Projekt verwendeten Units enthalten.
  • Zu Include Direktive springen: Wenn der Cursor in einer Datei positioniert ist, die eingebunden ist in einer anderen Datei, geht es zu dem Ort in der anderen Datei, wo die Include Datei aufgerufen wird.
  • Bezeichnerreferenzen suchen ...:
  • Bezeichner umbenennen:
  • Prozedur-Liste ...:

Das Untermenü Ansicht

Laz de menu ansic.jpg

Steuert die Anzeige der verschiedenen Fenster und Panels auf dem Bildschirm.

  • Objektinspektor: Das Fenster, das üblicherweise die linke Seite des Desktops in Anspruch nimmt und die Features des Formulars anzeigt, welches auf dem Desktop ist. Klicken mit der Maus auf jede Komponente des Formulars bewirkt die Anzeige von Details dieser Komponente im Objektinspektor. Es gibt oben ein Panel, welches die Baum-Struktur des aktuellen Projekts zeigt, und die Komponenten des Formulars können in diesem Panel optional ausgewählt werden. Dies wird auch zur Anzeige der korrespondierenden Details im Objektinspektor führen. Das untere Hauptpanel hat zwei Tabs, welche die Auswahl erlauben, entweder die Eigenschaften oder Ereignisse anzuzeigen. Die Auswahl von Eigenschaften führt zur Anzeige von Eigenschaften wie Name, Farbe, Überschrift, Font, Größe usw. Es gibt zwei Spalten, die linke zeigt die Eigenschaft, und die rechte zeigt den Wert, der mit dieser Eigenschaft verbunden ist. Die Auswahl von Ereignisse zeigt zwei Spalten: die linke listet die möglichen Ereignisse wie MouseClick oder KeyDown auf, die mit dieser Komponente assoziiert sind, und die rechte zeigt the Aktion, die aus diesem Ereignis resultiert. Wenn keine Aktion definiert ist, dann klicken Sie in das entsprechende Feld or on the
    ...
    button causes the Source Editor to be displayed, with the cursor already positioned in a dummy Procedure declaration, waiting for event-defining code to be typed in. Siehe auch IDE Window: Object Inspector/de.
  • Quelltexteditor: Das Hauptfenster, in welchem der Quellcode bearbeitet wird. Sein Verhalten ist sehr ähnlich wie das der meisten anderen graphischen Texteditoren, so dass die Maus den Cursor über den angezeigten Text bewegen kann, und Klicken mit der linken Maustaste während die Maus gezogen wird, selektiert den Text und hebt ihn hervor. Rechtsklicken mit der Maus zeigt ein Pop-up-Menü, aber wenn Sie vertraut sind mit Windows, Gnome oder KDE Editoren, werden Sie feststellen, dass das Pop-up-Menü NICHT die üblichen Bearbeiten, Ausschneiden, Kopieren oder Einfügen Funktionen enthält, aber Optionen wie Find Declaration oder Open File at Cursor. The top of the Source Editor window has a number of tabs, corresponding to the files that are open for the current project; das Klicken auf einen Tab macht die Datei sichtbar, and you can move easily from file to file, Kopieren und Einfügen between files and performing most of the normal editing functions. The Source Editor performs colour syntax highlighting on the code, with different colours for punctuation marks, comments, string constants etc. It will also maintain the level of indentation from line to line as you type in code, until you change the indentation. The function and appearance of the Source Editor are very configurable from the Main Menu by selecting Tools -> Options -> Editor and then selecting one of several tabs in the pop-up dialog box.
  • Code Explorer ...: A window usually placed on the right of the Desktop which displays, in tree form, the structure of the code in the current unit or program. It usually opens with just the Unit name and branches for Interface and Implementation sections, but clicking on the
    +
    box to the left of any branch will open up its sub-branches or twigs, in more and more detail until individual constants, types and variables are displayed as well as procedure and function declarations. If you change the file displayed in the main Source Editor window, you need to click on the Refresh button of the Code Explorer to display the structure of the new file.
  • LazDoc Editor: Öffnet den LazDoc-Editor
  • Units ...: Öffnet ein Dialogfenster mit einer Liste der Unit-Dateien im aktuellen Projekt. Ein Mausklick auf den Dateinamen wählt diese Datei aus; klicken Sie auf Öffnen um diese Datei im Editor anzuzeigen. Checking the Multi box allows several files to be selected simultaneously, and they will all be opened in the Source Editor (but only one at a time will be displayed). This Menu Option is rather like the Project -> Project Inspector option, zeigt aber nur die Liste der Unitdateien und erlaubt diese zu öffnen.
  • Formulare ...: Öffnet ein Dialogfenster mit einer Liste der Formulare im aktuellen Projekt, und erlaubt die Auswahl von einem oder mehreren von ihnen anzuzeigen.
  • Unitabhängigkeiten anzeigen: Öffnet ein Dialogfenster das zeigt, in a tree-like manner, die Struktur der Abhängigkeiten der aktuell geöffneten Unit Datei. Die meisten der aufgelisteten Dateien haben ihre eigenen
    +
    Felder, which allow the dependencies of the individual files to be explored, often in a highly recursive manner.
  • Unitinformationen anzeigen: Zeigt allgemeine und Pfad-Informationen zur aktuellen Unit an.
  • Formular/Unitansicht umschalten: Schaltet zwischen der Anzeige des Quelltexteditors und dem zugeordneten Formular um und macht das Fenster aktiv. Wenn der Quelltexteditor aktiv ist, kann der Quelltext editiert werden; wenn das Formular aktiv ist, so kann dieses manipuliert und die darauf befindlichen Komponenten editiert werden. Der leichteste Weg, um zwischen der Anzeige von Editor und Form zu wechseln, geht durch Drücken der Taste F12, der gleiche Effekt wird durch Auswahl dieser Option im Haupt-Menü bewirkt.
  • Nachrichten ...: Ein Fenster, das Compiler-Meldungen anzeigt, den Fortschritt einer erfolgreichen Kompilierung oder eine Liste der gefundenen Fehler.
  • Suchergebnisse: Ein Fenster, das die Ergebnisse einer Suchanfrage (z.B. In Dateien suchen ...) anzeigt.
  • Ankereditor anzeigen:
  • Komponentenpalette anzeigen: ermöglicht das Anzeigen/Verbergen der Komponentenpalette
  • Speedbuttons der IDE anzeigen: ermöglicht das Anzeigen/Verbergen der Speedbuttons (links von der Komponentenpalette)
  • Debuggerfenster: Öffnet ein Pop-Up-Menü mit verschiedenen Optionen für den Betrieb und die Konfiguration des Debuggers. Siehe unten, wo der Debugger beschrieben ist.

Das Untermenü Projekt

Laz de menu proje.jpg
  • Neues Projekt ...: Erzeugt ein neues Projekt. Ein Dialogfenster erscheint mit einer Auswahl von Projekttypen zum Anlegen.
  • Neues Projekt aus Datei ...: Ein Navigationsdialogfenster erscheint, welches die Auswahl einer Datei erlaubt, von der das neue Projekt erstellt wird.
  • Projekt öffnen ... Öffnet ein Projekt, welches bereits erzeugt und gespeichert wurde. Ein Navigationsdialog erscheint mit einer Liste von Lazarus Projekt Information (.lpi) Dateien, aus der ein Projekt ausgewählt werden kann.
  • Letzte Projekte ...: Zeigt eine Pop-up-Liste von Projekten an, an denen Sie kürzlich gearbeitet haben, und erlaubt die Auswahl eines der Projekte.
  • Projekt schließen:
  • Projekt speichern: Ähnlich wie Datei -> Speichern: alle Dateien des gegenwärtigen Projekts werden gespeichert. Wenn diese zuvor noch nicht gespeichert wurden, erscheint eine Eingabeaufforderung für die Dateinamen ähnlich wie Projekt speichern unter...
  • Projekt speichern unter ...: Fragt den Dateinamen ab, um das Projekt zu speichern. Ein Vorgabe Dateiname für Project1.lpi wird angeboten, aber Sie sollten Ihren eigenen Dateinamen wählen. Lazarus wird Ihnen nicht erlauben, den selben Namen für die Projektdatei und die Unitdatei zu benutzen (siehe unten).
  • Projekt veröffentlichen ...: Erzeugt eine Kopie des gesamten Projekts. Wenn Sie jemandem einfach die Quellen und Compilereinstellungen Ihres Codes senden wollen, dann sind Sie bei dieser Funktion richtig. Ein normales Projektverzeichnis enthält eine Menge von Informationen. Das meiste davon muss nicht veröffentlicht werden: die .lpi Datei enthält Sessionsinformationen (wie die Caret Position und Lesezeichen geschlossener Units) und das Projektverzeichnis enthält eine Menge von .ppu, .o Dateien und die .exe Datei. Um eine lpi Datei zu erstellen - nur mit den Basisinformationen und nur den Quellen zusammen mit allen Unterverzeichnissen - verwenden Sie "Projekt veröffentlichen". In dem Dialog können Sie die exclude und include Filter einrichten, und mit the command after you can compress the output into one archive. Siehe Lazarus IDE Tools
  • Projektinspektor ...: Öffnet ein Dialogfenster mit einer tree-like Anzeige der Dateien im aktuellen Projekt. Erlaubt Ihnen die ausgewählten Dateien hinzuzufügen, zu verschieben oder zu öffnen oder die Projektoptionen zu ändern.
  • Projekteinstellungen ...: Öffnet ein Dialogfenster mit Tabs zum Einstellen von Anwendung (Titel, Ausgabeeigenschaften), Formulare, Diverses, LazDoc, Sitzung, Versionsinformationen und .po Dateien.
  • Compilereinstellungen ...: Öffnet ein multi-page tabbed Fenster, welches die Konfiguration des Compilers erlaubt. Zu den Tabs im Detail: Im Reiter Pfade lassen sich Suchpfade für Units, Include-Dateien und Bibliotheken festlegen. Die Einstellung "LCL-Schnittstelle" legt fest, welche grafische Komponentenbibliothek für das zu erstellende Programm verwendet wird (gtk, gnome, win32, qt). Im Reiter Parse lassen sich Regeln festlegen, nach denen der Programmquelltext vom Parser interpretiert wird. Der Reiter Quelltext ermöglicht die Optimierung des vom Compiler erstellten Codes hinsichtlich der Codegröße und der Ausführungsgeschwindigkeit. Auch lässt sich der Code an eine bestimmte Zielarchitektur anpassen, die Heap-Größe und die Überprüfung von Überläufen, Stack-Fehlern, etc. lässt sich hier einschalten. Nicht zuletzt kann hier Smartlinking aktiviert werden. Im Reiter Linken lassen sich Debugger-Einstellungen vornehmen. Durch Deaktivierung von "Zeilennummern in Laufzeit-Backtraces anzeigen" und Aktivierung von "Debuggersymbole aus der ausführbaren Datei entfernen" lässt sich die Binärdateigröße erheblich reduzieren (aber Achtung: durch die Entfernung von Debuggersymbolen lässt sich der Debugger nicht mehr benutzen). Ist Smart-Linking erwünscht, muss unter "Linker-Stil" die entsprechende Einstellung gemacht werden. Ist die Option "Win32 gui application" deaktiviert, wird das erstellte Programm automatisch in der Windows-Konsole geöffnet (unter Windows). Unter Nachrichten ... lässt sich einstellen, welche Art von Nachrichten im Fenster "Ansicht-->Nachrichten ..." angezeigt werden sollen. Der Reiter Andere erlaubt die Benutzung einer zu fpc.cfg alternativen Konfigurationsdatei. Im Reiter Übernehmen wird in Form einer Baumstruktur festgehalten, how options have been inherited from units already incorporated; Im Reiter Kompilierung kann festgelegt werden, welche Befehle vor oder nach des Kompilierprozesses ausgeführt werden sollen und ermöglicht die Erstellung von Make-Files.
  • ToDo-Liste ...: Öffnet ein Dialogfeld mit einer Liste von ToDo Elementen, die mit diesem Projekt assoziert sind. Dies wird jeden ToDo-Kommentar in Ihrem Projekt anzeigen (Zeilen die mit //TODO beginnen), und jeden anderen in den Lazarus Units, die sie verwendet haben. You need to Refresh the ToDo items in the dialog (using arrow symbol button of toolbar) before new 'ToDos' appear. Die erste Spalte der ToDo Liste enthält die Zahlen, die Sie Ihren Kommentaren zugewiesen haben. Ein einfacher //TODO Kommentar wird als null erscheinen. Aber ein Kommentar //TODO999 (als Beispiel) wird die Zahl 999 in der ersten Spalte erscheinen lassen. Beachten Sie, dass in der Zeile vor //TODO keine Leerzeichen sein sollten und dass die nach dem letzten Speichern hinzugefügten Kommentare nicht angezeigt werden!
  • Datei im Editor ins Projekt aufnehmen: Fügt die Datei, die gerade bearbeitet wird, zum Projekt hinzu.
  • Aus Projekt entfernen ...: Bietet ein Pop-Up-Menü der zum Löschen vom Projekt verfügbaren Dateien.
  • Quelltext anzeigen: Egal, welche Datei Sie gerade bearbeiten, es bringt Sie zurück zur Hauptprogramm-Datei (.lpr) oder der Haupt-.pas Datei, wenn kein .lpr existiert.

Das Untermenü Start

Laz de menu start.jpg
  • Erstellen: Veranlasst Lazarus, jede Datei im Projekt, die seit der letzten Erstellung geändert wurde, zu erstellen (d.h. kompilieren).
  • Alles neu erstellen: Erstellt alle Dateien im Projekt, ob sie geändert wurden oder nicht.
  • Schnelles Kompilieren:
  • Erstellen abbrechen: Stoppt den Erstellungsprozess, sobald er läuft - entweder haben Sie sich erinnert, dass Sie etwas Unkluges getan haben und die Erstellung stoppen wollen, oder das System scheint sich allzu lange Zeit zu nehmen und etwas ist offensichtlich falsch.
  • Start: Dies ist der übliche Weg, den Compiler zu starten und, wenn die Kompilierung erfolgreich ist, die Ausführung der Anwendung zu starten. Was aktuell passiert ist, dass Lazarus eine Kopie Ihrer Dateien speichert, dann den Compiler und Linker startet, dann mit der Ausführung des endgültig verbundenen Binärprogramms beginnt.
  • Pause: Unterbricht die Ausführung des aktuell laufenden Programms. Dies kann Ihnen erlauben, jede Ausgabe die erzeugt wurde zu kontrollieren; die Ausführung kann fortgesetzt werden durch nochmalige Wahl von Start.
  • Einen Schritt hinein: Wird in Verbindung mit dem Debugger genutzt, löst die Ausführung des Programms einen Schritt jeweils bis zu einem bookmarked point im Quelltext aus.
  • Einen Schritt weiter: Löst die schrittweise Ausführung bis zur markierten Anweisung aus, überspringt dann die markierte Anweisung, und setzt die Ausführung mit normaler Geschwindigkeit fort. Hilfreich beim Versuch, eine Anweisung zu isolieren, die einen logischen Fehler einschleppt.
  • Start bis Cursor: Startet die Ausführung mit normaler Geschwindigkeit (ie NOT one statement at a time), bis die Anweisung erreicht wird, wo sich der Cursor befindet; dann stoppt sie. Fortsetzung der Ausführung mit normaler Geschwindigkeit durch Auswahl von Start.
  • Halt: Beendet die Ausführung des laufenden Programms. Kann nicht fortgesetzt werden durch die Wahl von Start; dies wird das Programm erneut vom Anfang starten (Rekompilierung, falls erforderlich).
  • Startparameter ...: Öffnet ein multi-page Pop-up-Fenster welches erlaubt, Kommandozeilenparameter und -optionen an das auszuführende Programm weiterzugeben; ermöglicht die Auswahl der Anzeige für ein Programm(Beispielsweise könnte ein remote X terminal in Linux genutzt werden); Systemumgebungsvariablen können übergangen werden.
Eine sehr wichtige Anwendung dieses Untermenüs ist die Aktivierung eines Terminal-Fensters in welchem herkömmliche (Pascal-)ein- und ausgaben angezeigt werden.

Bei der Entwicklung von Pascal-Konsolenprogrammen sollte "Startprogramm verwenden" aktiviert werden. Falls beim ersten Lauf eine unsanfte Fehlermeldung wie

 "xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied"

erscheint, müssen die Rechte für die entsprechende Datei angepasst werden. Danach sollte sich bei jedem Programmaufruf ein Konsolenfenster öffnen, in dem alle Textein- und -ausgaben erscheinen.

Nachdem das Programm beendet wurde erscheint im Konsolenfenster die Meldung "Press enter". Dadurch verbleibt die vom Programm generierte Ausgabe auf dem Bildschirm und man hat die Möglichkeit diese Ausgabe zu lesen. Nachdem man Enter drückt schliesst sich das Konsolenfenster.
Siehe das gesonderte Tutorial auf Console Mode Pascal programming.
  • Debugger zurücksetzen: Restores the debugger to its original state, so that breakpoints and values of variables etc are forgotten.
  • Datei erstellen: Kompiliert einfach die Datei, die gerade im Editor geöffnet ist.
  • Datei ausführen: Kompiliert, linkt und führt nur die aktuell geöffnete Datei aus.
  • Konfiguriere Erzeuge+Starte Datei ...: Opens a multi-page tabbed window with options to allow for build of just this file when Build Project is selected, allows selection of the working directory, the use of various Macros, etc. Then Builds and Runs the file.
These last three options enable you to open (and maintain) a test project. Use File -> Open to open an .lpr file, pressing cancel on the next dialog to open this file as "normal source" file.
  • Inspizieren ...:
  • Prüfen/Ändern:
  • Überwachung hinzufügen...:
  • Neuer Haltepunkt: Fügt einen neuen Haltepungt hinzu.

Das Untermenü Package

Laz de menu kompo.jpg
  • Packagedatei (.lpk) öffnen ...: Öffnet eine der Dateien im gewählten Package.
  • Package der aktuellen Unit öffnen: ?
  • Letztes Package wieder öffnen ...: Öffnet ein vor kurzem geöffnetes Package.
  • Aktuelle Unit zu einem Package hinzufügen: Plaziert die Unit-Datei (zur Zeit im Editor) in ein Package.
  • Package-Graph ...: Zeigt ein Schaubild , welches die Beziehungen der Packages, die gegenwärtig in Gebrauch sind, (Wenn Sie kein anderes Package benutzen, werden das Lazarus Package und die FCL und LCL angezeigt.) zeigt.
  • Installierte Packages einrichten ...: Wenn Sie einige Komponenten erzeugt haben, erlaubt es Ihnen sie zu konfigurieren.

Das Untermenü Werkzeuge

Laz de menu werkz.jpg
  • Externe Werkzeuge einrichten ...: Erlaubt dem Benutzer, verschiedene externe Werkzeuge (üblicherweise Makros) zum Toolkit hinzuzufügen.
  • Optionen für Projektschablonen:
  • Schnelle Syntaxprüfung: Führt eine schnelle Überprüfung der Syntax in Ihrer Quelldatei durch, ohne irgendetwas zu kompilieren. Essential step in developing long or complicated programs, where you don't want to waste time compiling if the code is wrong.
  • Offene Quelltextblöcke erraten: hilfreiches Werkzeug, wenn Sie eine komplexe verschachtelte Blockstruktur haben und sie irgendwo ein 'end' ausgelassen haben
  • Offene IFDEF/ENDIF erraten: useful if there is a complex or nested macro structure and you think you have left out an ENDIF directive
  • Ressourcenstring erzeugen ...: Macht die ausgewählte Zeichenkette zu einem resource string durch Platzierung im resourcestrings Abschnitt. Ein Vorteil von resource strings ist, dass Sie sie ändern können, ohne Ihr Projekt neu kompilieren zu müssen!
  • Diff: Erlaubt den Vergleich zwischen zwei Dateien (oder, üblicherweise, zwei Versionen von der selben Datei), um Unterschiede zu finden. Options to ignore white space at beginning or end of lines or differences in line termination: CR+LF versus LF). Hilfreich für die Prüfung, ob es Änderungen seit dem letzten SVN Update gegeben hat usw.
  • LFM-Datei im Editor überprüfen: Erlaubt die Prüfung der LFM Datei, welche die Einstellungen enthält, die das aktuelle Formular beschreiben.
  • Delphi- in Lazarus-Projekt konvertieren:
  • Delphi- in Lazarus-Package konvertieren:
  • Lazarus erstellen: Rekompiliert Lazarus und fügt der Komponentenpalette jedes entsprechend markierte Paket hinzu.
  • "Lazarus Erstellen" einrichten: Erlaubt es dem Benutzer zu spezifizieren, was geschehen soll, wenn Lazarus erstellen aufgerufen wird. In diesem Dialog muss die Option 'Mit Paketen eingestellt' werden, wenn Packages mit Komponenten eingeschlossen werden sollen.

Das Untermenü Einstellungen

Laz de menu einst.jpg
  • FPC-Quelltextverzeichnis neu einlesen Looks through the directory again. Lazarus uses the fpc sources to generate correct event handlers and while looking for declarations. If somebody changes the directory in the environment options, then this directory is rescanned, to make sure lazarus uses the version stored in that location. But if this directory has changed without lazarus noticing, then you may get some errors when designing forms or doing "Find declaration". If you get such an error, you can do two things:
    1. Check the fpc source directory setting in the environment option.
    2. Re-scan FPC source directory.

Das Untermenü Fenster

Laz de menu fenst.jpg

Enthält eine Liste der aktuell geöffneten Dateien und die verfügbaren Fenster wie Lazarus-Quelltexteditor und Objektinspektor. Das Klicken auf den Namen eines der Fenster bringt es in den Vordergrund und gibt ihm den Fokus.

Das Untermenü Hilfe

Laz de menu hilfe.jpg

Derzeit hat es drei Auswahlmöglichkeiten:

  • Onlinehilfe welches derzeit einen Browser öffnet, der ein Bild eines laufenden Geparden enthält und einige Links zu den Lazarus, FreePascal und Wiki Internetseiten.
  • Fehler melden ... öffnet die Wiki-Seite, welche beschreibt, wie man einen Bug meldet
  • Hilfe konfigurieren ... welches ein Pop-up-Menü öffnet mit Optionen, um Betrachter und Datenbanken auszuwählen, von denen die Hilfe gelesen werden kann. Diese Option erlaubt dem Benutzer, entweder den Online-Dokumente-Bereich der Lazarus-CCR Internetseite, einige andere Internetseiten, welche die Dokumente enthalten, oder einen lokalen Speicher für die Dokumentation (Dies wird eventuell die Voreinstellung werden, wenn das Hilfesystem völlig entwickelt ist.) zu spezifizieren. Derzeit ist die Voreinstellung, wenn Sie Ihren Editor Cursor platzieren über einem Schlüsselwort der FreePascal Components Library FCL oder der RunTime Library RTL (aber nicht der Lazarus Components Library LCL) und dann <<F1>> drücken, werden Sie zu der geeigneten Definition auf der Internetseite geleitet. DIESER BEREICH IST NOCH IN ARBEIT
  • Über Lazarus Zeigt eine Pop-up-Box mit einigen Informationen über Lazarus.

Eventuell wird es einen vollständigen Online-Hilfeservice geben, mit Informationen über die Pascal-Schreibweise, die Benutzung der IDE, wie man es gebraucht, Modifizierung oder Erstellung von Komponenten, und Hinweise darüber, wie man verschiedene Aufgaben erfüllt. Dieser Teil des Dokumentationsabschnitts (was Sie gerade lesen) repräsentiert den Anfang des Prozesses. Wir brauchen Beiträge von jedem, der sich in der Lage dazu fühlt, sie bereitzustellen: Das Wiki ist sehr einfach zu bearbeiten.

Die Button-Leiste

Eine kleiner Symbolleisten Bereich links im Haupt Editor Fenster, genau unter dem Hauptmenü und links von der Komponenten Palette, enthält eine Gruppe von Schaltflächen, welche häufig genutzte Hauptmenü Auswahlen wiederholt:

Neue Unit, Öffnen (mit einem Pfeil zur Anzeige einer drop-down Liste der zuletzt geöffneten Dateien), Speichern, Alles speichern, Neues Formular, Formular/Unit wechseln (zeigt entweder das Formular oder den Quellcode der Unit), Units anzeigen, Formulare anzeigen, Start, Pause, Einzelschritt hinein, Einzelschritt darüber (die letzten beiden sind Debugger-Funktionen).

Die Komponentenpalette

Eine tabbed Symbolleiste, welche eine große Anzahl von Icons anzeigt, die üblich genutzte Komponenten für die Formularerstellung vertreten.

Jeder tab bewirkt die Anzeige von verschiedenen Gruppen von Icons, die eine zweckmäßige Gruppe von Komponenten vertreten. Das ganz linke Icon in jeder tabbed Gruppe ist ein schräger linksgerichteter Pfeil, genannt das Auswahlwerkzeug.

Wenn Sie den Mauszeiger über irgendein Icon der Komponentenpalette bewegen, ohne auf das Icon zu klicken, wird der Titel dieser Komponente aufpoppen. Beachten Sie, dass jeder Titel mit einem 'T' beginnt - das bedeutet 'Typ' oder richtiger 'Klasse' der Komponente. Wenn Sie eine Komponente für die Verwendung in einem Formular auswählen, wird die Klasse zum type Abschnitt des interface Teils der Unit hinzugefügt (üblicherweise als Teil des gesamten TForm1), und eine instance dieser Klasse wird zum var Abschnitt hinzugefügt (üblicherweise als Variable Form1). Jede Methode die Sie design to be used by the Formular oder seine Komponenten (d.h. Prozeduren oder Funktionen) wird im implementation Teil der Unit platziert.

In der folgenden Liste der Komponenten werden Sie Links zu Dateien finden, die Beschreibungen der Units enthalten, in denen sie vorkommen. Wenn Sie etwas über die Eigenschaften einer bestimmten Komponente herausfinden wollen, lohnt es sich oft, auf die Vererbung dieser Komponente zu schauen und dann die Eigenschaften des Basistyps anschauen, von dem sie abgeleitet ist. Zum Beispiel, um TMaskEdit zu verstehen ist es auch hilfreich, TCustomMaskEdit zu untersuchen.

TABS (Die Namen sind größtenteils selbstbeschreibend.):

Laz de comp stand.jpg
Oft benutzte Komponenten: TMainMenu, TPopupMenu, TButton, TLabel, TEdit, TMemo, TToggleBox, TCheckBox, TRadioButton, TListBox, TComboBox, TScrollBar, TGroupBox, TRadioGroup, TCheckGroup, TPanel, TActionList
Laz de comp addit.jpg
weitere, oft benutzte Komponenten: TBitBtn, TSpeedButton, TStaticText, TImage, TShape, TBevel, TPaintBox, TNotebook, TLabeledEdit, TSplitter, TTrayIcon, TMaskEdit, TCheckListBox, TScrollBox, TApplicationProperties, TStringGrid, TDrawGrid, TPairSplitter, TColorBox, TColorListBox, TChart
Laz de comp common.jpg
TTrackBar, TProgressBar, TTreeView, TListView, TStatusBar, TToolBar, TUpDown, TPageControl, TTabControl, TImageList
Laz de comp dialog.jpg
TOpenDialog, TSaveDialog, TSelectDirectoryDialog, TColorDialog, TFontDialog, TOpenPictureDialog, TSavePictureDialog, TCalendarDialog, TCalculatorDialog (wenn Printer4Lazarus installiert ist auch TPrinterSetupDialog, TPrintDialog und TPageSetupDialog)

Verschiedene hilfreiche Dialog Prozeduren oder Funktionen erscheinen nicht auf der Palette, sind aber einfach zu nutzen als direkte Aufrufe von ihrem Quellprogramm.

Für verschiedene gute Beispiele der Benutzung der Komponenten schauen Sie im $LazarusPath/lazarus/examples Unterverzeichnis ihrer Quellen Installation nach. Viele der Programme zeigen, wie man Dialoge und andere Komponenten direkt verwendet, ohne Benutzung der IDE und der Komponentenpalette oder die eine separate Formulardefinitionsdatei haben. Alle Komponenten sind vollständig und ausdrücklich definiert im Haupt-Pascalprogramm. Andere Beispielprogramme machen völlig Gebrauch von der IDE.

Einige Beispiele arbeiten nicht sofort: Sie müssen möglicherweise mit den Pfaden und Zugriffsrechten von Dateien oder Verzeichnissen spielen. Wenn Sie einige der Beispiele kompilieren wollen stellen Sie sicher, dass Sie Lese-/Schreibrechte für die Dateien und Verzeichnisse haben, oder Sie kopieren die Dateien in ein Verzeichnis, für das Sie die entsprechenden Rechte haben.

Versuchen Sie das 'testall' Programm zu starten, um ein Menü der verfügbaren Komponenten zusammen mit kleinen Beispiel Testformularen für die meisten von ihnen zu sehen; dann kontrollieren Sie den Code um herauszufinden, wie sie funktionieren!

  • Misc
Laz de comp misc.jpg
TColorButton, TSpinEdit, TFloatSpinEdit, TArrow, TCalendar, TEditButton, TFileNameEdit, TDirectoryEdit, TDateEdit, TCalcEdit, TFileListBox, TXMLPropStorage, TIniPropStorage, TbarChart, TButtonPanel, TIDEDialogLayoutStorage
  • Data Controls
Laz de comp data con.jpg
Datensensitive Komponenten, welche weitgehend die Standard und Additional Gruppen wiederholen aber einsetzbar sind für Datenbanken: TDBNavigation, TDBText, TDBEdit, TDBMemo, TDBImage, TDBListBox,TDBComboBox, TDBCheckBox, TDBRadioGroup, TDBCalendar, TDBGroupBox, TDBGrid
  • Data Access
Laz de comp data acc.jpg
TDatasource, TSdfDataSet (Package SDFLaz), TFixedFormatDataSet (Package SDFLaz), TMemDataset (Package MemDSLaz), TDbf (Package DBFLaz)
  • System
Laz de comp syste.jpg
TTimer, TIdleTimer, TLazComponentQueue, THTMLHelpDatabase, THTMLBrowserHelpViewer, TProcess, TSimpleIPCClient, TSimpleIPCServer, TXMLConfig
  • SynEdit
Laz de comp syned.jpg
Eine Gruppe von Komponenten to help interfacing with other languages and software tools. SynEdit is an advanced multi-line edit control, for Borland Delphi, Kylix and C++Builder. It supports Syntax Highlighting and code completion, and includes exporters for html, tex and rtf. It is a full-VCL/CLX control, meaning it is not a wrapper for Microsoft Windows controls, and no run-time library is required; this make SynEdit a crossplatform component. Compatibility with FreePascal is also planned, and SynEdit is the edit component in Lazarus IDE. see synedit at sourceforge. TSynEdit, TSynAutoComplete, TSynExporterHTML, TSynMacroRecorder, TSynMemo, TSynPasSyn, TSynCppSyn, TSynJavaSyn, TSynPerlSyn, TSynHTMLSyn, TSynXMLSyn, TSynLFMSyn, TSynUNIXShellScriptSyn, TSynCssSyn, TSynPHPSyn, TSynTeXSyn, TSynSQLSyn, TSynMultiSyn

Um die Komponentenpalette zu nutzen, muss ein Formular im Editor geöffnet sein (falls nicht wählen Sie Datei -> Neues Formular). Klicken Sie auf das Icon im geeigneten Tab der Palette für die Komponente, die Sie verwenden wollen, dann klicken Sie auf das Formular, in der Nähe wo die Komponente erscheinen soll. Wenn die gewünschte Komponente erscheint, dann können Sie sie durch klicken mit der Maus auswählen, an die exakte Stelle auf dem Formular verschieben und ihre Größe anpassen. Adjustments can be made to the appearance either by altering the picture itself on the Form using the mouse, oder durch Änderung der relevanten Eigenschaft im Objekteditor für diese Komponente.

Wenn Sie zusätzliche Komponenten installieren, entweder jene, die Sie selbst geschrieben haben, oder einige, die als Package von einer anderen Quelle kommen, dann werden extra tabs mit den relevanten Icons in ihrer Komponentenpalette erscheinen. Diese neuene Komponenten können ausgewählt und in ihrem Formularen verwendet werden auf die selbe Weise, wie die mit Lazarus gelieferten Komponenten.

Der Debugger

Ist noch zu schreiben.

siehe auch IDE Fenster - Debuggen

Die Lazarus-Dateien

   (Dank an Kevin Whitefoot.)
   (Hinzufügungen von Giuseppe Ridinò, User:Kirkpatc und Tom Lisjac)

Wenn Sie speichern, wählen Sie eigentlich nur zwei Dateien aus:

  xxx.pas und yyy.lpr 

(Sie speichern mehr als das, aber die beiden sind diejenigen, die Sie benennen müssen). Die Projektdatei (lpr) und die Unitdatei (pas) müssen nicht denselben Namen haben, weil Lazarus freundlicherweise der Unit (im Quellcode) den selben Namen gibt wie den Dateinamen, unter dem Sie speichern. Genauso bekommt ein Programm den Namen der Projektdatei (Das muss so sein, weil ansonsten der Compiler möglicherweise die Unit später nicht finden könnte, wenn sie in der Projektdatei verwendet wird). Natürlich werden aus Konsistenzgründen alle Verweise auf unit1 auf xxx geändert.

Wenn Sie also versuchen, ein Projekt mit Namen again zu speichern - dabei wird versucht, again.pas und again.lpr anzulegen - wird das schiefgehen, weil Unit-Namen und Programmnamen denselben Namensraum verwenden. Die doppelten Namen werden abgelehnt.

So, das kommt dabei heraus:

e:/lazarus/kj/lazhello:
total 4740  free 76500
-rwxrwxrwx   1 kjwh     root  4618697 Mar 24 11:19 again.exe
-rw-rw-rw-   1 kjwh     root     3002 Mar 24 11:21 again.lpi
-rw-rw-rw-   1 kjwh     root      190 Mar 24 11:18 again.lpr
-rw-rw-rw-   1 kjwh     root      506 Mar 24 11:08 againu.lfm
-rw-rw-rw-   1 kjwh     root      679 Mar 24 11:08 againu.lrs
-rw-rw-rw-   1 kjwh     root      677 Mar 24 11:08 againu.pas
-rw-rw-rw-   1 kjwh     root     2124 Mar 24 11:08 againu.ppu
-rwxrwxrwx   1 kjwh     root      335 Mar 24 11:07 ppas.bat

Haben Sie gemerkt, dass viel mehr Dateien entstanden sind, als die beiden, die wir eigentlich speichern wollten?

Hier ist eine kurze Bemerkung über jede Datei:

again.exe: Das ausführbare Hauptprogramm. Unter Windows wird eine "exe"-Erweiterung hinzugefügt. Unter Linux gibt es keine Dateierweiterung. Im Normalfall ist diese Datei riesig, da viele Debugging-Symbole in der Programmdatei enthalten sind. Starten sie das "strip" Dienstprogramm, um sie zu entfernen und die Größe des ausführbaren Programms wesentlich zu schrumpfen.

again.lpi: Dies ist die Haupdatei eines Lazarus Projekts (Lazarus Project Information); die equivalente Delphi Hauptdatei einer Anwendung ist die .dpr Datei. Sie wird in einem XML Format gespeichert.

again.lpr: Die Hauptprogramm Quelldatei. Trotz seiner Lazarus-spezifischen Erweiterung ist es eigentlich eine völlig normale Pascal Quelldatei. Sie hat eine uses Anweisung, die dem Compiler angibt, welche Units er braucht. Beachten Sie, dass das Program Statement das Programm nicht notwendigerweise gleich nennen muss wie den Dateinamen.

againu.lfm: Hier speichert Lazarus das Layout der Formularunit. Lazarus braucht das, um eine Resourcen-Datei zu erzeugen, die im Initialisierungsteil der againu.pas Unit verwendet wird. Es ist möglich, Delphi .dfm -Dateien in der IDE in das .lfm-Format zu wandeln. Verwenden Sie dazu Werkzeuge->DFM in LFM-Datei konvertieren.

again.lrs: Dies ist die erzeugte Ressourcen Datei. Beachten sie, dass dies keine Windows Ressourcen Datei ist.

againu.pas: Die Unit, welche den Code für das Formular enthält.

again.ppu: Dies ist die kompilierte Unit.

ppas.bat: Dies ist ein einfaches Script zum Linken des Programms in eine ausführbare Datei. Wenn die Kompilierung erfolgreich war, wird es vom Compiler gelöscht.

Mitwirkende und Änderungen

Diese Seite wurde importiert von der epikwiki Version.

  • Created initial page and template. T. Lisjac - 11/04/2003 VlxAdmin
  • Inserted a note containing instructions for writing your first Lazarus Program. Suggest an administrator places it in the appropriate place on the Tutorial menu. 3/09/2004 User:Kirkpatc
  • Per above, moved Chris's writeup to the main body of the tutorial VlxAdmin
  • Began to insert text describing the Lazarus Editor - more to follow! 24 Mar 2004 User:Kirkpatc
  • Added some more to Lazarus Editor section of Tutorial. 25 Mar 2004 User:Kirkpatc
  • Added screenshots and revised some of the page formatting VlxAdmin 3/25/2004
  • Moved some of kwhitefoot's comments into Tutorial section. Formatting not quite right, but have to go to bed now! 26 Mar 2004 User:Kirkpatc
  • Formatted, added credits and comments. Removed original notes. VlxAdmin 3/26/2004
  • More material added to Editor section of tutorial. 26 Mar 2004 User:Kirkpatc
  • More material added describing the Main Menu. Renamed 'Hello World' to 'Getting Started' and moved it to nearer the top. 31 March 2004 User:Kirkpatc
  • Abschnitt einegfügt zum Start Untermenü. Some general editing (eg ended each entry with a period to ensure consistency). 9 Apr 2004 User:Kirkpatc
  • Inserted a new section on How to get started with MySQL in FPC/Lazarus. 13 Apr 2004 User:Kirkpatc
  • Abschnitt über MySQL von hier gelöscht: er wurde in den Lazarus Datenbanken Abschnitt des Tutorials kopiert. 14 Apr 2004 User:Kirkpatc
  • Added some more to the description of the Editor Main Menu. 18 Apr 2004 User:Kirkpatc
  • Abschnitt zum Einstellungen Untermenü hinzugefügt. 19 Apr 2004 User:Kirkpatc
  • Abschnitt zum Komponenten Untermenü hinzugefügt. 4 May 2004 User:Kirkpatc
  • Werkzeuge Untermenü Beschreibung hinzugefügt (unvollständig). 7 May 2004 User:Kirkpatc
  • Einige Screenshots hinzugefügt zu den Menü Beschreibungen. 9 May 2004 User:Kirkpatc
  • Fixed a bit in Environment Options - thanks VincentSnijders. 14 May 2004 User:Kirkpatc
  • Mehr Hinzufügungen zum Werkzeuge Untermenü. 19 May 2004 User:Kirkpatc
  • Added a section on the Button Bar and started work on The Component Palette. 20 May 2004 User:Kirkpatc
  • Posted a description file for the StdCtrls unit of the LCL, in the hope that people will add comments. 26 May 2004 User:Kirkpatc
  • Edited the StdCtrls file, removing a lot of repetitive material and doing some formatting. It is still far too long. 28 May 2004 User:Kirkpatc
  • Expanding on the Components Palette. 5 June 2004 User:Kirkpatc
  • Added a lot to the DialogExamples page. 10 June 2004 User:Kirkpatc
  • Beachtliche Revision der StdCtrls Seite, hopefully making it clearer and encouraging people to contribute - particularly in the 'Description' sections. 14 June 2004 User:Kirkpatc
  • Added pages for Menus and Dialogs units (linked to Component Palette description) - please feel free to add to these pages. 14 June 2004 User:Kirkpatc
  • Seite für Common Controls hinzugefügt (linked to Component Palette). 16 June 2004 User:Kirkpatc
  • MaskEdit Seite hinzugefügt (linked to Component Palette). 17 June 2004 User:Kirkpatc
  • Buttons und ExtCtrls Seiten hinzugefügt (linked to Component Palette). 17 June 2004 User:Kirkpatc
  • Edited MainMenu component description page. 23 June 2004 User:Kirkpatc
  • Some additions to Common Controls. 28 June 2004 User:Kirkpatc
  • A new tutorial on Text-mode Pascal programming has been added. 5 July 2004 User:Kirkpatc
  • Kleinere Änderungen an ComCtrls, ExtCtrls, Environment Menu. 10 July User:Kirkpatc
  • Added FormsTxt, component description page for Component Palette. 20 July 2004 User:Kirkpatc
  • Einige Korrekturen an ConsoleModePascal. 21 July 2004 User:Kirkpatc
  • Einige kleine Änderungen an ComponentPalette. 22 July 2004 User:Kirkpatc