Lazarus Tutorial/hu

From Free Pascal wiki
Jump to: navigation, search

Deutsch (de) English (en) español (es) suomi (fi) français (fr) magyar (hu) Bahasa Indonesia (id) italiano (it) 日本語 (ja) 한국어 (ko) македонски (mk) Nederlands (nl) português (pt) русский (ru) slovenčina (sk) shqip (sq) 中文(中国大陆)‎ (zh_CN) 中文(台灣)‎ (zh_TW)


Lazarus Tananyag


Itt indul a Lazarus tananyag. Nyugodtan bővítsd a saját tapasztalataiddal.

Áttekintés

Ebben a cikkben megismerheted a Lazarus felépítését, alapvető működését.

Ennek az oldalnak az elkészítéséhez az "IDE fordítás a 0.9.28.2-es verzióhoz" honosítás lett felhasználva. A Lazarus 1.2.2 kiadásától kezdődően a frissített és jelentősen kibővített magyar fordítások részei a hivatalos kiadásnak, így az egyes elemek kisebb-nagyobb mértékben eltérő szöveggel jelenhetnek meg.

A Lazarus egy ingyenes és nyílt forráskódú fejlesztőeszköz a Free Pascal fordítóhoz, ami szintén ingyenes és nyílt forráskódú. A Lazarus IDE (képernyő kép) egy stabil és lehetőségekben gazdag programozási környezet egyedülálló grafikus és konzolos alkalmazások készítéséhez. Jelenleg a Lazarus Linux-on, Mac OS X-en és Win32-n fut és egy testre szabható forráskód szerkesztőt, vizuális form tervezőt, csomagkezelőt, hibakeresőt és a Free Pascal-lal való teljes GUI integrációt kínál.

Első lépések - Ez első Lazarus programod!

(Köszönet User:Kirkpatc-nek)

Szerezd meg, telepítsd (A Lazarus telepítése) és indítsd el a Lazarus-t, amely elérhetővé teszi egyúttal a Free Pascal fordítót is.

Néhány ablak fog megjelenni az asztalon: a főmenü felül, az Objektum felügyelő a bal oldalon a Lazarus Forráskód szerkesztő a legnagyobb területen, és egy előre elkészített Form1 című ablak a forráskód szerkesztő mögött.

A felső menüablakban, a menüsor alatt található egy sor lapfül. Ha nem a 'Standard' lap van kiválasztva, klikkelj rá az egérrel. Majd keresd meg a 'Button' (gomb) ikont (egy téglalap OK felirattal), és klikkelj rá az egérrel. Ezután klikkelj a Form1-re, a közepétől egy kicsit balra. Egy 'Button1' feliratú gomb fog megjelenni. Most újra klikkelj a 'Standard' lap 'Button' ikonjára, és helyezz el egy újabb gombot a Form1-en, most a közepétől egy kicsit jobbra: egy 'Button2' feliratú gomb jelenik meg.

Most klikkelj a 'Button1'-re, hogy kiválaszd. Az Objektum felügyelő meg fogja jeleníti a Button1 objektum tulajdonságait. A felső részben található a 'Caption' tulajdonság, a megjelenített 'Button1' értékkel. Klikkelj rá a beviteli mezőre, és írd át a 'Button1'-et 'Klikklej rám'-ra. Ha ENTER-t nyomsz vagy egy másik beviteli mezőre klikkelsz, láthatod, hogy a Form1-en lévő Button1 felirata megváltozik 'Klikkelj rám'-ra. Most klikkelj az Események fülre az Objektum felügyelőben, hogy láthasd a különböző eseményeket, amelyeket a gombhoz lehet rendelni. Ezek: OnClick, OnEnter, OnExit stb. Válaszd ki az OnClick-hez tartozó beviteli mezőt; egy '...' feliratú gomb fog megjelenni. Amikor erre klikkelsz, automatikusan a Forráskód szerkesztőbe kerülsz, és a kurzor a következő kódrészleten belül lesz:

procedure TForm1.Button1Click(Sender: TObject);
begin
  { most írd be: }    Button1.caption := 'Klikkelj rám újra'; 
end;

Nyomd meg az F12-t, hogy visszakerülj a Form1 szerkesztőablakába, a Forráskód szerkesztőből.

Most szerkeszd a Button2 tulajdonságait: klikkelj a Button2 feliratú gombra, hogy megjelenjenek a tulajdonságai az Objektum felügyelőben. Változtasd meg a Caption tulajdonságát 'Kilépés'-re. Most válaszd ki az Események fület, és klikkelj az OnClick melletti beviteli mezőre, majd a '...' gombra, és a Forráskód szerkesztőbe kerülsz a következő kódrészletbe:

procedure TForm1.Button2Click(Sender: TObject);
begin
  { most írd be: }   Close;
end;

Most mentsd el a munkádat (ments gyakran!!) a Projekt -> Projekt mentése másként menüponttal, majd add meg a fájlnevet: pl. projekt1.pas

Nyomd meg újra az F12-t, hogy a Form1 szerkesztőablakába kerülj. Most már készen állsz a fordításra. Ennek a legegyszerűbb módja a Projekt -> Futtatás kiválasztása a felső menüből, vagy az F9 megnyomása. Így először le lesz fordítva a program, majd összefűzve, és futtatva.

Az Üzenetek szöveges ablak fog megjelenni mindenféle fordítási információval, de nemsokára a Form1 megjelenik a rácspontok nélkül. Ez az alkalmazásod fő ablaka, várva, hogy megnyomd a gombokat, vagy bármi mást csinálj vele.

Próbálj meg ráklikkelni a 'Klikkelj rám' feliratú gombra. A gomb felirata meg fog változni 'Klikkelj rám újra'-ra. Ha még egyszer ráklikkelsz, már nem változik meg a felirata.

Most klikkelj a 'Kilépés' feliratú gombra. Az ablak be fog záródnia és a program kilép. Az eredeti Form1 szerkesztőablak megnyílik újra a rácspontokkal, készen állva a további szerkesztésre.

Második menet

Nyisd meg újra a mentett projektedet. A Form1 ablakban klikkelj a 'Klikkelj rám' gombra (Button1), hogy jelöld ki. Válaszd ki az Események fület az Objektum felügyelőben, klikkelj az OnClick esemény beviteli mezőjébe, majd a megjelenő '...' gombra, hogy újra a megfelelő kódrészletbe kerülj.

Szerkeszd át a kódot ezek szerint:

procedure TForm1.Button1Click(Sender: TObject);
{ Használd a Tag tulajdonságot, 0-ra, majd 1-re való állításával }
begin
  if Button1.Tag = 0 then
  begin
    Button1.Caption := 'Klikkelj rám';
    Button1.Tag := 1;
  end
  else
  begin
    Button1.Caption := 'Klikkelj rám újra';
    Button1.Tag := 0;
  end;
end;

Mentsd a munkádat, fordítsd le és futtasd a programot. A bal oldali gombon most a két felirat fog váltakozni minden klikkeléskor.

A többi már rajtad múlik!

Ha jobban szeretnél konzolos vagy szöveges Pascal programokat írni (például kezdő Pascal kurzust folytatsz, vagy programokat kell írnod batch módhoz, vagy rendszer-közeli használathoz), akkor is használhatod a Lazarus-t a szerkesztéshez, fordításhoz és futtatáshoz. Ideális környezetet teremt a Pascal programozáshoz. Lásd: Szöveges módú Pascal.

A szerkesztő

Amikor először futtatod a Lazarus-t, egy sor különálló ablak fog megjelenni az asztalodon.

Az első címe, ami az asztal felső részén helyezkedik el Lazarus IDE vXXXXXX - project1 (ami az éppen megnyitott projekt neve szerint fog változni). Ez a fő vezérlő ablak, amely a főmenüt és a komponens palettát tartalmazza.

LazMain Win32 hu.png

A címsor alatt található a főmenü, a szokásos menüpontokkal, és néhány Lazarus-specifikus menüvel. Ez alatt néhány gomb (ami bizonyos menüpontok gyors elérésére szolgál) és a komponens paletta.

A főablak alatt, balra fog megjelenni az Objektum felügyelő:

LazObjInsp Win32 hu.png

Az objektum felügyelőtől jobbra a Forráskód szerkesztő:

LazSrcEditor Win32 hu.png

Továbbá egy kisebb ablak a forráskód szerkesztő fölött (ez a Form tervező):

LazForm1 Win32 hu.png

Ha ez nem látszik azonnal, megjelenítheted az F12 gombbal, ami a Forráskód szerkesztő és a Form tervező közötti átváltásra szolgál. A Form ablak az az ablak, ahol az alkalmazásod felületét fogod tervezni, a Forráskód szerkesztő pedig az, ahol az alkalmazásodhoz tartozó kódot. Az Objektum felügyelő működésének részletesebb leírása a Komponens paletta leírása után következik.

Amikor egy új projektet kezdesz (vagy először indítod el a Lazarus-t) egy alapértelmezett Form fog létrejönni, ami egy ablakból áll, rajta a komponensek elhelyezését segítő rácspontokkal, valamint az ablak címsorában megszokott gombokkal. Ha a Form-on belülre kattintasz, megjelennek a Form tulajdonságai az Objektum felügyelőben.

További ablakok, amelyek megjelenhetnek a munkád során: a Projekt felügyelő, ami a projektedhez felhasznált fájlok részleteit tartalmazza, valamint lehetőséget nyújt új fájlok hozzáadásához és fájlok törléséhez a projektből; az Üzenetek ablak, ami a fordító üzeneteit, hibákat, jelentéseket tartalmaz a projekteddel kapcsolatosan; ha a Lazarus egy terminál ablakból lett elindítva, az eredeti terminál látható marad, és a részletes fordítói információk oda fognak kerülni.

A főmenü

A fő menüsor a következő elemeket tartalmazza: Fájl Szerkesztés Keresés Nézet Projekt Futtatás Csomag Eszközök Környezet Ablak Súgó

Megszokott módon, a menüpontok kiválaszthatók az egérrel, vagy az Alt+F lenyomásával.

Fájl menü

LazFileMenu Win32 hu.png
  • Új unit: Egy új unit fájl létrehozása (Pascal forrás).
  • Új form: Egy új form létrehozása: mind a vizuális, mind a Pascal forrás hozzá lesz rendelve a projekthez.
  • Új ...: Egy listából választhatod ki, hogy milyen típusú dokumentumot szeretnél létrehozni.
  • Megnyitás ...: Egy létező fájl megnyitása.
  • Visszaállítás: A fájl minden változásának elvetése, és visszaállítása az eredeti állapotra.
  • Legutóbbi megnyitása ...: A legutóbb szerkesztett dokumentumok listájából egy fájl megnyitása.
  • Mentés: Az aktuális fájl elmentése az eredeti fájlnévvel. Ha nincs neve, a rendszer kérni fog egyet tőled (mint a Mentés másként ... esetén).
  • Mentés másként ...: Megadhatod, hogy hová és milyen néven szeretnéd menteni az aktuális fájlt.
  • Minden mentése: Minden, a szerkesztőben megnyitott fájl mentése.
  • Bezárás: Az aktuális fájl bezárása.
  • Minden szerkesztett fájl bezárása: Minden, a szerkesztőben megnyitott fájl bezárása. Rákérdez, hogy mented-e a változásokat.
  • Könyvtár tisztítása ...: Egy párbeszédablakban megadhatod, hogy milyen szűrők alapján töröljön fájlokat a Lazarus egy adott könyvtárból. Hasznos a .bak és egyéb régről maradt fájlok törléséhez.
  • Nyomtatás ...: A rendszernyomtató használata a kijelölt fájl kinyomtatásához. Ez a menü elem nem jelenik meg alapértelmezetten; telepítened kell alapértelmezetten a $Lazdir/components/printers/design/printers4lazide.pas-t és újra kell fordítanod az IDE-t.
  • Újraindítás: A Lazarus újraindítása - hasznos, ha a fájlok reménytelenül összekeveredtek!
  • Kilépés: Kilépés a Lazarus-ból, rákérdez a szerkesztett fájlok mentésére.

Szerkesztés menü

LazEditMenu Win32 hu.png
  • Visszavonás: A legutolsó szerkesztési művelet visszavonása (csak a forráskód szerkesztőben működik).
  • Újra: A Visszavonással visszavont művelet újra-végrehajtása.
  • Kivágás: A kijelölt szöveg vagy egyéb elem törlése, és vágólapra helyezése.
  • Másolás: A kijelölt szöveg másolása a vágólapra.
  • Beillesztés: A vágólap tartalmának beillesztése a kurzor pozíciójától kezdődően. Ha éppen van kijelölve szöveg, akkor az felülíródik a vágólap tartalommal.
  • Kijelölt szöveg behúzásának növelése: A kijelölt szöveg behúzásának növelése a beállított értékkel (Környezet -> Beállítások -> Szerkesztő -> Általános -> Behúzás és tabulátorok). Ez hasznos a Pascal kód formázásához, mivel így jobban átláthatóvá teheted a programod szerkezetét.
  • Kijelölt szöveg behúzásának csökkentése: A kijelölt szöveg behúzásának csökkentése a beállított értékkel.
  • Kijelölt szöveg körbezárása ...: Egy megnyíló ablakban adhatod meg, hogy milyen kifejezésekkel szeretnéd körbezárni a kijelölt kódrészletet (begin ... end; try ... except; try ... finally; repeat ... until; { ... } stb.).
  • Kijelölt szöveg megjegyzéssé alakítása: Megjegyzéssé alakítja a kijelölt szöveget, minden sor elé // -t helyezve.
  • Kijelölt szöveg kikommentezése: A komment jelek eltávolítása.
  • Megjegyzés be-/kikapcsolása: A kijelölt kódrészlet elé helyezi a komment ( // ) jeleket, ha nincsenek előtte, illetve eltávolítja őket, ha ott vannak.
  • $IFDEF beillesztése ...: {$IFDEF} fordítói direktíva beillesztése, amelynek a szerkezetét egy megnyíló ablakban lehet meghatározni.
  • Kijelölt szöveg rendezése ...: Sorok (vagy kifejezések vagy bekezdések) redezése ábécé rendbe; megadható, hogy növekvő vagy csökkenő sorrendben, illetve, hogy érzékeny legyen-e kis-/nagybetűre. Hasznos lehet pl. listák, függvények rendezéséhez.
  • Kijelölt szöveg nagybetűsre alakítása: A kijelölt szöveget nagybetűsre alakítja.
  • Kijelölt szöveg kisbetűsre alakítása: A kijelölt szöveget kisbetűsre alakítja.
  • Tab-ok cseréje szóközökre a kijelölt szövegben: A kijelölt szöveg minden TAB karakterét kicseréli a beállított mennyiségű szóközre (Környezet -> Beállítások -> Szerkesztő -> Általános -> Behúzás és tabulátorok).
  • Sorok tördelése a kijelölt szövegben: Ha bármelyik sor hosszabb 80 karakternél, illetve a beállított sorhossznál (Környezet -> Beállítások -> Szerkesztő -> Megjelenés -> Margó és hasábköz -> Jobb margó), akkor a sort megtöri a kifejezés határánál.
  • Kijelölés ...: Lehetővé teszi kódrészletek kijelölését bizonyos feltételek alapján.
  • Beszúrás karaktertáblából: Lehetővé teszi a billentyűzeten nem megtalálható karakterek beszúrását.
  • Szöveg beszúrása: Egy felugró menüből kiválasztható szabványos szövegek beszúrására ad lehetőset. Ilyenek pl.: CVS kulcsszavak, GPL megjegyzés, felhasználó neve, vagy a jelenlegi dátum és idő.
  • Kód kiegészítése: Kiegészíti a kurzornál lévő kódot. Tartalomérzékeny és rengeteg időt lehet megtakarítani vele. Például osztályokat, illetve azok tulajdonságait hozhatod létre, függvények implementációt szúrhatod be, vagy nem deklarált, de felhasznált változók deklarációját hozhatod létre vele. Lásd Lazarus IDE eszközök.
  • Áthelyezés új függvénybe ...: A kijelölt kódrészlet felhasználása egy új függvény létrehozásához.

Keresés menü

LazFindMenu Win32 hu.png
  • Keresés ...: Hasonlóan a legtöbb grafikus szövegszerkesztőhöz, itt is egy megnyíló új ablakban adhatod meg a keresendő szöveget, a szokásos keresési feltételekkel.
  • Következő keresése, Előző keresése: Értelemszerűen, az előzőleg megadott szöveg újra keresése, a megadott irányban.
  • Keresés fájlokban ...: Szöveg keresése fájlokban: egy megnyíló új ablakban adhatod meg, hogy melyik fájlokban szeretnél az adott szövegre keresni.
  • Csere: Hasonló a Kereséshez; a kereső ablakban adhatod meg, hogy a keresett szöveget mire szeretnéd cserélni.
  • Bővített keresés: Úgy tudsz szövegre keresni, hogy közben változtathatod a keresett szöveget. A forráskód szerkesztő alsó sávjában adhatod meg a keresendő szöveget, és azonnal megjelennek a találatok a forráskódban kiemelve.
  • Ugrás sorhoz ...: A kurzor mozgatása az adott sorhoz.
  • Ugrás vissza: Ugrás az előző pozícióhoz. Minden hibára való ugráskor, az IDE elmenti az előző pozíciót, így ezzel a funkcióval mindig eggyel visszább tudsz ugrani.
  • Ugrás előre: Ugrás a következő pozícióhoz. Visszavonja az Ugrás vissza parancsot.
  • Ugrási pont hozzáadása az előzményekhez: Hozzáadja a jelenlegi pozíciót az ugrási történethez.
  • Ugrás a következő hibára, Ugrás az előző hibára: A fordító által generált hibalista alapján ugorhatsz a hiba helyére a forráskódban előre vagy hátra.
  • Egy szabad könyvjelző hozzáadása: Az aktuális sor megjelölése a következő szabad könyvjelzőként, és hozzáadása a könyvjelző-listához.
  • Ugrás a következő könyvjelzőre, Ugrás az előző könyvjelzőre: Ugrás számsorrendben az előző vagy a következő könyvjelzőhöz.
  • Kód blokk másik végének megkeresése: Ha egy begin parancson áll a kurzor, akkor a hozzátartozó end-re ugrik, és fordítva.
  • Kód blokk kezdetének megkeresése: Annak a függvénynek a begin parancsára ugrik a kurzor, amelyiknek a belsejében éppen áll.
  • A kurzornál lévő kifejezés deklarációjának megkeresése: A kurzornál lévő kifejezés deklarációjára ugrik. Ha a fájl, amelyikben deklarálva van nincs megnyitva, akkor megnyílik automatikusan. (További információk)
  • A kurzornál lévő fájl megnyitása: Megnyitja azt a fájlt, amelyiknek a neve megegyezik a kurzornál lévő névvel. Hasznos a projektben használt include és unit fájlok megnyitásához.
  • Ugrás include direktívához: Ha a kurzor egy inkludált fájlban van, akkor oda fog ugrani, ahol a fájlhoz tartozó {$include} direktíva található.
  • Azonosító referenciáinak megkeresése ...: Előállít egy listát azokról a helyekről, ahol az adott azonosító referenciája megtalálható.
  • Azonosító átnevezése ...: Lehetővé teszi egy adott azonosító egyidejű átnevezését a megadott hatókörben.
  • Függvénylista ...: Előállít egy listát minden függvényről - ami az aktuális fájlban található - a deklarációjuk sorszámával együtt.

Nézet menü

LazViewMenu Win32 hu.png

A különböző ablakok és panelek megjelenítését vezérelheted innen. Azok az ablakok, amelyek meg vannak nyitva, előtérbe hozhatók, illetve amelyek nem voltak megnyitva, innen megnyithatók.

  • Objektum felügyelő: Az ablak, amely általában az asztal bal oldali részét foglalja el, és az éppen tervezés alatt álló form tulajdonságait tartalmazza. A form-on bármelyik komponensre kattintva, megjelennek annak tulajdonságai az Objektum felügyelőben. Van egy panel a felső részben, ahol a form komponens-struktúrája található. Az adott komponens, amit szerkeszteni szeretnél, ezen keresztül is kiválasztható. Az alsó részben található a tulajdonság- és eseményszerkesztő rész, amelyeket a lapfülekkel tudsz átváltani.
  • Forráskód szerkesztő: A fő ablak, amelyben a programod forráskódját szerkesztheted.
  • Üzenetek: Az ablak, amelyik a fordító üzeneteit jeleníti meg.
  • Kód böngésző: Egy ablak, amely általában a képernyő jobb oldali részén jelenik meg, és a jelenleg a forráskód szerkesztőben aktív oldalon lévő unit vagy program struktúráját tartalmazza faábrában. A faábrában a függvényeken (metódusokon) kívül a változók, típusok és konstansok is megjelennek. Ha a Forráskód szerkesztőben átváltasz egy másik lapra, frissítened kell a frissítés gombbal.
  • FPDoc szerkesztő: Megnyitja az FPDoc szerkesztőt, ahol a programodhoz dokumentációt készíthetsz.
  • Kód tallózó: Egy új ablakban különböző kifejezésekre kereshetsz az összes Lazarus-ban regisztrált kódban, beleértve a projektedet is, sokféle feltétel alapján.
  • Komponensek: A Lazarus-ba telepített komponensek között böngészhetsz, illetve kereshetsz egy új ablakban, többféle nézetben.
  • ToDo lista: Megnyithatod egy új ablakban a tennivalók listáját.
  • Ugrás előzmények ...: Egy új ablakban megjelenítheted az előző ugrásokat.
  • Unit-ok...: Egy olyan ablak, amely az aktuális projektben használt unit és include fájlokat tartalmazza. Itt ki tudsz közülük választani - akár egyszerre többet is - és az OK gombbal megnyithatod őket a Forráskód szerkesztőben.
  • Form-ok...: Egy olyan ablak, amely az aktuális projektben használt form-okat tartalmazza. Ki tudsz jelölni egyet vagy többet és az OK gombbal megnyithatod őket szerkesztésre.
  • Unit függőségek: Egy olyan ablakot nyit meg, ahol az aktuális projektben használt unit-ok függőségeit nézheted meg egy faábrában.
  • Unit információ: Egy ablakban kategorizáltan megtekintheted az éppen a Forráskód szerkesztőben megnyitott unit adatait.
  • Form/unit nézet átváltása: Átválthatsz a Forráskód szerkesztőről a Form tervező nézetbe, és vissza. Általában az F12 gyorsbillentyű van hozzárendelve ehhez a funkcióhoz.
  • Keresési eredmények: A Keresés fájlokban ... funkcióhoz tartozó eredmények tudod megjeleníteni ezzel a menüponttal.
  • Horgony szerkesztő: Az éppen kijelölt vezérlő horgonyzását szerkesztő ablakot nyitja meg.
  • Komponens paletta: Elrejtheted/megjelenítheted a fő ablakban lévő komponens palettát.
  • IDE gyorsgombok: Elrejtheted/megjelenítheted a fő ablakban lévő gyorsgombokat (pl. megnyitás, mentés stb.).
  • Hibakereső ablakok: Egy felugró menüből választhatod ki azt az eszközt, ami a hibakereséshez szükséges. Lásd: hibakereső.
  • IDE belügyek: Az IDE-hez tartozó állapotelemző ablakok nyithatók meg innin.

Projekt menü

LazProjectMenu Win32 hu.png
  • Új projekt ...: Egy új projekt létrehozása. Egy új ablakban választhatod ki, hogy milyen típusú projektet szeretnél létrehozni.
  • Új projekt fájlból ...: Kiválaszthatsz egy fájlt, ami alapján új projektet hozhatsz létre.
  • Projekt megnyitása ...: Egy létező projektet nyithatsz meg.
  • Legutóbbi projekt megnyitása ...: Almenüként megjelenő listából választhatod ki a legutóbb megnyitott projektek közül azt, amelyiket szeretnéd megnyitni.
  • Projekt bezárása: Bezárhatod az éppen megnyitott projektet. Ha változás történt a legutóbbi mentés óta, akkor egy párbeszédablak jelenik meg, ahol a változásokat mentheted, illetve eldobhatod. Ezután a projekt bezárul, és megjelenik a Projekt Varázsló ablak, ahol új projektet hozhatsz létre, megnyithatsz egyet, konvertálhatsz egy Delphi projektet, vagy kiléphetsz a Lazarus-ból.
  • Projekt mentése: Mentheted a teljes projektet, attól függetlenül, hogy történt-e változtatás.
  • Projekt mentése másként ...: Ezzel a paranccsal a projektet tulajdonképpen átnevezheted, illetve másolatot hozhatsz létre róla más néven. Az eredeti projekt fájlok is megmaradnak.
  • Projekt közzététele: Másolat készítése a teljes projektről, bizonyos feltételek szerint. A feltételekben megadhatod, hogy milyen fájlokat szeretnél, illetve nem szeretnél a másolatban közzétenni. Ez a parancs hasznos, ha a projektednek például csak a forráskódját szeretnéd közzétenni, a sok .ppu, .o és egyéb fájlok nélkül. Lásd Lazarus IDE eszközök.
  • Projekt felügyelő: Egy megnyíló ablakban láthatod a projekted szerkezetét egy faábrában. Itt megtalálhatók a projekt fájljai, szükséges csomagok, stb. Továbbá lehetőséged van új fájlokat hozzáadni, megnyitni, törölni, és a projekt beállításait szerkeszteni.
  • Projekt opciók ...: Egy megnyíló ablakban szerkesztheted a projekt beállításait, úgy mint az alkalmazás tulajdonságait (cím, cél fájlnév, stb.), form-okat, stb.
  • Fordító beállításai ...: Egy megnyíló ablakban szerkesztheted a projekttel kapcsolatos Free Pascal fordítói beállításokat.
  • Szerkesztett fájl hozzáadása a projekthez: Ha megnyitottál egy projekten kívüli fájlt, akkor ezzel a paranccsal adhatod hozzá a projekthez.
  • Eltávolítás a projektből ...: Egy megnyíló ablakban lévő listából választhatod ki azokat a fájlokat, amelyeket szeretnél eltávolítani a projektből.
  • Forráskód megjelenítése: Ez a parancs megnyitja a Forráskód szerkesztőben a projekt fő program fájlját (.lpr vagy .pas).

Futtatás menü

Fordítás folyamatban...