Lazarus Tutorial/ru

From Free Pascal wiki
Jump to: navigation, search

Deutsch (de) English (en) español (es) suomi (fi) français (fr) magyar (hu) Bahasa Indonesia (id) italiano (it) 日本語 (ja) 한국어 (ko) македонски (mk) Nederlands (nl) português (pt) русский (ru) slovenčina (sk) shqip (sq) 中文(中国大陆)‎ (zh_CN) 中文(台灣)‎ (zh_TW)

Это начальное руководство по Lazarus. Пожалуйста, не стесняйтесь добавлять свои пункты сюда.

Обзор

Lazarus это бесплатный инструмент разработки с открытым кодом, предназначенный для также бесплатного компилятора с открытым кодом Free Pascal (object pascal). IDE Lazarus (screenshot) это стабильная богатая возможностями среда разработки для создания самостоятельных графических и консольных приложений. В настоящее время она работает на Linux, FreeBSD и Win32 и предоставляет настраиваемый редактор кода и визуальную среду создания форм вместе с менеджером пакетов, отладчиком и GUI полноcтью интегрированным с компилятором FreePascal.

Начнем - Ваша первая Lazarus-программа!

(Благодарим User:Kirkpatc)

Найдите, установите(Installing Lazarus) и запустите Lazarus, который кроме того содержит и компилятор FreePascal.

На экране появятся несколько окон: главное окно вверху, Инспектор Объектов (Object Inspector) слева, занимаюший большую часть экрана Редактор Кода Lazarus (Lazarus Source Editor), и готовое к использованию окно Form1 поверх окна Редактора.

В главном окне сверху, под строкой меню располагается строка вкладок. Если вкладка 'Standard' еще не выбрана, выберите ее, щелкнув на ней левой кнопкой мыши. Затем найдите иконку Button (прямоугольник с текстом 'Ok' на нем) и щелкните на ней мышкой. Затем щелкните в окне Form1, где-нибудь слева от середины. Появится затененный прямоугольник с надписью 'Button1'. Вновь щелкните на иконке Button на вкладке Standard и щелкните на Form1 где-нибудь справа от центра: появится прямоугольник с надписью 'Button2'.

Теперь щелкните на Button1 чтобы выбрать ее. Инспектор Объектов отобразит свойства объекта Button1. Не далеко от верхнего края располагается свойство с именем 'Caption', в котором отображается значение 'Button1'. Щелкните в этой строке и измените 'Button1' на 'Нажми меня' (прим.пер.: в оригинальном тексте 'Press'. Далее будет приводиться только русский текст надписей, а оригинальный можно посмотреть на странице с английским текстом). Если вы нажмете клавишу ENTER или щелкнете в другой строке, то увидите, что надпись на первой кнопке Form1 изменилась на 'Нажми меня'. Теперь щелкните в Инспекторе объектов на вкладке Events (События) и вы увидите различные события, на которые может реагировать кнопка. Среди них OnClick, OnEnter, OnExit и так далее. Щелкните в строке справа от OnClick: появится маленькая кнопка с троеточием (...). Если вы ее нажмете, то автоматически перенесетесь в Редактор Кода и курсор окажется в участке кода, начинающегося с:

 procedure TForm1.Button1Click(Sender: TObject);
 begin
   {здесь наберите:}  Button1.caption := 'Нажми еще раз';
   {Редактор уже вставил завершение процедуры}
 end;

Нажмите F12 для переключения от Редактора Кода к окну формы Form1.

Теперь отредактируйте свойства кнопки2 (Button2): щелкните на Button2 для отображения ее свойств в Инспекторе Объектов. Измените свойство Caption на 'Выход' вместо 'Button2'. Теперь перейдите на вкладку событий (Events) и щелкните в строке OnClick. Щелкните на кнопке с троеточием и перенеситесь в Редактор Кода, в тело другой процедуры:

 procedure TForm1.Button2Click(Sender: TObject);
 begin
 {здесь наберите:}   Close;
 {Редактор уже вставил завершение процедуры} 
 end;

Теперь нажмите F12 чтобы увидеть форму Form1 вновь. Теперь вы можете попытаться скомпилировать. Простейшим способом сделать это является выбор в главном меню пункта 'Run' а в появившемся подменю пункта 'Run'. Вы также можете просто нажать клавишу F9. Сначала произойдет компиляция, а затем (если все в порядке) линковка и запуск вашей программы.

Ппромелькнет несколько текстовых окон и будут выведены различные сообщения компилятора, а потом вновь появится окно формы Form1, но уже без точечной сетки; это и есть реальное главное окно вашего приложения, и оно ожидает нажатия кнопок или любого другого вашего действия.

Попробуйте щелкнуть на кнопке 'Нажми меня'. Вы увидите, что надпись на ней сменится на 'Нажми еще раз'. Если вы нажмете еще раз, то на кнопке так и останется надпись 'Нажми еще раз'!!

Теперь щелкните на кнопке с надписью 'Выход'. Окно закроется и программа завершится. Вновь появится окно формы Form1 с точечной сеткой, готовое для редактирования.

Теперь (и вообще почаще) вы можете сохранить свою работу выбрав последовательно пункты меню Project > Save Project As > имя_вашего_файла.pas

Вторая попытка.

Вновь откройте сохраненный вами проект.

На форме Form1 щелкните на кнопке 'Нажми меня' (Button1) чтобы выбрать ее. В Инспекторе Объектов перейдите на вкладку событий (Events), щелкните на строке справа от события OnClick, щелкните на кнопке с многоточием, чтобы перенестись к соответствующему участку кода в Редакторе.

Измените код, на приведенный ниже:

 procedure TForm1.Button1Click(Sender: TObject);
{Используем свойство Tag, устанавливая его в положения 0 или 1}
 begin
   if Button1.tag =0 then
   begin
     Button1.caption := 'Нажми еще раз';
     Button1.tag := 1
   end else
   begin
     Button1.caption := 'Нажми меня';
     Button1.tag := 0
   end
 end;

Сохраните проект, перекомпилируйте и запустите. Левая кнопка теперь циклически меняет свой текст с одного сообщения на другое.

Сделай дело - гуляй смело!

Если вы хотите писать консольные или программы с текстовым интерфейсом на Pascal (например, если вы следуете стандартному курсу изучения программирования на Pascal, или вам нужно написать программу для работы в командном режиме или системную программу) вы также можете использовать Lazarus для написания, компилирования и выполнения ваших программ. Это прекрасная среда для программирования на Pascal. Смотри Console Mode Pascal.

Редактор

Когда вы запускаете Lazarus в первый раз, на вашем рабочем столе появляется набор несвязанных 'плавающих' окошек.

Первое, расположенное в самом верху рабочего стола имеет название Lazarus Editor vXXXXXX - project1 (название зависит от используемой версии и названия открытого проекта). Это главное окно управления проектом и оно содержит Главное Меню и Палитру Компонентов (Component Palette).

Lazmain.jpg

Строкой ниже располагается Главное Меню с обычными пунктами File, Edit, Search, View и некоторыми специфичными для Lazarus. Ниже Слева располагается набор кнопок, предоставляющих быстрый доступ к некоторым функциям главного меню, и справа - Палитра Компонентов. (Примечание переводчика: если при установке вы выбираете русский язык, то весь интерфейс будет на русском, то есть пункты меню, названия окон и вкладок, а также подсказки. В связи с этим далее все названия указаны на русском, а в скобках (на английском) языке. В любой момент можно переключить язык интерфеса в пункте меню Окружение. )

Под окном редактора Lazarus слева располагается окно Инспектора Объектов, а справа Редактор Исходного Кода (Lazarus Source Editor). Может быть и другое окно меньшего размера, озаглавленное Form1, расположенное поверх Редактора Исходного Кода. Если его в данный момент не видно, то можно переключиться к нему, нажав клавишу F12, которая позволяет переключаться между Редактором Исходного Кода и Окном Формы. Окно формы это то место, где вы разрабатываете графический интерфейс вашей программы, а в Редакторе Исходного Кода отображается разрабатываемый вами Pascal-код вашего приложения. Использование Инспектора Объектов детально обсуждается ниже после описания Палитры Компонентов.

Когда вы начинаете новый проект (или впервые запускаете Lazarus) по умолчанию создается стандартная форма, состоящая из прямоугольника с точечной сеткой для более легкого позиционирования различных компонентов на форме и системная строка сверху, которая обычно содержит кнопки Свернуть, Развернуть и Закрыть. Если вы щелкните мышкой в любом месте формы, вы увидите ее свойства в Инспекторе Объектов у левого края экрана.

Другие окна, которые могут появиться в процессе работы: Инспектор проектов, содержащий сведения о файлах, включенных в проект, и позволяющий вам добавлять и удалять файлы из проекта; Окно Messages (Сообщения), отображающее сообщения компилятора, ошибки и отчеты по вашему проекту; если Lazarus был запущен из терминала, то это окно остается запущенным и в нем отображаются подробные сообщения компилятора.

Главное меню

Главное текстовое меню содержит следующие пункты: File Edit Search View Project Run Components Tools Environment Windows Help

Как обычно любой пункт можно выбрать если навести на него курсор и нажать левую кнопку мыши или использовать горячие клавиши (например, клавиатурная комбинация Alt+F открывает меню File. Если меню не открылось, то следует нажимать TAB до тех пор, пока не будет активировано желаемое окно.


Меню Файл (File)

  • Создать модуль (New Unit): Создать новый модуль (Unit, исходный код на Pascal).
  • Создать форму (New Form): Создать новую форму. То есть два файла: саму форму и соответствующий ей файл с Pascal-кодом.
  • Создать... (New...): Открывает всплывающее окно (screenshot) в котором приведены различные типы проектов, которые можно создать (screenshot).
  • Открыть (Open): Открывает диалоговое окно, при помощи которого можно найти и открыть существующий файл.
  • Обратный экспорт (Revert): Отменяет сделанные изменения и возвращает файл в исходное состояние.
  • Сохранить (Save): Сохранить текущий файл под этим же именем. Если имя еще не дано, то система скажет об этом (это подобно пункту Сохранить как).
  • Сохранить как (Save As): Позволяет выбрать папку и имя под которым сохранить текущий файл.
  • Закрыть (Close): Закрывает текущий файл, с выводом сообщения о том следует ли сохранить сделанные изменения.
  • Закрыть все файлы редактора (Close all editor files): Закрывает все файлы, открытые в данный момент в редакторе. Выдаётся сообщение о сохранении изменений.
  • Очистить каталог (Clean directory): Выводится диалог со строками задания фильтров при помощи которых можно очистить текущий каталог. Полезно для удаления .bak файлов ненужных или устаревших проектов.
  • Выход (Quit): Выход из Lazarus с выводом запроса на сохранение всех открытых файлов.

Меню Правка (Edit)

  • Отменить (Undo): Отменяет последнее выполненное действие, переводя редактор в состояние до этого действия.
  • Повторить (Redo): Вновь выполняет ранее отмененное действие.
  • Вырезать (Cut): Удаляет выделенный текст или другой элемент и помещает его в буфер обмена.
  • Копировать (Copy): Создает копию выделенного текста, не затрагивая текст, и помещает её в буфер обмена.
  • Вставить (Paste): Помещает содержимое буфера обмена в позицию курсора. Если есть выделенный текст, то он будет заменен содержимым буфера обмена.
  • Сдвинуть блок вправо (Indent selection): Сдвигает выделенный текст вправо на количество позиций, указанных в настройках Окружение -> Настройки редактора -> Общие -> Отступ блока (Environment -> Editor options -> General -> Block indent). Эта опция удобна для форматирования исходного Pascal-кода для создания блочной структуры.
  • Сдвинуть блок влево (Unindent selection): Удаляет один уровень отступа, сдвигая текст влево на количество позиций, указанных в Отступе блока (Block indent).
  • Заключить выделение в (Enclose selection): Открывает всплывающее меню с набором опций для заключения выделенного текста в программные скобки (begin ... end; try ... except; try ... finally; repeat ... until; { ... } и т. д.).
  • Верхний регистр выделения (Uppercase selection): Преобразует выделенный текст в верхний регистр.
  • Нижний регистр выделения (Lowercase selection): Преобразует выделенный текст в нижний регистр.
  • ТАБ сделать пробелами в выделенном (Tabs to spaces in selection): Преобразует все символы табуляции в выделенном тексте в некоторое количество пробелов, настраиваемое посредством Окружение -> Настройки редактора -> Общие -> Ширина ТАБа(Environment -> Editor options -> General -> Tab widths). Вставляется не фиксированное количество пробелов, а только число необходимое для завершения данного табулятора.
  • Разрыв строк в выделенном (Break lines in selection): Если строка выделенного текста длиннее 80 символов или числа указанного в Окружение -> Настройки редактора -> Дисплей -> Правая граница (Environment -> Editor options -> Display -> Right Margin), то строка текста будет разорвана на границе слова и продолжится со следующей строки.
  • Закомментировать (Comment selection): Закомментировать выделенный текст, добавив в начало каждой строки //.
  • Раскомментировать (Uncomment selection): Удалить символы комментария.
  • Сортировка выбранного (Sort selection): Сортирует строки (слова или параграфы) в алфавитном порядке; настраивается порядок сортировки и чувствительность к регистру. Конечно же, в теле программы это не нужно, но если у вас есть некий список и вам нужно его отсортировать, то можете использовать этот трюк.
  • Выделить (Select): Позволяет выделить текстовый блок. Имеются опции для выделения всего, до скобки, выделить абзац или строку и т. д.
  • Вставить из таблицы символов (Insert from character map): Позволяет вставить специальные символы, такие как символы с акцентами, которые берутся из всплывающей таблицы символов.
  • Вставить текст (Insert text): Вызывает всплывающее меню, позволяющее вставить шаблоны текста, такие как ключи CVS (Author, Date, Header и т. д.) или заметку о GPL, имя пользователя или текущую дату и время.
  • Завершить код (Complete code): Завершает код под курсором. Действия зависят от контекста и позволяют сохранить довольно много времени. Например, можно завершить классы, добавив private переменные, Get и Set методы для доступа к свойствам и тела методов. Если переменной присваивается значение (например, i:=3), то будет добавлено описание переменной. Для процедур, описанных с ключом forward, будет добавлено тело процедуры. Если имеется присвоение событию (OnClick:=), то будут добавлены описание метода и тело метода. Смотри Lazarus IDE Tools.
  • Выделить процедуру (Extract procedure): Использует выделенный текст (один или несколько операторов) для построения новой процедуры.

Меню Поиск (Search)

  • Найти (Find): То же самое, что и в большинстве графических текстовых редакторов: появляется всплывающее диалоговое окно, позволяющее вам ввести строку поиска, а также опции поиска, такие как чувствительность к регистру, искать целые слова, целые выражения, область и направление поиска.
  • Найти впереди (Find Next), Найти сзади (Find previous): искать далее указанную ранее строку в соответствующем направлении.
  • Найти в файлах (Find in files): Искать строку в файлах: всплывающее окно с опциями во всех открытых файлах, во всех файлах проекта или поиск в каталогах; можно задать маску-фильтр для типов файлов.
  • Замена (Replace): Подобна Найти; появляется диалоговое окно со областью ввода искомой строки и текста для замены, а также опций чувствительности к регистру, направления и т.д.
  • Поиск с нарастанием (Incremental find): Поиск строки в то время, пока вы вводите ее. Например, после того, как вы выберете "Поиск с нарастанием" и нажмете "l" будет подсвечена ближайшая буква "l". Если затем вы нажмете "a", редактор найдет следующее "la" и так далее.
  • Переход к строке (Goto line): Перемещает курсор в указанную строку файла.
  • Переход назад (Jump back): Перемещается по файлу назад, к предыдущей закладке (необходимо использовать Добавить точку перехода в историю). Может перемещаться к закладкам в других файлах, открытых в редакторе.
  • Переход вперед (Jump forward): Переместиться к следующей закладке.
  • Добавить точку перехода в историю (Add jump point to history): Добавляет закладку или точку перехода в файл.
  • Просмотр истории перехода (View Jump-History): Просмотреть список закладок в файле: Еще не реализовано.
  • Найти другой конец блока кода (Find other end of code block): Если курсор стоит на begin, то осуществляется поиск соответствующего end и наоборот.
  • Найти начало блока кода (Find code block start): Перемещается к begin процедуры или функции в теле которой находится курсор.
  • Найти описание под курсором (Find Declaration at cursor): Поиск участка кода, где описан выбранный идентификатор. Оно может быть в этом же файле или в любом другом, открытом в редакторе; Если файл еще не открыт, то он будет открыт (так, если процедура или функция описана в classesh.inc, то этот файл будет открыт в Редакторе).
  • Открыть имя файла под курсором (Open filename at cursor): Открывает файл, имя которого выделено курсором. Полезно для просмотра Include файлов или файлов, содержащих другие модули Units, используемые в проекте.
  • Перейти к директиве include (Goto include directive): Если курсор помещен в файле, который включен Included в другой файл, то происходит перемещение в то место другого файла, из которого вызывается включенный.

Меню Вид (View)

Управляет отображением на экране различных окон и панелей.

  • Инспектор Объектов (Object Inspector): Окно, обычно расположенное по левому краю рабочего стола и отображающее возможности текущей формы. Щелчок на любом из компонентов формы приведет к отображению в Инспекторе Объектов деталей компонента (свойств и событий). Чуть выше располагается окно, отображающее древовидную структуру текущего проекта, в этом окне можно также выбрать компоненты формы, что также приведет к отображению их свойств в Инспекторе Объектов. Нижняя, главная, панель имеет две вкладки, позволяющих выбрать режим отображения Свойств (Properties) или Событий (Events). Вкладка Свойства отображает такие свойства, как имя (name), цвет (color), надпись (caption), шрифт (font), размер (size) и т. д.: она содержит два столбца - левый содержит имена свойств, а правый - их текущие значения. Щелкнув на значении свойства, можно изменить его значение через меню или окно настройки.
Вкладка События также имеет два столбца: левый содержит возможные события вроде нажатия кнопки мыши, ассоциированные с данным компонентом, а правый показывает действия, предусмотренные для этих событий. Если действие не определено, то нажатием на кнопку с точками
...
открывается Редактор Исходных текстов, где курсор уже находится в области объявления процедуры, ожидая ввода программы обработки данного события.
  • Редактор исходников (Source Editor): Основное окно для редактирования исходных текстов. Этот редактор очень похож на другие графические текстовые редакторы: мышью можно перемещать курсор по тексту, а нажав левую кнопку мыши и перемещая указатель, можно выделить участок текста. Нажатие правой кнопки вызывает меню, имеющее обычные функции редактирования: Вырезать, Копировать или Вставить, Найти объявление и Открыть файл. В верхней части окна Редактора может быть несколько вкладок, соответствующих файлам, открытым в текущем проекте; нажатием на вкладку выбирается нужный файл. Так можно легко перемещаться по файлам, копировать и вставлять куски текста, выполняя обычные функции редактирования. Редактор исходных текстов выполняет цветовое выделение текста программы, отображая разными цветами метки пунктуации, комментарии, строковые константы и т. д. Он также сохраняет размер отступа от строки к строке, пока его не изменить вручную. Функции и вид Редактора исходников имеют настройки, вызываемые из основного меню выбором Окружение -> Параметры -> Опции Редактора выбором одной или нескольких вкладок в диалоговом окне.
  • Обозреватель кода (Code Explorer): Это окно обычно расположено справа и отображает в древовидной форме структуру кода в текущем блоке или программе. Структура обычно открывается в виде только имен модулей и ветвей для секций интерфейса и реализации, но нажатием на рамку
    +
    слева от ветви открываются ее подветви, достигая более подробной детализации о константах, типах и переменных, а также объявлениях процедур и функций. Если сменить файл, отображаемый в окне Редактора Исходников, нужно нажать кнопку Обновить в обозревателе кода для просмотра структуры нового файла.
  • Модули ... (Units...): Открывается диалоговое окно с перечислением файлов модулей текущего проекта. Щелчком мыши на имени файла выбирается файл; Щелчком на ОК он открывается в Редакторе Исходников. Флажок Множественное выделение позволяет открывать одновременно несколько файлов (но только один будет отображен в окне Редактора Исходников). Эта опция меню очень похожа на опцию Проект -> Инспектор Проекта, но только отображает список файлов модулей и позволяет их открывать.
  • Формы... (Forms...): Открывается диалоговое окно со списком форм в текущем проекте, позволяющее выбрать одну или более форм для отображения.
  • Показать зависимости модулей (View Unit Dependencies): Открывается диалоговое окно, показывающее древовидную стуктуру зависимостей текущего открытого файла модуля. Большинство зависимых файлов будут иметь рамочку владения со знаком +
    +
    , позволяющую просмотреть зависимости отдельного файла рекурсивным способом.
  • Переключатель Форма/Модуль (Toggle form / unit view) F12: Позволяет помещать на верхний уровень отображения либо форму, либо Редактор Исходников, и дает фокус. Если фокус дан Редактору Исходников, можно редактировать исходный код; если фокус имеет форма, можно манипулировать ее компонентами и изменять ее вид. Проще всего переключаться между Редактором и Формой при помощи клавиши F12 на клавиатуре, но тот же самый эффект достигается выбором этой опции основного меню.
  • Сообщения (Messages): Окно, отображающее сообщения компилятора, показывающие ход успешной компиляции или перечисление найденных ошибок.
  • Результат поиска (Search Results): Окно, которое отображает результаты поиска в файлах.
  • Окна отладки (Debug windows): Открывает меню с несколькими опциями управления и конфигурирования работы отладчика. См. ниже описание debugger.

Меню Проект

  • Создать Проект: Создание нового проекта. Диалоговое окно позволяет выбрать тип создаваемого проекта.
  • Создать Проект из файла: Появляется окно для выбора файла, из которого следует создать проект.
  • Открыть Проект Открывается созданный и сохраненный проект. Появляется окно выбора со списком файлов Lazarus Project Information (.lpi).
  • Открыть недавний проект: Появляется список проектов, с которыми работали недавно; выбранный откроется.
  • Сохранить Проект: Походит на Файл -> Сохранить: Сохраняются все файлы текущего проекта; если ранее не сохранялись - будет запрошено имя файла(ов), подобно Сохранить Проект Как...
  • Сохранить Проект Как...: Запрашивается имя файла сохраняемого проекта. По умолчанию предлагается имя Project1.lpi, но лучше дать более выразительное. Lazarus не позволит применить одинаковое имя для файлов проекта и модуля (см. ниже).
  • Опубликовать Проект: Создается полная копия проекта. Эта функция полезна, если нужно переслать кому - либо исходники и установки компилятора. Обычно папка проекта содержит много информации. Большинство ее не нуждается в публикации: файл .lpi содержит сеансовую информацию (наподобие позиций символа * и закладок закрытых модулей) также папка проекта содержит множество файлов .ppu, .o и .exe. Для создания файла .lpi только с базовой информацией и исходниками из всех подпапок и применяется "Опубликовать проект". В диалоге можно настроить фильтр отбора и дальнейшей командой можно заархивировать выходные файлы. См. Lazarus IDE Tools
  • Инспектор Проекта: Открывается диалог древовидного отображения файлов в текущем проекте. Можно добавлять, удалять или открывать выбранные файлы, а также изменять опции проекта.
  • Опции Проекта...: Открывается диалог с вкладками для установки опций Приложения (Заголовок, имя файла вывода), Форм (можно выбрать доступные формы, сделать их автосоздаваемыми при запуске приложения) и Информация (указывающая, какая информация редактора должна сохраняться в закрытых файлах, или только в файлах проекта).
  • Опции Компилятора ...: (Недавно перемещено из меню Запуск). Открывается многостраничное окно с вкладками для настройки компилятора. Вкладка Пути позволяет настроить пути поиска модулей, подключаемых файлов, библиотек и т.д., а также выбрать тип форм (gtk, gnome, win32); Обработка позволяет выбрать правила синтаксического контроля исходных программ, Код позволяет оптимизировать размер и скорость выполнения программ, выбрать тип целевого процессора, типы проверок, размер кучи и т.д.; Связывание позволяет выбрать порядок работы отладчика, статические или динамические библиотеки, передавать опции компоновщику; Сообщения для определения, какие типы сообщений будут сгенерированы; Другое позволяет настроить применение встроенного конфигурационного файла (fpc.cfg) или другого; Унаследованные - показывает диаграмму древовидной структуры для индикации, какие опции унаследованы от уже подключенных модулей; Компиляция для определения команд, выполняемых до или после компиляции, а также возможного использования файлов Make.
  • Добавить файл редактора в Проект: Добавляет редактируемый файл в Проект
  • Убрать из Проекта: Выдает меню файлов, доступных для удаления из проекта.
  • Просмотреть исходный код Проекта: Независимо от того, какой файл редактируется, выдает основной файл программы (.lpr) или основной файл .pas, если отсутствует файл .lpr.
  • View ToDo List:Opens a dialog box with a list of ToDo items associated with this project. This will list any ToDo comments in your project (lines commencing //TODO), and any others in the Lazarus units you have used. You need to Refresh the ToDo items in the dialog (using arrow symbol button of toolbar) before new 'ToDos' appear. The first column of the ToDo list contains numbers you have allocated to your ToDo comments; a simple //TODO comment will appear as a zero, but a comment of //TODO999 (for example) will place the number 999 in the first column. Remember there should be no spaces on the line before //TODO and ToDo comments added after the last save will not be shown!

Меню Запуск

  • Собрать: Запускается сборка (т.е. компиляция) любых файлов проекта, которые были изменены со времени последней сборки.
  • Собрать все: Запускается сборка всех файлов проекта, независимо от наличия изменений.
  • Прервать сборку: Останавливает процесс сборки на ходу – если Вы вспомнили о наличии ошибок и хотите остановить сборку, или система работает слишком долго и очевидно, что-то не так.
  • Запуск: Это обычный путь запуска компилятора и если компиляция прошла успешно, запускается приложение. На самом деле Lazarus сохраняет копию файлов, затем запускает компилятор и компоновщик, затем выполняется собранная бинарная программа.
  • Пауза: Задерживается выполнение работающей программы. Это позволяет проверить промежуточные результаты. Выполнение программы можно продолжить повторным выбором Запуск.
  • Шаг со входом: Применяется совместно с отладчиком, запуская программу на один шаг вплоть до точки, помеченной в исходном тексте.
  • Шаг в обход: Вызывает пошаговое выполнение вплоть до помеченного оператора, пропускает его и продолжает работу с нормальной скоростью. Полезно для изоляции оператора, приводящего к логической ошибке.
  • Запуск до курсора: Запускает выполнение с нормальной скоростью (т.е. не пошагово), пока не встретится оператор, где находится курсор, и произойдет останов. Выполнение продолжится с нормальной скоростью после выбора Запуск.
  • Останов: Прекращается выполнение программы. Продолжить выполнение выбором Запуск нельзя; можно только запустить сначала (перекомпилировать, если необходимо).
  • Параметры Запуска: Открывается многостраничное окно, позволяющее передать программе опции командной строки и параметры; настроить отображение выполняемой программы (например, использовать в Linux удаленный терминал Х); можно изменить некоторые переменные системного окружения.
Важное свойство этого подменю – в возможности активировать терминальное окно, отображающее стандартный консольный ввод/вывод. Если разрабатывается программа консольного режима (не используется графический интерфейс пользователя с формами, кнопками и рамками), то следует установить флажок "Использовать приложение для запуска". Сначала при попытке компиляции и выполнения может появиться нехорошее сообщение
"xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied".  
В этом случае нужно изменить разрешения для соответствующего файла (например, с помощью chmod +x filename, или при помощи утилиты Windows, меняющей разрешения); войдя в систему в качестве root. После этого при запуске программы появится окно консоли, и весь текстовый ввод/вывод (readln, writeln и т.д.) появится в нем.
По окончании выполнения программы на экране появится сообщение "Press enter". Таким образом выведенная программой информация останется на экране для возможности ее прочтения; после нажатия 'enter' окно консоли закроется.
См. Отдельный учебник по программированию в Консольном режиме Pascal.
  • Сброс отладчика: Отладчик приводится в исходное состояние, так что точки останова, значения переменных и т.д. будут «забыты».
  • Собрать файл: Происходит компиляция (сборка) только файла, открытого в Редакторе.
  • Запустить файл: Компиляция, сборка и выполнение только открытого файла.
  • Параметры сборки + запуска: Открывается многостраничное окно с опциями сборки только данного файла, когда выбрано Собрать Проект, позволяющее выбрать рабочий каталог, использовать различные макросы и т.д. Затем файл собирается и выполняется.
Эти последние три опции позволяют открывать (и поддерживать) тестирование проекта. Используйте Файл -> Открыть для открытия файла .lpr, нажатием cancel в следующем диалоге – для его открытия, как "обычного исходника ".

Меню Пакет

  • Новый Пакет: Отображается окно выбора пакета для установки с возможностями настройки работы пакета.
  • Открыть файл пакета: Открывается один из файлов выбранного пакета.
  • Открыть загруженный пакет: Открывается недавно загруженный пакет.
  • Добавить активный модуль в пакет: Файл модуля (текущий в редакторе) помещается в пакет.
  • Диаграмма пакетов: Отображается graph, показывая взаимосвязи используемых пакетов (если не используются иные, будут отображены пакеты Lazarus, а также FCL и LCL).
  • Настройка установленных пакетов: Если созданы некоторые компоненты, здесь их можно настроить.

Меню Сервис

  • Настроить внешние средства: Позволяет добавлять различные внешние средства (обычно макросы) в инструментарий пакета разработчика.
  • Быстрая проверка синтаксиса: Выполняет быструю проверку синтаксиса исходного текста без реальной компиляции. Полезно при разработке длинных и сложных программ, поскольку не тратится время на компиляцию кода с ошибками.
  • Исправить незаконченный блок: Полезная утилита при работе со сложной блочной структурой, когда в каком-либо блоке пропущен 'end'.
  • Исправить несоответствие IFDEF/ENDIF: Полезно при работе со сложной или вложенной структурой макро, если есть подозрение, что пропущена директива ENDIF.
  • Создать строку ресурсов: Делает выбранную строку ресурсной, помещая ее в секцию ресурсных строк. Преимущество ресурса в том, что его можно менять без перекомпиляции проекта!
  • Разница Diff: Сравниваются два файла (или обычно две версии одного файла) для нахождения различий. Имеются опции для игнорирования пробелов в начале или конце строк, а также разницы в концах строк: CR+LF или LF). Полезно для обнаружения изменений после последней корректировки и т.д.
  • Проверить файл LFM в редакторе: Позволяет проверить файл LFM, содержащий настройки текущей формы.
  • Преобразовать модуль Delphi в Lazarus: Помогает перенести приложения Delphi в Lazarus; внося необходимые изменения в исходный файл. См. Lazarus For Delphi Users и Code Conversion Guide.
  • Преобразовать файл DFM в LFM: Для переноса из Delphi в Lazarus: преобразует файлы описания формы из Delphi в Lazarus. См. Lazarus For Delphi Users и Code Conversion Guide.
  • Собрать Lazarus: Запускается обновление Lazarus с недавно загруженными или скорректированными файлами CVS. Нажав кнопку, можно откинуться для наблюдения за происходящим! (процесс виден в окне Сообщения).
  • Параметры сборки Lazarus: Позволяет определить, какие части Lazarus должны быть пересобраны, и как. Например, можно выбрать перестройку только LCL, или пересборку всего, за исключением примеров; можно выбрать, какой использовать интерфейс LCL, выбрать целевую операционную систему и указать другую целевую папку.

Меню Окружение

  • Опции Окружения: Открывается многостраничное окно с вкладками:
    • Файлы - позволяет указать пути: папки по умолчанию, компилятора, папки исходных текстов и временной папки для компиляции;
    • Рабочий стол - опции языка, автосохранения, свойств рабочего стола, подсказок палитры компонентов и командных кнопок;
    • Окно, – для настройки размера и поведения различных окон;
    • Редактор Форм - выбор цветов для редактирования форм;
    • Инспектор Объектов - выбор цветов и высоты элементов;
    • Резервирование - настройка резервирования редактируемых файлов;
    • Именование - настройка расширения имени в именовании файлов Паскаля ('.pp' или '.pas'), сохранять ли файлы с именами в нижнем регистре, выполнять ли автоудаление или автопереименование.
  • Опции Редактора: многостраничное окно с вкладками:
    • Общие - настройка поведения: авто-отступ, подсветка скобок, редактирование перетаскиванием, прокрутка, подсветка синтаксиса, показ подсказок, размер отступа блока и вкладок, лимит откатов;
    • Отображение - опции показа номеров строк, границ, размера и типа шрифта редактора; имеется предварительный просмотр, показывающий расцветку синтаксиса (комментариев, директив, пунктуации, ошибок и точек останова;
    • Привязки клавиш - опции выбора схемы Lazarus или Turbo Pascal;
    • Цвет - позволяет выбор цветовой схемы для различных языков: Object Pascal, C++, Perl, HTML, XML и скриптов оболочки. Имеется панель предварительного просмотра для выбранного языка;
    • Code Tools - позволяет настроить возможности наподобие завершения идентификаторов, специфические шаблоны для завершения кода.
  • Опции Отладчика: многостраничное окно с вкладками:
    • Общие - выбор отладчика: none, GNU debugger (gdb) или gdb через SSH, указание пути к отладчикам, и специфические опции для выбранного отладчика;
    • Протокол событий - указание, когда очищать журнал при работе, и какие сообщения отображать;
    • Исключения языка - выбор исключений для игнорирования;
    • Исключения ОС - возможность добавлять некоторые сигналы, применимые в текущей операционной системе (не осуществлено).
  • Опции Code Tool: многостраничное окно с вкладками:
    • Общие - указание дополнительных путей к исходным кодам, методики перехода;
    • Создание Кода - определяется политика вставки созданных элементов программ;
    • Слова - определяется, как пишутся ключевые слова языка Паскаль – в верхнем или нижнем регистре, или с первой заглавной буквой;
    • Разрыв строк - установка правил разрыва строк (перед или после знаков пунктуации, после ключевых слов и т.д.);
    • Пробел - установка правил автоматического добавления пробелов до или после отдельных элементов синтаксиса – ключевых слов и знаков пунктуации.
  • Редактор определений Code Tools: Здесь можно видеть все внутренние определения для грамматического разбора исходников. Видны все определения, модули, исходники, включая пути к папкам с исходниками. Начиная от установок текущего компилятора FPC, настроек папки исходников Lazarus, папок пакетов и проектов.

Большинство этих установок сгенерированы автоматически, и только для чтения.

  • Пересмотреть папку исходного кода FPC Повторный просмотр папки. Lazarus использует исходники fpc для генерации правильной обработки событий и проверки объявлений. Если произведена смена папки в опциях окружения, то эта папка будет пересмотрена, чтобы lazarus убедился, что работает с версией, находящейся в этом месте. Но если эта папка была сменена без ведома lazarus, то можно получить некоторые ошибки при разработке форм или поиске объявлений. В этом случае возможны два пути:
1. Проверить установки папки исходников в опциях окружения. 
2. Пересмотреть папку исходного кода FPC.

Меню Окно

Содержит список открытых файлов и доступных окон вроде Редактор Исходного Кода, Инспектор Объектов и Инспектор Проекта. Щелчком на имени одного из окон оно выводится "наверх" и получает фокус.

Меню Справка

Имеется три выбора:

  • Оперативная Справка – открывается окно браузера с картинкой бегущего гепарда и несколькими связями на веб-сайты Lazarus, FreePascal и WiKi.
  • Параметры справки – открывается меню с опциями выбора инструмента просмотра и баз данных для чтения информации Справки. Можно указать либо секцию онлайновой документации, либо некоторые другие сайты, либо локальный набор документации (в дальнейшем он будет встроенным, по полном окончании разработки системы помощи).

Сейчас, по умолчанию, если поместить курсор на ключевое слово из FreePascal Components Library FCL, или из RunTime Library RTL (но не из Lazarus Components Library LCL) и нажать <<F1>>, то будет показано подходящее определение на сайте. ЭТА СЕКЦИЯ ПОКА ВСЕ ЕЩЕ В ПРОЦЕССЕ РАЗВИТИЯ.

  • О Проекте Lazarus – отображается многостраничное окно с информацией о установленной версии и участниках проекта Lazarus.

В конечном счете, найдется полная диалоговая услуга Справки с информацией о синтаксисе Pascal, работе с IDE, как использовать, изменять, или создавать компоненты, подсказки о том, как выполнять определенные задачи. Эта часть секции Документация (то, что Вы читаете сейчас) представляет собой начальный этап процесса. Нам нужна помощь любого, кто в силах оказать еe: WiKi очень упрощает редактирование.

Кнопочная панель

Маленькая панель в левой верхней части основного окна, слева от палитры компонентов, имеет набор кнопок, повторяющих наиболее часто применяемые выборы основного меню:

Создать модуль, Открыть (со стрелкой вниз для отображения списка недавно использованных файлов), Сохранить, Сохранить все, Создать форму, Переключить Форма/Модуль (т.е. показать либо форму, либо модуль исходного кода), Показать модули, Показать формы, Запуск (т.е. компиляция и выполнение), Пауза, Шаг со входом, Шаг в обход (последние два – функции отладчика).

Палитра Компонентов

Это панель инструментов с вкладками, показывающая множество иконок, представляющих обычно применяемые компоненты при построении форм.

Каждая вкладка представляет собой набор иконок, составляющих функциональную группу компонентов. Самая левая иконка на каждой вкладке в виде стрелочки называется Средством Выбора.

Если навести курсор мыши на иконку палитры компонентов без нажатия, появится название данной компоненты. Заметьте, что каждое название начинается с 'T', что означает 'Тип', а точнее 'Класс' компоненты. При выборе компоненты для размещения на форме, Class добавится в секцию type раздела interface модуля (обычно в виде части на TForm1), и instance (образец) этого класса добавится в секцию var (обычно как переменная Form1). Все Methods (методы), разработанные для формы или ее компонент (процедуры или функции) будут помещены в раздел implementation модуля.

В приведенном ниже списке компонентов можно найти связи с файлами, которые содержат описания модулей, в которых они найдены. Если нужно узнать о свойствах конкретного компонента, зачастую следует обратить внимание на Наследование этого компонента и просмотреть свойства базового типа, из которого он произведен. Например, для изучения TMaskEdit очень полезно просмотреть TCustomMaskEdit.

ВКЛАДКИ (их имена понятны и не требуют разъяснений):

Component Palette Standart.png
Наиболее часто применяемые компоненты: TMainMenu, TPopupMenu, TButton, TLabel, TEdit, TMemo, TToggleBox, TCheckBox, TRadioButton, TListBox, TComboBox, TScrollBar, TGroupBox, TStaticText, TRadioGroup, TCheckGroup, TPanel, TActionList
Component Palette Additional.png
Дополнительные, часто используемые: TBitBtn, TSpeedButton, TImage, TShape, TBevel, TPaintBox, TNotebook, TLabeledEdit, TSplitter, TMaskEdit, TCheckListBox, TScrollBox, TApplicationProperties, TStringGrid, TDrawGrid, TPairSplitter
Component Palette Common Controls.png
TTrackBar, TProgressBar, TTreeView, TListView, TStatusBar, TToolBar, TUpDown, TPageControl, TImageList
Component Palette Dialogs.png
TOpenDialog, TSaveDialog, TSelectDirectoryDialog, TColorDialog, TFontDialog, TOpenPictureDialog, TSavePictureDialog, TCalendarDialog, TCalculatorDialog

Некоторые полезные процедуры или функции группы Dialog не размещены на Палитре, но легко применяются путем прямого вызова из исходной программы.

Несколько хороших примеров использования компонентов находятся в папке $LazarusPath/lazarus/examples исходной установки. Многие программы показывают способы применения диалогов и других компонентов без использования IDE и палитры компонентов, при наличии файла определения отдельной формы: все компоненты явно и полно определены в основной программе. Другие программы примеров полностью используют IDE.

Некоторые примеры не будут сначала работоспособны: понадобится настройка путей и разрешений для файлов и папок. При желании скомпилировать пример убедитесь, что для файлов и папок установлены разрешения read/write/execute, или скопируйте файлы в папку с подходящими разрешениями.

Попробуйте выполнить программу 'testall' для просмотра меню доступных компонентов совместно с маленькими примерами тестовых форм для большинства из них; затем просмотрите исходный код для понимания принципов их работы!

  • Misc
Component Palette Misc.png
TColorButton, TSpinEdit, TArrow, TCalendar, TEditButton, TFileNameEdit, TDirectoryEdit, TDateEdit, TCalcEdit, TFileListBox
  • Data Controls
Component Palette DataControls.png
Компоненты работы с данными, которые в основном копируют стандартную и дополнительную группы, но применительно к базам данных: TDBNavigation, TDBText, TDBEdit, TDBMemo, TDBImage, TDBListBox,TDBComboBox, TDBCheckBox, TDBRadioGroup, TDBCalendar, TDBGroupBox, TdbGrid
  • Data Access
Component Palette DataAccess.png
TDatasource
  • System
Component Palette System.png
TTimer, TIdleTimer, TProcess
  • SynEdit
Component Palette SynEdit.png
Группа компонентов для сопряжения с другими языками и сервисными программами. SynEdit – продвинутый редактор для Borland Delphi, Kylix and C++Builder. Он поддерживает подцветку синтаксиса и завершение кода, экспорт в html, tex и rtf. Полное управление VCL/CLX, считая, что это не оболочка для управления Microsoft Windows, не нужна библиотека времени выполнения; это делает SynEdit кроссплатформенным компонентом. Также планируется совместимость с FreePascal, и SynEdit является компонентом редактирования в Lazarus IDE. См. synedit at sourceforge. TSynEdit, TSynAutoComplete, TSynExporterHTML, TSynMacroRecorder, TSynMemo, TSynPasSyn, TSynCppSyn, TSynJavaSyn, TSynPerlSyn, TSynHTMLSyn, TSynXMLSyn, TSynLFMSyn, TSynUNIXShellScriptSyn, TSynCssSyn, TSynPHPSyn, TSynTeXSyn, TSynSQLSyn, TSynMultiSyn

Для работы с палитрой нужно открыть форму (если форма не открыта, выбрать Файл -> Создать Форму). Щелкните на иконке нужного компонента на нужной вкладке Палитры, затем щелкните на форме, и этот компонент появится на ней. После этого можно выбрать новый компонент щелчком мыши, переместить его в желаемое место и подогнать размеры. Эти установки можно сделать также с помощью Инспектора Объектов, регулируя значения соответствующих свойств данного компонента.

При установке дополнительных компонентов, разработанных самостоятельно, или полученных со стороны, появятся дополнительные вкладки с соответствующими иконками на Палитре компонентов. Эти новые компоненты могут быть выбраны и использованы на формах, как и те, что поставлены по умолчанию.

Отладчик

Писал и редактировал: Romlo

Настройки

Чтобы пользоваться отладчиком, должны быть установлены галочки:

проект > параметры компилятора > вкладка "Связывание" >

  • галочка "Выдавать номера строк в ошибках времени исполнения"
  • галочка "Генерировать отладочную информацию для GDB (замедляет сборку)"

Кнопки

Управление отладкой производится вот этими пятью кнопками:

Buttons debugger.PNG

  • Зеленый треугольник - "Запуск" - скомпилировать и запустить приложение под отладчиком.
  • Вертикальные палочки - "Пауза" - здесь серые, а вообще синие - это пауза, можно приостановить приложение, например, при трассировке.
  • Квадратик - "Останов" - здесь серый, а вообще красный - закрыть приложение. Это если оно повисло (напр. в бесконечном цикле).

Остальные две кнопки используются при трассировке программы, про которую мы поговорим подробнее.

Трассировка

Трассировать программу - значит выполнять её шаг за шагом, построчно. Для трассировки какого-либо участка программы, нужно установить в нужном месте "точку останова". Для этого надо найти начало участка программы в редакторе кода, а затем щёлкнуть по его номеру слева. При этом сама строчка выделится красным, а рядом с номером появится красный кружок.

str debugger.PNG

После нажатия на "запуск", знак вопроса в кружке должен смениться галочкой. Если вместо галочки там крестик, значит, точка останова не была установлена по каким-то причинам. В этом случае лучше ещё раз проверить настройки и перезапустить Lazarus. Если же всё получилось, продолжим. Далее, нужно вызвать то событие, при котором начнёт выполняться данный участок кода (то есть если вы поставили точку останова в начале button1_click, например, то теперь вам надо нажать эту кнопку). При этом должен показаться редактор кода. Ранее красная строчка теперь станет серой, а галочка в кружке сменится стрелочкой:

str2 debugger.PNG

Вот теперь и вспомним про те две кнопки, что мы не рассмотрели. первая называется "Шаг со входом", вторая - "Шаг в обход". Смысл первой заключается в том, что если сейчас вы "стоите" на строчке с какой-то процедурой или функцией, то нажав эту кнопку, вы перейдете на эту процедуру и будете выполнять пошагово уже её. Когда она закончится, вы вернётесь обратно, но уже на следующую строку. Как несложно догадаться, нажав на вторую кнопку, вы не зайдёте в процедуру, она просто выполнится, а вы перейдёте на следующую строку.

Отдельно надо сказать, что "Шаг со входом" не работает, если функция, на которой вы "стоите", экспортирована из библиотеки (например, в WinAPI-функцию вы зайти не сможете).

Также имеется возможность просматривать содержимое переменных, для этого надо просто навести на неё мышку прямо в редакторе кода, во всплывающей подсказке будет указан адрес переменной и её содержимое:

var debugger.png

Ну и в дополнение к сказанному добавлю, что чтобы продолжить выполнение программы в обычном режиме (если вам надоело её трассировать), достаточно нажать кнопку "запуск". Ну а чтобы убрать точку останова, надо закрыть приложение и ещё раз щёлкнуть по номеру строки, на которой эта точка стоит. ну и после этого заново откомпилировать приложение.

Файлы Lazarus

   (Благодарим Kevin Whitefoot.)
   (ДОбавления от Giuseppe Ridinò, User:Kirkpatc и Tom Lisjac)

Когда вы выполняете сохранение на самом деле вы сохраняете два файла:

  xxx.pas и yyy.lpr 

(Вы сохраняете и больше, но это те файлы, которым вы даете имена). Файл проекта (lpr) и файл модуля (pas) должны иметь разные имена, потому что Lazarus присваивает имя модулю (в исходном коде) также, как и имя файла модуля, а программе по имени файла проекта (это необходимо сделать иначе компилятор может впоследствии не найти модуль по ссылке на него в файле проекта). Во избежание противоречий (ошибок) следует изменить все упоминания Unit1 на xxx.

Итак, если вы сохранили проект под именем again, то попытка сохранить again.pas и again.lpr приведет к ошибке, потому что имена модуля и программы одинаковы, что приводит к ошибке двойного именования.

Ниже приведен пример именования:

e:/lazarus/kj/lazhello:

total 4740  free 76500
-rwxrwxrwx   1 kjwh     root  4618697 Mar 24 11:19 again.exe
-rw-rw-rw-   1 kjwh     root     3002 Mar 24 11:21 again.lpi
-rw-rw-rw-   1 kjwh     root      190 Mar 24 11:18 again.lpr
-rw-rw-rw-   1 kjwh     root      506 Mar 24 11:08 againu.lfm
-rw-rw-rw-   1 kjwh     root      679 Mar 24 11:08 againu.lrs
-rw-rw-rw-   1 kjwh     root      677 Mar 24 11:08 againu.pas
-rw-rw-rw-   1 kjwh     root     2124 Mar 24 11:08 againu.ppu
-rwxrwxrwx   1 kjwh     root      335 Mar 24 11:07 ppas.bat

Заметьте, что появилось более двух файлов, как следовало бы ожидать.

Ниже приведена краткая справка по каждому файлу:

again.exe: Основной исполняемый файл программы. Win32 добавляет расширение "exe". Linux этого не делает. В Linux это файл будет иметь большой размер вследствие того, что включает отладочную информацию. Запустите утилиту "strip" чтобы удалить ее и значительно снизить размер исполняемого файла.

again.lpi: Это основной файл проекта Lazarus (Lazarus Project Information); эквивалент основного файла приложения в Delphi с расширением .dpr. Он сохраняется в XML формате.

again.lpr: Исходный код основной программы. Не смотря на специфичноое для Lazarus расширение на самом деле это обычный Pascal-код. Он содержит строку Uses, помогающую компилятору найти все необходимые модули Отметим, что программа называется не аналогично имени данного файла.

againu.lfm: Это файл, в котором Lazarus хранит описание формы. Lazarus использует его для создания файла ресурсов, который включает секцию инициализации модуля againu.pas. Файл Delphi с расширением .dfm может быть преобразован в lfm-формат в IDE Lazarus из главного меню: Tools->Convert DFM file.

again.lrs: Это автоматически генерируемый файл ресурсов. Заметьте, что это не файл ресурсов Windows.

againu.pas: Модуль, содержащий код формы.

again.ppu: Это скомпилированный модуль.

ppas.bat: Это простой скрипт, связывающий программу для создания выполняемого файла. Если компиляция успешна, он удаляется компилятором.

Авторство и изменения

Эта страница была импортирована из epikwiki версии.

  • Created initial page and template. T. Lisjac - 11/04/2003 VlxAdmin
  • Inserted a note containing instructions for writing your first Lazarus Program. Suggest an administrator places it in the appropriate place on the Tutorial menu. 3/09/2004 User:Kirkpatc
  • Per above, moved Chris's writeup to the main body of the tutorial VlxAdmin
  • Began to insert text describing the Lazarus Editor - more to follow! 24 Mar 2004 User:Kirkpatc
  • Added some more to Lazarus Editor section of Tutorial. 25 Mar 2004 User:Kirkpatc
  • Added screenshots and revised some of the page formatting VlxAdmin 3/25/2004
  • Moved some of kwhitefoot's comments into Tutorial section. Formatting not quite right, but have to go to bed now! 26 Mar 2004 User:Kirkpatc
  • Formatted, added credits and comments. Removed original notes. VlxAdmin 3/26/2004
  • More material added to Editor section of tutorial. 26 Mar 2004 User:Kirkpatc
  • More material added describing the Main Menu. Renamed 'Hello World' to 'Getting Started' and moved it to nearer the top. 31 March 2004 User:Kirkpatc
  • Inserted section on Run sub-menu. Some general editing (eg ended each entry with a period to ensure consistency). 9 Apr 2004 User:Kirkpatc
  • Inserted a new section on How to get started with MySQL in FPC/Lazarus. 13 Apr 2004 User:Kirkpatc
  • Deleted the section on MySQL from here: it has been copied to Lazarus Database section of tutorial. 14 Apr 2004 User:Kirkpatc
  • Added some more to the description of the Editor Main Menu. 18 Apr 2004 User:Kirkpatc
  • Added section on Environment sub-menu. 19 Apr 2004 User:Kirkpatc
  • Added section on Components sub-menu. 4 May 2004 User:Kirkpatc
  • Adding Tools sub-menu description (incomplete). 7 May 2004 User:Kirkpatc
  • Added some screenshots to Menu descriptions. 9 May 2004 User:Kirkpatc
  • Fixed a bit in Environment Options - thanks VincentSnijders. 14 May 2004 User:Kirkpatc
  • More additions to Tools sub-menu. 19 May 2004 User:Kirkpatc
  • Added a section on the Button Bar and started work on The Component Palette. 20 May 2004 User:Kirkpatc
  • Posted a description file for the StdCtrls unit of the LCL, in the hope that people will add comments. 26 May 2004 User:Kirkpatc
  • Edited the StdCtrls file, removing a lot of repetitive material and doing some formatting. It is still far too long. 28 May 2004 User:Kirkpatc
  • Expanding on the Components Palette. 5 June 2004 User:Kirkpatc
  • Added a lot to the DialogExamples page. 10 June 2004 User:Kirkpatc
  • Considerable revision of the StdCtrls page, hopefully making it clearer and encouraging people to contribute - particularly in the 'Description' sections. 14 June 2004 User:Kirkpatc
  • Added pages for Menus and Dialogs units (linked to Component Palette description) - please feel free to add to these pages. 14 June 2004 User:Kirkpatc
  • Added page for Common Controls (linked to Component Palette). 16 June 2004 User:Kirkpatc
  • Added MaskEdit page (linked to Component Palette). 17 June 2004 User:Kirkpatc
  • Added Buttons, ExtCtrls pages (linked to Component Palette). 17 June 2004 User:Kirkpatc
  • Edited MainMenu component description page. 23 June 2004 User:Kirkpatc
  • Some additions to Common Controls. 28 June 2004 User:Kirkpatc
  • A new tutorial on Text-mode Pascal programming has been added. 5 July 2004 User:Kirkpatc
  • Minor changes to ComCtrls, ExtCtrls, Environment Menu. 10 July User:Kirkpatc
  • Added FormsTxt, component description page for Component Palette. 20 July 2004 User:Kirkpatc
  • Some corrections to ConsoleModePascal. 21 July 2004 User:Kirkpatc
  • Some small changes to ComponentPalette. 22 July 2004 User:Kirkpatc