Lazarus Tutorial/sk

From Free Pascal wiki
Jump to: navigation, search

Deutsch (de) English (en) español (es) suomi (fi) français (fr) magyar (hu) Bahasa Indonesia (id) italiano (it) 日本語 (ja) 한국어 (ko) македонски (mk) Nederlands (nl) português (pt) русский (ru) slovenčina (sk) shqip (sq) 中文(中国大陆)‎ (zh_CN) 中文(台灣)‎ (zh_TW)

Úvod

Lazarus je free a open source vývojový nástroj pre prekladač FreePascal (Object Pascal), ktorý je tiež free a open source. IDE Lazarus je stabilné a vzhľadovo bohaté programovacie prostredie pre vytváranie samostatne bežiacich (.exe) grafických a konzolových aplikácií. Aktuálne beží na systémoch Linux, FreeBSD a Win32 a poskytuje prispôsobiteľný editor zdrojového kódu a vizuálnu tvorbu formulárov s manažérom balíčkov, debuggerom a úplnou integráciou prekladača FreePascal do GUI.

Začnite - Váš prvý program Lazarus!

(Vďaka User:Kirkpatc)

Získajte, nainštalujte a spusťte Lazarus, ktorý vám sprístupní aj prekladač FreePascal. Na pracovnej ploche sa objavia viaceré okná: hore základné menu, vľavo Object Inspector, Lazarus Source Editor zaberajúci najväčšiu časť plochy, pripravené okno formulára Form1, prekrývajúce Source Editor a vpravo Code Explorer.

Na vrchu základného okna Lazarus, pod riadkom základného menu, je riadok záložiek, tzv. Paleta komponentov. Ak nie je vybratá záložka 'Standard', vyberte ju kliknutím myšou. Potom nájdite ikonu Button (obdĺžnik s nápisom 'OK') a kliknite na ňu myšou. Potom kliknite na okno Form1, niekde vľavo od stredu. Objaví sa tieňovaný obdĺžnik s návestím 'Button1'. Znova kliknite na ikonu Button na záložke Standard a kliknite na Form1 niekde pravo od stredu: objaví sa obdĺžnik s návestím 'Button2'.

Teraz kliknite na Button1, čím ho vyberiete. Object Inspector bude zobrazovať vlastnosti objektu Button1. Niekde hore je vlastnosť nazvaná 'Caption', ktorá zobrazuje hodnotu 'Button1'. Kliknite do políčka a zmeňte 'Button1' na 'Press'. Ak stlačíte ENTER alebo kliknete myšou na iné políčko uvidíte, že sa prvé tlačítko na Form1 zmení na 'Press'. Teraz kliknite na záložku Events v Object Inspectore, čím uvidíte rôzne udalosti, ktoré môžu byť spojené s tlačítkom. Tieto zahŕňajú OnClick, OnEnter, OnExit atď. Vyberte políčko vpravo od OnClick: objaví sa malé tlačítko s tromi bodkami (značka ...). Keď kliknete na neho, automaticky budete prepnutí do Source Editor a kurzor bude umiestnený v časti začiatku kódu, kde dopíšte:

  procedure TForm1.Button1Click(Sender: TObject);
  begin
    {now type:}    Button1.caption := 'Press again';
    {the editor has already completed the procedure with}
  end;

Stlačte F12, čím sa prepnete z okna Editora zdrojového kódu do okna Form1. Teraz upravte vlastnosti Button2: kliknite na Button2, aby ste zobrazili jeho vlastnosti v Object Inspectore. Zmeňte jeho vlastnosť Caption na 'Exit' namiesto 'Button2'. Teraz vyberte záložku Events a kliknite na políčko pre OnClick. Kliknite na značku ... a budete prepnutý do Editora zdrojového kódu, uprostred inej procedúry, kde dopíšte:

  procedure TForm1.Button2Click(Sender: TObject);
  begin
  {now type:}   Close;
  {the editor has already completed the procedure with} 
  end;

Opäť stlačte F12, aby ste znova videli okno Form1. Teraz ste pripravený vyskúšať preklad. Najjednoduchšia cesta ako to urobiť, je vybrať zo základného menu 'Run' a potom voľbu 'Run' v podmenu. Alebo môžete jednoducho stlačiť F9. Týmto najprv preložíte a potom (ak je všetko v poriadku) spojíte a spustíte svoj program.

Objavia sa nejaké textové okná a budú vypísané všetky typy správ prekladača, ale nakoniec sa možno (ak preklad prebehne správne) znova objaví vaše okno Form1, ale bez mriežky z bodiek; to je skutočné základné okno vašej aplikácie a čaká na stlačenie tlačítka alebo na inú akciu s ním.

Skúste stlačiť tlačítko s návestím 'Press'. Všimnite si, že jeho návestie sa zmení na 'Press again'. Ak ho stlačíte znova, stále bude hovoriť 'Press again'!!

Teraz kliknite na tlačítko označené 'Exit'. Okno bude zatvorené a program skončí. Znova sa objaví pôvodné okno Form1 s mriežkou bodiek, pripravené na ďalšiu editáciu.

Svoju prácu môžete teraz uložiť (a často!!) zvolením Project > Save As > vyše_zvolené_meno_súboru.pas.

Druhá časť

Znova otvorte uložený Projekt. V okne Form1 kliknite na tlačítko 'Press' (Button1) aby steho vybrali. V object Inspectore vyberte záložku 'Events', kliknite do políčka vpravo od OnClick, kliknite na značku ..., aby ste sa dostali na príslušné miesto kódu v Editore zdrojového kódu.

Upravte svoj kód, aby vyzeral takto:

  procedure TForm1.Button1Click(Sender: TObject);
 {Makes use of the Tag property, setting it to either 0 or 1}
  begin
    if Button1.tag =0 then
    begin
      Button1.caption := 'Press again';
      Button1.tag := 1
    end else
    begin
      Button1.caption := 'Press';
      Button1.tag := 0
    end
  end;

Uložte svoju prácu, preložte a spusťte. Ľavé tlačítko bude teraz prepínať medzi dvoma alternatívnymi návestiami.

Zvyšok je na vás!

Ak dávate prednosť písaniu konzolových alebo textových programov v Pascale (napríklad ak skúšate nasledujúci základný kurz Programovania v Pascale alebo potrebujete napísať program pre použitie v dávkovom móde alebo pre systémové programovanie), tiež môžete použiť Lazarus na jeho úpravy, preloženie a spustenie. Tým sa lazarus stáva ideálnym prostredím pre vývoj v Pascale. Viď Programovanie v Pascale pre konzolu.

Editor

Pri prvom spustení IDE Lazarus sa na vašej pracovnej ploche objaví niekoľko samostatných, nespojených alebo plávajúcich okien.

Prvé z nich, zobrazené pri hornom okraji pracovnej plochy má titulok Lazarus Editor vXXXXXX - project1. Toto je základné ovládacie okno vášho projektu a obsahuje Základné menu, paletu komponentov a panel nástrojov.

LazMain GTK2.png

V riadku pod titulkom je Základné menu (Main Menu) so zvyčajnými položkami pre funkcie File, Edit, Search, View atď, spolu s niektorými možnosťami, ktoré sú špecifické pre Lazarus. Nižšie je umiestnený Panel nástrojov s množinou BitButtonov, ktoré sprístupňujú niektoré voľby základného menu a vpravo od neho je Paleta komponentov (Component Palette).

Pod základným oknom IDE Lazarus sa ešte vľavo obajví okno Object Inspector a vedľa neho okno Editora zdrojového kódu (Lazarus Source Editor). Môže sa objaviť ešte jedno menšie okno, nazvané Form1, prekrývajúce Editor zdrojového kódu. Ak nie hneď viditeľné, môžete ho zbraziť stlačením klávesy F12, ktorá prepína medzi zobrazením Editora zdrojového kódu a zobrazením formulára. Okno formulára, je tým, na ktorom budete budovať grafické rozhranie svojej aplikácie, kým okno Editora kódu zobrazuje zdrojový kód Pascalu patriaci aplikácii, ktorú navrhujete. Práca s Object Inspectorom je detailnejšie rozobratá ďalej, pri popise Palety komponentov.

Keď začnete nový projekt (alebo ak prvý krát spustíte Lazarus) je vytvorený štandartný formulár, ktorý obsahuje bodkovanú mriežku, pomáhajúcu umiestniť rôzne komponenty formulára a titulkový pruh, ktorý obsahuje zvyčajné tlačítka pre minimalizovanie, maximalizovanie a zatvorenie okna. Ak kliknete myšou kdekoľvek do formulára, v Object Inspector, na ľavej strane pracovnej plochy, uvidíte vlastnosti formulára.

Počas práce môžu byť zobrazené i ďalšie okná, ako: the Project Inspector, ktorý obsahuje detaily o súboroch, ktoré sú súčasťou projektu a umožňuje pridať alebo odstrániť tieto súbory z/do projektu; alebo okno Messages, ktoré zobrazuje správy prekladača, chyby alebo hlásenia postupu vášho projektu; ak je Lazarus spustený z okna terminálu, pôvodný terminál necháva viditeľné a detailné správy prekladača sú zobrazované i tam.

Základné menu

(Main Menu)

Riadok základného menu obsahuje nasledujúce položky:

File Edit Search View Project Run Components Tools Environment Windows Help

Ako je zvykom, položky môžu bať vybraté umiestnením myši nad položku menu a kliknutím ľavým tlačítkom myši alebo stlačením Alt-F na klávesnici (základné okno musí mať fokus, ak ho nemá stláčajte opakovane TAB na prepínanie fokusu medzi oknami, kým nie je titulkový pruh uíkladného okna zvýraznený farbou).

Menu File

FileMenu.png
  • New Unit: Vytvorí nový súbor jednotky (zdrojový kód Pascal).
  • New Form: Vytvorí nový formulár: vrátane pripojeného zdrojového súboru Pascal.
  • New ...: Poskytuje (pop-up menu box) s rôznymi typmi nových dokumentov.
  • Open: Otvorí dialóg pre otvorenie existujúceho súboru.
  • Revert: Ruší vykonané editácie a obnovuje súbor do pôvodného stavu.
  • Open Recent: Zoznam naposledy otvorených súborov.
  • Save: Uloží aktuálny súbor. Ak súbor ešte nemá meno, správa sa ako Save As.
  • Save As: Umožňuje vybrať adresár a meno pre uloženie aktuálneho súboru.
  • Save ALL:
  • Close: Zatvorí aktuálny súbor, spýtajúc sa na uloženie vykonaných úprav.
  • Close all editor files: Zatvorí všetky aktuálne otvorené súbory, spýtajúc sa na uloženie úprav.
  • Clean directory: Otvorí dialóg s nastaviteľnými filtrami, pre odstránenie súborov z aktuálneho adresára. Užitočné pre odstránenie súborov .bak a zvyškov projektov Delphi.
  • Print: Vytlačí zvolený súbor na tlačiarni systému. Táto položka menu sa predvolene neobjavuje, ale najprv je potrebné nainštalovať $Lazdir/components/printers/design/printers4lazide.pas a opäť preložiť IDE.
  • Restart:
  • Quit: Zatvorí Lazarus, spýtajúc sa na uloženie vykonaných úprav.

Menu Edit

EditMenu.png
  • Undo: Vrátenie poslednej editovanej akcie, ponechajúc Editor v stave tesne pred ňou.
  • Redo: Opakovanie poslednej akcie, ktorá bola vrátená pomocou Undo.
  • Cut: Vystrihne vybraný text a uiestni ho do schránky.
  • Copy: Prekopíruje vybratý text do schránky.
  • Paste: Vloží obsah schránky na pozíciu kurzora. Ak bol vybratý text, prepíše ho.
  • Indent selection: Posúva odsadenie vybratého textu doprava o rozsah zadaný v nastavení Environment -> Editor options -> General -> Block indent. Funkciaje užitočná pre formátovanie zdrojovéhokódu a vyvorenie blokovej štruktúry.
  • Unindent selection: Odstraňuje jednu úroveň odsadenia, posunúc text doľava o rozsah zadaný v nastavení Editora Block indent.
  • Enclose selection: Otvára pop-up menu s voľbami pre logické zakončenie vybratého textu (begin ... end; try ... except; try ... finally; repeat ... until; { ... } atď).
  • Uppercase selection: Konvertuje vybratý text na veľké písmená.
  • Lowercase selection: Konvertuje vybratý text na malé písmená.
  • Tabs to spaces in selection: Konveruje všetky tabulátory vybratého textu na medzery, podľa nastavenia Environment -> Editor options -> General -> Tab widths. Počet medzier nemá fixnú veľkosť, ale je to potrebný počet medzier na zaplnenie potrebnej šírky tabelátora medzerami.
  • Break lines in selection: Zalomí riadok vybratého textu, ktorý presahuje 80 znakov alebo počet zadaný v nastavení Environment -> Editor options -> Display -> Right Margin, riadok je zalomený na hranici slova a pokračuje na nasledujúcom riadku.
  • Comment selection: Vloží značky komentára // na každý riadok vybratého textu.
  • Uncomment selection: Odstráni značky komentára.
  • Sort selection: Zoradí riadky (alebo slová v odstavci) podľa abecedy; voľby pre smer radenia, citlivosť na veľkosť písmen. Uprostred zrojového kódu, samozrejme, to neprichádza do úvahy, ale ak máte zoznam, ktorý treba zoradiť, oceníte tento trik.
  • Select: Umožní výber blokov textu. Voľby zahŕňajú Vybrať všetko, vybrať po brace, vybrať odstavec alebo riadok, atď.
  • Insert from character map: Umožní vloženie symbolu, ktorý nie je na klávesnici, vybratý z pop-up mapy znakov.
  • Insert text: Zobrazí pop-up menu pre vloženie štandartných textov, ako kľúčové slová CVS (Author, Date, Header atď), či poznámku GPL, meno užívateľa, dátum a čas.
  • Complete code: Dokončí kód pod kurzorom. Závisí od kontextu a šetrí mnoho času. Napríklad dokončuje triedy, pridaním súkromných premenných, prístupové metódy Get a Set vlastností a pridaním tela metód. Na priradeniach premenných (tj. i:=3;) pridáva deklaráciu premennej. Pri forward deklarovaných procedúrach pridáva telá procedúr. Pri priradení udalostí (OnClick:=) pridáva definíciu a telo metódy. Viď Nástroje IDE Lazarus.
  • Extract procedure: Použije vybratý text (príkaz alebo sériu príkazov) na vytvorenie novej procedúry.

Menu Search

SearchMenu.png
  • Find: Obdoba vlastnosti skoro všetkých grafických editorov: pop-up dialógový box pre zadanie hľadaného textu a volieb hľadania, ako citlivosť na veľkosť písmen, celé slová, začiatok, oblasť a smer hľadania.
  • Find Next, Find previous: Pokračuje v hľadaní predtým zvoleného textu, zadaným smerom.
  • Find in files: Hľadá textový reťazec v súboroch: pop-up dialóg s voľbami všetky otvorené súbory, všetky súbory v projekte alebo všetky adresáre; umožňuje i zadanie masky pre výber typu súboru.
  • Replace: Podobné ako Find; zobrazí pop-up dialóg s miestom pre zadanie hľadaného reťazca a nahradzujúceho textu a volieb pre citlivosť na veľkosť písmen, smer atď.
  • Incremental find: Hľadanie reťazca kým zadávate hľadaný reťazec. Príklad: stlačíte "l" a je zvýraznené prvé "l", ak potom stlačíte "a", editor nájde nasledujúce "la" atď.
  • Goto line: Presunie kurzor na zadaný riadok súboru.
  • Jump back: Presunie kurzor späť k nasledujúcej záložke (musíte použiť Add jump point to history). Presúva i na záložky iných súborov otvorených v Editore.
  • Jump forward: Presunie kurzor vpred na nasledujúcu záložku.
  • Add jump point to history: Pridá do súboru záložky alebo skokové body.
  • View Jump-History: Ukáže zoznam záložiek v súbore: Zatiaľ neimplementované???.
  • Jump to next error, Jump to previous error: Skoč na na pozíciu nasledujúcej/predchádzajúcej hlásenej chyby v zdrojovom súbore.
  • Set a free bookmark: označ riadok, na ktorom je kurzor, ďalšou dostupnou (voľnou) číslovanou záložkou a pridaj ju do zoznamu záložiek. Pozor, vyskakovacie menu (získané kliknutím pravým tlačítkom myši na príslušný riadok zdrojového súboru) poskytuje väčší rozsah možností záložky, umožňujúc zadať číslo záložky, či skočiť na očíslovanú záložku, nie len na nasledujúcu/predchádzajúcu.
  • Jump to next bookmark, Jump to previous bookmark: Skoč na nasledujúcu/predchádzajúcu záložku v číselnom poradí.
  • Find other end of code block: Ak je kurzor umiestnený na begin, presunie kurzor na príslušný end a naopak.
  • Find code block start: Presunie kurzor na begin procedúry alebo funkcie, v tele ktorej je umiestnený.
  • Find Declaration at cursor: Presunie kurzor na miesto deklarácie zvoleného identifikátora. Môže to byť v rovnakom súbore alebo v inom. Ak nie je otvorený, otvorí ho v Editore (tak ak je procedúra alebo funkcia deklarovaná napr. v classesh.inc , tento bude otvorený v Editore).
  • Open filename at cursor: Otvorí súbor, ktorého meno je vybraté kurzorom. Užitočné na zobrazenie Include súborov alebo súborov obsahujúcich iné Jednotky použité v projekte.
  • Goto include directive: Ak je kurzor umiestnený v súbore, ktorý je Included v inom súbore, presunie kurzor na miesto v súbore, odkiaľ bol volaný súbor Include.
  • Find Identifier References: Poskytuje zoznam všetkých riadkov aktuálneho súboru, projektu alebo pripojených súborov, na ktorých je spomenutý identifikátor.
  • Rename Identifier: Umožňuje vývojárovi premenovať identifikátor. Pomocou vyskakovacie menu možno určiť, či sa má premenovanie vykonať len v aktuálnom súbore, v projekte, vo všetkých otvorených alebo pripojených súboroch atď. Dokoncá je možné premenovať aj identifikátory vyskytujúce sa v komentároch. Túto vlastnosť môžete využiť, napríklad, al prekladač hlási, že identifikátor už existuje, takže môžete potebovať nové meno svojho identifikátora.
  • Procedure List: Poskytuje zoznam všetkých procedúr a funkcií v aktuálnom súbore, spolu s číslom riadku, kde sú definované.

Menu View

Ovládanie zobrazenia rôznych okien a panelov na obrazovke.

ViewMenu.png
  • Object Inspector: Okno, zvyčajne umiestnené na ľavej strane obrazovky, ktoré zobrazuje funkcie formulára, ktorý je na obrazovke. Kliknutím myšou na ktorýkoľvek komponent formulára, spôsobí, že detaily komponentu budú zobrazené v Object Inspector. Na jeho vrchu je panel, ktorý zobrazuje stromovú štruktúru aktuálneho projektu a komponenty formulára môžu byť vybraté aj z tohoto panela. Základný panel má dve záložky, ktoré umožňujú zobraziť Properties alebo Events. Výber Properties zobrazí vlastnosti zvoleného komponentu v dvoch stĺpcoch, ľavý zobrazuje meno vlastnosti a pravý jej hodnotu. Výber Events zobrazí tiež dva stĺpce, ľavý s menom udalostí priradených ku komponentu a pravý ukazuje akciu, ktorá je výsledkom udalosti (procedúru udalosti). Ak nie je definovaná akcia, kliknutie na tlačítko
    ...
    spôsobí zobrazenie Editora zdrojového kódu s kurzorom umiestneným na prázdenj deklarácii procedúry, do ktorej môžete zadať svoj kód udalosti.
  • Source Editor: Základné okno pre editovanie zdrojového kódu. Jeho správanie je veľmi podobné iným grafickým editorom textu, takže môžete myšou presúvať kurzor nad zobrazeným textom a stlačenie ľavého tlačítka myši počas posúvania vyberie a označí text. Pravým kliknutím zobrazíte kontextové menu, ale ak ste zvyknutý na editory Windows, Gnome alebo KDE, budete márne hľadať zvyčajné funkcie, ako Vystrihnúť, Kopírovať a Vložiť, ale zahŕňa voľby ako Find Declaration alebo Open File at Cursor. Na vrchu okna Editora zdrojového kódu je niekoľko záložiek, reprezentujúcich otvorené súbory; kliknutie na jednu z nich vyvolá daný súbor do popredia, takto môžete jednoducho kopírovať zo súboru do súboru a vykonávať bežné editovacie funkcie. Editor zdrojového kódu poskytuje farebné zvýraznenie syntaxe kódu, s rôznymi farbami pre interpunkciu, komentáre, reťazcové konštanty atď. Rovnako zabezpečuje automatické odsadenie riadkov kódu. Funkcie a vzhľad Editora zdrojového kódu sú nastaviteľné cez menu Environment -> Editor options a zvolením jednej z viacerých záložiek.
  • Code Explorer: Okno, zvyčajne umiestnené na pravej strane pracovnej plochy, ktoré v stromovej forme zobrazuje štruktúru kódu aktuálnej jednotky alebo programu. Ak zmeníte súbor zobrazený v okne Editora zdrojového kódu, musíte zvoliť tlačítko Refresh na zobrazenie novej štruktúry súboru. Okno po otvorení zvyčajne zobrazuje meno jednotky a vetvy pre časti Interface a Implementation, ale kliknutím na
    +
    vľavo od vetvy otvoríte podvetvy a vetvičky :-), do úplných detailov samotných konštánt, typov a premenných, ako aj deklarácií procedúr a funkcií.
  • Units...: pop-up dialóg so zoznamom súborov jednotiek aktuálneho projektu, ktorý umožní vybrať súbor Zobrazený v Editore zdrojového kódu. Zaškrtnutím voľby Multi select môžete vybrať a otvoriť viac jednotiek naraz, ale len jedna bude zobrazená. Táto položka menu je lepšia ako položka Project -> Project Inspector, ale zobrazuje len zoznam jednotiek a dovoľuje ich otvoriť.
  • Forms...: pop-up dialóg so zoznamom formulárov aktuálneho projektu a umožní vybrať jeden alebo viac z nich pre zobrazenie.
  • View Unit Dependencies: pop-up dialóg, ktorý zobrazí stromovú štruktúru závislostí aktuálne otvorenej jednotky. Mnoho súborov zobrazených v tomto okne má svoje svoje vlastné
    +
    ,ktoré umožňujú preskúmať ich vlastné závislosti, často rekurzívnym spôsobom.
  • View Unit Information:
  • Toggle form / unit view F12: Prepína zobrazenie Formulár/Zdrojový kód formulára. Jednoduchším spôsobom je stlačenie F12 na klávesnici, ale táto položka menu má rovnaký význam.
  • Messages: Okno so správami prekladača, zobrazuje postup úspešného prekladu alebo vypisuje nájdené chyby.
  • Search Results: Okno s výsledkom hľadania textu v súboroch.
  • View Anchor Editor:
  • View Component Pallete:
  • View IDE Speed buttons:
  • Debug windows: pop-up menu s niekoľkými voľbami pre činnosť a konfiguráciu Debuggera. debugger je popísaný ďalej.

Menu Project

ProjectMenu.png
  • New Project: Vytvorí nový projekt a poskytuje možnosť zvoliť typ projektu.
  • New Project from file: Umožní vytvoriť nový projekt z existujúceho súboru.
  • Open Project: Otvorí projekt, ktorý už bol vytvorený a uložený. Dialóg ponúkne zoznam súborov Lazarus Project Information (.lpi), z ktorých si môžete vybrať.
  • Open Recent Project: Otvorí projekt zo zoznamu naposledy spracovávaných projektov.
  • Close Project:
  • Save Project: Obdoba File -> Save: uloží všetky súbory aktuálneho projektu; ak ešte neboli uložené, ponúkne dialóg na zadanie mena (ako Save Project As...).
  • Save Project As...: Požiada meno súboru pre uloženie projektu. Ponúkne prednastavené meno súboru Project1.lpi, ale môžete si zvoliť vlastné. Lazarus nedovoľuje použiť rovnaké meno súboru pre súbor projektu a súbor jednotky. Viz nižšie).
  • Publish Project: Vytvorí kópiu celého projektu. Bežný adresár projektu obsahuje veľa informácií, ktoré nie je potrebné publikovať (informácie o session, súbory .ppu, .o, .exe. Publish Project vytvorí súbor .lpi obsahujúci len základné informácie a do kópie presunie len zdrojové kódy, zo všetkych podadresárov. V dialógu môžete nastaviť filter exclude/include a spôsob kompresie výstupného archívu. Viz Nástroje IDE Lazarus
  • Project Inspector: pop-up dialóg so stromovou štruktúrou súborov aktuálneho projektu. Dovoľuje pridať, odstrániť alebo otvoriť zvolené súbory alebo zmeniť vlastnosti projektu.
  • Project Options...: pop-up dialóg s voľbami nastavenia projektu (titulok, meno cieľového súboru), Forms (dovoľuje výber z dostupných formulárov, a ich nastavenie Auto-create) a Info (určuje, či editačné informácie majú byť uložené pre zatvárané súbory, alebo len pre súbory projektu).
  • Compiler options ...: Konfigurácia prekladača, zahŕňa záložky: Paths definícia ciest hľadania jednotiek, include súborov, knižníc... ako aj voľbu pomocného typu formulára (gtk, gnome, win32); Parsing voľba pravidiel pre syntaktickú analýzu programov, Code voľby optimalizácie pre rýchlejšie alebo pomalšie programy, výber cieľového procesora, veľkosti haldy atď; Linking voľby použitia ladenia, statických alebo dynamických knižníc atď; Messages typy správ, generované pri výskyte chyby; Other určenie predvoleného konfiguračného súboru (fpc.cfg) alebo iného súboru; Inherited stromový diagram ukazujúci voľby zdedené z už zahrnutých jednotiek; Compilation dovoľuje zadať príkazy vykonávané pred/po spustení prekladača a použitie súborov Make.
  • Add editor file to Project: Do projektu pridá súbor, ktorý je práve upravovaný.
  • Remove from Project: pop-up menu na odstránenie súboru z projektu.
  • View Source: Bez ohľadu na to, ktorý súbor je práve upravovaný, zobrazí základný programový súbor (.dpr) alebo základný súbor .pas, ak .dpr neexistuje.

Menu Run

RunMenu.png
  • Build: Prekladá súbory projektu, ktoré boli zmenené od posledného prekladu.
  • Build all: Prekladá všetky súbory projektu, bez ohľadu na to, či boli alebo neboli zmenené.
  • Quick compile:
  • Abort build: Zastaví proces prekladu, ktorý je spustený - či už sa spamätáte, že máte niečo zle a chcete zastaviť preklad, alebo systém pracuje veľmi dlho a niečo je obvykle zle.
  • Run: Obvyklý spôsob spustenia prekladača a, ak je preklad úspešný, spustenia aplikácia. Lazarus uloží kópie súborov, potom spustí prekladač a linker, potom začne vykonávať finálny programový súbor (.exe).
  • Pause: Preruší vykonávanie aktuálne bežiaceho programu. Tým vám umožní skontrolovať akýkoľvek výstup, ktorý bol generovaný; vykonávanie môže pokračovať opätovným vybratím Run.
  • Step into: Used in conjunction with the debugger, causes execution of the program one step at a time up to a bookmarked point in the source.
  • Step over: Causes stepwise execution up to the statement marked, then skips the marked statement, and continues execution at normal speed. Useful in trying to isolate a statement that introduces a logical error.
  • Run to cursor: Spôsobí vykonávanie programu normálnou rýchlosťou (tj. nie jeden príkaz naraz) pokiaľ nedôjde po príkaz, na ktorom je umiestnený kurzor; potom zastaví. Pokračovanie vykonávania normálnou rýchlosťou dosiahnete zvolením Run.
  • Stop: Spôsobí zastavenie vykonávania bežiaceho programu. Nasledujúce zvolenie Run nepokračuje vo vykonávaní, ale spustí program od začiatku (ak treba i s prekladom).
  • Run Parameters: Otvorí viacstránkové pop-up okno, v ktorom môžete tadať voľby a parametre príkazového riadku pre spustenie programu; výber zobrazenia spusteného programu (tj. môžete použiť vzdialený X terminál terminal v Linuxe); môžete prepísať niektoré systémové premenné.
Veľmi zaujímavou možnosťou tohoto sub-menu je aktivácia okna terminálu pre zobrazenie vstupu/výstupu konvenčnej konzoly Pascalu. Ak pracujete na konzolovom programe Pascalu, (tj. nepoužijete pre program GUI s formulármi, tlačítkami...), potom môžete zaškrtnúť políčko "Use launching application". Keď to nastavíte prvý krát a skúsite sekvenciu Compile/Run, asi dostanete divoké hlásenie hovoriace
"xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied".
Ak toto nastane, potrebujete zmeniť prístupové práva príslušného súboru; možno to budete musieť urobiť ako root (administrator). Po tomto, sa pri každom spustení programu objaví konzolové okno, v ktorom sa budú obajovať všetky vaše textové vstupy/výstupy (readln, writeln ...).
Po skončení práce vášho programu sa objaví na obrazovke správa "Press enter". Takto celý výstup generovaný vašim programom ostane na obrazovke, aby ste mali šancu prečítať si ho a okno bude zatvorené až po stlačení 'enter'.
Poznámka: keďže v aktuálnej verzii nie je pripravený príkaz konzoly pre používateľov Windows. Zatiať Lazarus team odkazuje, že musí pracovať nasledujúci príkaz (vo WinXP)
C:\Windows\system32\cmd.exe /C ${TargetCmdLine}
  • Reset debugger: Obnovuje debugger do jeho pôvodného stavu, všetky ladiace body a hodnoty premenných... sú zabudnuté.
  • Build file: Preloží súbor, ktorý je aktuálne otvorený v Editre zdrojového kódu.
  • Run file: Preloží, spojí a spustí aktuálne otvorený súbor.
  • Configure Build + Run File: Otvorí viacstránkové okno s voľbami, ktoré nastavia preklad práve tohoto súboru pri výbere Build Project, dovolia výber pracovného adresára, použitie rôznych makier... Potom preloží a spustí súbor.
Tieto posledné tri voľby umožňujú otvoriť (a spravovať) testovací projekt. Použite File -> Open pre otvorenie súboru .lpr a v nasledujúcom dialógu stlačte cancel pre otvorenie tohoto súboru ako "normálneho zdrojového" súboru.

Menu Components

  • Open Package: Zobrazí zoznam nainštalovaných balíčkov, s možnosťou otvoriť jeden alebo viac z nich, alebo výber rôznych všeobecných volieb alebo volieb prekladača.
  • Open Package File: Otvorí jeden zo súborov vo zvolenom balíčku.
  • Open package of current unit:
  • Open Recent Package: Ponúkne zoznam naposledy otvorených balíčkov.
  • Add Active Unit to Package: Pridá aktuálny súbor (otvorený v editore) do balíčka.
  • Package Graph: Zobrazí graf vzťahov jednotlivých balíčkov, ktoré sú používané (ak nepoužívate žiadny iný balíček, budú zobrazené balíčeky Lazarus, FCL a LCL).
  • Configure custom components: táto položka už nie je...

Menu Tools

ToolsMenu.png
  • Configure custom tools: Umožňuje užívateľovi pridať do nástrojov rôzne externé nástroje (zvyčajne makrá).
  • Project templates options:
  • Quick syntax check: Vykoná rýchlu kontrolu syntaxe vášho zdrojového kódu bez skutočného prekladu. Základný krok pri vývoji veľkých alebo komplikovaných programov, ak nechcete mrhať čas prekladom chybného kódu.
  • Guess unclosed block: Užitočný nástroj, ak máte zložitú alebo vnorenú blokovú štruktúru a chcete niekde nájsť end.
  • Guess misplaced IFDEF/ENDIF: Užitočné, ak ak máte zložitú alebo vnorenú štruktúru makra a potebujete nájsť direktívu ENDIF.
  • Make resource string: Z vybratého reťazca robí zdrojový reťazec (resource string) jeho umiestnením v sekcii resourcestrings. Výhodou zdrojových reťazcov je, že môžu byť zmenené bez poteby rekompilácie projektu!
  • Diff: Umožňuje porovnanie dvoch súborov (alebo dvoch verzií rovnakého súboru) a nájdenie rozdielov. Poskytuje voľby na ignorovanie prázdneho miesta na začiatku alebo konci riadkov alebo rôznych zakončení riadkov (CR+LF a LF). Užitočné na kontrolu, či boli urobené zmeny od poslednej aktualizácie CVS atd.
  • Check LFM file in editor: Umožňuje kontrolu súboru LFM, ktorý obsahuje nastavenia aktuálneho formulára.
  • Convert Delphi unit to Lazarus unit: Pomáha pri prenose aplikácií Delphi do Lazarus; robí potrebné zmeny v zdrojovom súbore. Viz Prechod z Delphi na Lazarus a Code Conversion Guide.
  • Convert DFM file to LFM: Pre prenos z Delphi do Lazarus. Konvertuje súbory Form Description z Delphi do Lazarus. Viz Prechod z Delphi na Lazarus and Code Conversion Guide.
  • Build Lazarus: Spúšťa znovuzostavenie Lazarus z naposledy stiahnutých alebo aktualizovaných súborov CVS (proces môžete sledovať v okne Messages).
  • Configure "Build Lazarus": Umožňuje určiť, ktoré časti Lazarus budú znova zostavené a ako. Napríklad, môžete nastaviť, že bude preložená len LCL alebo všetko okrem príkladov. Môžete nastaviť ktoré rozhranie LCL použiť a môžete nastaviť cieľový operačný systém, či nastaviť iný cieľový adresár.

Menu Environment

EnvironmentMenu.png
  • Environment options: viacstránkové okno so záložkami pre
    • Files - cesty k predvolenému adresáru, prekladaču, zdrojovému adresáru a dočasnému adresáru pre prekladanie;
    • Desktop - voľby pre jazyk, správanie automatického ukladania, ukladanie vlastností pracovnej plochy, hinty pre paletu komponentov a speed tlačítka;
    • Windows - zadanie veľkosti a správania rôznych okien;
    • Form Editor - výber farieb pre editovanie formulárov;
    • Object Inspector - výber farieb a veľkosti položiek;
    • Backup - udáva ako zálohovať súbory pri úpravách;
    • Naming - udáva príponu názvov súborov Pascalu ('.pp' alebo '.pas'), či sa majú ukladať malými písmenami, či vykonávať automatické mazanie alebo premenovanie.
  • Editor options: viacstránkové okno so záložkami pre
    • General - určuje správanie ako automatické odsadenie, zvýrazňovanie zátvoriek, drag-drop upravovanie, posúvanie, zvýrazňovanie syntaxe, zobrazovanie hintov, veľkosť odsadenia bloku a tabulátora, hranicu Undo;
    • Display - voľby pre zobrazovanie čísel riadkov, zobrazovanie guttera, veľkosť a typ fontu editora a okno so zobrazením farieb rôznych typov syntaxe, ako komentáre, značky, direktívy, chyby a ladiace body;
    • Key Mappings - voľby pre výber schémy Lazarus alebo Turbo Pascal;
    • Color - umožňuje nastaviť farebnú schému textu pre viac typov jazyka, ako Object Pascal, C++, Perl, HTML, XML a skripty shellu. Zobrazuje aj ukážkový panel (pre zvolený jazyk);
    • Code Tools - umožňuje výber funkcií ako Identifier Completion, tooltips, zadanie šablón názvov súborov, šablóny pre dokončovanie kódu.
  • Debugger Options: viacstránkové okno so záložkami pre
    • General - voľby debugera: bez, GNU debugger (gdb) alebo gdb cez SSH, zadanie vyhľadávacej cesty a volieb pre zvolený debugger;
    • Event log - nastavenie, či zmazať log pri spustení a ktoré správy zobrazovať;
    • Language Exceptions - výber výnimiek, ktoré budú ignorované;
    • OS Exceptions - umožňuje pridať isté signály, ktoré aplikuje na aktuálny operačný systém.
  • Code Tool Options: viacstránkové okno so záložkami pre
    • General - zadanie ďalších ciest pre hľadanie zdrojových súborov a určenie metódy Jumping Method;
    • Code Creation - určuje, či je vytváraný kód pridaný pred alebo za určitú funkciu;
    • Words - určuje, či sú kľúčové slová Pascal zadávané malými alebo veľkými písmenami, alebo s veľkými počiatočnými písmenami;
    • Line Splitting - zavádza pravidlá zalamovania riadkov (pred alebo po interpunkčných znamienkach, za kľúčovým slovom atď);
    • Space - určuje či sú medzery automaticky pridané alebo za určité syntaktické črty, ako kľúčové slová, alebo interpunkčné značky.
  • Code Tools Defines Editor:
  • Re-scan FPC Source directory Znova prechádza adresár. Lazarus používa zdrojové kódy FreePascal na generovanie správnych obslúh udalostí a pri hľadaní deklarácií. Ak niekto zmení adresár v nastavení prostredia, potom je tento adresár znova prehľadaný, aby bolo zaistené, že Lazarus používa verziu uchovanú v danom umiestnení. Ale ak bol tento adresár zmenený a Lazarus nebol o tom informovaný, potom sa môžu objaviť chyby pri navrhovaní formulárov alebo vykonaním "Find declaration". Ak sa stretnete s touto chybou, môžete urobiť dve veci:
    1. skontrolovať nastavenie zdrojového adresára vo voľbách prostredia.
    2. znova prehľadať zdrojový adresár FreePascal.

Menu Windows

Obsahuje zoznam aktuálne otvorených súborov a dostupných okien, ako Source Editor, Object Inspector, či Project Inspector. Kliknutím na názov jedného z okien je okno vyvolané do popredia a získava zameranie.

Menu Help

  • Online Help otvorí okno prehliadača so súborom c:/lazarus/docs/index.html, ktoré obsahuje obrázok bežiacej cheetah a niekoľko odkazov nafew links to the Lazarus, FreePascal and WiKi websites
  • Configure Help umožňuje nastaviť prehliadač a databázy, z ktorých budú čítané informácie nápovedy. Tieto voľby dovoľujú užívateľovi zadať jeden z on-line dokumentov na webovej stránke Lazarus-CCR, niektoré ďalšie webové stránky obsahujúce dokumenty, alebo lokálne umiestnenie dokumentácie. Predvolene, ak umiestnite kurzor nad kľúčové slovo FCL alebo RunTime Library (ale nie LCL) a potom stlačíte <<F1>> dostanete sa na príslušnú stránku.
  • About Lazarus Zobrazí pop-up box s informáciami o Lazarus.

Časom tu bude úplný on-line Help, s informáciami o syntaxe Pascalu, o použití IDE, o používaní, úpravách a tvorbe komponentov a tipy ako urobiť niektoré úlohy. Táto časť sekcie Dokumentácia (to čo teraz čítate) predstavuje začiatok procesu. Potrebujeme spolupracovníkov, ktorí sú ochotní pomôcť: Editácia WiKi je veľmo jednoduchá.

Paleta komponentov

Panel nástrojov so záložkami, ktorý zobrazuje veľa ikôn, reprezentujúcich bežne používané komponenty pre budovanie formulárov. Na každej záložke je zobrazená iná množina ikôn, reprezentujúca funkčnú skupinu komponentov. Ikona celkom vľavo, na každej záložke, je obligátna šikmá šípka vľavo, slúžiaca na výber komponentu na formulári (Selection Tool).

Ak presuniete kurzor myši na ktorúkoľvek z ikon Palety komponentov, bez kliknutia na ikonu, objaví sa meno komponentu. Všimnite si, že každé meno začína s T - to označuje 'Type' alebo výstižnejšie 'triedu' komponentu. Keď vyberiete komponent pre vloženie na fomrulár, je trieda automaticky pridaná do definície type časti interface príslušnej jednotky (zvyčajne ako časť daného TForm1), a inštancia triedy je pridaná do do sekcie var (zvyčajne ako premenná Form1). Všetky metódy, ktoré navrhnete pre použitie formulárom alebo jeho komponentami (tj procedúry alebo funkcie) budú umiestnené v časti implementation jednotky.

V nasledujúcom zozname Komponentov, nájdete odkazy na súbory obsahujúce popis jednotiek, v ktorých sú umiestnené. Ak sa chcete dozvedieť niečo o vlastnostiach príslušného komponentu, je často vhodné preskúmať hierarciu dedičnosti komponentu a potom preskúmať i vlastnosti základnej triedy, od ktorej je odvodená. Napríklad, pre pochopenie TMaskEdit býva tiež užitočné vyskúšať TCustomMaskEdit.

Najčastejšie používané komponenty
Component Palette Standart.png
TMainMenu, TPopupMenu, TButton, TLabel, TEdit, TMemo, TToggleBox, TCheckBox, TRadioButton, TListBox, TComboBox, TScrollBar, TGroupBox, TStaticText, TRadioGroup, TCheckGroup, TPanel, TActionList

Ďalšie často používané komponenty:

Component Palette Additional.png
TBitBtn, TSpeedButton, TImage, TShape, TBevel, TPaintBox, TNotebook, TLabeledEdit, TSplitter, TMaskEdit, TCheckListBox, TScrollBox, TApplicationProperties, TStringGrid, TDrawGrid, TPairSplitter
Component Palette Common Controls.png
TTrackBar, TProgressBar, TTreeView, TListView, TStatusBar, TToolBar, TUpDown, TPageControl, TImageList
Component Palette Dialogs.png
TOpenDialog, TSaveDialog, TSelectDirectoryDialog, TColorDialog, TFontDialog, TOpenPictureDialog, TSavePictureDialog, TCalendarDialog, TCalculatorDialog

Niektoré užitočné dialógové procedúry alebo funkcie nenájdete na palete, ale je ľahšie ich volať priamo zo zdrojového kódu.

Niekoľko dobrých príkladov použitia komponentov nájdete v adresári $LazarusPath/lazarus/examples vašej zdrojovej inštalácie. Mnoho týchto programov ukazuje ako použiť dialógy a iné komponenty priamo, bez použitia IDE a palety komponentov alebo majú inú formu definičného súboru: všetky komponenty sú úplne a priamo definované v základnom programe Pascal. Iné príklady robia plne použiteľné IDE.

Niektoré príklady nepracujú priamym spôsobom, ale potrebujete sa pohrať s cestami a prístupovými právami súborov alebo adresárov. Ak chcete preložiť akýkoľvek z príkladov, zaistite, že máte nastavené prístupové práva read/write/execute pre súbory a adresáre, alebo prekopírujte súbory do adresára, pre ktorý máte príslušné or oprávnenia.

Vyskúšajte spúštenie programu 'testall', aby ste videli ponuku dostupných komponentov spolu s malým príkladom formy, pre väčšinu z nich; potom si pozrite udrojový kód a nájdite ako pracuje!

  • Misc
Component Palette Misc.png
TColorButton, TSpinEdit, TArrow, TCalendar, TEditButton, TFileNameEdit, TDirectoryEdit, TDateEdit, TCalcEdit, TFileListBox
  • Data Controls

Komponenty Data-aware, ktoré do zančnej miery replikujú skupiny Standard a Additional, ale sú použiteľné s databázami:

Component Palette DataControls.png
TDBNavigation, TDBText, TDBEdit, TDBMemo, TDBImage, TDBListBox,TDBComboBox, TDBCheckBox, TDBRadioGroup, TDBCalendar, TDBGroupBox, TdbGrid
  • Data Access
Component Palette DataAccess.png
TDatasource
  • System
Component Palette System.png
TTimer, TIdleTimer, TProcess
  • SynEdit
Skupina komponentov pomáhajúca s užívateľským rozhraním pre iné jazyky a programové nástroje. SynEdit je zdokonalený multi-line edit prvok, pre Borland Delphi, Kylix a C++Builder. Podporuje zvýrazňovanie syntaxe a dokončovanie kódu, zahŕňa tiež exportérov do html, tex a rtf. Jedná sa o plne-VCL/CLX prvok, tzn. nie je to obálka pre prvky Microsoft Windows a nevyžaduje behové knižnice; čím je SynEdit cezplatformový komponent. Kompatibilita s FreePascal je plánovaná tiež a SynEdit je editovací prvok IDE Lazarus. Viz synedit na sourceforge.
Component Palette SynEdit.png
TSynEdit, TSynAutoComplete, TSynExporterHTML, TSynMacroRecorder, TSynMemo, TSynPasSyn, TSynCppSyn, TSynJavaSyn, TSynPerlSyn, TSynHTMLSyn, TSynXMLSyn, TSynLFMSyn, TSynUNIXShellScriptSyn, TSynCssSyn, TSynPHPSyn, TSynTeXSyn, TSynSQLSyn, TSynMultiSyn

Pre použitie Palety komponentov, musíte mať otvorený a zobrazený formulár (ak nemáte zvoľte File -> New Form). Kliknite na ikonu v príslušnej záložke palety komponentov a vyberte tým komponent, ktorý chcete použiť, potom kliknite na formulár, blízko miesta, na ktorom sa má komponent objaviť. Po objavenís a komponentu ho môžete vybrať kliknutím myšou, potom posunúť na iné miesto formulára a zmeniť jeho veľkosť. Po vybratí komponentu môžete meniť jeho vlastnosti i v Objekt inspectore, či vabrať komponent pomocou Object inspectora.

Ak nainštalujete ďalšie komponenty, ktoré si môžete napísať sami alebo získať ako balíček z iného zdroja, objaví sa na palete komponent ďalšia záložka s príslušnou ikonou. Tieto nové komponenty môžete používať rovnakým spôsobom ako tie, ktoré sú poskytnuté štandartne.

Ako používať základné (Standard), spoločné (Common) a rozšírené komponenty

Programové jednotky StdCtrls, ComCtrls a ExtCtrls obsahujú definície a popisy mnohých kompoentov používaných pre zostrojovanie Formulárov a iných objektov v Lazarovských aplikáciách

Veľké množstvo výsledných komponentov, ktoré obvykle vývojár používa (napr. TButton, TMemo, TScrollBar a pod.) má definovaných predchodcov (triedy ako TCustomButton, TCustomMemo, TCustomScrollBar). Mnoho vlastností a metód výslednej komponenty je definovaných (a vysvetlených) v triedach TCustomXXX, a sú zdedené výslednou komponentou.

Pokiaľ cez editor formulárov pridáte nejakú komponentu, nie je nutné písať žiaden kód na jej explicitné vytvorenie. Komponenta je automaticky vytvorená IDE prostredím zároveň s formulárom, a deštruovaná keď je deštruovaný formulár.

Ak však vytvoríte komponentu samy v kóde, je nutné nezabudnúť ju uvoľniť, keď už nie je ďalej potrebná

Pokiaľ umiestnite komponentu na Form Designer a pozriete sa na okno Object Inspector, môžete preskúmať a meniť vlastnosti tejto komponenty.

Napr. pokiaľ umiestnite na formulár tlačidlo (TButton), vyznačíte ho kliknutím a budete ho premiestnovať po formulári, v okne Object Browser uvidíte ako sa menia hodnoty Top a Left, aby zodpovedali novej pozícii. Pokiaľ zmeníte veľkosť objektu, môžete si všimnút zmeny vlastností Width a Height, a pod.

Na druhej strane, použitím okna Object Inspector, môžete zmeniť hodnotu prislúchajúcu k nejakej vlastnosti (ako napr. Height), a takáto zmena sa prejaví na komponente.

Takisto môžete explicitne nastaviť niektoré vlastnosti objektu v kóde (v príslučnej Implementation časti v okne Source Editor), napr.

Form1.Button1.Height := 48;

Pokiaľ nastavíte hodnotu vlastnosti v Source Editore a pozriete sa späť na Form Editor, uvidíte, že tlačidlo zmenilo veľkosť. Táto nová veľkosť sa objaví tiež v Object Inspektore

Zhrnúť by sa to dalo tak, že obvykle existujú 3 spôsoby, ako nastaviť každú vlastnosť objektu:

  • použitím myši
  • nastavením hodnoty v Object Inspektore
  • explicitne napísaním kódu

Komponenty definované v týchto jednotkách majú niektoré vlastnosti spoločné pre väčšinu z nich, a niektoré, ktoré sú pre každú komponentu špecifické. Tu sa pokúsime popísať tie najčastie. Neobvyklé alebo špecifické vlastnosti sú popísané pre každú komponentu.

Dodatočnú nápovedu môžete získať vybraním vlastnosti alebo kľúčového slova (v Object Inspecotre alebo Source Editore) a stlačením ***F1***. Otvorí sa vám dokumentácia na príslušnej stránke.

Ako používať menu

V tejto kapitole sa dočítate o vytváraní Menu položiek do formulárov.

TMainMenu je hlavné menu, ktoré sa obvykle zobrazuje na vrchu väčšiny formulárov. Ich tvorcovia ho môžu prisposobovať potrebám konkrétneho programu pomocou rôznych položiek menu. TPopupMenu je vyskakovacie menu, ktoré sa zobrazuje obvykle po stlačení pravého tlačidla myši, na základe kontextu. Obvykle sa používa na rýchle nastavovanie detailov a pod.

TMainMenu je nevizuálna komponenta. To znamená, že pokiaľ prenesiete je ikonu z Palety Komponentov na formulár, táto ikona sa za behu programu nezobrazí. Namiesto nej sa zobrazí Panel menu vo formulári, ktorý bude mať takú štruktúru, akú ste nadefinovali v Menu Editore. Ikony komponentov TPopupMenu sa tiež za behu programu nezobrazujú, menu sa ale zobrazí až keď užívateľ klikne pravým tlačidlom myši na komponentu, ktorá takéto menu vlastní.

Pre vyvolanie Menu Editora, kliknite pravým tlačidlom na ikonu Hlavného alebo Vyskakovacieho menu na vašom formulári. Objaví sa okno, pomocou ktorého môžete pridávať položky do menu.

Zobrazí sa okno Edit box, ktorý obsahuje tlačidlo označené ako NewItem1. Na Edit box kliknite pravým tlačidlom, zobrazí sa vyskakovacie menu, ktoré vám umožní vložiť položky menu pred alebo za vybranú položku, prípadne vytvoriť podmenu.

Všetky položky typu MenuItems, ktoré ste vytvorili cez Edit box môžete nastavovať pomocou okna Object Inspector.

Každá položka by mala mať nastavenú minimálne vlastnosť Caption (text, ktorý sa zobrazí, napr. File Open, Close, Run, Exit a pod., podľa toho, akú funkciu bude položka vykonávať). Okrem toho sa odporúča nastaviť aj rozumné meno položky (vlastnosť Name), ktoré budete používať v zdrojovom kóde.

Pri každej položke je možné nastaviť isté písmeno, ktoré bude slúžiť ako klávesová skratka. Jednoducho v Caption položky pred písmeno vložte znak ampersand (&). Keď potom spustíte váš program, písmeno sa zobrazí ako podčiarknuté, a jeho stlačením sa aktivuje daná položka menu. Okrem toho je možné nastaviť aj klávesovú skratku, ako napr. Ctrl+C pre kopírovanie, či Ctrl+V pre vloženie. Pre tento účel sa používa vlastnosť ShortCut komponenty MenuItem.

Debugger

Už len napísať.

Súbory Lazarus

(Thanks to Kevin Whitefoot.) (Additions by Giuseppe Ridino, User:Kirkpatc and Tom Lisjac)

Pri ukladaní projektu budete vyzvaný na zadanie mena pre dva súbory:

  xxx.pas a yyy.lpr

(Uložených bude viac súborov). Súbor projektu (lpr) a súbor jednotky (pas) ktoré nesmú mať rovnaké meno, pretože Lazarus premenuje jednotku (vo vnútri zdrojového kódu) na rovnaké meno ako má súbor jednotky a program na rovnaké ako meno súboru projektu (toto je potrebné urobiť, pretože inak nebude prekladač schopný nájsť príslušnú jednotku neskôr, pri odkazovaní z projektového súboru). Samozrejme natrvalo to zmení všetky výskyty Unit1 na xxx.

Takže, ak uložíte projekt pod menom again, pokus uložiť again.pas a again.lpr toto zlyhá, pretože mená jednotky a programu sú rovnaké a výsledkom je Chyba duplikovaného mena. Inými slovami, aj súbor projektu (.lpr) sa odkazuje v sekcii uses na danú jednotku, ale bez rozlíšenia koncovky, takto by to prekladač interpretoval ako odkaz sám na seba.

Toto bude výsledok:

e:/lazarus/kj/lazhello:

total 4740  free 76500
-rwxrwxrwx   1 kjwh     root  4618697 Mar 24 11:19 again.exe
-rw-rw-rw-   1 kjwh     root     3002 Mar 24 11:21 again.lpi
-rw-rw-rw-   1 kjwh     root      190 Mar 24 11:18 again.lpr
-rw-rw-rw-   1 kjwh     root      506 Mar 24 11:08 againu.lfm
-rw-rw-rw-   1 kjwh     root      679 Mar 24 11:08 againu.lrs
-rw-rw-rw-   1 kjwh     root      677 Mar 24 11:08 againu.pas
-rw-rw-rw-   1 kjwh     root     2124 Mar 24 11:08 againu.ppu
-rwxrwxrwx   1 kjwh     root      335 Mar 24 11:07 ppas.bat

Nezabudnite, že adresár môže obsahovať veľa ďalších súborov, ktoré ste už uložili predtým.

Poznámky o každom súbore:

again.exe: Základný binárny program. Win32 pridáva príponu "exe". Linux niee. Tento súbor bude v Linuxe obrovský, pretože obsahuje symboly ladenia. Spusťte utilitu "strip" na ich odstránenie. Skrátite veľkosť súboru.

again.lpi: Základný súbor Lazarus projektu (Lazarus Project Information); je to ekvivalent k základnému súboru aplikácie Delphi .dpr. Je uchovávaný vo formáte XML.

again.lpr: Základný zdrojový súbor programu. Napriek špeciálnej prípone Lazarus ide v skutočnosti o klasický súbor zdrojového kódu Pascal. Má klauzulu uses, ktorá dovoľuje prekladaču nájsť všetky potrebné jednotky. Všimnite si, že príkaz program nemá rovnaké meno programu ako je meno súboru.

againu.lfm: V tomtmo súbore Lazarus uchováva vzhľad formulára. Lazarus ho používa na generovanie resource súboru, ktorý je vložený v do sekcie initialisation jednotky againu.pas. Delphi .dfm súbory môžete konvertovať do formátu .lfm v IDE Lazarus pomocou Tools->Convert DFM file to LFM.

again.lrs: Vygenerovaný resource súbor. Všimnite si, že to nie je súbor Windows resource.

againu.pas: Jednotka, obsahujúce kód formulára.

again.ppu: Preložená jednotka.

ppas.bat: Jednoduchý skript, ktorý linkuje program na produkciu exe. Ak je preklad úspešný, je zmazaný prekladačom.

Spolupracovníci a zmeny

This page has been imported from the epikwiki version.

  • Created initial page and template. T. Lisjac - 11/04/2003 VlxAdmin
  • Inserted a note containing instructions for writing your first Lazarus Program. Suggest an administrator places it in the appropriate place on the Tutorial menu. 3/09/2004 User:Kirkpatc
  • Per above, moved Chris's writeup to the main body of the tutorial VlxAdmin
  • Began to insert text describing the Lazarus Editor - more to follow! 24 Mar 2004 User:Kirkpatc
  • Added some more to Lazarus Editor section of Tutorial. 25 Mar 2004 User:Kirkpatc
  • Added screenshots and revised some of the page formatting VlxAdmin 3/25/2004
  • Moved some of kwhitefoot's comments into Tutorial section. Formatting not quite right, but have to go to bed now! 26 Mar 2004 User:Kirkpatc
  • Formatted, added credits and comments. Removed original notes. VlxAdmin 3/26/2004
  • More material added to Editor section of tutorial. 26 Mar 2004 User:Kirkpatc
  • More material added describing the Main Menu. Renamed 'Hello World' to 'Getting Started' and moved it to nearer the top. 31 March 2004 User:Kirkpatc
  • Inserted section on Run sub-menu. Some general editing (eg ended each entry with a period to ensure consistency). 9 Apr 2004 User:Kirkpatc
  • Inserted a new section on How to get started with MySQL in FPC/Lazarus. 13 Apr 2004 User:Kirkpatc
  • Deleted the section on MySQL from here: it has been copied to Lazarus Database section of tutorial. 14 Apr 2004 User:Kirkpatc
  • Added some more to the description of the Editor Main Menu. 18 Apr 2004 User:Kirkpatc
  • Added section on Environment sub-menu. 19 Apr 2004 User:Kirkpatc
  • Added section on Components sub-menu. 4 May 2004 User:Kirkpatc
  • Adding Tools sub-menu description (incomplete). 7 May 2004 User:Kirkpatc
  • Added some screenshots to Menu descriptions. 9 May 2004 User:Kirkpatc
  • Fixed a bit in Environment Options - thanks VincentSnijders. 14 May 2004 User:Kirkpatc
  • More additions to Tools sub-menu. 19 May 2004 User:Kirkpatc
  • Added a section on the Button Bar and started work on The Component Palette. 20 May 2004 User:Kirkpatc
  • Posted a description file for the StdCtrls unit of the LCL, in the hope that people will add comments. 26 May 2004 User:Kirkpatc
  • Edited the StdCtrls file, removing a lot of repetitive material and doing some formatting. It is still far too long. 28 May 2004 User:Kirkpatc
  • Expanding on the Components Palette. 5 June 2004 User:Kirkpatc
  • Added a lot to the DialogExamples page. 10 June 2004 User:Kirkpatc
  • Considerable revision of the StdCtrls page, hopefully making it clearer and encouraging people to contribute - particularly in the 'Description' sections. 14 June 2004 User:Kirkpatc
  • Added pages for Menus and Dialogs units (linked to Component Palette description) - please feel free to add to these pages. 14 June 2004 User:Kirkpatc
  • Added page for Common Controls (linked to Component Palette). 16 June 2004 User:Kirkpatc
  • Added MaskEdit page (linked to Component Palette). 17 June 2004 User:Kirkpatc
  • Added Buttons, ExtCtrls pages (linked to Component Palette). 17 June 2004 User:Kirkpatc
  • Edited MainMenu component description page. 23 June 2004 User:Kirkpatc
  • Some additions to Common Controls. 28 June 2004 User:Kirkpatc
  • A new tutorial on Text-mode Pascal programming has been added. 5 July 2004 User:Kirkpatc
  • Minor changes to ComCtrls, ExtCtrls, Environment Menu. 10 July User:Kirkpatc
  • Added FormsTxt, component description page for Component Palette. 20 July 2004 User:Kirkpatc
  • Some corrections to ConsoleModePascal. 21 July 2004 User:Kirkpatc
  • Some small changes to ComponentPalette. 22 July 2004 User:Kirkpatc
  • Preklad z anglického originálu Lazarus Tutorial a doplnenie obrázkov Palety komponentov. 25.marca 2005 User:Slavko
  • Aktualizácia slovenské preklady z anglického originálu Lazarus Tutorial. 24.decembra 2008 User:Adamm