Lazarus Tutorial/zh CN

From Lazarus wiki
Jump to: navigation, search

Deutsch (de) English (en) español (es) suomi (fi) français (fr) magyar (hu) Bahasa Indonesia (id) italiano (it) 日本語 (ja) 한국어 (ko) македонски (mk) Nederlands (nl) português (pt) русский (ru) slovenčina (sk) shqip (sq) 中文(中国大陆)‎ (zh_CN) 中文(台灣)‎ (zh_TW)

这是Lazarus教程的起点。你可以自由地把自己的体会添加到这里。

概述

Lazarus是一个自由并且开源的RAD(快速应用开发)开发工具,它基于同样自由开源的FreePascal(object pascal)编译器。Lazarus IDE(screenshot)可以创建独立的(原文是self-standing,我不确认是否准确)的图形或控制台程序,同时稳定并且富于特色.目前可以运行在Linux, FreeBSD和Win32平台下,同时提供可自定义的源代码编辑器,包含包管理器的可视化GUI设计环境,以及完整地集成在GUI环境中的调试器和FreePascal编译器。

起点 - 你的第一个Lazarus程序!

(感谢User:Kirkpatc)

首先,安装Lazarus,然后运行Lazarus,当然还要确定你有可以使用的FreePascal编译器。

桌面上将出现很多窗口:顶部是主菜单,左面是对象观察器,Lazarus源代码编辑器将占据大部分的桌面,而一个预置的Form1窗体将覆盖在源代码编辑器的上面。

首先,如果你的Lazarus是全英文的,那么你可以通过主菜单上的Environment -> Environment Options打开环境设置窗口,在Desktop标签下有Language选项,改成Chinese (zh_CN),确定后重新启动下Lazarus,大部分界面就是中文的了。

注:对于linux用户,Lazarus的默认编译/安装很大可能是使用GTK1库(非常容易辩认...因为非常丑...),GTK1对于Unicode的支持不完善,无法显示中文,你可以使用GTK2重新编译Lazarus,具体方法请参照Quick start: Recompile the IDE

在顶部的主菜单上,菜单分隔线的下面有一排标签。如果Standard标签还未被选中,单击选中它。然后找到TButton图标(一个有OK字样的矩形),单击Tbutton图标,然后在Form1窗体上找个宽敞的地方单击一下。一个有着"Button1"标题的矩形按钮就出现了。重复一次,你将获得"Button2"按钮,建议你把它放到Button1的右面。

现在单击Button1选中它,左侧的对象观察器上将出现Button1对象的所有属性。找到名为Caption的属性(你可以在"收藏夹"标签下更方便地找到它),现在这个属性的值是"Button1"。单击显示着"Button1"的方格,把里面"Button1"文本改成"Press",当你按下Enter(或者单击别的方格)后,你会看见Form1窗体上的Button1按钮上的文本变成了"Press"。然后找到对象观察器上的"事件"标签,你会看见可以给Button1关联很多事件(Event),包括OnClick,OnEnter,OnExit等等。选择OnClick右边的空白方格,将出现一个显示"..."(三个点,也就是省略号)的小方格,在这个方格上单击,你将自动跳转到源代码编辑器,同时你的光标会处于一段过程(procedure)代码中:

 procedure TForm1.Button1Click(Sender: TObject);
 begin
   {你的光标将位于这里,请输入后面的代码:}    Button1.caption := 'Press again';
   {源代码编辑器已经自动完成了这个过程的其他部分}
 end;

按下F12选中Form1窗体。

然后我们来编辑Button2的属性,将Caption修改为"Exit",然后选择OnClick事件,单击那个显示"..."的小方格,你又回到了源代码编辑器,光标位于另一段过程代码的中间:

 procedure TForm1.Button2Click(Sender: TObject);
 begin
 {输入:}   Close;
 end;

再次按下F12选中Form1窗体。现在可以尝试编译这个程序了。最简单的方法是在顶部主菜单中选择"运行",在弹出的子菜单中选择"运行"(你也可以使用快捷键F9)。如果一切顺利,你的程序将被编译执行。

所有的编译信息都会出现在底部的"消息"窗口中。最终,一个没有刻度标记(编辑状态下才会出现)的Form1窗口将出现在屏幕上。这是你的应用程序的主窗口,它正等着你去按按钮(以及其他操作)。

尝试下点击Press按钮,你会发现按钮的标签变成了"Press again"。之后你再怎么按,它依然显示"Press again"。

现在点击Exit按钮,窗口将关闭,程序也就终止了。编辑状态下有着丑陋刻度标志的Form1又回到了屏幕上,准备接受更多的修改完善。

现在你应该保存你的工作了(你应该经常这么做!),选择顶部主菜单上的" 工程 > 保存工程 "来保存工程文件。

第二步

再次打开你保存的工程。

在Form1窗体上选择Press按钮("Button1")。

在"事件"标签中选择OnClick,点击出现的"..."方格,来回到源代码编辑器。

按照下面的文本编辑你的代码:

 procedure TForm1.Button1Click(Sender: TObject);
{这段代码使用了Button1的Tag属性,使Tag属性在0和1之间转换}
 begin
   if Button1.tag =0 then
   begin
     Button1.caption := 'Press again';
     Button1.tag := 1
   end else
   begin
     Button1.caption := 'Press';
     Button1.tag := 0
   end
 end;

保存你的工作,重新编译并且运行,Press按钮的标签将会在点击时,在两个不同的文本间来回变换了

然后,随便玩吧:]

如果你准备编写控制或者基于文本的Pascal程序(例如你正在使用一份基本的Pascal指南,准备编写在控制台环境下运行的程序,以及为系统底层编程等等),你依然可以使用Lazarus编写,编译并且运行你的程序。Lazarus是一个理想的Pascal开发环境。具体请参照Console Mode Pascal.

第三步 常用调试方法

新人学习不少需要调试的内容

所以需要一些直接有效的打印出调试内容.

比如像VB 下的 Debug.print 可直接在立即窗口中打印出调试内容

其实可以使用

 WriteLn('XXXX ', XXX); 
 Write('XXXXXX');   

但是在网上发现不少新人使用会弹出: project project1 raised exception class 'EInOutError' with message:file not open

异常通知

只需要在文件头部加入预编译指令

 {$APPTYPE CONSOLE}

这样调试时会弹出一个类dos对话框,输出调试的内容


第四步 常用技巧

lazaurs的编辑器蛮强大的,支持代码补全,自动完成,模板编辑,多行缩进注释,选定代码后批量更改里面的单词!

1.代码补全

按下键盘的Ctrl+W键!输入变量后按下这个键就OK啦~

2.自动完成

自动完成的快捷键大多数都冲突了,解决方法是打开Tools->Option->Editor->Key Mappings->CodeTools commands->Identifier completion上右键edit,然后根据实际情况修改吧,我的是再勾选Alt,也就是说,我的热键是Ctrl+Alt+Space!不懂的看图

3.模板编辑

这个也蛮简单,按下键盘的Ctrl+J,然后输入class,回车!是不是很酷!

4.多行缩进注释

缩进的:向左 -> Ctrl+U

向右 -> Ctrl+I(选中多行代码更爽)

多行注释:Ctrl+/

5.选定代码后批量更改里面的单词 先选中一行代码,然后点击编辑器左边显示行号左边的那支笔,看看图哦。

这个时候你可以输入b,变量a就全部改为b,还可以按下tab跳到下一个单词。

6.编辑器的高亮

<?xml version="1.0"?>
<CONFIG>
 <EditorOptions Version="9">
   <Display DoNotWarnForFont="Ubuntu Mono" EditorFont="Ubuntu Mono" EditorFontSize="13">
     <MarkupCurrentWord NoKeyword="False"/>
   </Display>
   <KeyMapping>
     <default Count="1">
       <Version Value="6"/>
       <Item1 Name="Identifier completion">
         <KeyA Default="False" Key1="32" Shift1="5"/>
       </Item1>
     </default>
   </KeyMapping>
   <CodeTools CodeTemplateFileName="/home/lht/.lazarus/lazarus.dci" CompletionLongLineHintTypeCompletionLongLineHintType="sclpExtendRightOnly" AutoDelayInMSec="104"/>
   <Mouse>
     <Default Version="1"/>
   </Mouse>
   <Color Version="9">
     <LangObjectPascal Version="9">
       <ColorScheme Value="Twilight"/>
       <SchemeTwilight>
         <Space Background="1973790" FrameColor="5000268" FrameStyle="slsDotted" FrameEdges="sfeBottom"/>
         <Number Foreground="7434751"/>
         <String Foreground="7337839"/>
         <Symbol Foreground="clYellow"/>
         <Comment Foreground="clSkyBlue" Style="fsItalic"/>
         <Assembler Foreground="11715098"/>
         <Directive Foreground="22015"/>
         <Case_label Foreground="16541892"/>
         <IDE_Directive Foreground="1478752"/>
         <Reserved_word Foreground="1023473"/>
       </SchemeTwilight>
     </LangObjectPascal>
     <Globals Version="9">
       <SchemeTwilight>
         <ahaDefault Background="1973790"/>
       </SchemeTwilight>
     </Globals>
     <LangPython Version="9">
       <SchemeTwilight>
         <Float Foreground="8345087"/>
         <Octal Foreground="16755455"/>
         <Number Foreground="8345087"/>
         <String Foreground="8388522"/>
         <Symbol Foreground="clYellow"/>
         <Comment Foreground="clSkyBlue"/>
         <Hexadecimal Foreground="8345087"/>
         <SyntaxError Foreground="16755285"/>
         <Documentation Foreground="16755370"/>
         <Reserved_word Foreground="43775"/>
         <Non_reserved_keyword Foreground="8366847"/>
       </SchemeTwilight>
     </LangPython>
   </Color>
   <Misc PasExtendedKeywordsMode="True"/>
   <General>
     <Editor TabIndent="True" TabWidth="2"/>
   </General>
   <DividerDraw>
     <LangObjectPascal>
       <TypeSect>
         <TopColor Value="9157119"/>
       </TypeSect>
       <TypeGVar>
         <TopColor Value="9157119"/>
       </TypeGVar>
       <TypeGStruct>
         <TopColor Value="9157119"/>
       </TypeGStruct>
       <TypeProc>
         <TopColor Value="9157119"/>
       </TypeProc>
       <TypeLStruct>
         <MaxDepth Value="1"/>
         <TopColor Value="9157119"/>
       </TypeLStruct>
     </LangObjectPascal>
   </DividerDraw>
 </EditorOptions>
</CONFIG>

Lazarus编辑器

当你第一次运行Lazarus时,一系列独立的浮动窗口将出现在你的桌面上。

首先,在桌面顶部有一个窗口,标题是Lazarus 编辑器 vxxxx - project(这会随着你当前打开的工程名字而改变)。这是你工程的主要控制窗口,包括主菜单和组件面板。

Screenshot-Lazarus 编辑器 v0.9.24 测试版 - project1.png

标题栏下面是包括"文件""编辑""查找"等常见项目(以及Lazarus特有的一些项目)的主菜单。

主菜单下面,组件面板的左侧是一组按钮,包括了主菜单中的常用项目,例如新建文件,保存等等。

在这个窗口下面,左边是对象观察器

Screenshot-对象观察器.png

右边是源代码编辑器

Screenshot-Lazarus 源代码编辑器2.png

也许会有一个小窗口覆盖在源代码编辑器上,是Lazarus预置的一个Form1窗体

Screenshot-Form1.png

如果你没有看见它,可以按下F12在源代码编辑器和窗体预览间来回切换。

窗体预览展示了应用程序的图形界面,源代码编辑器则显示了应用程序所关联的Pascal代码。对象观察器则展示了组件的更多细节。

当你创建一个新工程时(或者第一次运行Lazarus时),一个默认的窗体将被创建。这个窗体包含了一个带有刻度标尺(帮助你定位放置到窗体上的组件)的区域,以及包含常见的"最小化""最大化""关闭窗口"按钮的顶部标签。用鼠标点击这个窗体,左侧的对象观察器将显示这个窗体的属性。

在你工作的时候,其他一些窗口也会出现:

包含你工程的一些细节,并且允许你从工程中添加或删除文件的工程浏览窗口

Screenshot-工程浏览 - project1.png

以及显示编译信息,错误以及运行报告的消息窗口

Screenshot-消息.png

如果你从一个终端窗口中运行Lazarus,那么这个原始的终端窗口将被保留,编译信息也会显示在这个终端窗口中。

主菜单

主菜单包括如下内容: File(文件) Edit(编辑) Search(查找) View(查看) Project(项目) Run(运行) Components(构件) Tools(工具) Environment(环境) Windows(窗口) Help(帮助)

通常情况下,你可以通过鼠标左键来点击相应的菜单功能,也可以通过热键Alt+相应热键字母(如果焦点不在菜单上,你可以使用Alt键和方向键选择菜单)

文件子菜单

Menu-file.JPG
  • 新建单元: 创建一个新的单元文件(Pascal 源代码).
  • 新建窗体: 创建一个新的窗体: 提供可视化窗口以及Pascal源代码.
  • 新建 ...: 弹出一个对话框,(screenshot) 可以选择各种类型的文档进行创建。
  • 打开: 弹出一个对话框,可以浏览文件,并选择文件打开。
  • 重新打开: 放弃你对打开文件所进行的编辑,恢复到该文件的初始状态。
  • 打开最近的文件: 列出你最近编辑的文件, 让你从中选择一个。
  • 保存: 保存当前文件, 使用其当前文件名,如果该文件未命名, 系统将提示你取一个(类似于另存为)。
  • 另存为: 允许您选择一个目录和文件名保存当前文件。
  • 全选: Lazarus翻译成“全选”,个人认为翻译成“全部保存”更好一点,顾名思义,将所有文件都保存下来。
  • 关闭: 关闭当前文件, 提示你是否保存已编辑过的文件。
  • 关闭所有编辑器中的文件: 关闭当前文件编辑器中所有的文件,提示保存已编辑的文件。
  • 清除目录: 提供可编辑的过滤器,从目录中清除项目临时文件。
  • 打印: 打印当前文件。该菜单某默认不显示,你需要安装 $Lazdir/components/printers/design/printers4lazide.pas,并重新编译IDE。
  • 重启: 退出并重新启动Lazarus。
  • 退出: 退出Lazarus,会提示你保存所有修改过的文件

编辑子菜单

EditMenu.JPG
  • 撤销: 撤销最后一次操作, 返回到上一步操作时状态。
  • 重做: 重新最后的操作,取消撤销。
  • 剪切: 删除选定的文本或其他项目,并将其放置在剪贴板中。
  • 复制: 复制选定的文本
  • 粘贴: 将剪贴板中文本复制到光标位置,如果光标位置有选定文本,剪贴板中的内容将取代所选文本。
  • 缩进所选: 将光标所选内容安装Lazarus设置缩进(环境->Options->Editor->普通->代码折叠)。这个将你的Pascle代码格式化,使之结构整齐。
  • 取消所选缩进: 删除你所选文本一个级别的缩进。
  • 封装所选: 提供一个窗口列表出一些逻辑上可以封装所选文本,如(begin ... end; try ... except; try ... finally; repeat ... until; { ... } 等等).该功能可以将所选代码包含在begin ... end;或者其他所选的块结构中.
  • 转换所选为大写: 转换选择的文本为大写.
  • 转换所选为小写: 转换选择的文本为小写.
  • 制表符转为空格: 将选择文本中的制表符转换为空格。在Environment -> Editor options -> General -> Tab widths中可以设置制表符宽度。
  • 选中节自动换行: 如果选择的内容所在行超出80个字符将不再显示,使用此功能,将会换行显示,Environment -> Editor options -> Display -> Right Margin, 设置显示宽度。
  • 注释选择: 注释选中的文本,即在行前加 // 。
  • 取消注释: 移除注释信息。
  • 排序所选: 排序所选内容,按字母顺序、区分大小写等等,在列表中对分类进行排序,它将非常有用。
  • 选择: 允许选择文本块、所有、到括号、段落、行、单词等。
  • 从字符映射表插入: 允许插入非键盘符号,如重音字符。
  • 插入文本: 弹出菜单,允许插入标准文本,如CVS关键字(作者、日期、标题等)或GPL信息,用户名或当前时间与日期。
  • 自动完成代码: 它可以节省你很多时间,在你获取或设置属性时,或使用方法时,你可以得到相关提示。在事件中加入方法,可参见Lazarus IDE工具
  • 解析过程: 使用选定文本(一条语句或多条),以创建一个新的过程。

查找子菜单

SearchMenu zh CN.png
  • 查找: 和大多编辑器一样,弹出一个搜索对话框,输入要搜索的内容,可以按大小写、全字匹配、范围、方向等查找。
  • 查找下一个, 查找上一个: 向上或向下再次搜索指定内容。
  • 在文件中查找: 在文件中搜索指定内容:在弹出的对话框中设置参数,可以按打开的文件,设定的目录,及筛选文件来查找。
  • 替换: 等同于 查找; 在弹出的替换对话框中,输入要搜索及要替换的内容。可以按区分大小写的方式,向上或向下进行替换操作。
  • 增量搜索: 高亮显示你搜索的字符串。如,选择增量搜索后,你按L后,将会高亮L显示,如果你再按A,编辑器会查找下一个LA并高亮显示。
  • 转到行: 移动光标到指定行。
  • 跳转到后一个:跳转到原来的位置。IDE会记录你的光标位置,根据它来决定你跳转或返回位置。
  • 跳转到前一个: 跳转到下一个位置。跳回来。
  • 添加跳转点到历史: 添加跳转位置到历史记录。
  • 查看跳转历史: 查看跳转点:功能未实现
  • 跳转到下一错误, 跳转到上一错误: 跳转到上一个或下一个错误处。
  • 设置一个自由书签:标记当前光标所在位置用作书签。在源文件中点击右键,在弹出来的菜单中跳到书签切换书签进行跳转操作。
  • 跳转到下一书签, 跳转到上一书签: 跳转到下一个或上一个书签。
  • 查找代码区段结束: 如果定位在beign处,则找到相应的end处,反之亦然。
  • 查找代码区段开始: 移动光标到过程或函数的begin处。
  • 在光标处查找声明: 查找选择的标识符被声明的地方,如文件没有被打开(如果是一个过程或函数的声明,如classesh.inc),将会被打开。
  • 在光标处打开文件名: 如果选择的内容是文件,将会打开它。你可以看看单元中引用的文件。
  • 前往包含指示处: 如果光标定位在包含的文件处,那么将打开包含的文件。
  • 查找标识符参考: Produces a list of all the lines in the current file, or the current project or all attached files, in which an identifier is mentioned. (显示包含标识符的过程(函数)列表。)
  • 重命名标识符: 允许开发人员重命名一个标识符。
  • 过程列表: 显示当前文件中定义的过程(函数)。

查看子菜单

ViewMenu zh CN.png

控制屏幕上的各种窗口和面板显示。

  • 对象观察器: 通常显示在编辑器的左侧,它显示了控件的属性选项。用鼠标选择列表中的控件,会显示它们的属性信息。也可以在窗体中选择控件来改变它们的属性值。

主面板中的标签“属性”:用来改变控件显示属性,如名称、颜色,标题、字体、大小等(两列中,左侧为属性,右来输入或选择属性值)。 “事件”:列表控件允许的事件,如点击、双击等。点击...在源代码编辑器中编写相应事件。 “常用”:显示常用的属性和事件列表(你也可以右击属性,也添加到“常用”中)。 “限制“,控件在各平台中的支持情况。

  • 源代码编辑器: 编辑源代码的地方。和大多图形化文本编辑器一样,可以使用鼠标定位输入位置,并支持高亮代码。右击将弹出菜单,通常包含:复制、剪切、粘贴功能。源代码编辑器顶部可多个选项卡,你可以单击来切换不同的源文件来编辑它。源代码编辑器支持缩进和语法高亮,你可以在“Environment”->"Editor"中设置相应参数。
  • 代码浏览器: 以树形方式显示定义的信息。“显示类别“:它通常只显示名称、接口部分与实现部分的定义。点击+展开显示更多。直到具体的常量、类型、变量及过程、函数的声明。如果修改了源代码,你需要点击“刷新”,来刷新文件结构。
  • 单元...:显示单元文件,显示包含的文件,并可以编辑它。允许显示多个文件,同时打开并编辑它。
  • 窗体...: 显示当前窗体列表,允许选择一个或多个。
  • 查看单元信赖关系: 以树状形式显示单元文件的信赖关系。
  • 切换窗体/单元 视图 F12: 切换源代码编辑器和窗体。你也可以按F12键来切换。
  • 消息:显示编译器消息,编译进度或编译错误的信息。
  • 查找结果: 显示找到文件的结果。
  • 调试窗口: 在子菜单中选择用于操作和配置的调试器。具体可以参看调试器

工程子菜单

ProjectMenu zh CN.png
  • 新建工程...: 在弹出的对话框中,选择工程类型,以创建一个新工程。
  • 从文件新建工程...: 打开“选择程序源代码”窗口,选择一个文件,以创建新的项目。
  • 打开工程... 打开“打开工程文件(*.lpi)”窗口,选择一个工程文件,以打开工程。
  • 打开最近的工程...: 显示最近打开的工程列表,以供选择。
  • 保存工程: 等同于“文件”->“保存”,将当前工程文件全部保存,如果工程文件未保存,将提示保存它。
  • 工程另存为...: 输入工程名后,另存工程,默认工程名为Project1.lpi;Lazarus不允许你使用相同名称做为项目文件、单元文件名。(参见 下文)。
  • 发布工程...: 创建整个项目的副本。一个正常的项目目录包含了大量信息,大部分不需要再作发布:lpi文件包含会话信息(如光标位置,单元标签等),项目目录也包含了很多ppu、o及可执行文件。此功能在对话框中你可以设置过滤器排除掉那些无用的文件;也可以使用命令压缩为一个文件。参见 Lazarus IDE 工具
  • 工程浏览器: 以树状列出当前工程包含的文件及需要的包,你可以删除,或打开选择的文件,也可以添加文件到工程。
  • 工程选项...: 配置工程,在这里,你可以设置程序标题,目标文件名等详细信息。
  • 编译器选项 ...: (Recently moved here from the Run Menu). Opens a multi-page tabbed window which allows configuration of the compiler. Tabs include Paths which allows definition of search paths for units, include files, libraries etc, as well as allowing choice of widget type for the forms (gtk, gnome, win32); Parsing which allows choice of rules for parsing source programs, Code which allows choice of optimisation for faster or smaller programs, choice of target processor, types of checks, heap size etc; Linking allowing choice of whether or how to use debugging, static or dynamic libraries, and whether to pass options through to the linker; Messages to define what type of messages should be generated during error conditions; Other which allows decision to use default configuration file (fpc.cfg) or some other file; Inherited which shows a tree structure diagram to indicate how options have been inherited from units already incorporated; Compilation which allows definition of commands to be executed before or after the compiler is launched and can allow use of Make files.
  • 添加代码编辑器中的文件到工程: 添加文件到当前项目。
  • 从工程中移除...: 在弹出的窗口中,选择文件,以从当前工程中移除。
  • View Source: 显示代码编辑器。
  • 显示 ToDo 列表:显示与此项目有关的待办事项。它将列出项目中的TODO注释(//TODO)。

新版本(如1.0.14),Ctrl+Shift+T键,在当前位置添加一个TODO。格式如// TODO : 待办说明。

运行子菜单

RunMenu zh CN.png
  • 构建: 构建(即编译)项目。
  • 构建所有: 编译项目中所有的文件。
  • 中止构建: 停止构建,一旦它运行——停止时会造成一些异常,如IDE失去响应。(你需要在任务管理器中关闭IDE进程)
  • 运行: 常用的方式编译程序,如果成功将开始运行程序;实际情况时,Lazarus保存编辑的文件,启动编译器和链接器。最后执行链接后的可执行程序。
  • 暂停: 暂停执行当前正在运行的程序,这样你可以检查调试输出。通过“运行”可进行恢复。
  • 单步进入: 与调试器配合使用,程序一步一步的执行。
  • Step over: Causes stepwise execution up to the statement marked, then skips the marked statement, and continues execution at normal speed. Useful in trying to isolate a statement that introduces a logical error.
  • 运行到光标处: 执行到光标所在位置,然后停止。通过“运行“恢复程序继续执行。
  • 停止: 停止当前正在运行的程序。无法通过“运行”恢复,这将再次启动程序。
  • 带参数运行: 打开“带参数运行”窗口,将参选参数传递给程序。你可以选择一个运行终端(如X终端);一些系统环境变量可以被覆盖。
其用途时,在Pascal控制台显示终端窗口。

如果你正在开发一个控制台模式的Pascal程序(即不使用图形界面),你应该勾选"使用运行的应用程序"。

当你尝试编译/运行程序时,会得到错误消息:

"xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied".(大意为:权限不足。) 

如果出现这种情况,你需要设置程序的拥有可执行权限(如使用 chmod +x 文件名);程序启动后,程序的所有输入/输出都将在控制台中显示。

程序执行完毕,“Press Enter”显示在屏幕上,这时,程序之前的输入/输出都将在屏幕上显示,直至你按 Enter关闭控制台窗口。

注意: 作为当前版本,对Windows用户,没有控制台命令。直到Lazarus团队的adressess说,下面一行应该工作(on WinXP -- someone please update for other Windowses)

C:\Windows\system32\cmd.exe /C ${TargetCmdLine}

参见Pascal 控制台模式的单独教程。

  • 重置调试器: 恢复调试器到最初状态,这时候,变量、断点的值都将重置。
  • 构建文件: 编译(构建)当前文件。
  • 运行文件: 编译、链接并执行当前文件。
  • 配置 编译+运行 文件: 打开“配置构建”窗口,进行构建设置。

--Feibaicamel 14:28, 31 12月 2009 (CET)

包子菜单

PackageMenu zh CN.png


  • 打开包文件: 打开包文件。


  • 打开最近的包: 打开最近使用的包。


  • 将活动单元添加到包: 将单元文件添加到包中。


  • 包关系图: 显示当前正在使用的软件包关系图(如果你没有使用其他包,将显示Lazarus包和FCL及LCL包。)


  • 配置已安装的包:如果你已经创建了一些组件,此项允许你配置它们。

注意:配图与介绍并不符合,因为Lazarus版本不同,但大多项是相似的,你可以参照着使用。)

工具子菜单

ToolsMenu zh CN.png
  • 配置外部工具: 允许用户添加各种外部工具(通常是宏)。


  • 快速语法检查: 非实际编译任何源文件,只进行语法快速检查。在开发大的或复杂的程序时,使用此项将节省你的时间;因为编译代码时错误是不可避免的。


  • 猜测未关闭的块: 这是个有用的工具,假设你的一个复杂的嵌套块,缺少end块,使用此项功能可能会帮到你。


  • 猜测错位的IFDEF/ENDIF: 如果你有一个复杂的嵌套,缺少或错位endif时,此项功能会帮到你。


  • 生成资源字符串: Makes the selected string a resource string by placing it in the resourcestrings section. An advantage of resource strongs is you can change them without the need to recompile your project!


  • 比较Diff: 允许两个文件进行比较(通常是文件的不同版本)。允许设置一些选项进行比较。


  • 在编辑器中检查LFM文件: 检查lfm文件。




  • 构建Lazarus: 重新构建Lazarus,按下按钮,等待构建。(在消息窗口会有状态显示。)


  • 配置 ”构建Lazarus: 允许用户确定Lazarus哪部分重建,以及如何重建。如,你可以重建LCL,或一些小部分,你可以选择目标系统,并指定不同目录。
  • 重新扫描FPC源代码目录: 如果改变了环境目录,可以使用此功能让Lazarus重新扫描源目录。如果扫描失败,你需要检查“工具”->“选项”中配置FPC源目录。及重新扫描FPC源代码目录。

IDE选项

在Lazarus 1.0.14版中,通过"工具"->"选项",可以打开IDE设置窗口。 在这里你可以对环境、编译器、JCF格式设置、代码工具、代码管理器、调试器、帮助等信息配置。

IDE Options zh CN.png
  • 环境
    • 文件:最大记录工程数、文件数及设置Lazarus目录、编译器路径、FPC源代码目录、Make文件目录等等。
    • 桌面:设置IDE语言、自动保存信息等等。
    • 窗口:可对窗口位置、终端输出进行相应设置。
    • 窗体编辑器:对颜色、风格等设置。
    • 对象查看器:对颜色、速度等设置。
    • 备份:工程文件备份设置,其他文件备份设置。
    • 命名:对Pascal后缀、可疑文件动作、自动重命名Pascal文件为小写、单元被重命名,更新引用等等配置。
    • FPDoc编辑器:配置FPDoc。
    • 文件筛选:对单元、工程、窗体、包、其他文件设置筛选器。
  • 编辑器
    • 普通:允许设置撤销/重做次数、滚动方式、缩进与制表符、光标等设置。
    • 显示:设置边界和边缝及默认编辑器字体。
    • 键盘映射:快捷键设置。
    • 鼠标:对鼠标操作进行相应设置。
    • 自动化功能:对自动补充信息进行设置。
    • 代码折叠:对代码折叠相关进行配置。
    • 隔离区绘制:代码块间线条设置。
    • 页和Windows:暂无。
  • JCF格式设置
    • 文件格式:暂无。
    • obfuscate:暂无。
    • clarify:暂无。
    • preprocessor:暂无。
  • 代码工具
    • 普通:方法跳转、工程附加源文件路径等设置、pascal源文件缩进设置。
    • 类完成:类、方法部分插入方式及属性自动完成配置。
    • 创建代码:插入过程策略、新单元添加到uses部分等配置。
    • 单词:设置关键字策略、标识符规则及例外等。
    • 分割行:可设置最大行宽、不拆分前面、后面行的条件。
    • 空格:空格插入方式,在关键字、标识符等前或后插入空格。
    • 标识符自动完成:设置标识符自动完成条件,如添加分号时。
  • 代码管理器
    • 更新:设置优先表现模式(分类、源代码),自动刷新条件及跟随光标。
    • 种类:设置只在类模式中使用变量、常量、引入、定义等。
    • 代码观察器:对代码观察器进行一些配置。
  • 调试器
    • 普通:可设置调试器类型和路径调试器特殊选项等。
    • 事件日志:对消息窗口进行设置,如错误时显示的颜色等。
    • 语言异常:设置忽略哪些异常,如 中止、代码工具错误、Fopen错误。并允许添加忽略。
    • 操作系统异常:设置操作系统异常处理方式。
  • 帮助
    • 帮助选项:设置FPC HTML文件路径、默认查看器等。
    • 外部:对外部程序进行配置,如Windows、PostgreSQL、Gtk2配置名称、单元文件及位置。并允许添加外部程序。

窗口子菜单

WindowMenu zh CN.png

包含当前打开的文件和可用窗口,如“源代码编辑器“,“对象观察器”,选择后,显示它。

帮助子菜单

HelpMenu zh CN.png

目前这有三个菜单项:

  • 在线帮助 在打开的浏览器窗口中,显示FPC和Lazarus的帮助链接。
  • 配置帮助 (1.0.14没有此菜单项)在弹出的菜单中,设置Lazarus帮助信息。目前,在默认情况下,鼠标选中关键字,按F1键盘,将会显示与此关键字相关的帮助信息。
  • 关于 Lazarus 显示一个弹出式窗口,里面有一些关于Lazarus的信息。

最终将有一个完整的在线帮助服务,包含Pascal语法、IDE使用、及如何创建和修改组件。该文档(目前你正在查看的)也是帮助的开始。

We need contributions from anyone who feels able to provide them: the WiKi is very easy to edit.(我们需要从任何人那里得到帮助:编辑维基很容易

按钮栏

ButtonBar zh CN.png

在主编辑器窗口左侧小工具栏位置,(主菜单下方与左侧组件面板中),包含一组按钮:

“新建单元”、“新建窗体”、“打开”、“保存”、“保存所有”、“新窗体”、“切换窗体/单元”、

“查看单元”、“查看窗体”、“运行”、“暂停”、“步进”、“下一步”、“运行,直到函数返回”。

组件面板

标签式工具栏里显示常用组件图标。

每个选项卡使用一组不同的图标显示,选项卡组最左边的第一个图片(指向箭头),称为选择工具。

如果你将鼠标悬停在组件面板中的图标上,将会显示该组件的提示信息。T意味着,Type类型,或者是Class组件。在窗体中,使用组件时,类将会添加到类型和接口处(通常作为TForm1一部分)。实例化处,添加到VAR部分(通常作为Form1变量)。任何方法,设计时要使用窗体或组件(程序或函数),将被放置在implementation部分。如果你要找出某一特定组件的属性,可以看组件的继承,之后检查其派生的基类型的属性。例如,你要了解TMaskEdit,可以查看TcustomMaskEdit。

选项卡(通过名称可以了解的其包含了哪些组件):

Component Palette Standart.png
通常使用的组件: TMainMenu, TPopupMenu, TButton, TLabel, TEdit, TMemo, TToggleBox, TCheckBox, TRadioButton, TListBox, TComboBox, TScrollBar, TGroupBox, TStaticText, TRadioGroup, TCheckGroup, TPanel, TActionList
Component Palette Additional.png
更多经常使用的组件: TBitBtn, TSpeedButton, TImage, TShape, TBevel, TPaintBox, TNotebook, TLabeledEdit, TSplitter, TMaskEdit, TCheckListBox, TScrollBox, TApplicationProperties, TStringGrid, TDrawGrid, TPairSplitter
Component Palette Common Controls.png
TTrackBar, TProgressBar, TTreeView, TListView, TStatusBar, TToolBar, TUpDown, TPageControl, TImageList
Component Palette Dialogs.png
TOpenDialog, TSaveDialog, TSelectDirectoryDialog, TColorDialog, TFontDialog, TOpenPictureDialog, TSavePictureDialog, TCalendarDialog, TCalculatorDialog

有几个有用的对话框,它不在组件面板中显示,但在你可在过程函数中直接调用。

有关组件使用的例子,请参看$LazarusPath/lazarus/examples目录。许多程序不使用IDE组件而直接使用对话框或其他组件的调色板,或者有一个单独的窗体定义文件:所有组件中,在Pascal主程序部分定义使用。


一些示例,不马上使用的:你可能需要调整路径和文件(目录)的执行权限。如果你想直接编译示例,请确保对文件(目录)具有读取/写入/执行权限。

请尝试运行testall程序,以查看可用组件和示例菜单,大多数的测试,可以确定你的环境是否能够正常使用这些组件!

  • 杂项组件
Component Palette Misc.png
TColorButton, TSpinEdit, TArrow, TCalendar, TEditButton, TFileNameEdit, TDirectoryEdit, TDateEdit, TCalcEdit, TFileListBox
  • 数据组件
Component Palette DataControls.png
数据组件,通常用于数据库: TDBNavigation, TDBText, TDBEdit, TDBMemo, TDBImage, TDBListBox,TDBComboBox, TDBCheckBox, TDBRadioGroup, TDBCalendar, TDBGroupBox, TdbGrid
  • 数据访问组件
Component Palette DataAccess.png
TDatasource
  • 系统组件
Component Palette System.png
TTimer, TIdleTimer, TProcess
  • SynEdit(编辑器组件
Component Palette SynEdit.png
SynEdit是一个高级的文本编辑器控制,对Borland的Delphi,Kylix、C++Builder等支持语法高亮和代码自动完成,并支持输出为HTML、Tex和RTF。这是一个VCL/CLX控件,意味着,适用于Microsoft的Windows,没有信赖的运行库,SynEdit作为跨平台组件,也是Lazarus IDE中的编辑器组件。 查看 sourceforge上的synedit. TSynEdit, TSynAutoComplete, TSynExporterHTML, TSynMacroRecorder, TSynMemo, TSynPasSyn, TSynCppSyn, TSynJavaSyn, TSynPerlSyn, TSynHTMLSyn, TSynXMLSyn, TSynLFMSyn, TSynUNIXShellScriptSyn, TSynCssSyn, TSynPHPSyn, TSynTeXSyn, TSynSQLSyn, TSynMultiSyn

要使用调色板,必须存在窗体(如果没有,选择文件->新建窗体)。单击调色板中需要使用的控件,在窗体上单击,这时候,窗体上,将显示出来调色板组件;你可以调整它到合适的位置,通过属性可以显示外观。

如果你想安装额外的组件,无论是你自己编写的,还是第三方的;完成后,将在组件面板中显示出来。

如何使用通用控件

StdCtrlsComCtrlsExtCtrls包含了常用控件的构建形式及Lazarus应用程序中常用对象。

许多控件应用程序开发人员都要使用,如TButtonTMemoTScrollBar等等。声明的控件都继承自父类。

使用这些控件时,你可以选择相应控件,在窗体上拖放就可以了。也可以使用代码创建,但是,在你不需要时,你需要销毁它。

设置属性

在窗体设计器上放置控件后,在对象检查器中,你可以设置控件属性或编写相应事件代码。

如,你在窗体上放置了一个按钮(TButton),选择它,并移动它以改变位置,你会可以看到它的top和left值的变化。在对象观察器中Height、Width值分别代表其大小高度和宽度。

此外,你可以使用代码来改变对象属性:

Form1.Button1.Height := 48;

在FormCreate过程中书写上面的代码,程序运行时,将看到效果。

总之,有三种方法,可以设置对象的属性:

  • 通过鼠标在窗体上调整
  • 通过设置对象观察器中的值
  • 通过代码来设置属性

公共属性

每个组件(控件)都有不同的属性,有某些是相同的,常见的,下面这介绍这些常用属性:

通过选择属性或关键字,在对象观察器或源代码编辑器中按F1来获得帮助。

If the description of a property on that page is insufficient, you can navigate to the corresponding description in the ancestor classes, by selecting the links in the Inheritance listing or by selecting the ancestor Type in the declaration of the object.

常用属性
属性说明介绍
Action 行动 与对象关联的主要动作或事件。如,在选择“退出”时,会导致“关闭”。
Align 对齐 定义与父对象对齐方式。alTop:顶对齐;alBottom:底对齐;alLeft、alRight:左对齐和右对齐;alNone:无;alClient:占用父对象所有空间。
Anchor 用于保持控件的父控件;当父控件调试大小将调整与其距离。[akBottom,akRight]将保持固定在父控制右下角距离。
AutoSelect 自动选择 为True时,控件在获取到焦点,或当按下 Enter键时选择所有文本。
AutoSelected 自动选中 True indicate that the edit or combobox control has just performed an AutoSelect operation so that subsequent mouse-clicks and keystrokes proceed normally without selecting the text.
BorderSpacing 边框间距 The space around the edge between an Anchored control and its parent.
Caption 标题 设置显示内容,如按钮标题为“关闭”或“执行”。默认情况下,标题名称与Name属性值相同。
CharCase 字符显示 设置字母在编辑控件中显示方式:Normal:正常(不改变字母大小写);ecLowerCase:转换为小写;ecUppercase:转换为大写。
Constraints 限制 设置控件最大、小、高、宽度。如果调整控件大小,新的大小将在此范围内。You should take care when setting these options that they do not conflict with the Anchors and Align settings.
Color 颜色 设置控件的文本颜色。
Enabled 启用 设置控制是否可用,如果为False,在窗体上显示为灰色
Font 字体 设置对象的字体信息,通常(+)号展开详细,如字体、字号、颜色等。
Hint 提示 鼠标悬停在控件上时,弹出的提示信息。请注意ShowHint属性为True时才显示。
Items 项目 包含的数据信息,如果文本行等。
Lines 列表 字符串数组,包含单个数据,数组为索引从0开始,即[0..numLines-1]。
Name 名称 设置控件的标识符。如TBitButton的实例,为Form1.BitBitton1、Form1.BitButton2等等,程序员应该使用见名真义的名称,如ExitButton(退出按钮)或OKButton(确定按钮)。
PopUpMenu 弹出式菜单 设置在控件上右击时,弹出的菜单。
Position (or Top, Left) 位置 设置控件位置。
ReadOnly 只读 为True时,控件只能被读取,不能被更改。如Edit。
ShowHint 显示提示 设置鼠标'悬停'在控件上时,是否显示提示信息。
Size (or Height and Width) 大小 设置控件尺寸。
Style 样式 The options available for Style depend upon the sort of Control being considered: for instance the Style may be defined by TFormStyle, TBorderStyle, TButtonStyle etc.
TabOrder Tab键顺序 输入整数,设置Tab 的顺序。
TabStop 制表位 为False时,Tab 将无法选中此控件,否则可以。
Text 文本 字符串文本,表示该控件包含的数据。适用于Text、Memo、StringList类型。Most of the editing operations (such as Select, Clear, Cut, Copy) are performed in this part of the object, which holds the actual string being edited. If the control contains more than a single line of text, for example TMemo or TComboBox, then the textual elements are arranged as an array of strings (zero-indexed, ie numbered from [0..numLines-1]) in Lines.
Visible 可见 为True,在窗体中可以看到此控件,否则将隐藏。
WordWrap 自动换行 为True时,文本内容将自动换行。

事件动作

许多行动通常列在“对象观察器”中的“事件”选项卡里。在列表中选择相应事件,在下拉列表中将会显示你已经定义的方法,并允许你对其关联。点击旁边的"..."按钮,将跳到源代码编辑器里,你在那里可以编写相应程序。

“事件“选项卡中,显示了当前控件支持的事件,像OnClick事件:鼠标点击事件;OnEntry:当获得焦点时;OnExit:当失去焦点时;或者你可以编写:OnChange:内容改变时;或OnScroll:在滚动条上操作时等等,根据你的需要来选择使用哪些事件进行哪些操作。

在窗体设计器上右击控件 ,“创建默认的事件“也有相同的效果,通常是OnClick(点击)事件。之后在源代码编辑器里编写相应操作。

在面向对象程序设计中,使用 TActionList 组件是为了集中处理许多常用的操作,把用户界面和应用逻辑分开,减少程序的代码行数,方便程序的维护和调试。它用于维护一系列动作列表,以供其他组件或控制所使用,如菜单和按钮。


单击方法
常用事件
事件 说明 介绍
OnChange 改变事件 当检测到任何更改(如鼠标移动、点击、按键、编辑文字、更改图片等)都将触发此事件。
OnClick 点击事件 鼠标点击时触发此事件(点击,指的是鼠标左键点击),点击事件大多是控件默认的事件,如点击一个按钮、单选框或复选框。
Click 单击方法 单击方法,在代码中模拟点击控件。一个程序可以调用相同代码的OnClick事件,通过点击激活其他事件。这个方法可以在程序启动时使用,而不是用户点击后再进行某些操作。
OnDragDrop 拖放事件 拖放操作之前,即当鼠标选中某些信息(如文本)要移动到新位置时。
OnEditingDone 编辑完成事件 当用户完成编辑/修改时,通常用来验证输入内容,如检测输入的文本是不是有效的IP地址。
OnEntry 获得焦点事件 当控件获取到焦点时,触发此事件。
OnExit 移出事件 当鼠标移出控件区域时触发此事件。
OnKeyPress 按键事件 按键事件,当按下某键时,将触发此事件。不同于OnKeyDown:当按下但不松开某键时触发此事件。
OnKeyDown 按下键不松事件 如果一个键被按下,但不松开,将触发此事件。
OnKeyUp 松开键事件 松开按键时触发此事件。
OnMouseMove 鼠标移动事件 当鼠标在控件上移动时触发此事件。
OnMouseDown 鼠标按下事件 鼠标按下但不松开时触发此事件。
OnMouseUp 鼠标松开事件 鼠标按下并松开时触发此事件。
OnResize 改变大小事件 调整控件大小时触发此事件。

构造和析构函数

每个对象都有两个相关联的方法:

  • 构造函数:在创建时,即分配对象所需内存和资源时。
  • 析构函数:在删除时,即释放分配对象所需内存和资源时。

释放对象,你需要使用free方法,因为它会检测对象值是否为nil。如果你调用已经销毁的对象,它将产生一个错误。

销毁时,注意以下:

  • Declare Destroy with the override directive, because it is a virtual method.
  • Always call 'inherited Destroy;' as the last thing on the destructor code.
  • Be aware that an exception may be raised on the constructor in case there is not enought memory to create an object, or something else goes wrong. If the exception is not handled inside the constructor, the object will be only partially built. In this case Destroy will be called when you weren't expecting it, so your destructor must check if the resources were really allocated before disposing of them.
  • Remember to call Free for all objects created on the constructor.

为窗体创建菜单

TMainMenu是大多都使用的;在窗体顶部会出现菜单栏,设计者可以定制不同的菜单项。TPopupMenu是一个与上下文相关的菜单。通常是在控件附近点击时弹出的。

主菜单是非可视组件:也就是说,在组件面板中选择菜单图标,放置在窗体上,运行时不会被显示,你需要创建菜单项,像TPopupMenu菜单,你需要关联相应组件的PopupMenu属性。


若要使用菜单编辑器:右击窗体上的菜单控件,在弹出的菜单中选择(Menu Editor)菜单编辑器,在弹出的窗口中,对菜单进行设置。

默认将显示一个NewItem1菜单项,右击它,弹出的菜单中,你可以继续在其上面或下面添加菜单,也可以子菜单。在对象观察器中,设置菜单项属性。

当然,你应该给菜单项起个有意义的名字,如File open(打开文件)、Close(关闭)等。 如果你想热键,即在菜单项后显示(&N),你只需要直接输入即可。当然,你也可以给菜单项关联快捷键,对象观察器中的ShortCut和ShortCutKey2属性,分别设置第1,2快捷键;如(复制,Ctrl+C;粘贴,Ctrl+V)。

另外,如需要在菜单项间插入一条分隔线,只需要设置菜单项的Caption属性为-即可。


你可以结合ActionList组件,对菜单各项的事件进行统一编写。

By default, a number of standard actions are pre-loaded from StdActns or, if DataAware controls are used, from DBActns. These actions can be chosen using the ActionList editor which appears when you right-click on the ActionList icon on the Form Designer.

调试器

待写

更多 category: IDE Window - Debug

Lazarus 文件

   (感谢 Kevin Whitefoot.)
   (Giuseppe Ridinò, User:Kirkpatc 和 Tom Lisjac 添加)

当你保存时,实际上会保存两个文件:

  xxx.pas 和 yyy.lpr

不止这些,还有项目文件(lpr)、单元文件(pas),名称不能相同,否则Lazarus会覆盖掉原文件,在编辑器会因为无法找到指定文件而报错。

所以,你需要保存为一个不重名的项目。

这是我最终的文件列表:

e:/lazarus/kj/lazhello:

total 4740  free 76500
-rwxrwxrwx   1 kjwh     root  4618697 Mar 24 11:19 again.exe
-rw-rw-rw-   1 kjwh     root     3002 Mar 24 11:21 again.lpi
-rw-rw-rw-   1 kjwh     root      190 Mar 24 11:18 again.lpr
-rw-rw-rw-   1 kjwh     root      506 Mar 24 11:08 againu.lfm
-rw-rw-rw-   1 kjwh     root      679 Mar 24 11:08 againu.lrs
-rw-rw-rw-   1 kjwh     root      677 Mar 24 11:08 againu.pas
-rw-rw-rw-   1 kjwh     root     2124 Mar 24 11:08 againu.ppu
-rwxrwxrwx   1 kjwh     root      335 Mar 24 11:07 ppas.bat

Note that there are many more files than the two that I thought I was saving.(注意,好像是多了两个文件,我想是我存的吧。)

下面是对每个文件的简短介绍:

again.exe: 二进制可执行文件,Win32中添加exe扩展名。linux没有。此文件在Linux上很大的原因是,加入了调试标记。 注意:在1.0.14版,可以勾选,“工程”->“工程选项”中的“编译选项”->“链接”:“从可执行程序中除去符号,可以减少程序体积(Strip Symbol)”;以减少程序体积。

again.lpi: 它以XML格式存储,是Lazarus项目的主要文件(项目信息);Delphi应用程序文件是.dpr。

again.lpr: 这是主程序的源代码文件,尽管使用了特定的扩展名,但它仍是正常的Pascal源文件。它有use部分,可以让编译器找到所需的单元。注意,程序名可以和该名称相同。

againu.lfm: 存储了Lazarus窗体布局信息;也包含了初始化部分的资源文件。Delphi的DFM文件可以转换为LFM格式:“工具“->“转换DFM文件为LFM文件”。

againu.lrs: 生成的资源文件。需要注意的是它不是Windows的资源文件。

againu.pas: The unit that contains the code for the form. 包含窗体代码的单元文件。

againu.ppu: 编译的单元文件。

ppas.bat: 一个简单的脚本,链接程序生成可执行文件。如果编译完成,将由编译器删除。

原作者和变化

这个页面来自 这里(失效)。

  • Created initial page and template. T. Lisjac - 11/04/2003 VlxAdmin
  • Inserted a note containing instructions for writing your first Lazarus Program. Suggest an administrator places it in the appropriate place on the Tutorial menu. 3/09/2004 User:Kirkpatc
  • Per above, moved Chris's writeup to the main body of the tutorial VlxAdmin
  • Began to insert text describing the Lazarus Editor - more to follow! 24 Mar 2004 User:Kirkpatc
  • Added some more to Lazarus Editor section of Tutorial. 25 Mar 2004 User:Kirkpatc
  • Added screenshots and revised some of the page formatting VlxAdmin 3/25/2004
  • Moved some of kwhitefoot's comments into Tutorial section. Formatting not quite right, but have to go to bed now! 26 Mar 2004 User:Kirkpatc
  • Formatted, added credits and comments. Removed original notes. VlxAdmin 3/26/2004
  • More material added to Editor section of tutorial. 26 Mar 2004 User:Kirkpatc
  • More material added describing the Main Menu. Renamed 'Hello World' to 'Getting Started' and moved it to nearer the top. 31 March 2004 User:Kirkpatc
  • Inserted section on Run sub-menu. Some general editing (eg ended each entry with a period to ensure consistency). 9 Apr 2004 User:Kirkpatc
  • Inserted a new section on How to get started with MySQL in FPC/Lazarus. 13 Apr 2004 User:Kirkpatc
  • Deleted the section on MySQL from here: it has been copied to Lazarus Database section of tutorial. 14 Apr 2004 User:Kirkpatc
  • Added some more to the description of the Editor Main Menu. 18 Apr 2004 User:Kirkpatc
  • Added section on Environment sub-menu. 19 Apr 2004 User:Kirkpatc
  • Added section on Components sub-menu. 4 May 2004 User:Kirkpatc
  • Adding Tools sub-menu description (incomplete). 7 May 2004 User:Kirkpatc
  • Added some screenshots to Menu descriptions. 9 May 2004 User:Kirkpatc
  • Fixed a bit in Environment Options - thanks VincentSnijders. 14 May 2004 User:Kirkpatc
  • More additions to Tools sub-menu. 19 May 2004 User:Kirkpatc
  • Added a section on the Button Bar and started work on The Component Palette. 20 May 2004 User:Kirkpatc
  • Posted a description file for the StdCtrls unit of the LCL, in the hope that people will add comments. 26 May 2004 User:Kirkpatc
  • Edited the StdCtrls file, removing a lot of repetitive material and doing some formatting. It is still far too long. 28 May 2004 User:Kirkpatc
  • Expanding on the Components Palette. 5 June 2004 User:Kirkpatc
  • Added a lot to the DialogExamples page. 10 June 2004 User:Kirkpatc
  • Considerable revision of the StdCtrls page, hopefully making it clearer and encouraging people to contribute - particularly in the 'Description' sections. 14 June 2004 User:Kirkpatc
  • Added pages for Menus and Dialogs units (linked to Component Palette description) - please feel free to add to these pages. 14 June 2004 User:Kirkpatc
  • Added page for Common Controls (linked to Component Palette). 16 June 2004 User:Kirkpatc
  • Added MaskEdit page (linked to Component Palette). 17 June 2004 User:Kirkpatc
  • Added Buttons, ExtCtrls pages (linked to Component Palette). 17 June 2004 User:Kirkpatc
  • Edited MainMenu component description page. 23 June 2004 User:Kirkpatc
  • Some additions to Common Controls. 28 June 2004 User:Kirkpatc
  • A new tutorial on Text-mode Pascal programming has been added. 5 July 2004 User:Kirkpatc
  • Minor changes to ComCtrls, ExtCtrls, Environment Menu. 10 July User:Kirkpatc
  • Added FormsTxt, component description page for Component Palette. 20 July 2004 User:Kirkpatc
  • Some corrections to ConsoleModePascal. 21 July 2004 User:Kirkpatc
  • Some small changes to ComponentPalette. 22 July 2004 User:Kirkpatc
  • Returned after a long absence! Changed link for component descriptions in StdCntls group of ComponentPalette to point directly at the Lazarus on-line help html pages. 25 Sept 2007 User: Kirkpatc
  • Uploaded some more up-to-date screenshots and fixed links in descriptions of the Menus. 2 October 2007 User: Kirkpatc
  • Fixed links for component descriptions in Extra Controls section of Component Palette. 2 October 2007 User: Kirkpatc