Project Templates

From Free Pascal wiki
Jump to: navigation, search

Overview

You can adapt how to create new projects. The IDE allows to register your own project types via designtime packages. The package projtemplates (the normal lazarus binary packages have this preinstalled) allows to simply use existing projects as templates.

Package projtemplates

This package implements project templates and comes with the lazarus sources (components/projecttemplates/projtemplates.lpk).

The package comes preinstalled with the binary packages of Lazarus (e.g. the windows installer). This package adds a category to the File-New dialog: Template projects

It also adds a New project from Template menu item to the File menu, as well as a project template options menu under the Tools menu. This menu item is visible only if the templates directory (see next paragraph) exists and contains at least one template subdirectory.

In the Project template options, a directory can be selected. This directory should contain a subdirectory per template. Each template directory contains a template for a project: A collection of files which will be copied and used as a new project.

During the copy, the package will scan the file/directory names and the contents of the files for variable substitution: __VARNAME__ will be replaced by the value of a variable VARNAME

By default, the engine knows 2 variables:

  • ProjDir: The directory where the new project will be created.
  • ProjName: The name of the project.

Additional variables must be defined in a file called project.ini in the directory of the project. This is a file in Windows INI format.

The section [Variables] will be scanned for variable names:

[Variables]
VarName1=Description 1
VarName2=Description 2

The variables found will be presented with their description in a dialog, and the user must present a value for the variables.

The' 'project.ini file can contain a second section, called Project, which can contain some info about the project. The following keywords can be found there:

ProjectFile

Any file that has a name equal to this (no extension) is treated specially, it is renamed to the project name. That is ProjectFile=example will replace example.lpi, example.lpr and example.cfg with the name given by the user. By default, the value of ProjectFile is assumed to be project. (note that the .ini file is not copied)

Name

Name of the template. The Name and description will be presented in the 'File-New' dialog.

Author

Author of the template

Description

Short (one-line) description of the project. The Name and description will be presented in the 'File-New' dialog.

Recurse

A boolean value (1/0) which tells the engine to recurse in subdirectories or not.

Exclude

Comma separated list of filename extensions which should not be searched for keyword subsitution.

Getting Started

Step 1;

Create your own template directory (for example ~/.lazarus/mytemplates) and set this path in Lazarus (menu: Tools -> Project Template Options).

Step 2:

For any template functions to even appear in the Lazarus File menu, you will need at least one template which you can base on your existing (normal) project;

- Create a directory in your template directory (for example ~/.lazarus/mytemplates/myfirsttemplate)

- Copy your project files in this new directory (*.lfm, *.pas, *.ico, *.lpi, *.lpr, *.res)

Step 3:

Create a "project.ini" file in the new template directory.

The minimum should look something like this:

project.ini:

[Variables]

[Project] 
Name=My Form Template

Optional:

The nice thing of Project Templates is that it supports variables. Since a project will probably not be named the same as your example template you will have to do some code editing and file renaming.

Files: Rename the project file (ico, lpi, lpr, res) to __PROJNAME__.ext (where extension is the original extension of course). For example: project.lpi becomes __PROJNAME__.lpi. Note: the content of the lpi file might need some cleaning, for example removing history, reference to files, not sure if the lpi file is even needed.

File content: For all files that referred to project.lpi etc, change the content of your files so all "project" references become "__PROJNAME__" (with the quotes).

You can optionally define your own variables, for example to give the "unit.pas" a different filename. You could define for example __MAINUNIT__ and __MAINFORM__ in project.ini as MAINUNIT and MAINFORM - during creation Lazarus will ask you for these names. Now every occurrence of __MAINUNIT__, for example, will be replaced with the text you provided (avoid special characters and spaces).

Note that this works for all variables; Every occurrence of a variable in filenames and file content will be replaced by what you entered on creation of a new project based on your template. Predefined variables are PROJNAME and PROJDIR but I didn't find a purpose for PROJDIR just yet.

Some examples:

project.ini

[Variables] 
MAINUNIT=Filename for the default unit.pas file
MAINFORM=Form name

[Project]
Name=My Custom Form
Author=Hansaplast
Description=Lazarus LCL form specifically for my needs

__PROJNAME__.lpr:

program __PROJNAME__;

{$mode objfpc}{$H+}
  
uses
 {$IFDEF UNIX}{$IFDEF UseCThreads}
 cthreads,
 {$ENDIF}{$ENDIF}
 Interfaces, // this includes the LCL widgetset
 Forms, __MAINUNIT__; 
  
{$R *.res}
  
begin
 Application.Initialize;
 Application.CreateForm(T__MAINFORM__, __MAINFORM__);
 Application.Run;
end.

__MAINUNIT__.pas:

unit __MAINUNIT__;
   
{$mode objfpc}{$H+}
  
interface
  
uses
 Classes, SysUtils, FileUtil, Forms, Controls, Graphics, Dialogs, ExtCtrls,
 Buttons, StdCtrls, LCLIntf, LCLType, ComCtrls;
  
type
  
 { __MAINFORM__ }
  
 T__MAINFORM__ = class(TForm)
  
...
  
procedure T__MAINFORM__.FormPaint(Sender: TObject);
...
  
//etc


__MAINUNIT__.lfm:

object __MAINFORM__: T__MAINFORM__
...


Keep in mind that this brief tutorial is just to get you started, the variable replacement mechanism offered can be utilized for many different purposes. For example to define a form caption, a copyright statement, a web link on your forms, specific objects, etc. --Hansaplast 16:30, 4 August 2012 (UTC)