Issues 3.2.2

From Free Pascal wiki
Revision as of 22:07, 1 April 2021 by Kirinn (talk | contribs)

Issues with 3.2.2 release candidates

This page is supposed to contain all issues discovered while testing release candidates and their status. Make sure to include information about the platform where the problem appears (if applicable). Once the issue gets resolved, you should strike it over and add number of SVN revision fixing it. If the revision number refers to a SVN repository different from "fpc" (i.e. "fpcbuild" or "fpcdocs"), include information about the SVN repository too.

Issues with 3.2.2-rc1

macOS

Getting Started (Intel and ARM64).rtf

"Requirements:

  • Intel: Mac OS X 10.6.0 or later with Xcode and the Xcode command line tools installed.
  • ARM64: macOS 11.0 or later with Xcode and the Xcode command line tools installed."

Is it really necessary for every user to instal the 16GB of Xcode as well as the Xcode Command Line Tools package? From my experiments, it seems the full Xcode is only needed to:

  • access the non-macOS SDKs for iOS, iPadOS, watchOS and tvOS; or
  • validate and upload applications to the Mac App Store; or
  • notarize applications for distribution outside of the Mac App Store.

Note: xcode-select (for installing the CLT package) coms bundled with macOS.

Suggestion: Add link to the FPC + Lazarus Wiki.

Linux

  • Readme, news, and FAQ need to be updated for 3.2.2
  • Compiler's copyright date should be updated to 2021
  • On a 64-bit archlinux laptop, running "fppkg update -v" errored with "Warning: Host name resolution for "www.freepascal.org" failed." I'm not sure why; I can ping the URL on the same machine without problems, and use elinks to fetch the exact xml file fppkg was trying to get.

Windows 7 32-bit

  • The x32+x64 installer shows an introduction text when installation is done; afterward, you can view the included readme.txt which is similar. Both say version 3.2.2rc1 at the top, but the text body describes 3.2.0 and older versions only.
  • whatsnew and FAQ also needs to be updated for 3.2.2
  • Compiler's copyright date should be updated to 2021
  • Running the x86_64-win64-windres.exe errors out with "'x86_64-win64-gcc' is not recognized as an internal or external command, operable program or batch file." There is a gcc.exe among the provided binaries, but no x86_64 gcc. (The 64-bit crosscompiler appears to work correctly on the 32-bit system regardless.)
  • "fppkg update" failed with "Could not initialize OpenSSL library".