LazReport Documentation/de

From Free Pascal wiki
Revision as of 14:53, 12 October 2023 by Kornelius (talk | contribs) (→‎Report Records from a Dataset: Übersetzung)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigationJump to search

Deutsch (de) English (en) español (es) polski (pl)

Überblick

LazReport ist eine Gruppe von Komponenten, um Anwendungen um die Möglichkeit zur Reporterstellung zu erweitern. Es verwendet einen visuellen Designer, um auf Bändern basierende Berichte zu erstellen. Es beinhaltet eine Report Engine mit Vorschaufunktion sowie einen Interpreter, um Benutzerskripte auszuführen. Der Report-Designer kann auch zur Laufzeit aufgerufen werden.

Lizenz

LazReport basiert auf FreeReport 2.32 (von Fast Reports Inc). Es ist unter einer modifizierten LGPL verfügbar, der selben Lizenz wie auch die Lazarus LCL. Die Details stehen in lazreport/license.txt, license-rus.txt und license-lazreport.txt.

Autoren

FreeReport wurde von Fast Reports Inc erstellt. Die erste LazReport Portierung erfolgte durch Olivier Guilbaud. Die Integration in Lazarus sowie zahlreiche Fehlerbehebungen wurden durch Jesus Reyes A. vorgenommen. Zahlreiche weitere Personen haben an LazReport mitgewirkt (siehe lazreport/doc/contributors.txt).

Installation

Um LazReport in die Lazarus IDE zu installieren:

  1. Öffnen sie das Package "LazReport". Menü: Package -> Package-Datei (.lpk) öffnen ...
  2. Wählen sie die Datei "components/lazreport/source/lazreport.lpk"
  3. Klicken sie auf Installieren

Beim nächsten Start von Lazarus sollte es einen Tab "LazReport" in der Komponentenpalette geben.

Dokumentation

Entwickler- und Benutzerhandbücher für LazReport müssen noch geschrieben werden. In der Zwischenzeit sind die meisten LazReport Features im FreeReport Entwicklerhandbuch (siehe lazreport/doc/fr_eng.sxw) beschrieben. Plattform-spezifische Dinge wie OLE Objekte, die dort beschrieben sind, sind noch nicht in LazReport implementiert. Auch sind einige Beispiele bzw. Referenzen darauf nur für Delphi verfügbar.

Bis eine LazReport Dokumentation ausgearbeitet ist, soll diese Wiki-Seite als Aufbewahrungsort für Informationen dienen. Vielleicht können in der Zukunft fehlende Teile aus dieser Seite erstellt werden. Die Benutzer sind aufgerufen, Themen zu ergänzen, zu denen sie eine Dokumentation vermissen.

Exportfilter

Die LazReport Exportfilter werden wie folgt aufgerufen:

  if TheReport.PrepareReport then
    TheReport.ExportTo(TfrHTMExportFilter, 'exportiertedatei.html');

wobei TheReport eine Instanz der Komponente "TfrReport" ist. In diesem Beispiel wird ein TfrHTMExportFilter verwendet, um eine Datei namens 'exportiertedatei.html' zu erstellen. Ist der Bereicht bereits erstellt (prepared), muss er nicht erneut erstellt werden. Um den TfrHTMExportFilter zu nutzen, muss man eine Instanz der Komponente "TfrHTMExportFilter" aus dem Tab "LazReport" in der Komponentenpalette auf dem Formular ablegen (im Formular-Desginer). Alternativ muss die Unit "LR_E_HTM" (Dateiname: lr_e_htm.pas) zum Abschnitt uses der aktuellen Unit hinzugefügt werden.

Seit LazReport 0.9.6 wurde die Exportfilter-Unterstützung verbessert. Jetzt können die Exportfilter Parameter übernehmen, die die Benutzer entweder durch direktes Ändern der Werte oder durch eine Bedienoberfläche (UI) anpassen können. In order to make changes in parameters, the developer can create an event handler for TfrReport.OnExportFilterSetup event, available by selecting the TfrReport component and selecting the Events tab in Object Inspector.

The OnExportFilterSetup (of type TExportFilterSetup) event handler takes an argument sender of type TfrExportFilter, in order to use this types, lr_class.pas unit must be added to unit uses clause. All ExportFilter clases share this event and developer has to type-cast the sender argument to the desired export filter class for example:

if sender is TfrHTMExportFilter then
begin
  TfrHTMExportFilter(sender).UseCSS := false;
end;

Es folgt eine Beschreibung der verfügbaren Exportfilter:

TfrExportFilter

ist die Basisklasse aller Exportfilter. Sie definiert zwei Eigenschaften, die vom Entwickler im Ereignis OnExportFilterSetup angepasst werden können:

  • BandTypes: TfrBandTypes. Dies ist ein Satz von Bandtypen, nur die in diesem Satz enthaltenen Bänder werden tatsächlich exportiert, der Rest der im Bericht vorhandenen Bänder wird ignoriert. Mit dieser Eigenschaft kann ein Entwickler zum Beispiel nur den Inhalt des Masterbandes exportieren und dabei Titel, Kopf- und Fußzeilen aus der exportierten Ausgabe herauslassen:
sender.BandTypes := [btMasterData];

standardmäßig werden alle Bänder verarbeitet, aber TfrCSVExportFilter ändert diese Eigenschaft so, dass nur Stammkopf-, Spaltenkopf- und Stammdatenbänder verarbeitet werden.

  • UseProgressbar: boolean. Mit dieser Eigenschaft lässt sich die Anzeige eines Fortschrittsbalkens aktivieren oder deaktivieren, der den Fortschritt des Exportprozesses zeigt. Per Vorgabe ist die Eigenschaft auf false gesetzt.

TfrTextExportFilter

Vererbung: TfrExportFilter <- TfrTextExportFilter
befindet sich in der Datei: lr_e_txt.pas, die zum LazReport Package gehört.

ist die Basisklasse der textbasierten Exportfilter. Dieser Exportfilter versucht, eine Textdarstellung eines grafischen Berichts zu erstellen, indem er die ursprünglichen grafischen Koordinaten in ein gröberes Raster einpasst, bei dem jede Einheit aus "UsedFont"-Pixeln besteht. Abhängig vom Wert des UsedFont-Wertes kann die exportierte Ausgabe mehr oder weniger das Layout der Objekte im grafischen Bericht darstellen. Neben den Eigenschaften, die von der Klasse TfrExportFilter geerbt wurden, definiert TfrTextExportFilter zwei weitere Eigenschaften.

  • UsedFont:integer. Diese Eigenschaft definiert die Pixelabmessungen des Ausgaberasters, in das die Objekte im Bericht durch Umrechnung der einzelnen x- und y-Positionen eingepasst werden. Der Standardwert ist 10, wenn der Benutzer diesen Wert auf 0 oder weniger ändert, wird LazReport automatisch einen Dialog anzeigen, der nach dem UsedFont Wert fragt, wenn der Benutzer einen ungültigen Wert eingibt, wird ein 10er Wert verwendet. Der Wert 10 wird verwendet, weil er besser zu den üblichen Berichten passt, die mit Schriftarten von 10-13 Punkten erstellt werden.
  • UseBOM:boolean. Diese Eigenschaft ermöglicht die Einbeziehung eines UTF-8 Byte Order Mark Zeichens am Beginn der Textausgabe (siehe BOM), das von einigen Editoren/Betrachtern benötigt wird. Per Vorgabe wird BOM in der exportierten Ausgabe nicht verwendet.

TfrCSVExportFilter

Vererbung: TfrExportFilter <- TfrTextExportFilter <- TfrCSVExportFilter
befindet sich in der Datei: lr_e_csv.pas, die zum Package "LazReport" gehört.

Dieser spezielle Text-Exportfilter erzeugt eine Ausgabe von Komma-separierten Werte (Comma Separated Value). Aktuell kann jedes Zeichen als Separator verwendet werden (wobei dies nicht bedeutet, dass das auch sinnvoll ist). Er unterscheidet sich von ihrer Vorgängerklasse dadurch, dass er nicht versucht, eine Textlayout-Darstellung des grafischen Berichts zu erstellen. Stattdessen versucht er, für jede Datensatzausgabe die Reihenfolge der Felder aus dem Quellbericht zu erraten und erzeugt dann eine Liste von Feldern unter Verwendung eines vom Benutzer definierten Trennzeichens. Neben den Eigenschaften, die er von seinen Vorgängerklassen geerbt hat, definiert er einige Eigenschaften zur Anpassung der generierten Ausgabe.

  • QuoteType:TfrQuoteType. Diese Eigenschaft steuert, ob der generierte Feldwert mit dem angegebenen Anführungszeichen umgebrochen werden soll oder nicht. Mögliche Werte sind qtNone, qtQuoteChar und qtAutoQuote. Mit qtNone wird der Wert des Feldes niemals umgebrochen, qtQuoteChar verwendet den Character, der in QuoteChardefiniert ist, wobei alle QuoteChar innerhalb des Feldes dupliziert werden. qtAutoQuote prüft zuerst, ob QuoteChar in dem Feld vorkommt. Wenn das der Fall ist, wird QuoteChar gesetzt, andernfalls wird nichts unternommen (als hätte man qtNone gesetzt). Standardmäßig wird QuoteType wie qtQuoteChar gesetzt.
  • QuoteChar:TUTF8Char. Hier wird das Zeichen angegeben, mit dem der Feldwert umbrochen werden soll, wenn der Quotetype des Wertes qtQuoteChar angegeben bzw. abgeleitet wurde, wenn qtAutoQuote eingestellt ist. Jede Instanz dieses Zeichens im Feldwert wird dupliziert. Standardmäßig ist QuoteChar auf das Zeichen " gesetzt.
  • Separator:TUTF8Char. Dieses Zeichen wird verwendet, um die Felder in jedem Datensatz zu separieren. Per Vorgabe wird das Komma (',') verwendet. Es kann aber auch jedes adere gültige UTF-8 Zeichen verwendet werden. Einige CSV Dateien verwenden das TAB Zeichen zum Separieren. Um dies zu erreichen, setzen sie Separator:=#9 ein.

Der CSV-Exporter verwendet den geerbten Eigenschaftswert UsedFont nicht, so dass jeder eingestellte Wert ignoriert wird. Mit den Standard-Eigenschaftswerten erzeugt TfrCSVExportFilter Excel-kompatible Dateien. Der einzige Nachteil ist, dass Excel die Datei nicht als UTF-8-kodiert erkennt. Um Excel zu zwingen, die Kodierung automatisch zu erkennen, setzen Sie die Eigenschaft UseBOM auf true.

TfrHTMExportFilter

Vererbung: TfrExportFilter <- TfrTextExportFilter <- TfrHTMExportFilter.
befindet sich in der Datei: lr_e_htm.pas, die zum Package "LazReport" gehört.

Dieser spezielle Text-Exportfilter erzeugt eine gültige "HTML 4.01 Transitional" Ausgabe. Gegenwärtig definiert er nur eine zusätzliche Eigenschaft:

  • UseCSS:boolean. Diese Eigenschaft bestimmt, ob die erzeugte Ausgabe CSS Informationen enthält oder nicht. Sie ist per Vorgabe auf false gesetzt.

TfrImageExportFilter und TfrHtmlDivExportFilter

Für die Verwendung dieser beiden Filter muß das Package lr_extexp installiert werden. Man findet es im addons Unterverzeichnis von LazReport.

PDF-Exportfilter

Um einen Report ins PDF-Format exportieren zu können, muß das Package LazReportPDFExport installiert werden. Man findet es im addons Unterverzeichnis von LazReport. Dieses Package wiederum setzt PowerPDF voraus, welches daher zuerst installiert werden sollte. Nach der Installation kann der neue Exportfilter wie einer der anderen Exportfilter verwendet werden.

Schnellstart

Report Records from a Dataset

In diesem Beispiel werden wir einen Bericht entwerfen, um Datensätze aus einer abgeleiteten Komponente zu drucken (TDbf, TSQLQuery, TZTable, TZQuery, etc.). Dabei wird davon ausgegangen, dass LazReport bereits installiert ist und die Komponente "dataset", hier "Dbf1" genannt, bereits konfiguriert und aktiv ist.

  1. Vom LazReport Tab wählen sie eine TfrReport Komponente und legen diese auf dem Formular ab, sie erhält den Namen "frReport1".
  2. Fügen Sie eine TfrDbDataset-Komponente hinzu, sie erhält den Namen "frDbDataset1"
  3. Fügen Sie einen TButton hinzu, er enthält den Namen Button1, benennen Sie ihn um zu "btnShowReport"
  4. Nach Auswahl von frDbDataset1 im Objekt Inspector setzen Sie in der "Dataset" Eigenschaft den Wert auf "Dbf1"
  5. Wählen Sie nun frReport1 und verknüpfen Sie mit demselben Verfahren die Eigenschaft "Dataset" mit "frDbDataset1":

    lrformsetup.png

  6. Klicken Sie mit der rechten Maustaste auf frReport1 und wählen Sie "Bericht entwerfen" aus dem Menü, LazReport Berichtsdesigner wird erscheinen.
  7. Wählen Sie im Designer-Fenster das Menü Werkzeuge(Tools)->Werkzeuge->DB-Felder einfügen, der Dialog Felder einfügen erscheint.
  8. In der Liste mit den Feldern wählen sie die Felder, die sie im Report verwenden möchten.
  9. Aktivieren sie die Optionen "Include Headers" und "Include Bands". Das Ergebnis sollte etwa so aussehen:

    lrinsertfieldsdialog.png

  10. Klicken sie auf "Ok" und LazReport wird die Bänder und Felder etwa so anordnen:

    lrreportwithfields.png

  11. Klicken sie auf den Vorschau Button lrprevieweye.png, LazReport wird dann die Daten zusammenführen und etwa so anzeigen:

    lrpreviewreport.png

  12. Speichern sie den Report über das Menü: Datei -> Speichern. Wählen sie das selbe Verzeichnis wie für das aktuelle Projekt und benennen sie den Report listing1.lrf .
  13. Schließen sie den Report-Designer.
  14. Klicken sie doppelt auf btnShowReport und geben sie in der Prozedur den folgenden Code ein:
  frReport1.LoadFromFile('listing1.lrf');
  frReport1.ShowReport;

Bug Reports

Bitte melden sie Probleme und Fehler mittels des lazarus/freepascal Bugtrackers. Wählen sie dort unter project: "Lazarus Packages" und als Category "LazReport". Für Patches erstellen sie bitte einen Bug Report und hängen dort den Patch an.