Main menu/ru

From Free Pascal wiki
Revision as of 14:31, 8 December 2021 by Kupferstecher (talk | contribs) (Content from the Lazarus Tutorial/ru page (now linked to here))
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigationJump to search

Deutsch (de) English (en) español (es) suomi (fi) français (fr) magyar (hu) italiano (it) 日本語 (ja) македонски (mk) Nederlands (nl) português (pt) русский (ru) slovenčina (sk) shqip (sq) 中文(中国大陆)‎ (zh_CN) 中文(台灣)‎ (zh_TW)

Главное меню

Главное текстовое меню содержит следующие пункты: File Edit Search View Project Run Components Tools Environment Windows Help

Как обычно любой пункт можно выбрать если навести на него курсор и нажать левую кнопку мыши или использовать горячие клавиши (например, клавиатурная комбинация Alt+F открывает меню File. Если меню не открылось, то следует нажимать TAB до тех пор, пока не будет активировано желаемое окно.


Меню Файл (File)

  • Создать модуль (New Unit): Создать новый модуль (Unit, исходный код на Pascal).
  • Создать форму (New Form): Создать новую форму. То есть два файла: саму форму и соответствующий ей файл с Pascal-кодом.
  • Создать... (New...): Открывает всплывающее окно (screenshot) в котором приведены различные типы проектов, которые можно создать (screenshot).
  • Открыть (Open): Открывает диалоговое окно, при помощи которого можно найти и открыть существующий файл.
  • Обратный экспорт (Revert): Отменяет сделанные изменения и возвращает файл в исходное состояние.
  • Сохранить (Save): Сохранить текущий файл под этим же именем. Если имя еще не дано, то система скажет об этом (это подобно пункту Сохранить как).
  • Сохранить как (Save As): Позволяет выбрать папку и имя под которым сохранить текущий файл.
  • Закрыть (Close): Закрывает текущий файл, с выводом сообщения о том следует ли сохранить сделанные изменения.
  • Закрыть все файлы редактора (Close all editor files): Закрывает все файлы, открытые в данный момент в редакторе. Выдаётся сообщение о сохранении изменений.
  • Очистить каталог (Clean directory): Выводится диалог со строками задания фильтров при помощи которых можно очистить текущий каталог. Полезно для удаления .bak файлов ненужных или устаревших проектов.
  • Выход (Quit): Выход из Lazarus с выводом запроса на сохранение всех открытых файлов.

Меню Правка (Edit)

  • Отменить (Undo): Отменяет последнее выполненное действие, переводя редактор в состояние до этого действия.
  • Повторить (Redo): Вновь выполняет ранее отмененное действие.
  • Вырезать (Cut): Удаляет выделенный текст или другой элемент и помещает его в буфер обмена.
  • Копировать (Copy): Создает копию выделенного текста, не затрагивая текст, и помещает её в буфер обмена.
  • Вставить (Paste): Помещает содержимое буфера обмена в позицию курсора. Если есть выделенный текст, то он будет заменен содержимым буфера обмена.
  • Сдвинуть блок вправо (Indent selection): Сдвигает выделенный текст вправо на количество позиций, указанных в настройках Окружение -> Настройки редактора -> Общие -> Отступ блока (Environment -> Editor options -> General -> Block indent). Эта опция удобна для форматирования исходного Pascal-кода для создания блочной структуры.
  • Сдвинуть блок влево (Unindent selection): Удаляет один уровень отступа, сдвигая текст влево на количество позиций, указанных в Отступе блока (Block indent).
  • Заключить выделение в (Enclose selection): Открывает всплывающее меню с набором опций для заключения выделенного текста в программные скобки (begin ... end; try ... except; try ... finally; repeat ... until; { ... } и т. д.).
  • Верхний регистр выделения (Uppercase selection): Преобразует выделенный текст в верхний регистр.
  • Нижний регистр выделения (Lowercase selection): Преобразует выделенный текст в нижний регистр.
  • ТАБ сделать пробелами в выделенном (Tabs to spaces in selection): Преобразует все символы табуляции в выделенном тексте в некоторое количество пробелов, настраиваемое посредством Окружение -> Настройки редактора -> Общие -> Ширина ТАБа(Environment -> Editor options -> General -> Tab widths). Вставляется не фиксированное количество пробелов, а только число необходимое для завершения данного табулятора.
  • Разрыв строк в выделенном (Break lines in selection): Если строка выделенного текста длиннее 80 символов или числа указанного в Окружение -> Настройки редактора -> Дисплей -> Правая граница (Environment -> Editor options -> Display -> Right Margin), то строка текста будет разорвана на границе слова и продолжится со следующей строки.
  • Закомментировать (Comment selection): Закомментировать выделенный текст, добавив в начало каждой строки //.
  • Раскомментировать (Uncomment selection): Удалить символы комментария.
  • Сортировка выбранного (Sort selection): Сортирует строки (слова или параграфы) в алфавитном порядке; настраивается порядок сортировки и чувствительность к регистру. Конечно же, в теле программы это не нужно, но если у вас есть некий список и вам нужно его отсортировать, то можете использовать этот трюк.
  • Выделить (Select): Позволяет выделить текстовый блок. Имеются опции для выделения всего, до скобки, выделить абзац или строку и т. д.
  • Вставить из таблицы символов (Insert from character map): Позволяет вставить специальные символы, такие как символы с акцентами, которые берутся из всплывающей таблицы символов.
  • Вставить текст (Insert text): Вызывает всплывающее меню, позволяющее вставить шаблоны текста, такие как ключи CVS (Author, Date, Header и т. д.) или заметку о GPL, имя пользователя или текущую дату и время.
  • Завершить код (Complete code): Завершает код под курсором. Действия зависят от контекста и позволяют сохранить довольно много времени. Например, можно завершить классы, добавив private переменные, Get и Set методы для доступа к свойствам и тела методов. Если переменной присваивается значение (например, i:=3), то будет добавлено описание переменной. Для процедур, описанных с ключом forward, будет добавлено тело процедуры. Если имеется присвоение событию (OnClick:=), то будут добавлены описание метода и тело метода. Смотри Lazarus IDE Tools.
  • Выделить процедуру (Extract procedure): Использует выделенный текст (один или несколько операторов) для построения новой процедуры.

Меню Поиск (Search)

  • Найти (Find): То же самое, что и в большинстве графических текстовых редакторов: появляется всплывающее диалоговое окно, позволяющее вам ввести строку поиска, а также опции поиска, такие как чувствительность к регистру, искать целые слова, целые выражения, область и направление поиска.
  • Найти впереди (Find Next), Найти сзади (Find previous): искать далее указанную ранее строку в соответствующем направлении.
  • Найти в файлах (Find in files): Искать строку в файлах: всплывающее окно с опциями во всех открытых файлах, во всех файлах проекта или поиск в каталогах; можно задать маску-фильтр для типов файлов.
  • Замена (Replace): Подобна Найти; появляется диалоговое окно со областью ввода искомой строки и текста для замены, а также опций чувствительности к регистру, направления и т.д.
  • Поиск с нарастанием (Incremental find): Поиск строки в то время, пока вы вводите ее. Например, после того, как вы выберете "Поиск с нарастанием" и нажмете "l" будет подсвечена ближайшая буква "l". Если затем вы нажмете "a", редактор найдет следующее "la" и так далее.
  • Переход к строке (Goto line): Перемещает курсор в указанную строку файла.
  • Переход назад (Jump back): Перемещается по файлу назад, к предыдущей закладке (необходимо использовать Добавить точку перехода в историю). Может перемещаться к закладкам в других файлах, открытых в редакторе.
  • Переход вперед (Jump forward): Переместиться к следующей закладке.
  • Добавить точку перехода в историю (Add jump point to history): Добавляет закладку или точку перехода в файл.
  • Просмотр истории перехода (View Jump-History): Просмотреть список закладок в файле: Еще не реализовано.
  • Найти другой конец блока кода (Find other end of code block): Если курсор стоит на begin, то осуществляется поиск соответствующего end и наоборот.
  • Найти начало блока кода (Find code block start): Перемещается к begin процедуры или функции в теле которой находится курсор.
  • Найти описание под курсором (Find Declaration at cursor): Поиск участка кода, где описан выбранный идентификатор. Оно может быть в этом же файле или в любом другом, открытом в редакторе; Если файл еще не открыт, то он будет открыт (так, если процедура или функция описана в classesh.inc, то этот файл будет открыт в Редакторе).
  • Открыть имя файла под курсором (Open filename at cursor): Открывает файл, имя которого выделено курсором. Полезно для просмотра Include файлов или файлов, содержащих другие модули Units, используемые в проекте.
  • Перейти к директиве include (Goto include directive): Если курсор помещен в файле, который включен Included в другой файл, то происходит перемещение в то место другого файла, из которого вызывается включенный.

Меню Вид (View)

Управляет отображением на экране различных окон и панелей.

  • Инспектор Объектов (Object Inspector): Окно, обычно расположенное по левому краю рабочего стола и отображающее возможности текущей формы. Щелчок на любом из компонентов формы приведет к отображению в Инспекторе Объектов деталей компонента (свойств и событий). Чуть выше располагается окно, отображающее древовидную структуру текущего проекта, в этом окне можно также выбрать компоненты формы, что также приведет к отображению их свойств в Инспекторе Объектов. Нижняя, главная, панель имеет две вкладки, позволяющих выбрать режим отображения Свойств (Properties) или Событий (Events). Вкладка Свойства отображает такие свойства, как имя (name), цвет (color), надпись (caption), шрифт (font), размер (size) и т. д.: она содержит два столбца - левый содержит имена свойств, а правый - их текущие значения. Щелкнув на значении свойства, можно изменить его значение через меню или окно настройки.

Вкладка События также имеет два столбца: левый содержит возможные события вроде нажатия кнопки мыши, ассоциированные с данным компонентом, а правый показывает действия, предусмотренные для этих событий. Если действие не определено, то нажатием на кнопку с точками

...

открывается Редактор Исходных текстов, где курсор уже находится в области объявления процедуры, ожидая ввода программы обработки данного события.

  • Редактор исходников (Source Editor): Основное окно для редактирования исходных текстов. Этот редактор очень похож на другие графические текстовые редакторы: мышью можно перемещать курсор по тексту, а нажав левую кнопку мыши и перемещая указатель, можно выделить участок текста. Нажатие правой кнопки вызывает меню, имеющее обычные функции редактирования: Вырезать, Копировать или Вставить, Найти объявление и Открыть файл. В верхней части окна Редактора может быть несколько вкладок, соответствующих файлам, открытым в текущем проекте; нажатием на вкладку выбирается нужный файл. Так можно легко перемещаться по файлам, копировать и вставлять куски текста, выполняя обычные функции редактирования. Редактор исходных текстов выполняет цветовое выделение текста программы, отображая разными цветами метки пунктуации, комментарии, строковые константы и т. д. Он также сохраняет размер отступа от строки к строке, пока его не изменить вручную. Функции и вид Редактора исходников имеют настройки, вызываемые из основного меню выбором Окружение -> Параметры -> Опции Редактора выбором одной или нескольких вкладок в диалоговом окне.
  • Обозреватель кода (Code Explorer): Это окно обычно расположено справа и отображает в древовидной форме структуру кода в текущем блоке или программе. Структура обычно открывается в виде только имен модулей и ветвей для секций интерфейса и реализации, но нажатием на рамку
    +
    слева от ветви открываются ее подветви, достигая более подробной детализации о константах, типах и переменных, а также объявлениях процедур и функций. Если сменить файл, отображаемый в окне Редактора Исходников, нужно нажать кнопку Обновить в обозревателе кода для просмотра структуры нового файла.
  • Модули ... (Units...): Открывается диалоговое окно с перечислением файлов модулей текущего проекта. Щелчком мыши на имени файла выбирается файл; Щелчком на ОК он открывается в Редакторе Исходников. Флажок Множественное выделение позволяет открывать одновременно несколько файлов (но только один будет отображен в окне Редактора Исходников). Эта опция меню очень похожа на опцию Проект -> Инспектор Проекта, но только отображает список файлов модулей и позволяет их открывать.
  • Формы... (Forms...): Открывается диалоговое окно со списком форм в текущем проекте, позволяющее выбрать одну или более форм для отображения.
  • Показать зависимости модулей (View Unit Dependencies): Открывается диалоговое окно, показывающее древовидную стуктуру зависимостей текущего открытого файла модуля. Большинство зависимых файлов будут иметь рамочку владения со знаком +
    +
    , позволяющую просмотреть зависимости отдельного файла рекурсивным способом.
  • Переключатель Форма/Модуль (Toggle form / unit view) F12: Позволяет помещать на верхний уровень отображения либо форму, либо Редактор Исходников, и дает фокус. Если фокус дан Редактору Исходников, можно редактировать исходный код; если фокус имеет форма, можно манипулировать ее компонентами и изменять ее вид. Проще всего переключаться между Редактором и Формой при помощи клавиши F12 на клавиатуре, но тот же самый эффект достигается выбором этой опции основного меню.
  • Сообщения (Messages): Окно, отображающее сообщения компилятора, показывающие ход успешной компиляции или перечисление найденных ошибок.
  • Результат поиска (Search Results): Окно, которое отображает результаты поиска в файлах.
  • Окна отладки (Debug windows): Открывает меню с несколькими опциями управления и конфигурирования работы отладчика. См. ниже описание debugger.

Меню Проект

  • Создать Проект: Создание нового проекта. Диалоговое окно позволяет выбрать тип создаваемого проекта.
  • Создать Проект из файла: Появляется окно для выбора файла, из которого следует создать проект.
  • Открыть Проект Открывается созданный и сохраненный проект. Появляется окно выбора со списком файлов Lazarus Project Information (.lpi).
  • Открыть недавний проект: Появляется список проектов, с которыми работали недавно; выбранный откроется.
  • Сохранить Проект: Походит на Файл -> Сохранить: Сохраняются все файлы текущего проекта; если ранее не сохранялись - будет запрошено имя файла(ов), подобно Сохранить Проект Как...
  • Сохранить Проект Как...: Запрашивается имя файла сохраняемого проекта. По умолчанию предлагается имя Project1.lpi, но лучше дать более выразительное. Lazarus не позволит применить одинаковое имя для файлов проекта и модуля (см. ниже).
  • Опубликовать Проект: Создается полная копия проекта. Эта функция полезна, если нужно переслать кому - либо исходники и установки компилятора. Обычно папка проекта содержит много информации. Большинство ее не нуждается в публикации: файл .lpi содержит сеансовую информацию (наподобие позиций символа * и закладок закрытых модулей) также папка проекта содержит множество файлов .ppu, .o и .exe. Для создания файла .lpi только с базовой информацией и исходниками из всех подпапок и применяется "Опубликовать проект". В диалоге можно настроить фильтр отбора и дальнейшей командой можно заархивировать выходные файлы. См. Lazarus IDE Tools
  • Инспектор Проекта: Открывается диалог древовидного отображения файлов в текущем проекте. Можно добавлять, удалять или открывать выбранные файлы, а также изменять опции проекта.
  • Опции Проекта...: Открывается диалог с вкладками для установки опций Приложения (Заголовок, имя файла вывода), Форм (можно выбрать доступные формы, сделать их автосоздаваемыми при запуске приложения) и Информация (указывающая, какая информация редактора должна сохраняться в закрытых файлах, или только в файлах проекта).
  • Опции Компилятора ...: (Недавно перемещено из меню Запуск). Открывается многостраничное окно с вкладками для настройки компилятора. Вкладка Пути позволяет настроить пути поиска модулей, подключаемых файлов, библиотек и т.д., а также выбрать тип форм (gtk, gnome, win32); Обработка позволяет выбрать правила синтаксического контроля исходных программ, Код позволяет оптимизировать размер и скорость выполнения программ, выбрать тип целевого процессора, типы проверок, размер кучи и т.д.; Связывание позволяет выбрать порядок работы отладчика, статические или динамические библиотеки, передавать опции компоновщику; Сообщения для определения, какие типы сообщений будут сгенерированы; Другое позволяет настроить применение встроенного конфигурационного файла (fpc.cfg) или другого; Унаследованные - показывает диаграмму древовидной структуры для индикации, какие опции унаследованы от уже подключенных модулей; Компиляция для определения команд, выполняемых до или после компиляции, а также возможного использования файлов Make.
  • Добавить файл редактора в Проект: Добавляет редактируемый файл в Проект
  • Убрать из Проекта: Выдает меню файлов, доступных для удаления из проекта.
  • Просмотреть исходный код Проекта: Независимо от того, какой файл редактируется, выдает основной файл программы (.lpr) или основной файл .pas, если отсутствует файл .lpr.
  • View ToDo List:Opens a dialog box with a list of ToDo items associated with this project. This will list any ToDo comments in your project (lines commencing //TODO), and any others in the Lazarus units you have used. You need to Refresh the ToDo items in the dialog (using arrow symbol button of toolbar) before new 'ToDos' appear. The first column of the ToDo list contains numbers you have allocated to your ToDo comments; a simple //TODO comment will appear as a zero, but a comment of //TODO999 (for example) will place the number 999 in the first column. Remember there should be no spaces on the line before //TODO and ToDo comments added after the last save will not be shown!

Меню Запуск

  • Собрать: Запускается сборка (т.е. компиляция) любых файлов проекта, которые были изменены со времени последней сборки.
  • Собрать все: Запускается сборка всех файлов проекта, независимо от наличия изменений.
  • Прервать сборку: Останавливает процесс сборки на ходу – если Вы вспомнили о наличии ошибок и хотите остановить сборку, или система работает слишком долго и очевидно, что-то не так.
  • Запуск: Это обычный путь запуска компилятора и если компиляция прошла успешно, запускается приложение. На самом деле Lazarus сохраняет копию файлов, затем запускает компилятор и компоновщик, затем выполняется собранная бинарная программа.
  • Пауза: Задерживается выполнение работающей программы. Это позволяет проверить промежуточные результаты. Выполнение программы можно продолжить повторным выбором Запуск.
  • Шаг со входом: Применяется совместно с отладчиком, запуская программу на один шаг вплоть до точки, помеченной в исходном тексте.
  • Шаг в обход: Вызывает пошаговое выполнение вплоть до помеченного оператора, пропускает его и продолжает работу с нормальной скоростью. Полезно для изоляции оператора, приводящего к логической ошибке.
  • Запуск до курсора: Запускает выполнение с нормальной скоростью (т.е. не пошагово), пока не встретится оператор, где находится курсор, и произойдет останов. Выполнение продолжится с нормальной скоростью после выбора Запуск.
  • Останов: Прекращается выполнение программы. Продолжить выполнение выбором Запуск нельзя; можно только запустить сначала (перекомпилировать, если необходимо).
  • Параметры Запуска: Открывается многостраничное окно, позволяющее передать программе опции командной строки и параметры; настроить отображение выполняемой программы (например, использовать в Linux удаленный терминал Х); можно изменить некоторые переменные системного окружения.
Важное свойство этого подменю – в возможности активировать терминальное окно, отображающее стандартный консольный ввод/вывод. Если разрабатывается программа консольного режима (не используется графический интерфейс пользователя с формами, кнопками и рамками), то следует установить флажок "Использовать приложение для запуска". Сначала при попытке компиляции и выполнения может появиться нехорошее сообщение
"xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied".  
В этом случае нужно изменить разрешения для соответствующего файла (например, с помощью chmod +x filename, или при помощи утилиты Windows, меняющей разрешения); войдя в систему в качестве root. После этого при запуске программы появится окно консоли, и весь текстовый ввод/вывод (readln, writeln и т.д.) появится в нем.
По окончании выполнения программы на экране появится сообщение "Press enter". Таким образом выведенная программой информация останется на экране для возможности ее прочтения; после нажатия 'enter' окно консоли закроется.
См. Отдельный учебник по программированию в Консольном режиме Pascal.
  • Сброс отладчика: Отладчик приводится в исходное состояние, так что точки останова, значения переменных и т.д. будут «забыты».
  • Собрать файл: Происходит компиляция (сборка) только файла, открытого в Редакторе.
  • Запустить файл: Компиляция, сборка и выполнение только открытого файла.
  • Параметры сборки + запуска: Открывается многостраничное окно с опциями сборки только данного файла, когда выбрано Собрать Проект, позволяющее выбрать рабочий каталог, использовать различные макросы и т.д. Затем файл собирается и выполняется.
Эти последние три опции позволяют открывать (и поддерживать) тестирование проекта. Используйте Файл -> Открыть для открытия файла .lpr, нажатием cancel в следующем диалоге – для его открытия, как "обычного исходника ".

Меню Пакет

  • Новый Пакет: Отображается окно выбора пакета для установки с возможностями настройки работы пакета.
  • Открыть файл пакета: Открывается один из файлов выбранного пакета.
  • Открыть загруженный пакет: Открывается недавно загруженный пакет.
  • Добавить активный модуль в пакет: Файл модуля (текущий в редакторе) помещается в пакет.
  • Диаграмма пакетов: Отображается graph, показывая взаимосвязи используемых пакетов (если не используются иные, будут отображены пакеты Lazarus, а также FCL и LCL).
  • Настройка установленных пакетов: Если созданы некоторые компоненты, здесь их можно настроить.

Меню Сервис

  • Настроить внешние средства: Позволяет добавлять различные внешние средства (обычно макросы) в инструментарий пакета разработчика.
  • Быстрая проверка синтаксиса: Выполняет быструю проверку синтаксиса исходного текста без реальной компиляции. Полезно при разработке длинных и сложных программ, поскольку не тратится время на компиляцию кода с ошибками.
  • Исправить незаконченный блок: Полезная утилита при работе со сложной блочной структурой, когда в каком-либо блоке пропущен 'end'.
  • Исправить несоответствие IFDEF/ENDIF: Полезно при работе со сложной или вложенной структурой макро, если есть подозрение, что пропущена директива ENDIF.
  • Создать строку ресурсов: Делает выбранную строку ресурсной, помещая ее в секцию ресурсных строк. Преимущество ресурса в том, что его можно менять без перекомпиляции проекта!
  • Разница Diff: Сравниваются два файла (или обычно две версии одного файла) для нахождения различий. Имеются опции для игнорирования пробелов в начале или конце строк, а также разницы в концах строк: CR+LF или LF). Полезно для обнаружения изменений после последней корректировки и т.д.
  • Проверить файл LFM в редакторе: Позволяет проверить файл LFM, содержащий настройки текущей формы.
  • Преобразовать модуль Delphi в Lazarus: Помогает перенести приложения Delphi в Lazarus; внося необходимые изменения в исходный файл. См. Lazarus For Delphi Users и Code Conversion Guide.
  • Преобразовать файл DFM в LFM: Для переноса из Delphi в Lazarus: преобразует файлы описания формы из Delphi в Lazarus. См. Lazarus For Delphi Users и Code Conversion Guide.
  • Собрать Lazarus: Запускается обновление Lazarus с недавно загруженными или скорректированными файлами CVS. Нажав кнопку, можно откинуться для наблюдения за происходящим! (процесс виден в окне Сообщения).
  • Параметры сборки Lazarus: Позволяет определить, какие части Lazarus должны быть пересобраны, и как. Например, можно выбрать перестройку только LCL, или пересборку всего, за исключением примеров; можно выбрать, какой использовать интерфейс LCL, выбрать целевую операционную систему и указать другую целевую папку.

Меню Окружение

  • Опции Окружения: Открывается многостраничное окно с вкладками:
    • Файлы - позволяет указать пути: папки по умолчанию, компилятора, папки исходных текстов и временной папки для компиляции;
    • Рабочий стол - опции языка, автосохранения, свойств рабочего стола, подсказок палитры компонентов и командных кнопок;
    • Окно, – для настройки размера и поведения различных окон;
    • Редактор Форм - выбор цветов для редактирования форм;
    • Инспектор Объектов - выбор цветов и высоты элементов;
    • Резервирование - настройка резервирования редактируемых файлов;
    • Именование - настройка расширения имени в именовании файлов Паскаля ('.pp' или '.pas'), сохранять ли файлы с именами в нижнем регистре, выполнять ли автоудаление или автопереименование.
  • Опции Редактора: многостраничное окно с вкладками:
    • Общие - настройка поведения: авто-отступ, подсветка скобок, редактирование перетаскиванием, прокрутка, подсветка синтаксиса, показ подсказок, размер отступа блока и вкладок, лимит откатов;
    • Отображение - опции показа номеров строк, границ, размера и типа шрифта редактора; имеется предварительный просмотр, показывающий расцветку синтаксиса (комментариев, директив, пунктуации, ошибок и точек останова;
    • Привязки клавиш - опции выбора схемы Lazarus или Turbo Pascal;
    • Цвет - позволяет выбор цветовой схемы для различных языков: Object Pascal, C++, Perl, HTML, XML и скриптов оболочки. Имеется панель предварительного просмотра для выбранного языка;
    • Code Tools - позволяет настроить возможности наподобие завершения идентификаторов, специфические шаблоны для завершения кода.
  • Опции Отладчика: многостраничное окно с вкладками:
    • Общие - выбор отладчика: none, GNU debugger (gdb) или gdb через SSH, указание пути к отладчикам, и специфические опции для выбранного отладчика;
    • Протокол событий - указание, когда очищать журнал при работе, и какие сообщения отображать;
    • Исключения языка - выбор исключений для игнорирования;
    • Исключения ОС - возможность добавлять некоторые сигналы, применимые в текущей операционной системе (не осуществлено).
  • Опции Code Tool: многостраничное окно с вкладками:
    • Общие - указание дополнительных путей к исходным кодам, методики перехода;
    • Создание Кода - определяется политика вставки созданных элементов программ;
    • Слова - определяется, как пишутся ключевые слова языка Паскаль – в верхнем или нижнем регистре, или с первой заглавной буквой;
    • Разрыв строк - установка правил разрыва строк (перед или после знаков пунктуации, после ключевых слов и т.д.);
    • Пробел - установка правил автоматического добавления пробелов до или после отдельных элементов синтаксиса – ключевых слов и знаков пунктуации.
  • Редактор определений Code Tools: Здесь можно видеть все внутренние определения для грамматического разбора исходников. Видны все определения, модули, исходники, включая пути к папкам с исходниками. Начиная от установок текущего компилятора FPC, настроек папки исходников Lazarus, папок пакетов и проектов.

Большинство этих установок сгенерированы автоматически, и только для чтения.

  • Пересмотреть папку исходного кода FPC Повторный просмотр папки. Lazarus использует исходники fpc для генерации правильной обработки событий и проверки объявлений. Если произведена смена папки в опциях окружения, то эта папка будет пересмотрена, чтобы lazarus убедился, что работает с версией, находящейся в этом месте. Но если эта папка была сменена без ведома lazarus, то можно получить некоторые ошибки при разработке форм или поиске объявлений. В этом случае возможны два пути:
1. Проверить установки папки исходников в опциях окружения. 
2. Пересмотреть папку исходного кода FPC.

Меню Окно

Содержит список открытых файлов и доступных окон вроде Редактор Исходного Кода, Инспектор Объектов и Инспектор Проекта. Щелчком на имени одного из окон оно выводится "наверх" и получает фокус.

Меню Справка

Имеется три выбора:

  • Оперативная Справка – открывается окно браузера с картинкой бегущего гепарда и несколькими связями на веб-сайты Lazarus, FreePascal и WiKi.
  • Параметры справки – открывается меню с опциями выбора инструмента просмотра и баз данных для чтения информации Справки. Можно указать либо секцию онлайновой документации, либо некоторые другие сайты, либо локальный набор документации (в дальнейшем он будет встроенным, по полном окончании разработки системы помощи).

Сейчас, по умолчанию, если поместить курсор на ключевое слово из FreePascal Components Library FCL, или из RunTime Library RTL (но не из Lazarus Components Library LCL) и нажать <<F1>>, то будет показано подходящее определение на сайте. ЭТА СЕКЦИЯ ПОКА ВСЕ ЕЩЕ В ПРОЦЕССЕ РАЗВИТИЯ.

  • О Проекте Lazarus – отображается многостраничное окно с информацией о установленной версии и участниках проекта Lazarus.

В конечном счете, найдется полная диалоговая услуга Справки с информацией о синтаксисе Pascal, работе с IDE, как использовать, изменять, или создавать компоненты, подсказки о том, как выполнять определенные задачи. Эта часть секции Документация (то, что Вы читаете сейчас) представляет собой начальный этап процесса. Нам нужна помощь любого, кто в силах оказать еe: WiKi очень упрощает редактирование.