Difference between revisions of "fpcupdeluxe/de"

From Free Pascal wiki
m (MS-DOS)
m (Added page template; moved categories to page template)
 
(22 intermediate revisions by 4 users not shown)
Line 1: Line 1:
{{Translate}}
+
{{fpcupdeluxe}}
=FPCUPdeluxe=
+
 
 
== Vorwort ==
 
== Vorwort ==
FPCUPdelux ist ein sehr mächtiges Tool, mit dem man die aktuelle Stable und Trunk von FPC und Lazarus erzeugen kann.<br>
+
 
Es sind auch sehr viele Cross-Compiler damit möglich. Vor allem auch für den Rasberry PI.
+
FPCUPdeluxe ist ein sehr mächtiges Tool, mit dem man die aktuelle Stable und Trunk von FPC und Lazarus erzeugen kann.<br>
 +
Es sind auch sehr viele Cross-Compiler damit möglich. Vor allem auch für den '''Raspberry Pi'''.<br>
 +
Wichtig ist, das man immer die neuste Version von FPCUPdeluxe verwendet.
  
 
== Download ==
 
== Download ==
 +
 
* [https://github.com/newpascal/fpcupdeluxe FPCUPdeluxe Sourcen]
 
* [https://github.com/newpascal/fpcupdeluxe FPCUPdeluxe Sourcen]
 
* [https://github.com/newpascal/fpcupdeluxe/releases/latest FPCUPdeluxe Latest release]
 
* [https://github.com/newpascal/fpcupdeluxe/releases/latest FPCUPdeluxe Latest release]
 +
 
Die Sourcen lassen sich mit einem aktuellen FPC/Lazarus kompilieren.
 
Die Sourcen lassen sich mit einem aktuellen FPC/Lazarus kompilieren.
  
 
== Mögliche Fehler beim Bauen von FPC/Lazarus ==
 
== Mögliche Fehler beim Bauen von FPC/Lazarus ==
=== Linux Mint 64Bit( Ubuntu ) ===
+
 
Bei einem frisch installierten Linux Mint / Ubuntu kann es zu folgendem Fehler kommen:
+
=== Linux Mint 64Bit( Ubuntu ) / Raspberry ===
<pre>
+
 
fpcupdeluxe: info: 15-4-18 15:40:52: fpcupdeluxe: V047 (20180127) started.
+
Bei einem frisch installierten / Ubuntu kann es zu folgendem Fehler kommen:
fpcupdeluxe: ERROR: Missing library:
+
 
fpcupdeluxe: ERROR: libX11.so
+
    fpcupdeluxe: info: 15-4-18 15:40:52: fpcupdeluxe: V047 (20180127) started.
fpcupdeluxe: ERROR: libgdk_pixbuf-2.0.so
+
    fpcupdeluxe: ERROR: Missing library:
fpcupdeluxe: ERROR: libpango-1.0.so
+
    fpcupdeluxe: ERROR: libX11.so
fpcupdeluxe: ERROR: libgdk-x11-2.0.so
+
    fpcupdeluxe: ERROR: libgdk_pixbuf-2.0.so
fpcupdeluxe: WARNING: You need to install at least the libraries to get libX11.so and libgdk_pixbuf-2.0.so and libpango-1.0.so and libgdk-x11-2.0.so, but also make and binutils to build Lazarus !!
+
    fpcupdeluxe: ERROR: libpango-1.0.so
fpcupdeluxe: WARNING: Make, binutils, subversion/svn [and gdb] are also required !!
+
    fpcupdeluxe: ERROR: libgdk-x11-2.0.so
fpcupdeluxe: ERROR: FPCNativeInstaller (CheckAndGetTools): Could not find SVN executable. Please make sure it is installed.
+
    fpcupdeluxe: WARNING: You need to install at least the libraries to get libX11.so and libgdk_pixbuf-2.0.so and libpango-1.0.so and libgdk-x11-2.0.so, but also make and binutils to build Lazarus !!
</pre>
+
    fpcupdeluxe: WARNING: Make, binutils, subversion/svn [and gdb] are also required !!
 +
    fpcupdeluxe: ERROR: FPCNativeInstaller (CheckAndGetTools): Could not find SVN executable. Please make sure it is installed.
 +
 
 
Die fehlenden Pakete kann man folgendermassen nachinstallieren:
 
Die fehlenden Pakete kann man folgendermassen nachinstallieren:
 +
 
<syntaxhighlight lang="bash">
 
<syntaxhighlight lang="bash">
 
#!/bin/bash
 
#!/bin/bash
Line 40: Line 47:
 
sudo apt-get install subversion
 
sudo apt-get install subversion
  
# Wen die Komponente TOpenGLControl verwendet wird.
+
# Für GIT
 +
sudo apt-get install git
 +
 
 +
# Wen OpenGL ( TOpenGLControl ) verwendet wird.
 
sudo apt-get install freeglut3-dev
 
sudo apt-get install freeglut3-dev
 +
</syntaxhighlight>
  
# Datenbanktreiber für Linux-MS SqlTreiber ( Nur bei Verwendung von SQL ).
+
Auf dem Raspi muss evtl.  für OpenGL folgendes installiert werden.
sudo apt-get install freetds-bin
 
sudo apt-get install libsybdb5
 
  
 +
<syntaxhighlight lang="bash">
 +
sudo apt-get install libgl-dev
 
</syntaxhighlight>
 
</syntaxhighlight>
Anschliessend sollte fpcupdelux wie gewohnt laufen.
+
Anschliessend sollte fpcupdeluxe wie gewohnt laufen.
 +
 
 +
== Raspberry ==
 +
 
 +
'''Achtung !''' Das Bauen von FPC/Lazarus auf einem Raspberry geht sehr lange.<br>
 +
Bei meinem Raspberry 2 ging es ca. '''1 Stunde'''.
  
 
== Cross-Compiler ==
 
== Cross-Compiler ==
 +
 
=== AVR/Arduino ===
 
=== AVR/Arduino ===
 +
 
* [[AVR Embedded Tutorial - Entry Lazarus and Arduino/de|AVR Cross-Compiler]] - Lazarus mit AVR-Crosscompiler für Arduino Nano/Uno bauen.
 
* [[AVR Embedded Tutorial - Entry Lazarus and Arduino/de|AVR Cross-Compiler]] - Lazarus mit AVR-Crosscompiler für Arduino Nano/Uno bauen.
 +
 +
=== Android ===
 +
 +
* [[Android - Android with FPCUPDeluxe/de|Android Cross-Compiler]] - Lazarus für Android.
 +
=== Windows ===
 +
unter Setup+ im Menupunkt Module muss "Auto-Switch repo URL" aktiviert werden, damit neben der stables auch die trunks erzeugt werden konnten.
  
 
=== MS-DOS ===
 
=== MS-DOS ===
 +
 
Hier müssen folgende Einstellungen vorgenommen werden:
 
Hier müssen folgende Einstellungen vorgenommen werden:
 +
 
* CPU -> i8086
 
* CPU -> i8086
 
* OS -> msdos
 
* OS -> msdos
 +
 
Dabei ist es möglich, das man nur das einte der beiden Optionen anwählen kann, dies ist aber egal.
 
Dabei ist es möglich, das man nur das einte der beiden Optionen anwählen kann, dies ist aber egal.
  
 
Weiterhin empfehlenswert, um möglichst Turbo-Pascal kompatibel zu sein:
 
Weiterhin empfehlenswert, um möglichst Turbo-Pascal kompatibel zu sein:
* {{keypress|Setup+}} --> Cross Build Options Override --> -WmLarge
+
 
 +
* {{keypress|Setup+}}
 +
* Select CPU -> i8086
 +
* Select OS -> msdos
 +
* Cross Build Options Override --> -WmLarge
  
 
== Siehe auch ==
 
== Siehe auch ==
* [[fpcupdeluxe|FPCUPdelux]] - Komplette Anleitung (english)
+
 
 +
* [[fpcupdeluxe|FPCUPdeluxe]] - Komplette Anleitung (english)
  
 
Autor: [[User:Mathias|Mathias]]
 
Autor: [[User:Mathias|Mathias]]
 
[[category:Install]]
 

Latest revision as of 02:08, 16 September 2020

Deutsch (de) English (en) español (es) русский (ru)

Vorwort

FPCUPdeluxe ist ein sehr mächtiges Tool, mit dem man die aktuelle Stable und Trunk von FPC und Lazarus erzeugen kann.
Es sind auch sehr viele Cross-Compiler damit möglich. Vor allem auch für den Raspberry Pi.
Wichtig ist, das man immer die neuste Version von FPCUPdeluxe verwendet.

Download

Die Sourcen lassen sich mit einem aktuellen FPC/Lazarus kompilieren.

Mögliche Fehler beim Bauen von FPC/Lazarus

Linux Mint 64Bit( Ubuntu ) / Raspberry

Bei einem frisch installierten / Ubuntu kann es zu folgendem Fehler kommen:

   fpcupdeluxe: info: 15-4-18 15:40:52: fpcupdeluxe: V047 (20180127) started.
   fpcupdeluxe: ERROR: Missing library:
   fpcupdeluxe: ERROR: libX11.so
   fpcupdeluxe: ERROR: libgdk_pixbuf-2.0.so
   fpcupdeluxe: ERROR: libpango-1.0.so
   fpcupdeluxe: ERROR: libgdk-x11-2.0.so
   fpcupdeluxe: WARNING: You need to install at least the libraries to get libX11.so and libgdk_pixbuf-2.0.so and libpango-1.0.so and libgdk-x11-2.0.so, but also make and binutils to build Lazarus !!
   fpcupdeluxe: WARNING: Make, binutils, subversion/svn [and gdb] are also required !!
   fpcupdeluxe: ERROR: FPCNativeInstaller (CheckAndGetTools): Could not find SVN executable. Please make sure it is installed.

Die fehlenden Pakete kann man folgendermassen nachinstallieren:

#!/bin/bash
# Paketliste auf neusten Stand bringen und Updaten
sudo apt-get update
sudo apt-get upgrade

# Die fehlenden Pakete installieren.
sudo apt-get install libx11-dev
sudo apt-get install libgdk-pixbuf2.0-dev
sudo apt-get install libpango1.0-dev 
sudo apt-get install libgtk2.0-dev 

# Für SVN
sudo apt-get install subversion

# Für GIT
sudo apt-get install git

# Wen OpenGL ( TOpenGLControl ) verwendet wird.
sudo apt-get install freeglut3-dev

Auf dem Raspi muss evtl. für OpenGL folgendes installiert werden.

sudo apt-get install libgl-dev

Anschliessend sollte fpcupdeluxe wie gewohnt laufen.

Raspberry

Achtung ! Das Bauen von FPC/Lazarus auf einem Raspberry geht sehr lange.
Bei meinem Raspberry 2 ging es ca. 1 Stunde.

Cross-Compiler

AVR/Arduino

Android

Windows

unter Setup+ im Menupunkt Module muss "Auto-Switch repo URL" aktiviert werden, damit neben der stables auch die trunks erzeugt werden konnten.

MS-DOS

Hier müssen folgende Einstellungen vorgenommen werden:

  • CPU -> i8086
  • OS -> msdos

Dabei ist es möglich, das man nur das einte der beiden Optionen anwählen kann, dies ist aber egal.

Weiterhin empfehlenswert, um möglichst Turbo-Pascal kompatibel zu sein:

  • Setup+
  • Select CPU -> i8086
  • Select OS -> msdos
  • Cross Build Options Override --> -WmLarge

Siehe auch

Autor: Mathias