LazPaint File/fi

From Free Pascal wiki

English (en) suomi (fi)

Kuvia voidaan ladata kokonaisuutena File-valikosta tai käytetään tiedostoja niin että ne "sulautetaan" nykyiseen kuvaan.

LazPaint tarjoaa kuvaformaatin (* .LZP) tallentamaan kaikenlaisia kuvia (ne voivat olla kerroksellisia tai ei ja ne voivat olla läpinäkyviä tai ei). Kyseessä on häviötön muoto joka tarkoittaa, että kuten PNG niin tarkka kuva on tallennetaan, ei likiarvoa siitä. Tämä tiedostomuoto on nopeampi kuin PNG ja tarjoaa kerrokset mutta tiedostot ovat hieman suurempia. Jos halutaan PNG kaltainen pakkaaminen kerroksilla niin voidaan käyttää OpenRaster tiedostomuotoa (* .ORA).


Uuden tiedoston luominen

Valikko: Tiedosto> Uusi

Ikkuna pyytää sinua näppäillä leveys ja korkeus sekä esikatselu näyttää kuvasuhteen. Kääntämispainikkeella avulla vaihtaa leveys ja korkeus.

lazpaint newimage.png

Tiedoston avaaminen

Valikko: Tiedosto> Avaa


Tiedosto-valikosta, voidaan avata tavallinen tai kerrostettu kuva, muokata sitä tai tuoda yhden kuvan kuvake (* ICO, * .CUR) tai animoitu GIF.

Versio 6.0 toi kuvien selaimen ja Photoshop (* .PSD) "litistettyjen" kuvien tuonti.

lazpaint browser.jpg

Tiedostomuodot

LazPaint tukee seuraavia tiedostoformaatteja:

kerroksilla:

  • LZP (luku / kirjoitus): LazPaint tiedostomuoto
  • ORA (luku / kirjoitus): OpenRaster tiedostomuoto
  • PDN (luku): Paint.NET kuvia
  • PSD (lukee litystettyjä): Photoshop kuvia

Normaalit kerrostomattomat kuvat:

  • BMP (luku / kirjoitus): pakkaamatonta bittikarttoja (mukaan lukien alfa-kanava, mutta monet ohjelmat eivät lue läpinäkyvyystietoja)
  • GIF (lukee yhden kehyksen): käyttäjä voi valita kehyksen jos kuva on animoitu
  • ICO/CUR (lukee yhden koon): kuvake, käyttäjä voi valita koon
  • JPEG : valokuvista tunnettu, pakattu mutta kuitenkin häviöllinen
  • PCX (luku / kirjoitus) : Personal Computer eXchange
  • PNG (luku / kirjoitus) : Portable Network Graphic
  • TGA (luku / kirjoitus) : kutsutaan myös Targa
  • TIFF (luku / kirjoitus) : kaikkia pakkaustyyppejä ei ole tuettuna
  • XPM (luku / kirjoitus) : X PixMap (pienet C kaltainen formaatti)
  • XWD (luku) : X Window Dump (kuvakaappaus)

Päivitä tiedosto

Valikko: Tiedosto > Reload

Tämä valinta lataa nykyisen tiedoston viimeisen tiedostonimen mukaisen tiedoston. Se kumoaa tallentamattomat muutokset.

Tallenna tiedosto

Valikko: Tiedosto> Tallenna

Jos tiedosto avataan niin se voidaan kirjoittaa LazPaintssa samoin, niin voit klikata levykkeellä painiketta korvata nykyinen. Huomaa, että sinun täytyy olla varovainen JPEG-tiedostojen kanssa, koska tiedostoa ei tallenneta parhaalla laadulla, joten on parempi käyttää toista muotoa, kuten LZP ja PNG.

Kerroksen lisääminen tiedostoon

Kerrosikkunassa on painike jolla tuodaan kuva ja lisätään se suoraan kerrospinoon. Huomaa, että kuvan kokoa ei muuteta, mutta se voidaan leikata. Jos haluat muuttaa tai soveltaa muutosta, käytä tekstuuri työkalua.


Tekstuuri työkalua

Työkalupalkissa on "no tex" kuvake, jota seuraa "avaa" -painike. Sillä voidaan avata minkä tahansa tekstuuri ja sitten käyttää sitä piirtotyökaluilla. Tekstuuri kartoitustyökalu erityisesti tarkoitettu venyttämiseen ja halutessa kuvakulman muuttamiseen, jotta sen koko sopii täydellisesti kuvaasi.

3D-tiedostojen tuonti

Valikko: Tiedosto > Import 3D object

Voidaan tuoda tiedostoja Wavefront tiedostomuodossa (* OBJ). Aseta kierto ja väri sopivaksi ja se tuodaan nykyiselle kerrokselle.

lazpaint import3d.png