IDE Window: Editor Options/de

From Lazarus wiki

Deutsch (de) English (en) español (es) suomi (fi) français (fr)

Der Dialog kann aufgerufen werden

  • im Hauptmenü unter Werkzeuge -> Einstellungen
  • im Kontextmenü des Quelltexteditors unter Editoreigenschaften


Allgemein

Einstellungen für Rücknahme

  • Rücknahme auch nach dem Speichern: Bewahrt die Undo-Liste beim Speichern.
  • Gruppenrücknahme: Bei der Rücknahme/ beim Wiederherstellen, werden alle ausständigen Änderungen der selben Art in einem Aufruf durchgeführt anstatt jede Änderung einzeln.
  • Rücknahmemaximum: Maximale Anzahl von Rücknahmeschritten.

Scrolleinstellungen

  • Über das Dateiende hinaus scrollen: Erlaubt es, den Cursor über die Dateiende-Markierung hinaus zu bewegen.
  • Halbseitiges Scrollen: Beim Scrollen mit Bild-hoch und Bild-ab wird nur eine halbe Seite weit bewegt.
  • Eine Zeile weniger scrollen: Erzwingt beim Scrollen eine Zeile weniger.
  • Scrollhinweise anzeugen:

Cursoreinstellungen

  • X-Position des Cursors beibehalten: Beim Bewegen durch die Zeilen des Quellcodes wird die X-Position des Cursors beibehalten, solange das Zeilenende nicht überschritten wird.
  • Persistenter Cursor: Der Cursor blinkt auch dann, wenn das Editorfenster den Fokus verliert. Dies wird bei einigen Betriebssystemen benötigt, bei denen das Fokussieren von Meldungen nicht richtig funktioniert.
  • Ständig sichtbarer Cursor: Beim Scrollen bleibt der Cursor ständig sichtbar.
  • Über das Zeilenende hinaus scrollen: Erlaubt den Cursor hinter das letzte Zeichen in einer Zeile zu bewegen.
  • Cursor überspringt Auswahl: When there is a selection and you press the left arrow, the cursor will go to the start of the selection.
  • Cursor überspringt Tabulatoren:
  • Pos1-Taste springt zum nächsten Anfang: home key jumps to line start if nearer, similar to visual studio.
  • Ende-Taste springt zum nächsten Ende:

Auswahl

  • Persistenter Block:
  • Block überschreiben:

Einrückung und Tabulatoren

Tabulatoren:

  • Tabulatoren in Leerzeichen umwandeln: Beim Bearbeiten von Zeilen fügt der Editor Leerzeichen anstatt Tabulatoren ein. Der Rest der Zeile wird nicht geändert und Tabulatoren bleiben erhalten. Um alle Tabulatoren umzuwandeln markieren Sie die gesamte Datei (Strg + A) und gehen im Hauptmenü zu Bearbeiten -> Tabulatoren in Auswahl in Leerzeichen umwandeln.
  • Tab-Breite: Maximale Anzahl von Leerzeichen als Tabulatorersatz.
  • Intelligentes Einrücken: Wenn eingerückt wird, geht der Cursor zum nächsten Leerzeichen der vorherigen Zeile. Wenn die aktuelle Zeile länger ist als die vorhergehende, wird nach einer längeren Zeile davor gesucht.

Einrückung:

  • Automatische Einrückung: Wenn neue Zeilen eingefügt werden (z.B. durch das Drücken der Enter Taste), wird der Editor den Cursor auf der neue Zeile mit der selben Anzahl von führenden Leerzeichen wie auf der vorhergehenden Zeile einrücken. Dies enthält auch "automatisches Ausrücken": Wenn die Einfügemarke hinter dem letzen Whitespace-Zeichen eines zusammenhängenden Blockes solcher Zeichen am Zeilenanfang steht, dann bewirkt das Drücken von Backspace ein Ausrücken. Dabei wird auf die Einrückung der vorigen Zeile geachtet. Enthält eine Zeile nur Leerzeichen, passiert dies nur, wenn die Einfügemarke am Zeilenende steht.
  • Tab rückt ganze Blöcke ein: Wenn aktiviert können mit <Tab> und <Shift><Tab> Blöcke eingerückt oder selektierter Text ausgerückt werden.
  • Blockeinrückung: Anzahl von Leerzeichen, um die ein Block eingerückt wird. Zum Beispiel mit Strg + I.

Kommentare:

Verschiedenes

  • Sonderzeichen anzeigen: Leerzeichen werden als Punkte und ungültige Zeichen als Fragezeichen angezeigt.
  • Abschneiden von Leerzeichen am Zeilenende: Leerzeichen am Zeilenende werden abgeschnitten und nicht gespeichert. Dies trifft nur auf bearbeitete Zeilen zu.
  • Text am Cursor suchen: Wenn der 'Suche' Dialog aufgerufen wird, wird das Wort am Cursor genommen und in das Suchtext Feld eingetragen.
  • Ohne Markierung Wort kopieren: Wenn nichts ausgewählt ist und der Benutzer Kopieren (Strg + C) drückt, markiert der Editor das Wort und kopiert es. Das selbe gilt für Ausschneiden.
  • Kopieren/Einfügen mit Faltungsinformationen: Gefaltete Bereiche bleiben beim Kopieren und Einfügen (von einem Editorfenster zu einem anderen) erhalten.


  • Leerzeichenbehandlung:
  • Reiterposition des Quell-Notebooks:

Anzeige

Auf dieser Seite lassen sich Einstellungen bezüglich der Ränder und der Schrift im Quelltexteditor treffen. Ein Vorschaufenster im unteren Bereich erlaubt einen Blick darauf, wie sich Änderungen auswirken.

Mit der Option Sichtbarer rechter Rand wird eine Linie am rechten Rand gezeichnet. Mit dieser Linie wird die Stelle angezeigt, ab der beim Ausdruck ein Zeilenumbruch erfolgt. Die Anzahl der Zeichen bis zur Trennlinie wird im folgenden Eingabefeld festgelegt. Vorgabe sind 80 Zeichen, was sich an früheren Zeiten orientiert, als es Editoren nur im Textmodus gab. Da auf modernen Monitoren deutlich mehr als 80 Zeichen in einer Zeile dargestellt werden können, hat die Option keine Auswirkung auf die Darstellung am Monitor. Soll die Farbe der Linie geändert werden, so führt ein Klick auf den Link zur Seite mit den Farbeinstellungen.

Eine Leiste am linken Rand läßt sich mit Sichtbare Randleiste einschalten. Diese Leiste wird zur Darstellung zusätzlicher Informationen wie Zeilennummern oder Haltepunkte benötigt.

Da sich Fehlermeldungen oft auf eine bestimmte Zeilennummer beziehen, lassen sich die Ursachen schneller finden, wenn die Anzeige der Zeilennummern aktiviert ist. Da die Anzeige der Zeilennummern in der linken Randleiste erfolgt, muß die Anzeige der Randleiste ebenfalls aktiviert sein. Da die Nummerierung einer jeden Zeile bei einer Suche nicht unbedingt übersichtlich ist, läßt sich die Anzeige auf jede n-te Zeile einschränken.


Da die richtige Schriftart im Editor die Lesbarkeit verbessern kann, bietet auch Lazarus verschiedene Einstellmöglichkeiten. Die Schriftart kann einfach sein wie 'courier' oder kompliziert wie '-adobe-courier-medium-r-normal-*-*-140-*-*-*-*-iso10646-1' unter GTK/X. Weiterhin läßt sich die Schriftgröße ändern sowie ein zusätzlicher Abstand zwischen Zeilen und auch den Zeichen einrichten. Der zusätzliche Abstand wird in Pixeln angegeben. Mit dem Abschalten des Antialiasing läßt sich auf leistungsschwächeren Systemen die Belastung verringern, um Fehlern bei der Darstellung vorzubeugen.

Farben

Auf dieser Seite können die Farbeinstellungen für die Syntaxhervorhebung in der IDE vorgenommen werden. Der Haupt-Hervorheber ist derjenige für Object Pascal. Alle anderen Hervorheber nutzen dessen Farben als Vorgabeeinstellung.

Quick overview of provided functionality

This dialog provides access to the following color and highlight related settings and functions Choosing Color-Schemes

Color-scheme are set individually for each language. This allows to highlight different languages with different schemes.

To change the scheme for a language choose the language from the first drop-down, then choose the color-scheme in the 2nd drop-down.

The color-scheme will be applied to all files of this language. The language of a file is detected by the file-extension. The list of extensions can be chosen or edited in the 3rd drop-down. Editing Colors in a Scheme

Individual colors and styles in any scheme can be edited. Changes like this will be applied to all files (that are of a language which is) using the scheme.

More details of how to edit colors and styles can be found below.

How Colors are determined "Default Text"

The base color (fore and background) used to display any text. All other colors act as modification to this color pair.

Language-specific and Mark-up colors are based on the "default text" colors. They only specify Attributes that need to be modified. (e.g. pascal keywords are bold, otherwise using the default colors) This allows to change the default color and all elements will follow to the new setting (unless they have a modified fore/background color) Language specific colors

Specify colors or styles for language specific elements.

Any color set to "not modified" uses the "default text" setting. The default for styles is no-style (not bold, not italic, ...).

An exception is the style/color for pascal "Case label". It modifies the style of the underlying pascal element, which can be String, Number or Identifier. If those make no modification, then the default come from the "default text" again.

For this reason "Case label" has extended style settings like "mark-up" colors (see there). Mark-up colors

Specify colors for all forms of mark-up (text-selection, brackets, ...)

The modifications made by mark-up settings are applied on top of those made by the language specific settings. They may even be applied on top of other mark-up settings, if several mark-ups apply to a text. (e.g. selected text with bracket highlight in selection)

Since they modify text that can already have styles (e.g language specific settings may display pascal keywords/comments in bold), they allow to either force a style on/off or invert it's current state.


Die Buttons und Comboboxen am oberen Rand bieten die folgenden Funktionen:

  • Syntaxhervorhebung nutzen: Bei Deaktivierung dieser Funktion bleiben die anderen Einstellungen ohne Auswirkung.
  • Sprache: Hier läßt sich der Hervorheber für eine bestimmte Sprache wählen. Voreingestellt ist Object Pascal. Zur Auswahl stehen aber z.B. auch C++ oder Python. Language refers to the content type of a file. Highlighting recognizes different types of content, such as pascal files, XML/HTML, LFM, diff-files and some other programming languages
  • Farbschema: Die IDE enthält einige vordefinierte Farbschemata (z.B. für die von Turbo Pascal bekannten Farben). Es empfiehlt sich, erst ein Farbschema zu wählen, bevor einzelne Elemente bearbeitet werden. Ein Farbschema definiert, wie Text in verschiedenen Sprachen hervorzuheben ist. Es definiert auch, wie sprachunabhängige Bereiche wie markierter Text hervorzuheben sind. Ein Farbschema besteht aus:
    • A basic default color for text and the editors background color. Usually a single scheme uses the same "default colors" for all languages.
    • individuellen Farb- und Stil-Einstellungen/Modifikationen für sprachspezifische Elemente, z.B. Pascal-Schlüsselworte oder XML-Tags.
    • General color and style settings/modifications for mark-up. For example selected-text, matching-brackets, syncro-edit. Again usually for one scheme those colors are the same cross all languages supported by the scheme.
  • Dateiendungen: Hier lassen sich die Dateitypen einschränken, für welche die Hervorhebung gelten soll.
  • Export: Bietet die Möglichkeit, die getroffenen Einstellungen in eine XML-Datei zu sichern. Um ein exportiertes Schema (z.B. auf einem anderen Computer) nutzbar zu machen, muß die XML-Datei in ein Verzeichnis "userschemes" kopiert werden, welches sich im primären Konfigurationspfad von Lazarus befindet. Das Schema aus der Datei wird dann in der Schema-Auswahlliste (Dropdown) erscheinen.
  • Alle Elemente auf Voreinstellungen setzen: Wenn man sich bei der Einstellung der Farben total vertan hat, dann bietet sich hier eine schnelle Möglichkeit, den Ausgangszustand wiederherzustellen.

Es folgen zwei Fenster, in denen sich einzelne Elemente auswählen und die getroffenen Änderungen in einer Vorschau betrachten lassen.

Im Bereich Elementattribute läßt sich festlegen, ob globale oder lokale Schema-Einstellungen verwendet werden sollen. Außerdem kann man hier einzelne Elemente auf ihre Voreinstellung zurücksetzen. Mit der Wahl von Vorder- und Hintergrundfarbe läßt sich jedem Element eine individuelle Note geben. Dabei sollte beachtet werden, dass nicht jede mögliche Farbkombination auch sinnvoll ist.

Globale Schema-Einstellungen

Most colors can be set globally for the whole scheme or have language specific settings. Using the global-scheme default allows to quickly change a setting for all languages.

Global settings are available for the "default text" and for all "mark-up" settings. They can be switched off on a per language base, allowing to specify a language specific exception for some or all of those colors.

Note If the "Use global scheme settings" check-box is checked for any settings, then the colors shown and editing are the global colors. Changes will affect all languages.

The difference between "use global" and "Not modified"

"not modified" always refers to the color/style the text has according to the language specific setting, or settings already applied to it.

(Block-selection may act on default text, on pascal-comment, or even on bracket pair highlight.) "not modified" does not mean to take the color from the global scheme settings.

"use global" means that the values for all colors styles of the selected element will be determined according to global settings. The global settings will be treated as if they where local).

global settings can them self specify "not modified, in which case the color will be chosen from the languages upward settings.

Hervorhebung

Es gibt eine Reihe von Möglichkeiten, um das current-word-markup Feature zu steuern. Diese finden sich unter Automatische Funktionen und Farben in den Editoreinstellungen.

Anmerkung: Wenn Sie einen Block markiert haben, dann wird der Block als Grundlage für die Hervorhebung verwendet und nicht das Wort unter dem Cursor. Manche Einstellungen sind nur für Blöcke sinnvoll, andere für einzelne Wörter.

  • Timer für Wort-Hervorhebung deaktivieren: Normalerweise startet die Hervorhebung nicht unmittelbar, sondern erst nach einer (einstellbaren) Verzögerung. Wird der Timer für diese Verzögerungszeit deaktiviert, dann kann mittels der Maus keine Hervorhebung mehr ausgelöst werden. Es verbleibt aber die Möglichkeit, die Hervorhebung über die Tastatur auszulösen. Die (Standard-)Tastenkombination dafür ist Alt + M. You can toggle the highlight to any chosen word, or selection by pressing Alt-M while at the word, or while having selected the desired block. Pressing Alt-M again will set the "fixed" word to the word at your new location. To untoggle, press Alt-M twice at the same location (The exact behaviour is: If your current selected block, or (if no block selected) the current word under cursor is the same term as the word you toggled-fixed, this will clear the fixed word. Otherwise the fixed word will be set)
  • Schlüsselworte übergehen: Jeder Hervorheber enthält eine hardcodierte Liste von Schlüsselworten. Bei Aktivierung der Option werden diese Schlüsselworte bei der Hervorhebung nicht berücksichtigt, auch wenn sie in einem Kontext verwendet werden, der sie nicht als Schlüsselworte erkennen lässt. Andere Hervorheber können andere Schlüsselwortlisten enthalten.
  • Leerzeichen anpassen:
  • Klammerhervorhebung: Wenn der Cursor vor oder hinter einer Klammer ist, dann wird diese zusammen mit der zugehörigen Klammer (bei einer öffnenden Klammer ist dies die schließende Klammer, bei einer schließenden Klammer die öffnende Klammer) hervorgehoben. Auf diese Weise lassen sich verschachtelte Ausdrücke besser erkennen und analysieren. Die Hervorhebung erfolgt standardmäßig durch Fettschreibung. Ist der Quelltext an der betreffenden Stelle bereits fett geschrieben (z.B. innerhalb eines Kommentars), dann erfolgt die Hervorhebung durch Normalschreibung.
  • Steueranweisungen wie Schlüsselworte hervorheben:


4) for current-word only: You can choose to only highlight exact matches(match word boundaries) instead of any occurrence including occurrences in other words. By Default this applies to words shorter than 3 chars.

For example: Set option to true and field to 3.

If the word at caret is the 3 letter word 'laz' then all 'laz' will be marked, but not 'lazarus' or 'blaz'.

If the word at caret is the 4 letter word 'laza' then all words including 'laza' will be marked, such as 'lazarus'.


5) blocks only: by default leading/trailing spaces are ignored/stripped from the search term

To disable the feature completely: Set all colors (FG,. BG and Frame) to default (check the tickbox); make sure no Styles (bold, italic) are selected.

This will be recognized, and the Editor is clever enough and will not even trigger the search for other words.

Benutzerdefinierte Hervorhebung

Tastaturbelegung

Siehe auch Lazarus IDE Shortcuts.

  • Filter: Am oberen Rand der Seite gibt es ein Eingabefeld, um einen Textfilter einzurichten. Geben Sie einige Buchstaben ein und in der Baumansicht darunter werden nur die Tasten angezeigt, in deren Beschreibung der eingegebene Text enthalten ist. Löschen Sie den Inhalt des Eingabefelds, um alle Tasten anzuzeigen.
  • Baum der IDE-Shortcuts: Hier können Sie alle Kommandos und Shortcuts der IDE sehen. Klicken Sie auf einen der Schlüssel, um einen Dialog zum Bearbeiten des Shortcuts erscheinen zu lassen.
  • Tastenkombination suchen: Click on the button to show a dialog. Grab a key and press ok. The tree will then only show those keys that start with the shortcut. Wählen sie VK_UNKNOWN, um alle anzuzeigen.
  • Ein Schema laden: Lädt eine der vordefinierten Tastaturbelegungen. Dies wird alle ihre Shortcuts überschreiben.
  • Tastenbelegung löschen: Löscht für den gerade ausgewählten Befehl den Shortcut.
  • Konsistenz prüfen: Sucht nach mehrfach definierten Tasten.

Maus

Diese Seite ist ein Teil der Online-Hilfe für die IDE.
Sie beschreibt den Abschnitt: "Editor" / "Maus". Sie können diesen Dialog in Ihrer IDE aufrufen über:

  • das Menü: Werkzeuge => Einstellungen -> Editor -> Maus ...
  • das Kontextmenü des Quelltexteditors (Rechtsklick): -> Einstellungen ...

Navigation

     
  • IDE Options Überblick über alle Einstellungen der IDE


Allgemein

Maus beim Tippen verbergen

Wenn der Mauszeiger über einem Editor ist, wird er während Sie tippen verborgen. Jede Mausbewegung, Mausklick oder Menübefehl machen ihn wieder sichtbar.

Randleiste

Sie können aktuell zwischen zwei vordefinierten Modi für die Randleiste wählen:

Standard

Alle Klicks mit der linken Maustaste auf die Randleiste reagieren, wenn die Maustaste gedrückt wird.

Erweitert

Alle Klicks mit der linken Maustaste auf die Randleiste reagieren, wenn die Maustaste losgelassen wird. Dieser Modus erlaubt es, mit der Maus Text zu markieren und trotzdem eine Klickaktion auszulösen.

  • Maus gedrückt und bewegt (zu einer anderen Zeile oder in den Textbereich hinein), erstellt eine Auswahl. Beim Auslassen erfolgt keine Aktion.
  • Maus gedrückt und ausgelassen ohne Bewegung, führt den normalen Randleistenklick aus (Breakpoint / Codefaltung)

Text

Alt-Taste aktiviert Spaltenmodus

Erlaubt die spaltenweise Auswahl. Halten Sie die Alt-Taste gedrückt, während Sie mit der Maus Text auswählen.

Auswahl verschieben

Mit der linken Maustaste ziehen Sie eine Auswahl an eine neue Stelle. Bei zusätzlicher Strg-Taste wird die Auswahl kopiert.

Rechte Maustaste bewegt auch den Cursor

DIe rechte Maustaste zeigt immer das Kontextmenü an. Die Einfügemarke auf die Klickposition zu setzen ist optional.

Doppelklick markiert Zeile

Normalerweise wählt ein Doppelklick ein Wort aus, ein Dreifachklick eine Zeile (ohne führende und nachfolgende Leerzeichen). Mit dieser Einstellung wählt der Doppelklick die Zeile aus, ein Dreifachklick schließt auch führende/nachfolgende Leerzeichen ein.

Mittlere Taste

"Auswahl einfügen": Bei einer aktiven Auswahl wird eine Kopie an der angeklickten Position eingefügt.

Strg + linke Taste

Als Vorgabe: Wenn Sie auf einen Bezeichner (wie z.B. eine Funktion, eine Variable oder einen Typnamen) klicken, springt die IDE zur Deklaration dieses Bezeichners (sogar in eine andere Unit hinein).

Dieses Merkmal ist auch als Tastenkürzel verfügbar (üblicherweise Alt+. Siehe "Einstellungen" / "Tastaturbelegung" / "CodeTools-Befehle" / "Deklaration suchen"

"zum anderen Blockende" bedeutet: Wenn Sie nicht auf einem Bezeichner sondern auf einem Blockanfang sind ("begin", "end" oder einem Klammerpaar oder etwas Ähnlichem), dann erfolgt ein Sprung zum passenden Wort / zur passenden Klammer. Auf der Tastatur ist das Strg+Q+K, siehe: "Tastaturbelegung" / "Codetools-Befehle" / "Anderes Blockende suchen".

Erweitert

Für erweiterte Einstellungen sehen Sie bitte hier: Erweiterte Maus-Einstellungen

Wenn Sie in den erweiterten Einstellungen Änderungen vorgenommen haben, zeigt diese Seite einen Hinweis darauf.

In diesem Fall werden Ihre Änderungen nicht mehr sofort vorgenommen. Stattdessen wird ein Knopf angezeigt, der Sie zum Überschreiben der Einstellungen mit Ihren Änderungen auffordert. Falls Sie ungespeicherte Änderungen haben, wird ein Warnhinweis angezeigt.

Vervollständigung/Hinweise

  • Leere Methoden automatisch entfernen: Wenn eine Methode zwischen begin und end keinen weiteren Code enthält, dann wird sie beim nächsten Speichern entfernt.
  • Blöcke vervollständigen: Wenn Sie z.B. begin eingeben und die Enter Taste drücken, dann fügt die IDE ein end; hinzu. Dieses Feature gibt es seit Version 0.9.27.
  • Deklarations-Hinweise anzeigen:
  • Werte-Hinweise während des Debuggens anzeigen:
  • Verzögerung für Hinweise und Vervollständigung:
  • Verzögerung für lange Zeilenhinweise:
  • Lange Zeilenhinweise anzeigen:

Codefaltung

Codefaltung: (De)Aktiviert die Codefaltung

Umgekehrte Faltungsreihenfolge im Popup:

Unter Sprache läßt sich auswählen, für welche Dokumente in der unterhalb folgenden Liste die Einstellung der Codefaltung vorgenommen werden kann. Zu Auswahl stehen:

  • ObjectPascal Dateien
  • HTML Dokumente
  • XML Dokumente
  • Lazarus Formulardateien
  • Diff-Dateien

Trennlinien

In diesem Bereich läßt sich festlegen, ob im Quelltexteditor horizontale Trennlinien gezeichnet werden. Mit diesen Linien lassen sich z.B. zusammengehörige Bereiche im Quelltext besser hervorheben. Früher gebräuchliche Konstruktionen (z.B. ganze Kommentarzeilen mit ********) sind somit nicht mehr notwendig.

Unter Sprache kann einstellt werden, für welche Art von Dateien die Festlegung der Trennlinien erfolgen soll. Derzeit steht nur ObjectPascal zur Verfügung. In der darunter folgenden Liste können die Bereiche ausgewählt werden, um die eine Trennlinie gezeichnet werden soll. Man sollte sich aber im Klaren darüber sein, dass zuviele Trennlinien zu Lasten der Lesbarkeit gehen. Bei Bedarf können den Trennlinien auch abweichende Farben zugewiesen werden.

Seiten und Fenster

Notebook-Reiter:

  • Schließen-Schaltfläche im Notebook anzeigen: Zeigt einen Schließen-Button auf jeder Seite im Quelltexteditor. Nicht alle Widgetsets unterstützen dies (im Moment nur die Gtk, Gtk2 und Qt Schnittstelle).
  • Reiter bei einseitigen Fenstern ausblenden: Ist im Quelltexteditor nur eine Seite geöffnet, dann wird der Reiter ausgeblendet (die meisten Befehle im Zusammenhang mit dem Reiter lassen sich nur sinnvoll nutzen, wenn mindestens zwei Seiten geöffnet sind).
  • Strg-Mittelklick auf Tab schließt alle anderen: Ein Klick der mittleren Maustaste zusammen mit gedrückter Strg-Taste schließt alle Editorfenster mit Ausnahme desjenigen, auf das geklickt wurde.
  • Reiternummern im Notebook anzeigen:
  • Tabs laut Historie schließen:
  • Mehrzeilige Tabs:

Reiterpositionen des Quell-Notebooks:

Editorauswahl für Sprungziele:

  • Zuletzt fokussierter Editor für die Datei:
  • Editor der zuletzt den Fokus hatte:
  • Kriterien, nach denen ein Editor ausgewählt wird: