Talk:Introduction to platform-sensitive development

From Free Pascal wiki

Lazarus already has a ssModifier which is ssMeta on Darwin/MacOs/iPhoneIsm and ssCtrl on all other platforms.

Thanks for providing this hint. I didn't know of the even existence of ssModifier. I will give it a try. Which LCL version introduced it?--Jwdietrich 16:55, 9 March 2014 (CET)
Revision 35131 (in controls.pp) --Bart 19:25, March 9th 2014 (CET)
Thanks. Which LCL version does this revision correspond to? I write FLOSS applications, and therefore I would like to provide code that reads the LCL version and uses ssModifier if the LCL version is new enough (some platforms like Raspberry Pi support quite old Lazarus versions only). Is there a wiki page or website with a detailled version history (including revision numbers)? Thanks again.--Jwdietrich 20:16, 9 March 2014 (CET)
I don't think that'll work. LCLVersion is a constant not a define. So something like "if LCLVersion >= 1.1 then" will not compile on an LCL version that does not have the ssModifier constant. But AFAICS it was in 0.9.31.
Thanks. Where can I find a reference that maps builds or revision numbers to Lazarus versions?--Jwdietrich 21:42, 9 March 2014 (CET)
The release notes, e.g. Lazarus_1.2.0_release_notes?!?!--BigChimp 11:08, 10 March 2014 (CET)
Thank you. This is interesting, but I can't find out, which LCL version the build 35131 corresponds to. It must be somewhere around Lazarus 1.0, but in the article Lazarus 1.0 release notes this information is missing.--Jwdietrich 21:50, 10 March 2014 (CET)
I looked at lclversion.pas. Revision 28811 was 0.9.31, Revision 36507 was 1.1. The latter one being after 35131, so that particular revision must have been in 0.9.31.
I adjusted the example code accordingly (Bart 28 march 2014).