Main menu/es

From Lazarus wiki
Jump to navigationJump to search

Deutsch (de) English (en) español (es) suomi (fi) français (fr) magyar (hu) italiano (it) 日本語 (ja) македонски (mk) Nederlands (nl) português (pt) русский (ru) slovenčina (sk) shqip (sq) 中文(中国大陆)‎ (zh_CN) 中文(台灣)‎ (zh_TW)

   La línea del menú principal contiene las siguientes entradas: Archivo Editar Buscar Ver Proyecto Ejecutar Componentes (Paquete en la versión 0.9.26.2) Herramientas Entorno Ventanas Ayuda

   Como de costumbre, las opciones se pueden seleccionar colocando el cursor del ratón sobre la opción del menú y pulsando con el botón izquierdo, o pulsando Alt+F en el teclado (suponiendo que la ventana del Menú Principal tenga el foco: si no lo tiene, pulse Tab varias veces para completar un ciclo del foco a través de varias ventanas hasta que la ventana deseada tenga su barra de título resaltada).

El submenú Archivo

Lazarus Menu Achivo.png
  • Nueva Unidad: Crea un nuevo archivo Unidad (en código fuente Pascal).
  • Nuevo Formulario: Crea un nuevo Formulario: tanto la ventana visual en pantalla como el archivo asociado en código fuente Pascal.
  • Nuevo ...: Muestra ventana emergente con un menú (captura de pantalla) con los distintos tipos de proyectos y archivos nuevos que se pueden crear.
  • Abrir: Muestra un cuadro de diálogo emergente para permitirle recorrer el sistema de archivos y elegir un archivo existente para abrirlo..
  • Deshacer: Anula los cambios de edición y devuelve el archivo a su estado original.
  • Guardar: Guarda el archivo actual, usando su nombre original. Si no tiene nombre, el sistema se lo pregunta (igual que Guardar como)
  • Guardar como: Le permite escoger una carpeta y un nombre para guardar el archivo actual.
  • Cerrar: Cierra el archivo actual, preguntando si quiere guardar todos los cambios del editor.
  • Cerrar todos los archivos del editor: Cierra todos los archivos abiertos actualmente en el editor. Pregunta si se guardan los cambios.
  • Limpiar directorio: Muestra un diálogo con varios filtros editables para borrar archivos del directorio actual. Útil para borrar archivos .bak y restos de antiguos proyectos en Delphi.
  • Salir: Sale de Lazarus, después de preguntar si se guardan los archivos editados.

El submenú Editar

Lazarus Menu Editar.png
  • Deshacer: Deshace el último cambio, dejando el Editor como estaba antes de la última acción.
  • Rehacer: Rehace la última acción que fue anulada por Deshacer.
  • Cortar: Borra el texto u otros objetos seleccionados y los coloca en el portapapeles.
  • Copiar: Hace una copia del texto seleccionado, dejando el original en su sitio y colocando una copia en el portapapeles.
  • Pegar: Sitúa el contenido del portapapeles en la posición del cursor. Si el texto ha sido seleccionado en la posición del cursor, el contenido del portapapeles sustituirá al texto seleccionado.
  • Sangrar selección: Mueve el texto seleccionado hacia la derecha según lo indicado en Entorno -> Opciones del Editor -> General -> Sangrar bloque. Esta característica es útil para formatear su código fuente Pascal para mostrar la estructura del bloque subyacente.
  • Desangrar selección: Elimina un nivel de sangrado, moviendo el texto hacia la izquierda según lo indicado en Sangrar bloque.
  • Encerrar selección: Muestra un menú emergente con varias opciones para, lógicamente, encerrar el texto seleccionado (begin ... end; try ... except; try ... finally; repeat ... until; { ... }; etc).
  • Selección en mayúsculas: Convierte el texto seleccionado en mayúsculas.
  • Selección en minúsculas: Convierte el texto seleccionado en minúsculas.
  • Tabulaciones a espacios en selección: Convierta cualquier tabulación en el texto seleccionado según el número de espacios especificado en Entorno -> Opciones del Editor -> General -> Anchura de tabulación. No se fija el número de espacios cuantitativamente, sino el número que se necesita para rellenar el ancho restante de tabulación.
  • Romper líneas seleccionadas: Si algunas líneas en el texto seleccionado o el número especificado en Entorno -> Opciones del Editor -> Pantalla -> Margen derecho, tienen más de 80 caracteres, la línea se rompe en una palabra límite y continúa en la línea siguiente.
  • Comentar selección: Convierte el texto seleccionado en comentarios, insertando // en cada línea.
  • Descomentar selección: Borra las marcas de comentario.
  • Ordenar selección: Ordena líneas (o palabras o párrafos) alphabeticamente; en orden ascendente o descendente, puede ser sensible o insensible a mayúsculas/minusculas. En mitad del código fuente del programa, claro, se convierte en insensible, pero si tiene una lista que necesita ordenar lo puede hacer con esto.
  • Seleccionar: Permite seleccionar bloques de texto. Las opciones son Seleccionar todo, Seleccionar tira, seleccionar párrafo o línea, etc.
  • Insertar desde mapa de caracteres: Permite insertar símbolos que no están en el teclado tales como caracteres acentuados, seleccionándolos desde un mapa de caracteres emergente.
  • Insertar texto: Muestra un menú emergente que permite insertar texto normal, tal como palabras clave de CVS (Author, Date, Header, etc) o avisos de GPL, usuario o fecha y hora actual.
  • Completar código: Completa el código donde está el cursor. Es sensible al contexto y le ahorra mucho tiempo. Por ejemplo: completa clases, añadiendo variables privadas, las propiedades Get y Set acceden a métodos y añaden partes principales de métodos. Asignando variables (por ejemplo i:=3;) añade las declaraciones de las variables. En los procedimientos definidos en adelante añade las partes principales de los métodos. Al asignar eventos (OnClick:=) añade la definición del método y su parte principal. Véase Herramientas del IDE de Lazarus.
  • Extraer procedimiento: Usa el texto seleccionado (una declaración o varias) para construir un nuevo procedimiento.

El submenú Buscar

Lazarus Menu Buscar.png
  • Buscar: Parecido a lo que existe en casi todos los editores de texto: aparece un cuadro de diálogo emergente que permite introducir una cadena de texto a buscar, con opciones como sensible a mayúsculas/minúsculas, palabras completas, origen, alcance y dirección de búsqueda.
  • Buscar Siguiente, Buscar Anterior: Busca otra vez según la entrada de texto previa, en la dirección especificada.
  • Buscar en archivos: Busca el texto en archivos: cuadro de diálogo emergente con las opciones todos los archivos abiertos, todos los archivos en el proyecto, o todos los directorios; se pueden utilizar caracteres comodín para seleccionar archivos de un tipo determinado.
  • Reemplazar: Parecido a Buscar; muestra un cuadro de diálogo emergente con espacio para escribir una cadena de texto y sustituir texto y opciones de sensibilidad a mayúsculas/minúsculas, dirección, etc.
  • Búsqueda incremental: Busca la cadena de texto mientras estamos introduciendo la cadena a buscar. Por ejemplo: después de elegir "Búsqueda incremental" si teclea "l" la primera "l" se resaltará. Si después presiona "a", el editor buscará la siguiente "la" y así sucesivamente.
  • Ir a línea: Mueve el cursor de edición a la línea especificada de un archivo.
  • Saltar atrás: Regresa en el archivo a el anterior marcador (es necesario haber utilizado Añadir punto de salto al historial. Se moverá a marcadores en otros archivos abiertos en el Editor.
  • Saltar adelante: Se mueve hacia delante al próximo marcador.
  • Añadir punto de salto al historial: Añade marcadores o puntos de salto al archivo.
  • Ver historial de salto: Muestra la lista de marcadores del archivo: Todavia no llevado a cabo.
  • Buscar otro final del bloque de código: Situados en un begin, busca el correspondiente end o viceversa.
  • Buscar comienzo del bloque de código: Se mueve al begin de un procedimiento o función en la que está situado el cursor.
  • Buscar declaración desde el cursor: Buscar el lugar en el que se ha declarado el identificador seleccionado. Esto puede ser en el mismo archivo u otro ya abierto en el Editor; si el archivo no está abierto, se abrirá (cuando se declara un procedimiento o una función, por ejemplo, en classesh.inc , se abrirá en el Editor).
  • Abrir nombre de archivo a cursor: Abre el archivo cuyo nombre se ha seleccionado con el cursor. Es útil para examinar archivos Include o archivos que contienen otras Unidades usadas en el proyecto.
  • Ir a directiva de inclusión: Si el cursor está situado en un archivo que está Incluido en otro archivo, va al lugar en el otro archivo que llamó el archivo Include.

El submenú Ver

Lazarus Menu Ver.png

   Controla la visualización de varias ventanas y paneles en la pantalla.

  • Inspector de Objectos: La ventana que normalmente ocupa el lado izquierdo del escritorio y muestra las propiedades del formulario que aparece en él. Si hace clic con el ratón en cualquier componente de un formulario se mostrarán los detalles de ese componente en el Inspector de Objetos. En la parte superior hay un panel que muestra la estructura en árbol del proyecto actual y en el que se pueden seleccionar los componentes del formulario: esto también hará que se muestren en el Inspector de Objetos los correspondientes detalles. El panel principal inferior tiene dos pestañas que permiten seleccionar Propiedades o Eventos. Si se selecciona Propiedades se muestran características como nombre, color, etiqueta, tipo de letra, tamaño, etc.: hay dos columnas, la izquierda muestra la propiedad y la derecha el valor asociado a esa propiedad. Si se selecciona Eventos muestra dos columnas: la izquierda lista los posibles eventos tales como MouseClick o KeyDown asociados con ese componente, y la izquierda la acción que resulta de ese evento. Si ho hay una acción definida, haciendo clic en la casilla apropiada o en el botón lazarus.IDE.Boton.Eventos.png hace que aparezca el Editor de Código, con el cursor ya colocado en una plantilla de declaración de procedimiento, esperando que tecleemos el código que defina el evento.
  • Editor del código fuente: La ventana principal donde se edita el código fuente. Su funcionamiento es muy parecido a la mayoría de los editores de texto gráficos, así que el ratón puede mover el cursor sobre el texto mostrado, y al hacer clic con el botón izquierdo mientras arrastramos se seleccionará y sombreará texto. Al pulsar con el botón derecho se muestra un menú emergente, pero si está familiarizado con Windows, o editores de Gnome o KDE, encontrará que el menú emergente NO tiene las funciones habituales de edición: Cortar, Copiar y Pegar, sino que incluye opciones como Buscar Declaración o Abrir archivo en cursor. La parte superior del Editor del código fuente tiene varias pestañas, que corresponden a los archivos que están abiertos para el proyecto actual; pulsando sobre cualquiera se verá el archivo, y podrá moverse fácilmente de un archivo a otro, copiando y pegando entre archivos y realizando la mayoría de las funciones normales de edición. El Editor del código fuente resalta texto en color, con colores diferentes para signos de puntuación, comentarios, constantes, etc. También mantiene el nivel de sangrado de línea en línea, mientras no lo cambie. La funcionalidad y apariencia del Editor del código fuente son muy configurables desde el Menú Principal seleccionando Entorno -> Opciones del editor y seleccionando después una de las pestañas del cuadro de diálogo emergente.
  • Explorador de código: Una ventana emergente. normalmente situada a la derecha del escritorio que muestra, en forma de árbol, la estructura del código en la unidad o programa actual. Habitualmente se abre con el nombre de unidad y ramas para las secciones Interface e Implementation, pero pulsando en el recuadro lazarus.IDE.Boton.desplegar.png situado a la izquierda de cualquier rama abrirá sus sub-ramas o ramitas, con más y más detalles hasta constantes individuales, se mostrarán tipos y variables, así como procedimientos y declaraciones de función. Si cambia el archivo mostrado en la ventana principal del Editor del código fuente, necesitará pulsar el botón Refrescar del Explorador de Código para mostrar la estructura del nuevo archivo.
  • Unidades...: Abre una ventana emergente de diálogo con una lista de los archivos de unidades en el proyecto actual. Haciendo clic con el ratón sobre un nombre de archivo se selecciona ese archivo; pulse en Abrir para mostrar ese archivo en el Editor del código fuente. Si marca el recuadro Multi podrá seleccionar varios archivos a la vez, y todos ellos se abrirán en el Editor del código fuente (pero sólo se mostrará uno cada vez). Este Menú Opción se parece bastante a Proyecto -> Opciones del Inspector del Proyecto, pero sólo muestra la lista de archivos unidades y permite que sean abiertos.
  • Formularios...: Abre una ventana de diálogo emergente con una lista de los formularios del proyecto actual, y permite seleccionar uno o más para que sean mostrados.
  • Ver dependencias de la unidad: Abre una ventana de diálogo emergente que muestra, como un árbol, la estructura de dependencias del archivo unidad actualmente abierto. La mayoría de los archivos listados como dependencias tendrán sus propios recuadros lazarus.IDE.Boton.desplegar.Dependencias.png, lo que permite que se exploren las dependencias de los archivos individuales, a menudo de una manera muy recursiva.
  • Commutar Ver formulario / unidad: Commuta entre el Editor del código y el formulario actual situado en la capa superior del escritorio, y le da el foco. Si el Editor del código tiene el foco, puede editar el código fuente; si se le da el foco al formulario podrá manipular los componentes en el escritorio y cambiar el aspecto del formulario. El modo más sencillo de alternar entre el Editor y el formulario es usar la tecla F12, pero se consigue el mismo resultado seleccionando esta opción en el Menú Principal.
  • Mensajes: Una ventana que muestra los mensajes del compilador, el avance de una compilación con éxito o lista los errores encontrados.
  • Buscar resultados: Una ventana que muestra los resultados de una búsqueda en archivos.
  • Ventanas de depuración: Abre un menú emergente con varias opciones para operar y configurar el depurador. Más abajo se describe el Depurador

El submenú Proyecto

Lazarus Menu Proyecto.png
  • Nuevo proyecto: Crea un nuevo proyecto. Aparece una ventana de diálogo emergente que ofrece la posibilidad de elegir entre varios tipos de proyectos.
  • Nuevo proyecto desde archivo: Aparece una ventana de diálogo de navegación, que permite seleccionar un archivo desde el cual crear un nuevo proyecto.
  • Abrir proyecto Abre un proyecto que ya había sido creado y guardado. Aparece un diálogo de navegación con una lista de archivos con Información del Proyecto Lazarus (Lazarus Project Information (.lpi)) desde el que se puede elegir un proyecto.
  • Abrir proyecto reciente: Muestra una lista emergente de los proyectos recientes en los que ha estado trabajando y permite seleccionar uno de ellos.
  • Guardar proyecto: Parecido a Archivo -> Guardar: se guardan todos los archivos del proyecto actual; si no fueron previamente guardados, se nos pregunta el nombre- como en Guardar Proyecto como...
  • Guardar proyecto como...: Pide un nombre para guardar el proyecto. Se ofrece por defecto el nombre Project1.lpi, pero debería elegir su propio nombre. Lazarus no permitirá usar el mismo nombre para el archivo proyecto y el archivo unidad (véase más abajo).
  • Publicar proyecto: Crea una copia de todo el proyecto. Si desea mandárselo a alguien sólo la configuración de las fuentes y el compilador de su código, esta función es su amiga. Una carpeta normal de proyecto contiene mucha información. La mayoria no es necesario hacerla pública: el archivo .lpi contiene información de la sesión (como posición de inserción de texto y marcadores de unidades cercanas) y la carpeta del proyecto contiene muchos archivos .ppu, .o y el ejecutable. Para crear un archivo lpi solamente con la información base y sólo las fuentes, en todas las subcarpetas use "Publicar proyecto". En el diálogo puede establecer los filtros excluir e incluir y con la orden después puede condensar la salida a un único archivo. Véase Herramientas del IDE de Lazarus
  • Inspector del proyecto: Abre un diálogo con aspecto de árbol que muestra los archivos del proyecto actual. Permite añadir, borrar y abrir los archivos que se seleccionen, o cambiar las opciones del proyecto.
  • Opciones del proyecto...: Abre una ventana de diálogo con varias pestañas para establecer opciones para Aplicación (título, archivo de salida), Formularios (que permite seleccionar, de entre los formularios disponibles, los que se crearan automáticamente al arrancar la aplicación) y Miscelánea (especifica si la información del editor debería guardarse para archivos cerrados, o sólo para archivos del proyecto). NO ESTOY REALMENTE SEGURO DE LO QUE SIGNIFICA ESTO: ¡¡AYUDA!! --> en la versión 0.9.24 estas casillas figuran en la pestaña Sesión y lo que viene a decir es si se salvan cambios realizados en archivos abiertos en el editor, pero que no pertenecen al proyecto, normalmente unidades que figuran en la cláusula uses y otros que nosotros hayamos abierto, pero no añadido al proyecto. Lo de los archivos cerrados si que es un misterio.
  • Opciones del compilador...: (Se trasladó a aquí recientemente desde el Menú Ejecutar). Abre una ventana multipagina con pestañas para configurar el compilador. Las pestañas son Rutas para definir trayectorias de búsqueda para unidades, archivos include, librerías, etc., también permite elegir un tipo de interfaz para los formularios (gtk, gnome, win32); Procesando para elegir las reglas para procesar programas fuente, Código para hacer que los programas sean mas rápidos y pequeños, elegir procesador objetivo, tipos de comprobaciones, tamaño de la pila, etc; Enlazando permite elegir como usar la depuración, librerías estáticas o dinámicas, y si se pasarán las opciones a través del enlazador; Mensajes definir que tipo de mensajes se generarán si hay errores; Otro para decidir si usar el archivo de configuración por defecto (fpc.cfg) o algún otro archivo; Heredado muestra un diagrama con estructura de árbol para indicar cómo han sido heredadas las opciones desde unidades ya incorporadas; Compilación permite definir comandos que se ejecutarán antes o después de lanzar el compilador y puede permitir usar archivos Make.
  • Añadir archivo de editor al proyecto: Añade al proyecto el archivo que se está editando en este momento.
  • Eliminar del proyecto: Aparece un menú emergente con los archivos que se pueden quitar del proyecto.
  • Ver fuente: Independientemente del archivo que está editando, lo lleva de regreso al archivo del programa principal (.lpr), o al archivo principal .pas si no hay .lpr.
  • Ver lista Para-Hacer: Abre un cuadro de diálogo con una lista de tareas pendientes asociadas a este proyecto. Listará cualquier comentario de tareas pendientes de su proyecto (líneas que comienzan por //TODO), y cualesquiera otras en las unidades Lazarus que utilizó. Necesita Refrescar las tareas pendientes en el diálogo (usando el botón con el símbolo de una flecha en la barra de herramientas) para que aparezcan las nuevas tareas pendientes. La primera columna de la lista de tareas pendientes contiene números que ha destinado a sus comentarios ToDo; un simple //TODO hará que aparezca un cero, pero un comentario //TODO999 (por ejemplo) pondrá el número 999 en la primera columna. Recuerde que no puede haber espacios antes de //TODO y que los comentarios ToDo añadidos después de la última vez que guardó ¡no se mostrarán!

El submenú Ejecutar

Lazarus Menu Ejecutar.png
  • Construir: hace que Lazarus construya (es decir compile) los archivos del proyecto que han sufrido cambios desde la última construcción.
  • Construir todo: Construye todos los archivos del proyecto, hayan sufrido cambios o no.
  • Abortar construcción: Para el proceso de construcción una vez iniciado - si ha recordado que hizo algo mal y quiere parar la construcción , o el proceso parece que se alarga mucho y evidentemente, hay algún error.
  • Ejecutar: Este es el modo normal para lanzar el compilador y, si la compilación tiene éxito, empezar la ejecución de la aplicación. Lo que relamente ocurre es que Lazarus guarda una copia de sus archivos, después inicia el compilador y el enlazador, luego comienza la ejecución del programa binario enlazado final.
  • Pausar: Suspende la ejecución del programa. Esto le puede permitir inspeccionar cualquier salida que haya sido generada; la ejecución se puede continuar seleccionando Ejecutar otra vez.
  • Paso a paso por instrucciones: Utilizado junto con el depurador, produce la ejecución del programa paso a paso hasta un punto señalado del código fuente.
  • Paso a paso por funciones: Produce la ejecución paso a paso hasta la declaración señalada, después salta la declaración y continúa la ejecución a velocidad normal. Útil para intentar aislar una declaración que provoca un error lógico.
  • Ejecutar hasta cursor: Provoca la ejecución a velocidad normal (es decir, NO una declaración cada vez) hasta la declaración donde está el cursor; después se para. Continúe la ejecución a velocidad normal seleccionando Ejecutar
  • Detener: Para la ejecución del programa. No se puede continuar seleccionando Ejecutar; esto hará que comience el programa otra vez desde el principio (recompilando si es necesario).
  • Parámetros de ejecución: Abre una ventana emergente multipágina que permite opciones de consola y parámetros que se le pasarán al programa para que sean ejecutados; permite la selección de monitor para ejecutar el programa (por ejemplo, en Linux se puede utilizar un terminal X remoto); algunas variables de entorno pueden ser invalidadas.
Una aplicación muy importante de este submenú es activar una ventana de terminal en la que se muestra una consola Pascal de entrada/salida. Si está desarrollando un programa Pascal en modo consola (por ejemplo, que no use el interfaz gráfico de usuario (GUI) con sus formularios, botones y recuadros) debería marcar la casilla "Usar lanzando aplicación". La primera vez que haga esto e intente Compilar/Ejecutar, probablemente obtendrá un desagradable mensaje que diga:
"xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied".  
Si ocurre esto, necesita cambiar los permisos del archivo apropiado (por ejemplo usando chmod +x archivo, o usando la utilidad de Windows para cambiar permisos); puede que tenga que hacer esto como administrador. Después, cada vez que ejecute el programa, aparecerá una ventana de terminal con todo su texto de entrada/salida (readln, writeln, etc).
Después de terminar la ejecución de su programa, aparecerá un mensaje "Presione intro" en la pantalla. Así, cualquier salida que produzca su programa permanecerá en la pantalla hasta que haya podido leerla; después de que presione 'intro' se cerrará la ventana de consola.
Véase este tutorial sobre programación Pascal en modo consola.
  • Reiniciar depurador: Devuelve el depurador a su estado original, con lo que se borran los puntos de interrupción y los valores de las variables.
  • Construir archivo: Compila (construye) sólo el archivo que está abierto en este momento en el editor.
  • Ejecutar archivo: Compila, enlaza y ejecuta sólo el archivo abierto en este momento.
  • Configurar Construir+Ejecutar archivo: Abre una ventana multipágina con opciones que permiten construir únicamente este archivo cuando se selecciona Construir proyecto, permite seleccionar la carpeta de trabajo, el uso de varias macros, etc. Después construye y ejecuta el archivo.
Estas tres últimas opciones le permiten abrir (y mantener) un proyecto de prueba. Use Archivo -> Abrir, para abrir un archivo .lpr, presione cancelar en el diálogo siguiente para abrir este archivo como un archivo "fuente normal".

El submenú Componentes (Paquete en la v0.9.26.2)

Lazarus Menu Componentes.png
  • Abrir paquete cargado...: Muestra una Lista de los paquetes instalados, dándonos la posibilidad de abrir uno de ellos , y en la ventana que sale configurarlo, compilarlo o editarlo.
  • Abrir archivo de paquete (lpk)...: Abre el paquete seleccionado y en la ventana que sale configurarlo, compilarlo o editarlo.
  • Abrir paquete de unidad actual: Abre la ventana de configuración del paquete al que pertenece la unidad activa en el editor de código.
  • Abrir paquete reciente...: Abre un paquete que fue abierto recientemente.
  • Añadir unidad activa al paquete: Sitúa el archivo unidad (que se encuentra seleccionado en este momento en el editor) dentro de un paquete.
  • Gráfico de paquete...: Muestra un gráfico con las relaciones entre los paquetes que se están usando (si no estás usando ningún otro paquete, se mostrarán el paquete Lazarus y el FCL y el LCL).
  • Configurar paquetes instalados...: Muestra los paquetes disponibles y los instalados. Permite añadir y suprimir paquetes.

El submenu Herramientas

Lazarus Menu Herramientas.png
  • Configurar herramientas personalizadas: Permite al usuario añadir varias herramientas externas (generalmente macros) al juego de herramientas.
  • Comprobación rápida de la sintaxis: Realiza una comprobación rápida de la sintaxis en su archivo fuente sin compilar nada realmente. El paso esencial en el desarrollo de programas largos y complicados, cuando no quiere perder tiempo compilando si el código está equivocado.
  • Adivinar bloque sin cerrar: Útil si tiene una estructura de bloques anidados y ha dejado un 'end' en algún lugar.
  • Adivinar IFDEF/ENDIF perdido: De utilidad si hay una estructura de macro anidada o compleja y cree que ha dejado una directiva ENDIF.
  • Hacer ResourceString: Convierte la cadena seleccionada en un ResourceString situándola en una sección resourcestrings, que debe existir en alguna unidad del proyecto. Una ventaja de ResourceStrings es que pueden ser modificadas ¡sin necesidad de compilar el proyecto de nuevo! con las herramientas adecuadas.
  • Diff: Permite comparar dos archivos (generalmente dos versiones del mismo archivo) para encontrar diferencias. Opciones para ignorar espacios en blanco al principio o al final de las líneas o variaciones del terminador delínea: CR+LF frente a LF. Útil para comprobar si ha habido cambios desde la última actualización de CVS, etc.
  • Opciones de las plantillas del proyecto: Este elemento es añadido por el paquete Project Templates.
  • Verificar archivo LFM en editor: Permite inspeccionar el archivo LFM que contiene las especificaciones que describen el formulario actual.
  • Convertir unidad de Delphi a unidad de Lazarus: Ayuda a convertir aplicaciones Delphi en Lazarus; realiza los cambios necesarios en el archivo fuente. Ver Lazarus para usuarios de Delphi y Guía de conversión de código.
  • Convertir proyecto de Delphi a proyecto de Lazarus: Ayuda a convertir proyectos Delphi en proyectos Lazarus; realiza los cambios necesarios en los archivos que componen el proyecto. Ver Lazarus para usuarios de Delphi y Guía de conversión de código.
  • Convertir paquete de Delphi a paquete de Lazarus: Ayuda a convertir paquetes Delphi en paquetes Lazarus; realiza los cambios necesarios en los archivos que componen el paquete. Ver Lazarus para usuarios de Delphi y Guía de conversión de código.
  • Convertir archivo DFM a LFM: Para llevar de Delphi a Lazarus: convierte los archivos de descripción del formulario de Delphi a Lazarus. Véase Lazarus para usuarios de Delphi y Guía de conversión de código.
  • Construir Lazarus: Ejecuta una reconstrucción de Lazarus desde los archivos más recientemente descargados o actualizados vía CVS. Añadirá o eliminará los paquetes sgún hallamos indicado en la ventana configurar paquetes instalados. Pulse el botón y ¡siéntese a mirar lo que ocurre! (siga el proceso en la ventana Mensajes).
  • Configurar "Construir Lazarus": Permite al usuario determinar qué partes de Lazarus serán reconstruidas, y cómo. Por ejemplo, puede seleccionar que sólo se reconstruya la LCL, o todo excepto los ejemplos; puede seleccionar qué interfaz de LCL usar (por ejemplo qué conjunto de interfaces) , y puede seleccionar el sistema operativo y especificar una carpeta diferente.

El submenú Entorno

Lazarus Menu Entorno.png
  • Opciones del Entorno: exhibe una ventana de páginas con múltiples pestañas para
    • Archivo - permite que el usuario especifique la ruta para la carpeta por defecto, el compilador, la carpeta de fuentes y la carpeta temporal para la compilación;
    • Escritorio - opciones para el idioma, guardar automáticamente, guardar propiedades del escritorio, sugerencias para paleta de componentes y botones rápidos;
    • Ventanas, permite la especificación del tamaño y del comportamiento de varias ventanas;
    • Editor de formulario - elegir los colores para editar formularios;
    • Inspector de objetos - elegir el color y la altura de elementos;
    • Copia de seguridad - especificar cómo hacer copias de seguridad de los archivos cuando editamos;
    • Nombrando - especificar qué extensión utilizar al nombrar archivos de PASCAL ('pp' o 'pas'), si se guardarán los archivos con nombres en minúsculas, si se borrarán o renombrarán automáticamente.
  • Opciones del Editor: ventana de páginas múltiples, con pestañas para
    • General - determina comportamientos como sangrado automático, resaltado de paréntesis, arrastrar y soltar, desplazamiento por el texto, resaltado de sintaxis, mostrar sugerencias, tamaño de sangrado de bloques y las pestañas, límite de deshacer;
    • Visualizar - opciones para mostrar números de línea, la presencia de canales, el tamaño y el tipo de fuente para el editor, y contiene un panel de vista previa que muestra los colores de varias características de la sintaxis tales como comentarios, carpetas, puntuación, errores y puntos de ruptura;
    • Accesos rápidos - para seleccionar entre el esquema de Lazarus o el de Turbo Pascal;
    • Color - permite elegir el esquema de color para las características del texto, para varios lenguajes tales como Objet PASCAL, C++, Perl, HTML, XML y scripts de shell. Muestra el panel de vista previa otra vez (para cualquier lenguaje seleccionado);
    • Herramientas de código - permite seleccionar características como la terminación del identificador, consejos, especificación del nombre del archivo plantilla, plantillas específicas para la terminación del código.
  • Opciones de depuración: ventana de páginas múltiples con pestañas para
    • General - eligir depurador: ninguno, depurador de GNU (gdb) o gdb a través de SSH, especificar las rutas de búsqueda para las depuraciones, y las opciones específicas para la depuración elegida;
    • Registro de eventos - especificar si borrar el registro y ejecutar, y qué mensajes exhibir;
    • Excepciones del lenguaje - seleccionar qué excepciones se pueden ignorar;
    • Excepciones del sitema operativo - permite que el usuario agregue ciertas señales que se apliquen al sistema operativo actual (no funciona todavía).
  • Opciones de CodeTools: ventana de páginas múltiples, pestañas para
    • General - permite la entrada de las rutas de búsqueda de código fuente adicionales, especificar método de salto;
    • Creación de código - se determina si el código creado está agregado antes o después de cierto punto;
    • Palabras - se determina si las palabras claves de Pascal se deben introducir en mayúsculas o minúsculas, o como palabras todas en mayúsculas;
    • Separación de línea - establece las reglas sobre dónde se permite partir las líneas (antes o después de la puntuación, después de las palabras claves, etc);
    • Espacio - decidir si un espacio debe ser agregado automáticamente antes o después de ciertos rasgos sintácticos tales como palabras claves o signos de puntuación.
  • Definir editor de CodeTools: permite insertar plantillas de Free Pascal, Lazarus, Delphi o Kylix.
  • Escanear de nuevo el directorio de fuentes de FPC: busca por la carpeta otra vez. Lazarus utiliza las fuentes del FPC para generar eventos correctos y cuando busca declaraciones. Si cambia la carpeta en las opciones del entorno, esa carpeta se vuelve a explorar, para cerciorarse de que Lazarus utiliza la versión que se almacenó en esa localización. Pero si esa carpeta ha cambiado sin que Lazarus lo advierta, entonces puede obtener algunos errores al diseñar formularios o hacer "Encontrar declaración". Si obtiene tal error, puede hacer dos cosas:
    1. Comprobar la carpeta de fuentes del FPC configurada en la opción Entorno.
    2. Volver a explorar la carpeta de fuentes del FPC.

El submenú Ventanas

Lazarus Menu Ventanas.png

   Contiene una lista de las ventanas abiertas y por tanto disponibles, como Editor de código fuente, Inspector de Objetos ,Inspector del proyecto, Mensajes y las de los formularios. Seleccionando el nombre de una de las ventanas la pondrá en primer plano y le dará el foco.

El submenú Ayuda

Lazarus Menu Ayuda.png

   Tiene tres opciones:

  • Ayuda en línea abre una ventana del navegador que contiene una imagen de un guepardo corriendo y varios enlaces a Lazarus, FreePascal y el sitio web del WiKi.
  • Configurar Ayuda abre un menú emergente con opciones para seleccionar visores y bases de datos para leer información de ayuda. Esta opción permite especificar cualquiera de los documentos en línea del sitio web de Lazarus-CCR, algunos otros sitios que contienen documentos, o un almacenamiento local para la documentación (esta será la opción por defecto, cuando esté terminado completamente el sistema de ayuda).

   En la actualidad, al situar el cursor en la ventana del Editor sobre cualquier palabra clave de la Librería de Componentes de FreePascal (FCL) o la Librería de tiempo de ejecución (RTL) (pero no la Librería de Componentes de Lazarus, LCL) y presionar F1 se abrirá a la definición apropiada en el sitio web.

Hay otras opciones de ayuda para el usuario final fuera de línea. Por ejemplo, si tienes una copia de Kylix, puede reutilizar los archivos de ayuda que vienen con él, dentro del IDE de Lazarus. Ver la página Installing Help in the IDE para más detalles.

  • Acerca de Lazarus muestra un recuadro emergente con información sobre Lazarus, cómo la versión, los integrantes del equipo de desarrollo y agradecimientos varios.

   Cuándo esté finalizado, será un completo servicio de ayuda en línea, con información sobre sintaxis de Pascal, el uso del IDE, cómo usar, modificar o crear componentes, y sugerencias sobre cómo realizar ciertas tareas. Esta parte de la sección de Documentación (lo que está leyendo ahora mismo) representa el comienzo del proceso. Necesitamos contribuciones de cualquiera que se sienta capacitado: es muy fácil editar el Wiki.