Main menu/de

From Lazarus wiki
Jump to navigationJump to search

Deutsch (de) English (en) español (es) suomi (fi) français (fr) magyar (hu) italiano (it) 日本語 (ja) македонски (mk) Nederlands (nl) português (pt) русский (ru) slovenčina (sk) shqip (sq) 中文(中国大陆)‎ (zh_CN) 中文(台灣)‎ (zh_TW)

Die Hauptmenü Linie enthält die folgenden Einträge: Datei Bearbeiten Suche Ansicht Projekt Start Komponenten Werkzeuge Einstellungen Fenster Hilfe

Wie gewöhnlich, können die Optionen gewählt werden entweder durch Platzieren des Mauscursors über der Menü Option und klicken der linken Maustaste, oder durch Eingeben von Alt-F auf der Tastatur (sofern das Hauptmenü den Fokus hat: wenn nicht, dann drücken Sie TAB mehrmals um den Fokus durch die verschiedenen Fenster zu bewegen, bis das gewünschte Fenster mit seiner Titelleiste farbig hervorgehoben ist).

Die Online-Hilfe zu einzelnen Menüpunkten finden Sie hier.

Das Untermenü Datei

Laz de menu datei.jpg
  • Neue Unit: Erzeugt eine neue Unit-Datei (Pascal Quelle).
  • Neues Formular: Erzeugt ein neues Formular: sowohl das visuelle Bildschirmfenster als auch die verbundene Pascal-Quelltext-Datei.
  • Neu ...: Bietet ein Dialogfenster (Screenshot) mit einer Auswahl von neuen Dokumenttypen zum Erzeugen.
  • Öffnen ...: Bietet ein Dialogfenster, welches die Navigation durch das Dateisystem ermöglicht, um eine existierende Datei zu öffnen.
  • Wiederherstellen: Abbrechen der Editieränderungen und Wiederherstellen der Datei zu ihrem anfänglichen Status.
  • Wieder öffnen ...: Zuletzt geöffnete Dateien wieder öffnen.
  • Speichern: Speichert die aktuelle Datei unter Verwendung des originalen Dateinamens. Wenn es noch keinen Namen gibt, wird das System danach fragen (wie bei Speichern unter).
  • Speichern unter ...: Erlaubt Ihnen, ein Verzeichnis und den Dateinamen zu wählen, um die aktuelle Datei zu speichern.
  • Alles speichern: Speichert alle geöffneten Dateien.
  • Schließen: Schließt die aktuelle Datei, fragt, ob alle Änderungen gespeichert werden sollen.
  • Alle Editorfenster schließen: Schließt alle im Editor geöffneten Dateien. Fragt, ob Änderungen gespeichert werden sollen.
  • Verzeichnis säubern ...: Bietet einen Dialog mit einer Reihe von editierbaren Filtern, um Dateien aus dem gegenwärtigen Verzeichnis zu entfernen. Nützlich zum Entfernen von .bak Dateien und Überresten von früheren Delphi-Projekten.
  • Drucken ...: Druckt den Quelltext der aktiven Unit aus.
  • Neustart: Startet Lazarus neu.
  • Beenden: Beendet Lazarus, nachdem gefragt wurde, ob die bearbeiteten Dateien gespeichert werden sollen.

Das Untermenü Bearbeiten

Hinweis: Bei den neueren Lazarus-Versionen sind gewisse Menüpunkte von Bearbeiten nach Quelltext verschoben worden, auch sind neue Optionen dazu gekommen.

Laz de menu bearb.jpg
  • Rückgängig: Widerruft die letzte Editieraktion, versetzt den Editor in den Status vor der letzten Aktion zurück.
  • Wiederholen: Setzt die letzte Aktion, die mit Rückgängig aufgehoben wurde, wieder ein.
  • Ausschneiden: Entfernt den markierten Text oder andere Objekte und fügt sie in die Zwischenablage ein.
  • Kopieren: Erstellt eine Kopie des markierten Texts, hinterlässt das Original an seinem Platz, und fügt die Kopie in die Zwischenablage ein.
  • Einfügen: Plaziert den Inhalt der Zwischenablage an der Cursorposition. Wenn Text an der Cursorposition markiert war, dann wird der Inhalt der Zwischenablage den Text überschreiben.
  • Block einrücken: Bewegt den markierten Text nach rechts um den Betrag, der in Einstellungen -> Editoreinstellungen -> Allgemein -> Blockeinzug spezifiziert ist. Dieses Feature ist nützlich zur Formatierung Ihres Pascal Quelltextes, um die grundlegende Blockstruktur zu zeigen.
  • Auswahl ausrücken: Entfernt eine Ebene der Einrückung, bewegt den Text nach links um den Betrag, der in Blockeinzug spezifiziert ist.
  • Auswahl einschließen ...: Bietet ein Dialogfenster mit einer Anzahl von Optionen für folgerichtiges Einschließen des markierten Textes (begin ... end; try ... except; try ... finally; repeat ... until; { ... } etc).
  • Auswahl kommentieren: Wandelt den markierten Text in einen Kommentar um durch Einfügen von // auf jeder Zeile.
  • Auswahl entkommentieren: Entfernt die Kommentarmarkierungen.
  • $IFDEF einfügen: Fügt eine $IFDEF Deklaration an der Cursorposition ein.
  • Auswahl sortieren ...: Sortiert die Zeilen (oder Wörter oder Paragraphen) alphabetisch; Optionen für aufsteigende oder absteigende Anordnung, mit oder ohne Beachtung der Groß- und Kleinschreibung. In der Mitte des Progamm-Quelltexts, macht es natürlich keinen Sinn, aber wenn Sie eine Liste haben, die Sie sortieren müssen, wird dieser Kniff es tun.
  • Auswahl großschreiben: Wandelt den markierten Text in Großbuchstaben um.
  • Auswahl kleinschreiben: Wandelt den markierten Text in Kleinbuchstaben um.
  • Tabulatoren in Auswahl in Leerzeichen umwandeln: Wandelt jeden Tabulator im markierten Text in die Anzahl Leerzeichen um, die spezifiziert sind durch Einstellungen -> Editoreinstellungen -> Allgemein -> Tabulatorsprung. Die Anzahl von Leerzeichen ist keine feste Anzahl, aber die Anzahl wird benötigt, um die verbleibende Breite des Tabulators zu füllen.
  • Zeilen in der Auswahl trennen: Wenn irgendeine Zeile im markierten Text länger als 80 Zeichen ist oder die Anzahl spezifiziert in Einstellungen -> Editoreinstellungen -> Anzeige -> Rechter Rand, dann wird die Zeile an einem Wortende umgebrochen und in der nächsten Zeile fortgesetzt.
  • Auswählen: Erlaubt die Auswahl von Textblöcken. Optionen enthalten Alles auswählen, Bis zu einer Klammer, Zeile auswählen etc.
  • Aus der Zeichentabelle einfügen: Erlaubt das Einfügen von Symbolen, die nicht auf der Tastatur sind, wie akzentuierte Zeichen, aufgelesen von einer pop-up Zeichentabelle.
  • Text einfügen: Zeigt ein pop-up Menü, welches das Einfügen von Standardtext erlaubt wie z.B. CVS Stichwörter (Autor, Datum, Kopf etc.) oder GPL Hinweise, Benutzername oder aktuelles Datum und Zeit.
  • Quelltext vervollständigen: Komplettiert den Code an der Cursorposition. Es ist kontextsensitiv und erspart Ihnen eine Menge Zeit. Zum Beispiel: Es komplettiert Klassen, durch Hinzufügen von privaten Variablen, Get und Set Eigenschaftszugriff Methoden und Hinzufügen von Methodenrümpfen. Bei Variablenzuweisungen (z.B. i:=3;) fügt es die Variablendeklaration hinzu. Bei forward defined Prozeduren fügt es die Prozedurrümpfe hinzu. bei Ereigniszuweisungen (OnClick:=) fügt es die Methodendefinitionen und den Methodenrumpf hinzu. Siehe Lazarus IDE Tools.
  • Prozedur extrahieren ...: Nutzt den markierten Text (eine Anweisung oder Serien von Anweisungen), um eine neue Prozedur zu erstellen.

Das Untermenü Suche

Laz de menu suche.jpg
  • Suchen ...: Ähnlich wie die Möglichkeit in beinahe allen graphischen Texteditoren: ein Dialogfenster erscheint, welches die Eingabe einer zu suchenden Zeichenkette erlaubt, mit Optionen wie Schreibweise beachten, nur ganze Worte, reguläre Ausdrücke und die Richtung der Suche.
  • Nächstes suchen, Vorheriges suchen: Erneute Suche nach der zuvor eingegebenen Zeichenkette, in der spezifizierten Richtung.
  • In Dateien suchen ...: Sucht nach Zeichenketten in Dateien: ein Dialogfenster mit Optionen: alle offenen Dateien, alle Dateien im Projekt, oder alle Verzeichnisse; Masken sind verfügbar für die Auswahl der Dateitypen.
  • Ersetzen ...: Ähnlich wie Suchen ...; zeigt ein Dialogfenster mit Platz, um die zu suchende Zeichenkette und den ersetzenden Text einzugeben, und Optionen für Schreibweise beachten, Richtung etc.
  • Inkrementielle Suche: Suche nach der Zeichenkette während Sie die zu suchende Zeichenkette eingeben. Beispiel: Nachdem Sie "Inkrementielle Suche" gewählt haben und zuerst "l" drücken, dann wird "l" hervorgehoben. Wenn Sie dann "a" drücken, wird der Editor das nächste "la" finden und so weiter.
  • Zu Zeile springen ...: Bewegt den Cursor zur spezifizierten Zeile in der Datei.
  • Zurückspringen: Schritt zurück in der Datei zum nächsten Lesezeichen (zuvor muss Add jump point to history verwendet worden sein). Springt auch zu Lesezeichen in anderen geöffneten Dateien.
  • Vorwärtsspringen: Schritt vorwärts zum nächsten Lesezeichen.
  • Sprungmarke speichern: Fügt Lesezeichen (Bookmark) oder Sprungpunkt zur Datei hinzu.
  • Sprungliste anzeigen ...: Anschauen der Liste der Lesezeichen in der Datei: Noch nicht implementiert.
  • Zum nächsten Fehler springen:
  • Zum vorherigen Fehler springen:
  • Freies Lesezeichen setzen:
  • Springe zum nächsten Lesezeichen:
  • Springe zum vorherigen Lesezeichen:
  • Anderes Ende des Quelltextblocks suchen: Wenn auf einem begin positioniert, findet es das zugehörige end und umgekehrt.
  • Zu Quelltextblockanfang gehen: Geht zum begin der Prozedur oder Funktion, in welcher der Cursor platziert ist.
  • Deklaration unter Cursor suchen: Findet den Ort, an dem der markierte Bezeichner deklariert ist. Dies kann in der selben Datei sein oder in einer anderen Datei, die bereits im Editor geöffnet ist. Wenn die Datei nicht geöffnet ist, wird sie geöffnet (wenn eine Prozedur oder Funktion deklariert ist, zum Beispiel in classesh.inc , wird diese im Editor geöffnet).
  • Datei unter Cursor öffnen: Öffnet die Datei, deren Name unter dem Cursor ausgewählt ist. Hilfreich zum Schauen in Include Dateien oder andere Dateien, die die im Projekt verwendeten Units enthalten.
  • Zu Include Direktive springen: Wenn der Cursor in einer Datei positioniert ist, die eingebunden ist in einer anderen Datei, geht es zu dem Ort in der anderen Datei, wo die Include Datei aufgerufen wird.
  • Bezeichnerreferenzen suchen ...:
  • Bezeichner umbenennen:
  • Prozedur-Liste ...:

Das Untermenü Ansicht

Laz de menu ansic.jpg

Steuert die Anzeige der verschiedenen Fenster und Panels auf dem Bildschirm.

  • Objektinspektor: Das Fenster, das üblicherweise die linke Seite des Desktops in Anspruch nimmt und die Features des Formulars anzeigt, welches auf dem Desktop ist. Klicken mit der Maus auf jede Komponente des Formulars bewirkt die Anzeige von Details dieser Komponente im Objektinspektor. Es gibt oben ein Panel, welches die Baum-Struktur des aktuellen Projekts zeigt, und die Komponenten des Formulars können in diesem Panel optional ausgewählt werden. Dies wird auch zur Anzeige der korrespondierenden Details im Objektinspektor führen. Das untere Hauptpanel hat zwei Tabs, welche die Auswahl erlauben, entweder die Eigenschaften oder Ereignisse anzuzeigen. Die Auswahl von Eigenschaften führt zur Anzeige von Eigenschaften wie Name, Farbe, Überschrift, Font, Größe usw. Es gibt zwei Spalten, die linke zeigt die Eigenschaft, und die rechte zeigt den Wert, der mit dieser Eigenschaft verbunden ist. Die Auswahl von Ereignisse zeigt zwei Spalten: die linke listet die möglichen Ereignisse wie MouseClick oder KeyDown auf, die mit dieser Komponente assoziiert sind, und die rechte zeigt the Aktion, die aus diesem Ereignis resultiert. Wenn keine Aktion definiert ist, dann klicken Sie in das entsprechende Feld or on the
    ...
    button causes the Source Editor to be displayed, with the cursor already positioned in a dummy Procedure declaration, waiting for event-defining code to be typed in. Siehe auch IDE Window: Object Inspector/de.
  • Quelltexteditor: Das Hauptfenster, in welchem der Quellcode bearbeitet wird. Sein Verhalten ist sehr ähnlich wie das der meisten anderen graphischen Texteditoren, so dass die Maus den Cursor über den angezeigten Text bewegen kann, und Klicken mit der linken Maustaste während die Maus gezogen wird, selektiert den Text und hebt ihn hervor. Rechtsklicken mit der Maus zeigt ein Pop-up-Menü, aber wenn Sie vertraut sind mit Windows, Gnome oder KDE Editoren, werden Sie feststellen, dass das Pop-up-Menü NICHT die üblichen Bearbeiten, Ausschneiden, Kopieren oder Einfügen Funktionen enthält, aber Optionen wie Find Declaration oder Open File at Cursor. The top of the Source Editor window has a number of tabs, corresponding to the files that are open for the current project; das Klicken auf einen Tab macht die Datei sichtbar, and you can move easily from file to file, Kopieren und Einfügen between files and performing most of the normal editing functions. The Source Editor performs colour syntax highlighting on the code, with different colours for punctuation marks, comments, string constants etc. It will also maintain the level of indentation from line to line as you type in code, until you change the indentation. The function and appearance of the Source Editor are very configurable from the Main Menu by selecting Tools -> Options -> Editor and then selecting one of several tabs in the pop-up dialog box.
  • Code Explorer ...: A window usually placed on the right of the Desktop which displays, in tree form, the structure of the code in the current unit or program. It usually opens with just the Unit name and branches for Interface and Implementation sections, but clicking on the
    +
    box to the left of any branch will open up its sub-branches or twigs, in more and more detail until individual constants, types and variables are displayed as well as procedure and function declarations. If you change the file displayed in the main Source Editor window, you need to click on the Refresh button of the Code Explorer to display the structure of the new file.
  • LazDoc Editor: Öffnet den LazDoc-Editor
  • Units ...: Öffnet ein Dialogfenster mit einer Liste der Unit-Dateien im aktuellen Projekt. Ein Mausklick auf den Dateinamen wählt diese Datei aus; klicken Sie auf Öffnen um diese Datei im Editor anzuzeigen. Checking the Multi box allows several files to be selected simultaneously, and they will all be opened in the Source Editor (but only one at a time will be displayed). This Menu Option is rather like the Project -> Project Inspector option, zeigt aber nur die Liste der Unitdateien und erlaubt diese zu öffnen.
  • Formulare ...: Öffnet ein Dialogfenster mit einer Liste der Formulare im aktuellen Projekt, und erlaubt die Auswahl von einem oder mehreren von ihnen anzuzeigen.
  • Unitabhängigkeiten anzeigen: Öffnet ein Dialogfenster das zeigt, in a tree-like manner, die Struktur der Abhängigkeiten der aktuell geöffneten Unit Datei. Die meisten der aufgelisteten Dateien haben ihre eigenen
    +
    Felder, which allow the dependencies of the individual files to be explored, often in a highly recursive manner.
  • Unitinformationen anzeigen: Zeigt allgemeine und Pfad-Informationen zur aktuellen Unit an.
  • Formular/Unitansicht umschalten: Schaltet zwischen der Anzeige des Quelltexteditors und dem zugeordneten Formular um und macht das Fenster aktiv. Wenn der Quelltexteditor aktiv ist, kann der Quelltext editiert werden; wenn das Formular aktiv ist, so kann dieses manipuliert und die darauf befindlichen Komponenten editiert werden. Der leichteste Weg, um zwischen der Anzeige von Editor und Form zu wechseln, geht durch Drücken der Taste F12, der gleiche Effekt wird durch Auswahl dieser Option im Haupt-Menü bewirkt.
  • Nachrichten ...: Ein Fenster, das Compiler-Meldungen anzeigt, den Fortschritt einer erfolgreichen Kompilierung oder eine Liste der gefundenen Fehler.
  • Suchergebnisse: Ein Fenster, das die Ergebnisse einer Suchanfrage (z.B. In Dateien suchen ...) anzeigt.
  • Ankereditor anzeigen:
  • Komponentenpalette anzeigen: ermöglicht das Anzeigen/Verbergen der Komponentenpalette
  • Speedbuttons der IDE anzeigen: ermöglicht das Anzeigen/Verbergen der Speedbuttons (links von der Komponentenpalette)
  • Debuggerfenster: Öffnet ein Pop-Up-Menü mit verschiedenen Optionen für den Betrieb und die Konfiguration des Debuggers. Siehe unten, wo der Debugger beschrieben ist.

Das Untermenü Projekt

Laz de menu proje.jpg
  • Neues Projekt ...: Erzeugt ein neues Projekt. Ein Dialogfenster erscheint mit einer Auswahl von Projekttypen zum Anlegen.
  • Neues Projekt aus Datei ...: Ein Navigationsdialogfenster erscheint, welches die Auswahl einer Datei erlaubt, von der das neue Projekt erstellt wird.
  • Projekt öffnen ... Öffnet ein Projekt, welches bereits erzeugt und gespeichert wurde. Ein Navigationsdialog erscheint mit einer Liste von Lazarus Projekt Information (.lpi) Dateien, aus der ein Projekt ausgewählt werden kann.
  • Letzte Projekte ...: Zeigt eine Pop-up-Liste von Projekten an, an denen Sie kürzlich gearbeitet haben, und erlaubt die Auswahl eines der Projekte.
  • Projekt schließen:
  • Projekt speichern: Ähnlich wie Datei -> Speichern: alle Dateien des gegenwärtigen Projekts werden gespeichert. Wenn diese zuvor noch nicht gespeichert wurden, erscheint eine Eingabeaufforderung für die Dateinamen ähnlich wie Projekt speichern unter...
  • Projekt speichern unter ...: Fragt den Dateinamen ab, um das Projekt zu speichern. Ein Vorgabe Dateiname für Project1.lpi wird angeboten, aber Sie sollten Ihren eigenen Dateinamen wählen. Lazarus wird Ihnen nicht erlauben, den selben Namen für die Projektdatei und die Unitdatei zu benutzen (siehe unten).
  • Projekt veröffentlichen ...: Erzeugt eine Kopie des gesamten Projekts. Wenn Sie jemandem einfach die Quellen und Compilereinstellungen Ihres Codes senden wollen, dann sind Sie bei dieser Funktion richtig. Ein normales Projektverzeichnis enthält eine Menge von Informationen. Das meiste davon muss nicht veröffentlicht werden: die .lpi Datei enthält Sessionsinformationen (wie die Caret Position und Lesezeichen geschlossener Units) und das Projektverzeichnis enthält eine Menge von .ppu, .o Dateien und die .exe Datei. Um eine lpi Datei zu erstellen - nur mit den Basisinformationen und nur den Quellen zusammen mit allen Unterverzeichnissen - verwenden Sie "Projekt veröffentlichen". In dem Dialog können Sie die exclude und include Filter einrichten, und mit the command after you can compress the output into one archive. Siehe Lazarus IDE Tools
  • Projektinspektor ...: Öffnet ein Dialogfenster mit einer tree-like Anzeige der Dateien im aktuellen Projekt. Erlaubt Ihnen die ausgewählten Dateien hinzuzufügen, zu verschieben oder zu öffnen oder die Projektoptionen zu ändern.
  • Projekteinstellungen ...: Öffnet ein Dialogfenster mit Tabs zum Einstellen von Anwendung (Titel, Ausgabeeigenschaften), Formulare, Diverses, LazDoc, Sitzung, Versionsinformationen und .po Dateien.
  • Compilereinstellungen ...: Öffnet ein multi-page tabbed Fenster, welches die Konfiguration des Compilers erlaubt. Zu den Tabs im Detail: Im Reiter Pfade lassen sich Suchpfade für Units, Include-Dateien und Bibliotheken festlegen. Die Einstellung "LCL-Schnittstelle" legt fest, welche grafische Komponentenbibliothek für das zu erstellende Programm verwendet wird (gtk, gnome, win32, qt). Im Reiter Parse lassen sich Regeln festlegen, nach denen der Programmquelltext vom Parser interpretiert wird. Der Reiter Quelltext ermöglicht die Optimierung des vom Compiler erstellten Codes hinsichtlich der Codegröße und der Ausführungsgeschwindigkeit. Auch lässt sich der Code an eine bestimmte Zielarchitektur anpassen, die Heap-Größe und die Überprüfung von Überläufen, Stack-Fehlern, etc. lässt sich hier einschalten. Nicht zuletzt kann hier Smartlinking aktiviert werden. Im Reiter Linken lassen sich Debugger-Einstellungen vornehmen. Durch Deaktivierung von "Zeilennummern in Laufzeit-Backtraces anzeigen" und Aktivierung von "Debuggersymbole aus der ausführbaren Datei entfernen" lässt sich die Binärdateigröße erheblich reduzieren (aber Achtung: durch die Entfernung von Debuggersymbolen lässt sich der Debugger nicht mehr benutzen). Ist Smart-Linking erwünscht, muss unter "Linker-Stil" die entsprechende Einstellung gemacht werden. Ist die Option "Win32 gui application" deaktiviert, wird das erstellte Programm automatisch in der Windows-Konsole geöffnet (unter Windows). Unter Nachrichten ... lässt sich einstellen, welche Art von Nachrichten im Fenster "Ansicht-->Nachrichten ..." angezeigt werden sollen. Der Reiter Andere erlaubt die Benutzung einer zu fpc.cfg alternativen Konfigurationsdatei. Im Reiter Übernehmen wird in Form einer Baumstruktur festgehalten, how options have been inherited from units already incorporated; Im Reiter Kompilierung kann festgelegt werden, welche Befehle vor oder nach des Kompilierprozesses ausgeführt werden sollen und ermöglicht die Erstellung von Make-Files.
  • ToDo-Liste ...: Öffnet ein Dialogfeld mit einer Liste von ToDo Elementen, die mit diesem Projekt assoziert sind. Dies wird jeden ToDo-Kommentar in Ihrem Projekt anzeigen (Zeilen die mit //TODO beginnen), und jeden anderen in den Lazarus Units, die sie verwendet haben. You need to Refresh the ToDo items in the dialog (using arrow symbol button of toolbar) before new 'ToDos' appear. Die erste Spalte der ToDo Liste enthält die Zahlen, die Sie Ihren Kommentaren zugewiesen haben. Ein einfacher //TODO Kommentar wird als null erscheinen. Aber ein Kommentar //TODO999 (als Beispiel) wird die Zahl 999 in der ersten Spalte erscheinen lassen. Beachten Sie, dass in der Zeile vor //TODO keine Leerzeichen sein sollten und dass die nach dem letzten Speichern hinzugefügten Kommentare nicht angezeigt werden!
  • Datei im Editor ins Projekt aufnehmen: Fügt die Datei, die gerade bearbeitet wird, zum Projekt hinzu.
  • Aus Projekt entfernen ...: Bietet ein Pop-Up-Menü der zum Löschen vom Projekt verfügbaren Dateien.
  • Quelltext anzeigen: Egal, welche Datei Sie gerade bearbeiten, es bringt Sie zurück zur Hauptprogramm-Datei (.lpr) oder der Haupt-.pas Datei, wenn kein .lpr existiert.

Das Untermenü Start

Laz de menu start.jpg
  • Erstellen: Veranlasst Lazarus, jede Datei im Projekt, die seit der letzten Erstellung geändert wurde, zu erstellen (d.h. kompilieren).
  • Alles neu erstellen: Erstellt alle Dateien im Projekt, ob sie geändert wurden oder nicht.
  • Schnelles Kompilieren:
  • Erstellen abbrechen: Stoppt den Erstellungsprozess, sobald er läuft - entweder haben Sie sich erinnert, dass Sie etwas Unkluges getan haben und die Erstellung stoppen wollen, oder das System scheint sich allzu lange Zeit zu nehmen und etwas ist offensichtlich falsch.
  • Start: Dies ist der übliche Weg, den Compiler zu starten und, wenn die Kompilierung erfolgreich ist, die Ausführung der Anwendung zu starten. Was aktuell passiert ist, dass Lazarus eine Kopie Ihrer Dateien speichert, dann den Compiler und Linker startet, dann mit der Ausführung des endgültig verbundenen Binärprogramms beginnt.
  • Pause: Unterbricht die Ausführung des aktuell laufenden Programms. Dies kann Ihnen erlauben, jede Ausgabe die erzeugt wurde zu kontrollieren; die Ausführung kann fortgesetzt werden durch nochmalige Wahl von Start.
  • Einen Schritt hinein: Wird in Verbindung mit dem Debugger genutzt, löst die Ausführung des Programms einen Schritt jeweils bis zu einem bookmarked point im Quelltext aus.
  • Einen Schritt weiter: Löst die schrittweise Ausführung bis zur markierten Anweisung aus, überspringt dann die markierte Anweisung, und setzt die Ausführung mit normaler Geschwindigkeit fort. Hilfreich beim Versuch, eine Anweisung zu isolieren, die einen logischen Fehler einschleppt.
  • Start bis Cursor: Startet die Ausführung mit normaler Geschwindigkeit (ie NOT one statement at a time), bis die Anweisung erreicht wird, wo sich der Cursor befindet; dann stoppt sie. Fortsetzung der Ausführung mit normaler Geschwindigkeit durch Auswahl von Start.
  • Halt: Beendet die Ausführung des laufenden Programms. Kann nicht fortgesetzt werden durch die Wahl von Start; dies wird das Programm erneut vom Anfang starten (Rekompilierung, falls erforderlich).
  • Startparameter ...: Öffnet ein multi-page Pop-up-Fenster welches erlaubt, Kommandozeilenparameter und -optionen an das auszuführende Programm weiterzugeben; ermöglicht die Auswahl der Anzeige für ein Programm(Beispielsweise könnte ein remote X terminal in Linux genutzt werden); Systemumgebungsvariablen können übergangen werden.
Eine sehr wichtige Anwendung dieses Untermenüs ist die Aktivierung eines Terminal-Fensters in welchem herkömmliche (Pascal-)ein- und ausgaben angezeigt werden.

Bei der Entwicklung von Pascal-Konsolenprogrammen sollte "Startprogramm verwenden" aktiviert werden. Falls beim ersten Lauf eine unsanfte Fehlermeldung wie

 "xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied"

erscheint, müssen die Rechte für die entsprechende Datei angepasst werden. Danach sollte sich bei jedem Programmaufruf ein Konsolenfenster öffnen, in dem alle Textein- und -ausgaben erscheinen.

Nachdem das Programm beendet wurde erscheint im Konsolenfenster die Meldung "Press enter". Dadurch verbleibt die vom Programm generierte Ausgabe auf dem Bildschirm und man hat die Möglichkeit diese Ausgabe zu lesen. Nachdem man Enter drückt schliesst sich das Konsolenfenster.
Siehe das gesonderte Tutorial auf Console Mode Pascal programming.
  • Debugger zurücksetzen: Restores the debugger to its original state, so that breakpoints and values of variables etc are forgotten.
  • Datei erstellen: Kompiliert einfach die Datei, die gerade im Editor geöffnet ist.
  • Datei ausführen: Kompiliert, linkt und führt nur die aktuell geöffnete Datei aus.
  • Konfiguriere Erzeuge+Starte Datei ...: Opens a multi-page tabbed window with options to allow for build of just this file when Build Project is selected, allows selection of the working directory, the use of various Macros, etc. Then Builds and Runs the file.
These last three options enable you to open (and maintain) a test project. Use File -> Open to open an .lpr file, pressing cancel on the next dialog to open this file as "normal source" file.
  • Inspizieren ...:
  • Prüfen/Ändern:
  • Überwachung hinzufügen...:
  • Neuer Haltepunkt: Fügt einen neuen Haltepunkt hinzu.

Das Untermenü Package

Laz de menu kompo.jpg
  • Packagedatei (.lpk) öffnen ...: Öffnet eine der Dateien im gewählten Package.
  • Package der aktuellen Unit öffnen: ?
  • Letztes Package wieder öffnen ...: Öffnet ein vor kurzem geöffnetes Package.
  • Aktuelle Unit zu einem Package hinzufügen: Plaziert die Unit-Datei (zur Zeit im Editor) in ein Package.
  • Package-Graph ...: Zeigt ein Schaubild , welches die Beziehungen der Packages, die gegenwärtig in Gebrauch sind, (Wenn Sie kein anderes Package benutzen, werden das Lazarus Package und die FCL und LCL angezeigt.) zeigt.
  • Installierte Packages einrichten ...: Wenn Sie einige Komponenten erzeugt haben, erlaubt es Ihnen sie zu konfigurieren.

Das Untermenü Werkzeuge

Laz de menu werkz.jpg
  • Externe Werkzeuge einrichten ...: Erlaubt dem Benutzer, verschiedene externe Werkzeuge (üblicherweise Makros) zum Toolkit hinzuzufügen.
  • Optionen für Projektschablonen:
  • Schnelle Syntaxprüfung: Führt eine schnelle Überprüfung der Syntax in Ihrer Quelldatei durch, ohne irgendetwas zu kompilieren. Essential step in developing long or complicated programs, where you don't want to waste time compiling if the code is wrong.
  • Offene Quelltextblöcke erraten: hilfreiches Werkzeug, wenn Sie eine komplexe verschachtelte Blockstruktur haben und sie irgendwo ein 'end' ausgelassen haben
  • Offene IFDEF/ENDIF erraten: useful if there is a complex or nested macro structure and you think you have left out an ENDIF directive
  • Ressourcenstring erzeugen ...: Macht die ausgewählte Zeichenkette zu einem resource string durch Platzierung im resourcestrings Abschnitt. Ein Vorteil von resource strings ist, dass Sie sie ändern können, ohne Ihr Projekt neu kompilieren zu müssen!
  • Diff: Erlaubt den Vergleich zwischen zwei Dateien (oder, üblicherweise, zwei Versionen von der selben Datei), um Unterschiede zu finden. Options to ignore white space at beginning or end of lines or differences in line termination: CR+LF versus LF). Hilfreich für die Prüfung, ob es Änderungen seit dem letzten SVN Update gegeben hat usw.
  • LFM-Datei im Editor überprüfen: Erlaubt die Prüfung der LFM Datei, welche die Einstellungen enthält, die das aktuelle Formular beschreiben.
  • Delphi- in Lazarus-Projekt konvertieren:
  • Delphi- in Lazarus-Package konvertieren:
  • Lazarus erstellen: Rekompiliert Lazarus und fügt der Komponentenpalette jedes entsprechend markierte Paket hinzu.
  • "Lazarus Erstellen" einrichten: Erlaubt es dem Benutzer zu spezifizieren, was geschehen soll, wenn Lazarus erstellen aufgerufen wird. In diesem Dialog muss die Option 'Mit Paketen eingestellt' werden, wenn Packages mit Komponenten eingeschlossen werden sollen.

Das Untermenü Einstellungen

Laz de menu einst.jpg
  • FPC-Quelltextverzeichnis neu einlesen Looks through the directory again. Lazarus uses the fpc sources to generate correct event handlers and while looking for declarations. If somebody changes the directory in the environment options, then this directory is rescanned, to make sure lazarus uses the version stored in that location. But if this directory has changed without lazarus noticing, then you may get some errors when designing forms or doing "Find declaration". If you get such an error, you can do two things:
    1. Check the fpc source directory setting in the environment option.
    2. Re-scan FPC source directory.

Das Untermenü Fenster

Laz de menu fenst.jpg

Enthält eine Liste der aktuell geöffneten Dateien und die verfügbaren Fenster wie Lazarus-Quelltexteditor und Objektinspektor. Das Klicken auf den Namen eines der Fenster bringt es in den Vordergrund und gibt ihm den Fokus.

Das Untermenü Hilfe

Laz de menu hilfe.jpg

Derzeit hat es drei Auswahlmöglichkeiten:

  • Onlinehilfe welches derzeit einen Browser öffnet, der ein Bild eines laufenden Geparden enthält und einige Links zu den Lazarus, FreePascal und Wiki Internetseiten.
  • Fehler melden ... öffnet die Wiki-Seite, welche beschreibt, wie man einen Bug meldet
  • Hilfe konfigurieren ... welches ein Pop-up-Menü öffnet mit Optionen, um Betrachter und Datenbanken auszuwählen, von denen die Hilfe gelesen werden kann. Diese Option erlaubt dem Benutzer, entweder den Online-Dokumente-Bereich der Lazarus-CCR Internetseite, einige andere Internetseiten, welche die Dokumente enthalten, oder einen lokalen Speicher für die Dokumentation (Dies wird eventuell die Voreinstellung werden, wenn das Hilfesystem völlig entwickelt ist.) zu spezifizieren. Derzeit ist die Voreinstellung, wenn Sie Ihren Editor Cursor platzieren über einem Schlüsselwort der FreePascal Components Library FCL oder der RunTime Library RTL (aber nicht der Lazarus Components Library LCL) und dann <<F1>> drücken, werden Sie zu der geeigneten Definition auf der Internetseite geleitet. DIESER BEREICH IST NOCH IN ARBEIT
  • Über Lazarus Zeigt eine Pop-up-Box mit einigen Informationen über Lazarus.

Eventuell wird es einen vollständigen Online-Hilfeservice geben, mit Informationen über die Pascal-Schreibweise, die Benutzung der IDE, wie man es gebraucht, Modifizierung oder Erstellung von Komponenten, und Hinweise darüber, wie man verschiedene Aufgaben erfüllt. Dieser Teil des Dokumentationsabschnitts (was Sie gerade lesen) repräsentiert den Anfang des Prozesses. Wir brauchen Beiträge von jedem, der sich in der Lage dazu fühlt, sie bereitzustellen: Das Wiki ist sehr einfach zu bearbeiten.