Main menu/pt

From Free Pascal wiki
Jump to navigationJump to search

Deutsch (de) English (en) español (es) suomi (fi) français (fr) magyar (hu) italiano (it) 日本語 (ja) македонски (mk) Nederlands (nl) português (pt) русский (ru) slovenčina (sk) shqip (sq) 中文(中国大陆)‎ (zh_CN) 中文(台灣)‎ (zh_TW)

O Menu Principal

O menu principal contem as seguintes entradas em inglês: File Edit Search View Project Run Components Tools Environment Windows Help

Como de costume, as opções podem ser selecionadas colocando o cursor do mouse(ponteiro) sobre a opção do menu e clicando(estalando) o botão esquerdo do mouse(ponteiro), ou digitando o Alt-F no teclado (fornecido a janela do menu principal tem foco: se não tiver, aperte Tab repetidamente para dar um ciclo no foco através das várias janelas até que a janela desejada tenha sua barra do título destacada na cor).

O sub-menu Arquivo(File)

  • Nova Unidade: Cria um arquivo para nova unidade (Pascal Source).
  • New Form: Cria um novo formulário: uma janela visual da tela e seu arquivo fonte Pascal associado.
  • Novo ...: Abre uma caixa (screenshot) com uma variedade de novos tipos de documentos para criar.
  • Abrir: Abre uma caixa de diálogo que habilita você a navegar pelos arquivos e escolher um existente arquivo para abrir.
  • Revert: Remove as mudanças durante a edição e restaura o arquivo para seu estado original.
  • Salvar: Salva o arquivo corrente(em uso), utilizando seu nome original do arquivo. Se este não tiver um nome, o sistema irá perguntar pelo nome que você deseja salvar(como no Save As).
  • Save As: Permite que você escolha um diretório e um nome de arquivo para salvar o arquivo atual.
  • Fechar: Fecha o arquivo atual, perguntando se salva todas as mudanças do editor..
  • Close all editor files: Fecha todos os arquivos abertos no editor. E oferece para salvar mudanças.
  • Clean directory: Disponibiliza um diálogo com uma série de filtros editáveis para remoção de arquivos do corrente diretório. Muito utilizado para remoção de arquivos .bak e restir que formavam os projetos Delphi.
  • Sair: Sai do ambiente Lazarus, depois de perguntar se salva todos os arquivos editados.

O sub-menu Editar(Edit)

  • Undo: Desfaz a última ação de edição.
  • Redo: Refaz a última ação de edição que foi revertida pelo Undo.
  • Cut: Remove o texto ou item selecionado e o coloca na área de transferência.
  • Copy: Faz uma cópia do texto selecionado, deixando o original no lugar, e coloca uma cópia na área de transferência.
  • Paste: Coloca o conteúdo da área de transferência na posição do cursor. Se texto tem sido selecionado na posição do cursor, o conteúdo da área de transferência irá substituir o texto selecionado.
  • Indent selection: indenta(adiciona um espaço especificado) antes do texto selecionado.
  • Unindent selection: desindenta(remove o espaço especificado) antes do texto selecionado.
  • Enclose selection: disponibiliza um menu flutuante com opções para incluir o texto selecionado dentro de uma das opções(begin ... end; try ... except; try ... finally; repeat ... until; { ... } etc).
  • Uppercase selection: passa todo o texto selecionado para caixa alta, letras maiúsculas.
  • Lowercase selection: passa todo o texto selecionado para caixa baixa, letras minúsculas.
  • Tabs to spaces in selection: Converte as tabulações(TAB) no texto selecionado em número de espaços especificados no Environment -> Editor options -> General -> Tab widths. O número de espaços não tem quantidade fixa, mas é o número necessário para preencher a largura restante da tabulação.
  • Break lines in selection: Se alguma linha no texto selecionado for maior que 80 caracteres ou que o número especificado em Environment -> Editor options -> Display -> Right Margin, então a linha é quebrada no limite de palavras e continua na próxima linha.
  • Comment selection: Torna o texto selecionado um comentário inserindo antes de cada linha os caracteres: // .
  • Uncomment selection: Remove as marcas de comentários.
  • Sort selection: Ordena linhas (ou palavras ou paragráfos) alfabeticamente; podendo ser : ascendente ou descendente; e sensitívo a caixa ou não. No meio do código fonte do programa, é claro, não faz sentido, mas se você tem uma lista em que você precisa ordená-la você utilizará esta ferramenta.
  • Select: Seleciona blocos do texto. As opções incluem selecionar tudo, para apoiar, um parágrafo ou uma linha, etc.
  • Insert from character map: Insere de símbolos não existentes no teclado como caracteres acentuados, obtém de janela com o mapa de caracteres.
  • Insert Text:abre um menu à parte para inserir textos padrões: palavras chaves do CVS (Author, Date, Header etc) ou notícia do GPL, nome do usuário ou data e hora atual.
  • Complete code: Muito utilizado pelo desenvolvedor permite completar o código de um método, procedimento ou função, declarado na interface. Ao chamar esta rotina ele é adicionado na implementação(implementation) com o cursor dentro deste para você programar este.
  • Extract procedure: Usa o texto selecionado(a statement or series of statements) para gerar um novo procedimento(procedure).

O sub-menu Localizar(Search)

  • Find: similar a facilidade encontrada na maioria dos editores de texto: uma caixa de diálogo aparece disponibilizando a entrada de um texto para procurar, com opções como: case sensitive(sensível a caixa: maiúscula <> minúscula), palavras inteiras, origem, escopo e direção da procura.
  • Find Next, Find previous: procurar novamente pelo anterior texto entrado, na especificada direção.
  • Find in files: procura pelo texto nos arquivos: diálogo com as opções: all open files(todos os arquivos abertos), all files in project (todos os arquivos no projeto) ou all directories(todos diretórios); mascara disponível para selecionar tipos de arquivo.
  • Replace: parecido com "Find", exibe um diálogo com lugares para entrar com o texto para procurar e substituir, e opções para sensível à caixa(case sensitivity), direção(direction) etc.
  • Incremental find: Procura pelo texto enquanto você está colocando os caracteres de procura. Exemplo: depois de você escolher "Incremental Find" se você pressionar "l" o primeiro "l" irá ser marcado. Se em seguida você apertar "a", o editor irá procurar o próximo "la" e marcá-lo. E assim por diante.
  • Goto line: Move o cursor de edição para uma linha específica no arquivo.
  • Jump back: Move de volta no arquivo para a próxima marcação(precisa ter usado Add jump point no histórico). Irá mover para marcações em outros arquivos no editor.
  • Jump forward: Move para próxima marcação.
  • Add jump point to history: Adiciona marcações ou pontos de pulo para o arquivo.
  • View Jump-History: Visualiza a lista de marcações no arquivo: Não implementada ainda.
  • Find other end of code block: Se posicionado em um início de bloco, encontra o correspondente fim e vice-versa.
  • Find code block start: Move para o início do procedimento ou função em que o cursor se encontra.
  • Find Declaration at cursor: Encontra o lugar em que o identificador selecionado é declarado. Pode ser o mesmo arquivo ou outro aberto no editor; se o arquivo não está aberto, ele será aberto (então se um procedimento ou função está declarado, por exemplo, no arquivo classesh.inc , este irá ser aberto no editor).
  • Open filename at cursor: Abre o arquivo cujo o nome é selecionado no cursor. Útil para olhar arquivos incluídos ou que contêm outras unidades usadas no projeto.Opens the file whose name is selected at the cursor.
  • Goto include directive: Se o cursor for posicionado em um arquivo que esteja incluído em um outro arquivo, vai ao lugar no outro arquivo que chamou o arquivo incluído.

O sub-menu Exibir (View)

Controla as várias janelas e painéis exibidas da ferramenta(Lazarus) na tela.

  • Object Inspector: Esta janela usualmente ocupa o lado esquerdo do ambiente, e exibe as características, os atributos publicados(que se encontram no "published" da classe) do formulário(Form), módulo ou componente selecionado em um dos containers anteriores que está no ambiente.
  • Source Editor: é a janela encarregada de editar o código fonte do programa, geralmente são arquivos de extensão: pas, pp e inc.
  • Code Explorer: abre uma janela com as divisões do código fonte para facilitar o desenvolvimento.
  • Units: abre uma janela que exibe todas as unidades(bibliotecas) utilizadas pelo projeto.
  • Forms: abre uma janela que lista todas as janelas criadas e utilizadas no projeto.
  • View Unit Dependencies: abre uma janela que exibe em árvore as unidades que o projeto depende.
  • Toogle form/unit view: alterna entre o formulário e a unidade(biblioteca) do formulário.
  • Messages: exibe a janela de mensagens de compilação, exibindo progresso da compilação ou listando os erros econtrados...
  • Search Results: Uma janela que exibe os resultado de procura nos arquivos.
  • Debug windows: Abre um menu com várias opções para operar e compilar o debugador.

O sub-menu Projeto(Project)

  • New Project: Cria um novo projeto. Uma janela de diálogo aparece oferecendo a escolha de tipos de projeto para criar.
  • New Project from file: Um diálogo de navegação aparece, aguardando a seleção de um arquivo para criar um novo projeto.
  • Open Project: Abre um projeto existente que já tenha sido criado e salvo. Um diálogo de navegação aparece com uma lista de arquivos de informações de projetos lazarus(.lpi) para escolher.
  • Open Recent Project: Exibe uma lista de projetos recentes que você tenha trabalhado recentemente para você selecionar.
  • Save Project: Salva o projeto.
  • Save Project As: Salva o projeto como, ou seja com um nome determinado por você.