Main menu/fi

From Free Pascal wiki

English (en) suomi (fi)

Päävalikko

Päävalikko sisältää seuraavat nimikkeet:

Tiedosto   Muokkaa   Etsi   Näytä   Lähdekoodi   Projekti   Suorita-valikko   Paketti   Työkalut   Ikkunat   Ohje

Kuten tavallista, vaihtoehdot voidaan valita joko asettamalla hiiren osoitin valikkokohdan ja klikkaamalla hiiren vasenta painiketta.


Tiedosto-valikko

FileMenu.jpg
  • Uusi käännösyksikkö: Luo uuden käännösyksikön (unit)tiedoston (Pascal koodi).
  • Uusi lomake: Luo uuden lomakkeen: siis molemmat visuaalinen lomakkeen ja siihen liittyvän käännösyksikön.
  • Uusi ...: Tarjoaa pop-up-valikon, jolla on mahdollista luoda erilaisia uusia dokumenttityyppejä.
  • Avaa: Tarjoaa pop-up-valintaikkunan, jolla voidaan navigoida tiedostojärjestelmässä ja valita olemassa tiedosto joka avataan.
  • Palauta: Hylkää muokatut muutokset ja palauttaa tiedoston sen alkuperäiseen tilaan.
  • Avaa esillä ollut: Tarjoaa luettelon äskettäin muokattuja tiedostoja ja niistä on mahdollisuus valita yksi.
  • Tallenna: Tallentaa nykyisen tiedoston käyttäen alkuperäistä tiedostonimeä. Jos sillä ei ole nimeä, järjestelmä kysyy nimeä (kuten Tallenna nimellä).
  • Tallenna nimellä: Voidaan valita kansio ja tiedostonimi kun tallentaa käytettävän tiedoston.
  • Tallenna kaikki: Tallentaa kaikki lähdekoodieditorin tiedostot, ei vain yhtä.
  • Vie HTML:nä: Vie nykyisen tiedoston sisällön uuteen tiedostoon HTML-muodossa.
  • Sulje välilehti: Sulkee nykyisen tiedoston, varmistaen että tallennetaako kaikki editorin muutokset.
  • Sulje kaikki: Sulkee kaikki editorin tiedostot. Kysyy tallennetaanko jos jossakin niistä on tallentamatta muutoksia.
  • Siivoa hakemisto: Tarjoaa dialogin jossa on joukko muokattavissa olevia suodattimia tiedostojen poistamiseksi hakemistossa. Hyödyllisiä *.bak tiedostojen poistoon ja entisten Delphi projektien jäänteiden poistoon.
  • Tulosta: Käyttää järjestelmän tulostinta tulostaessa valittua tiedostoa. Tämä valinta ei ehkä näy oletusarvoisesti, jos et käytä windowsia. Jos ei näy niin sitten täytyy asentaa $Lazdir/components/printers/design/printers4lazide.pas ja kääntää lazarus kehitysympäristö uudelleen.
  • Käynnistä Lazarus uudelleen: Käynnistää Lazaruksen - hyödyllinen jos tiedostot ovat menneet toivottoman sekaiseksi!
  • Lopeta: Lopettaa Lazaruksen käytön , varmistaen että kaikki muokatut tiedostot tallennetaan.

Muokkaa-valikko

EditMenu.jpg
  • Kumoa: Kumoa viimeisin muokkaus toiminto, jättäen editorin tilaan joka oli juuri ennen viimeistä toimintaa.
  • Tee uudelleen: Tekee uudelleen viimeisen toiminnon, joka purettiin kumoa valinnalla.
  • Leikkaa: Poistaa valitun tekstin tai muun kohteen ja asetaa sen leikepöydälle.
  • Kopioi: Tekee kopion valitusta tekstistä, jättää alkuperäisen paikalleen ja asettamalla kopion leikepöydälle.
  • Liitä: Asettaa sisällön leikepöydältä osoittimen kohdalle. Jos valittua tekstiä on osoittimen kohdalla, leikepöydän sisältö korvaa valitun tekstin.
  • Valitse: Mahdollistaa valita tekstilohkoja. Vaihtoehtoja ovat Valitse kaikki, Valitse sulkuun asti, Valitse koodilohko, Valitse sana, Valitse rivi tai Valitse kappale.
  • Sisennä valinta: Siirrä valittua tekstiä oikealle määrällä joka on määritelty Työkalut -> Asetukset... -> Editori -> Yleistä -> Tab ja sisennys. Tämä ominaisuus on hyödyllinen kun muotoillaan Pascal lähdekoodin lohkorakennetta.
  • Poista valinnan sisennys: Poistaa yksi tasoa sisennystä, siirtämällä tekstiä vasemmalle ennalta valitulla määrällä.
  • Valinta isoiksi kirjaimiksi: Muuntaa valitun tekstin isoiksi kirjaimiksi.
  • Valinta pieniksi kirjaimiksi: Muuntaa valitun tekstin pieniksi kirjaimiksi.
  • Käännä kirjainten koko valinnassa: Kääntää valitun tekstin pienet kirjaimet isoiksi ja isot pieniksi.
  • Järjestä valinta: Lajittelee rivit (tai sanoja tai kappaleista) aakkosjärjestykseen; vaihtoehtoja nouseva tai laskeva järjestys, kirjainkoko huomioiden tai jätetään huomioitta. Keskellä ohjelman lähdekoodia, ei tietenkään, ole järkevää, mutta jos on jokin luettelo joka täytyy olla järjestetty niin silloin.
  • Muuta tabit välilyönneiksi valinnassa: Korvaa valitun tekstin kaikki tabit tietyllä määrällä välilyöntejä joka on määritelty Työkalut -> Asetukset... -> Editori -> Yleistä -> Tab ja sisennys.
  • Rivitä valinta uudelleen: Jos valitun tekstin rivit ovat pidempiä kuin 80 merkkiä tai luvun joka määritetty kohdassa Työkalut -> Asetukset... -> Editori -> Yleistä -> Näkymä -> Marginaali ja reunapalkki olevan merkkimäärän niin loppurivi jatkuu seuraavalla rivillä .
  • Lisää merkkitaulukosta: Mahdollistaa näppäimistöltä löytymättömien , kuten aksenttimerkkien, merkkien lisäämisen. Merkki poimitaan "pop-up" ikkunan merkkikartalta.

Etsi-valikko

SearchMenu.jpg
  • Etsi: Samanlainen ominaisuus kuin lähes kaikissa graafisissa editoreissa: pop-up valintaikkuna mahdollistaa merkkijonon etsimisen erilaisilla vaihtoehdoilla, kuten sama kirjaisinkoko, merkkijonon pitää olla kokonainen sana, etsinnän lähtöpiste, etsinnän laajuus ja etsintäsuunta.
  • Etsi seuraava, Etsi edellinen: Etsii uudelleen aiemmin kirjoitetun merkkijonon, määrättyyn suuntaan.
  • Etsi tiedostoista: Etsii merkkijonon tiedostoista: pop-up dialogi tarjoaa vaihtoehtoja kaikki avoimet tiedostot, kaikki projektin tiedostot tai kaikki hakemistot; läpikäytävien tiedostotyyppien valitsemiseksi voidaan antaa maskeja.
  • Etsi ja korvaa: Samanlainen kuin Etsi; näyttää ponnahdusvalintaikkunan jossa on paikka etsittävälle merkkijonolle ja sen korvaavalle merkkijonolle. Etsintää voi rajata erilaisilla vaihtoehdoilla kuten sama kirjaisinkoko, merkkijonon pitää olla kokonainen sana, etsinnän lähtöpiste, etsinnän laajuus ja etsintäsuunta.
  • Etsi kirjain kerrallaan:Etsii merkkijonon, sitä mukaa kuin kirjoittaa hakusanan. Esimerkki: kun valitset "Etsi kirjain kerrallaan" jos painat "l" ensimmäinen "l" on korostettu. Jos sitten painat "a" niin löydetään seuraavaksi "la" ja niin edelleen.
  • Mene riville: Siirtää kohdistimen määritellylle tiedoston riville.
  • Hyppää takaisin: Siirtyy edelliseen paikkaan. Jokakerta kun hyppätään virheeseen tai etsitään määrittely niin kehitysympäristö tallentaa kyseisen paikan. Tämän toiminnon avulla voidaan palata takaisin siihen missä oltiin aikaisemmin.
  • Hyppää eteenpäin: Siirtyy seuraavaan paikkaan. Kumoaa hyppää takaisin toiminnan.
  • Lisää hyppypiste historiaan: Lisää tämän hetkisen paikan hyppyhistoriatietoihin.
  • Hyppää seuraavaan virheeseen, Hyppää edelliseen virheeseen: Hyppää lähdekooditiedoston seuraavaan tai edelliseen raportoituun virheeseen.
  • Aseta vapaa kirjanmerkki: Merkitse nykyinen rivi jossa kursori sijaitsee seuraavaksi saatavilla (vapaana) olevalla kirjanmerkillä ja lisää tämä kirjanmerkkiluetteloon. Huomaa, että ponnahdusvalikossa (saadaan klikkaamalla hiiren oikealla näppäimellä lähdekoodieditorissa) on mahdollisesti suurempi joukko kirjanmerkkivalintoja, jolloin kirjanmerkin numeroa on täsmennettävä, tai joiden avulla käyttäjä voi siirtyä numeroituun kirjanmerkkiin, ei vain seuraavan tai aiemmat.
  • Siirry seuraavaan kirjainmerkkiin, Siirry edelliseen kirjainmerkkiin: Siirtyy seuraavaan tai edelliseen kirjanmerkkiin numerojärjestyksessä.
  • Etsi koodilohkon toinen pää: Jos sijaitaan varatun sanan begin kohdalla etsitään sitä vastaavaa end:iä tai päinvastoin.
  • Etsi koodilohkon alku: Siirtyy kyseisen aliohjelman tai funktion varattuun sanaan begin missä kursori sijaitsee.
  • Etsi määrittely: Etsii paikkaa, jossa valittu tunniste on määritelty. Tämä voi olla samassa tiedostossa tai toisessa, editorissa jo avoinna olevassa tiedostossa ja jos tiedosto ei ole auki, se avataan (joten jos aliohjelma tai funktio on esitelty, esimerkiksi tiedostossa classesh.inc niin tämä avataan editoriin). ( katso lisätietoa).
  • Avaa kursorin osoittama tiedosto: Avataan tiedosto, jonka nimi on valittu kursoriin. Hyödyllinen kun katsotaan Include tiedostoja tai tiedostoja, jotka sisältävät projektin muita käännösyksikköjä (Unit ) joita siinä on käytetty.
  • Siirry Include määrittelyyn':Jos kursori sijaitsee tiedostossa joka sisälletty (Included) toiseen tiedostoon

niin se siirtyy tähän tiedostoon missä on tämä Include kutsu.

  • Etsi viittauksia tunnisteihin: Tuottaa luettelon kaikista nykyisen tiedoston, nykyisen projektin tai kaikista liitetiedostojen riveistä jossa tunniste on mainittu.
  • Aliohjelma luettelo: Tuottaa luettelon kaikista aliohjelmista (procedure)ja funktioista (function) rivinumeroineen missä ne on määritelty jotka ovat nykyisessä tiedostossa.


Näytä-valikko

ViewMenu.jpg

Ohjaa näytön eri ikkunoita ja paneeleita ruudulla.

  • Siirry lomakkeen ja käännösyksikön välillä F12: Vaihtaa lähdekoodieditorin ja nykyisen lomakkeen välillä ja sijoittaa sen työpöydän pintakerrokseen päällimmäiseksi ja valitsee sen aktiiviseksi. Jos lähdekoodieditori tuli valituksi niin voidaan muokata lähdekoodia; Jos lomake tuli valituksi niin voidaan muokata komponentteja ja muokata lomakkeen muotoa. Helpoin tapa vaihtaa lähdekoodieditorin ja lomakkeen välillä on käyttää F12-näppäintä, mutta sama vaikutus saadaan valitsemalla tämä vaihtoehto päävalikosta.
  • Komponenttimuokkain: Ikkuna joka yleensä on työpöydän vasemmalla puolella, näyttää lomakkeen(Form) ominaisuudet joka on työpöydällä. Klikkaamalla hiirellä mitä tahansa komponenttia lomakkeella se aiheuttaa komponentin yksityiskohtien näytön komponenttimuokkaimessa. Yläosassa on paneeli, joka esittää projektin rakenteen puumaisena myös komponentit voidaan valita tässä paneelissa: tämän seurauksena myös vastaavat yksityiskohdat näytetään komponenttimuokkaimessa. Alemman paneelin tärkein asia on kaksi välilehteä, jotka näyttävät Ominaisuudet ja Tapahtumat välilehdet. Valitsemalla Ominaisuudet-välilehti niin nähdään ominaisuuksia, kuten nimi, väri, kuvateksti, fontti, koko jne. Siinä näytetään kaksi saraketta, vasenmpi näyttää ominaisuutta ja oikea osoittaa siihen liittyvän arvon. Myös välilehti Tapahtumat näyttää kaksi saraketta: vasenmalla luetellaan mahdolliset tapahtumat kuten MouseClick tai KeyDown jotka liittyvät kyseiseen komponenttiin. Oikealla näkyy toiminta, joka on kytketty kyseisen tapahtumaan. Jos ei ole toimintaa määritetty, niin se voidaan valita valitsemalla soveltuva kohta tai painamalla ...-painiketta. Painikkeen ... aiheuttaa sen että siirrytään lähdekoodieditoriin ja kohdistin sijoitettu tyhjän aliohjelman (Procedure) sisälle odottamaan tapahtuman määrittelevän koodin kirjoittamista. Kyseiselle aliohjelmalle on tehty kaikki muut vaadittavat määrittelyt.
  • Lähdekoodieditori: Pääikkuna, jossa lähdekoodia muokataan. Sen käyttäminen on samantapaista kuin muiden graafisten tekstieditorien: kursorin voi siirtää hiirellä tekstiin, klikkaamalla hiiren vasenta painiketta, vetämällä hiirellä voidaan valita ja korostaa tekstiä. Klikkaamalla hiiren oikeaa painiketta niin näytetään ponnahdusvalikko. Se sisältää mm tavalliset muokkaustoiminnot: leikkaa, kopioi ja liitä. Niiden lisäksi muita toimintoja kuten: Etsi määrittely ja Avaa tiedosto. Lähdekoodieditorin yläosassa on useita välilehtiä, jotka vastaavat tiedostoja, jotka ovat avoinna nykyisessä projektissa. Klikkaamalla välilehteä tuodaan kyseinen tiedosto näkyviin. Näin voidaan siirtyä helposti tiedostosta toiseen, kopioida tiedostojen välillä ja suorittaa suurimman osan normaalista muokkaustoimintoja. Lähdekoodieditori on värillinen koodin syntaksin korostus, jossa tuodaan erivärisenä välimerkit, kommentit, merkkijonovakiot jne. Se myös ylläpitää samaa sisennystä kun kirjoittaessa koodia siirrytään riviltä toiselle. Lähdekoodieditorin toiminnot ja ulkonäkö ovat hyvin monipuolisesti muokattavissa valitsemalla päävalikosta Työkalut->Asetukset -> Editori.
  • Kääntäjän viestit: ikkuna, joka näyttää kääntäjän viestejä osoittaa kääntämisen edistymistä onnistuen tai luetellen havaittuja virheitä.
  • Koodin tutkija: Ikkuna oletusarvoisesti sijoitettu työpyödän oikealla puolella, se näyttää käytettävän käännösyksikön tai ohjelman koodin rakenteen puun muodossa. Se avautuu yleensä vain näyttäen käännösyksikön nimen ja Interface ja Implementation lohkot, mutta klikkaamalla pientä kolmiota vasemmalla niin avautuu se enemmän ja tarkemmin, kunnes yksittäiset vakiot ja muuttujat näkyvät sekä aliohjelma että funktiomäärittelyt. Jos muutetaan tiedostoa lähdekoodieditorissa, niin täytyy klikata Päivitä-painiketta jotta koodin tutkija näyttää muutetun tiedoston uuden rakenteen.
  • Näytä käännösyksikön riippuvuudet: Avaa ikkunan, joka näyttää puumaisella tavalla avoinna käännösyksikön rakenteen riippuvuudet. Useimmilla lueteltuilla tiedostoilla on riippuvuuksia. Näillä on omat "laajennuskolmiot"

jotka näyttävät riippuvuudet. Yksitäistä tiedostoa tutkittaessa, riippuvuudet tulee esiin usein hyvin rekursiivisella tavalla.

  • Hakutulokset: ikkuna, joka näyttää tiedostoista haun tulokset.
  • Virheenjäljitysikkunat: Avaa ponnahdusvalikonjossa useita vaihtoehtoja virheenjäljittimen käyttöön ja konfigurointiin. Katso #Virheenjäljityskappaletta.

Lähdekoodi-valikko

SourceMenu.jpg
  • Kommentoi valinta: Kommentoi valitun tekstin.
  • Poista valinnan kommentti: Poistaa valitun tekstin kommentointi.
  • Valinnan kommentti päälle/pois:Kommentoi tai poistaa valitun tekstin kommentoinnin.
  • Kapseloi valinta...: Kapseloi valitun tekstin valitun rakenteen sisään kuten esimerkiksi Try...Finally.
  • Kapseloi $IFDEF:n sisään...: Kapseloi valitun tekstin IFDEF (Ehdollinen määrittely) rakenteen sisään.
  • täydennä koodi:
  • Lisää käännösyksikkö uses-lauseeseen...: Lisää yhden tai useamman käännösyksikön uses-lauseeseen.
  • Järjestele uudelleen: Avaa järjestele uudelleen alavalikon.
  • Nopea kieliopin tarkistus: Suorittaa nopean kieliopin tarkistuksen.
  • Arvaa sulkematta jäänyt lohko: Antaa editorin lopettaa suljettu lohko, kuten puuttuva "End" käytettäessä "If" lausetta.
  • Arvaa väärinsijoitettu IFDEF/ENDIF: Antaa editorin korjata puuttuva ehdollinen määrittely.
  • Liitä CVS-sana...: Liittää CVS-avainsanan, kuten "Author" tai "Date".
  • Liitä kenttiä: Liittää yleisiä arvoja kuten "GPL ilmoitus".
  • Lisää tiedoston koko nimi...: Valitaan tiedosto jonka nimi polkuineen lisätään.
  • Lisää ToDo-merkintä: Lisää ToDo-kommentin.
  • Käännösyksikön tietoja...: Näyttää tietoja käännösyksiköstä.
  • JEDI Code Format: Näyttää JEDI Code Format optiot projektista.

Projekti-valikko

ProjectMenu.jpg
  • Uusi projekti: Luo uuden projektin. Ponnahdusikkuna avautuu josta valitaan minkä tyyppinen projekti on.
  • Luo uusi projekti tiedostosta: Navigation valintaikkuna avautuu, sallien valita tiedoston, josta luodaan uusi projekti.
  • Avaa projekti Avaa projektin, joka on jo luotu ja tallennettu. Valintaikkuna näkyy luettelona kyseisen kansion Lazarus Project Information (.lpi) tiedostoja, joista projekti voidaan valita.
  • Avaa esillä ollut Projekti: Näyttää pop-up luettelon viimeaikaisista projekteista, joita on aikaisemmin avattu Lazaruksessa ja mahdollistaa valinta yhden näistä.
  • Sulje projekti Sulkee avoinna olevan projektin.
  • Tallenna projekti: Samanlainen kuin Tiedosto -> Tallenna: kaikki avoinna olevan projektin tiedostot tallennetaan; jos niitä ei ole aiemmin tallennettu, kysytään tiedostonimi - samanlailla kuin "Tallenna projekti nimellä..." .
  • Tallenna projekti nimellä...: Kysyy projektin tiedostonimeä jolla se tallennetaan . Oletuksena tiedostonimi on Project1.lpi, mutta olisi parempi valita sovellusta kuvaavampi tiedostonimi. Lazarus ei salli että käytettäisiin samaa nimeä projektin ja käännösyksikön tiedostoniminä (katso alla ).
  • Julkaise projekti...: Luo kopion koko projektista. Jos haluat lähettää jollekin vain lähdekoodin ja kääntäjän asetukset, tämä toiminto on ystäväsi. Normaali projektikansio sisältää paljon tietoa. Suurinta osaa siitä ei tarvitse julkaista: Tällä .lpi tiedosto sisältää istunnon tiedot (kuten kursorin asema ja suljettujen käännösyksikköjen kirjaimerkit) ja projektikansio sisältää paljon .ppu, .o tiedostoja ja ajettavan tiedoston. "Julkaise projektin" luomma lpi tiedosto sisältää vain perustietoa ja lähdekoodia sekä alikansioita. Dialogissa voidaan asettaa sulkevan poistosuodattimen ja sisältävän lisäyssuodattimen ja komennolla "komento jälkeen" voit pakata tuotoksen yhdeksi arkistotiedostoksi. Katso Lazarus IDE Työkalut
  • Projektin hallinta: Avaa ikkunan jossa puumainen näyttö projektin tiedostoista. Voidaan lisätä, poistaa tai avata valittuja tiedostoja tai siirtyä muuttamaan projektin asetuksia.
  • Projektikohtaiset asetukset ...: Avaa ikkunan jossa voi asettaa projektin asetuksia tai kääntäjän asetuksia. Asetus mahdollisuuksia on monia: sovellus (nimi, kuvake), lomakkeet (josta voidaan valita käytettävissä olevista lomakkeista ovatko ne sovelluksen alussa automaattisesti luotavia) ja istunto ( mitä istuntokohtaisia tietoja tallennetaan). Kääntäjän asetukset sisältävät: Hakupolut joka mahdollistaa määritellä hakupolkuja käännösyksikköille, include tiedostoille, kirjastoille jne. Jäsennys joka mahdollistaa valinnan sääntöjä lähdekoodin jäsentämiseen. Käännös ja linkitys joka mahdollistaa valinnan koodin optimointiin: nopeammin tai pienempiä ohjelmia, keon ja pinon kokoa jne. Virheenjäljitys mahdollistaa päätettäväksi, miten käyttää virheenjäljitystä.
  • Lisää aktiivinen tiedosto projektiin: Lisää muokattavan tiedoston projektiin.
  • Poista projektista: Avaan Luettelo projektin kaikista käännösyksiköistä joita voi poistaa.
  • Käännösyksiköt...: Luettelo projektin kaikista käännösyksiköistä.
  • Lomakkeet...: Luettelo projektin kaikista lomakkeista.
  • Näytä projektin lähdekoodi: Ei ole väliä mitä tiedostoa muokataan vaan siirrytään pääohjelman lähdekooditiedostoon (yleensä .lpr tai sitten .pas tiedosto).

Suorita-valikko

RunMenu.jpg
  • Käännä: Kääntää projektin kaikki tiedostot.
  • Kokoa: Kokoaa projektin kaikki tiedostot.
  • Nopea käännös: Kääntää projektin ne tiedostot jotka ovat muuttuneet.
  • Siivoa ja kokoa...
  • Keskeytä kokoaminen: Keskeyttää kokoamisen, käytetään kun se on käynnissä silloin kuin olet muistanut, että teit jotain typerää ja haluat lopettaa kokoamisen tai järjestelmä näyttää ottavan liian kauan aikaa ja jotain on selvästi väärin.
  • Suorita: Tämä on tavanomainen tapa käynnistää kääntäjä ja jos kokoaminen onnistuu se käynnistää sovelluksen suorittamisen. Se mitä todella tapahtuu on, että Lazarus tallentaa tiedostot, alkaa sitten kääntämään ja lopuksi linkkaa, kun ne suoritettu niin käynnistää juuri nyt käännetyn ohjelman.
  • Keskeytä: Keskeyttää käynnissä olevan ohjelman suorituksen. Tämä saattaa mahdollistaa tarkastaa kaikki joka on luot output virtaan, suoritusta voidaan jatkaa valitsemalla Suorita uudelleen.
  • Näytä suorituspiste: Näyttää nykyisen suorituksen kohdan.
  • Askella sisään: Käytetään virheenjäljityksen yhteydessä, aiheuttaa ohjelman toteuttamisen yksi askel kerrallaan kirjanmerkittyyn kohtaan lähdekoodissa.
  • Askella yli:Aiheuttaa vaiheittaisen toteutuksen, ohittaa alatason toteutuksen jossa suoritus jatkuu normaalilla nopeudella. Hyödyllinen yrittäessä paikantaa lausetta jossa on looginen virhe.
  • Askella ulos: Nousee lohkotasolla ylöspäin.
  • Jatka kursorin kohtaan: Etenee ohjelmassa normaalilla nopeudella (eli ei yksi lause kerrallaan), kunnes kohta on saavutettu, missä kohdistin sijaitsee tai nykyisestä aliohjelmasta poistutaan; sitten pysähtyy. Ei pysähdy, jos sijainti on saavutettu rekursion aikana. Suoritusta voidaan jatkaa normaalinopeudella valitsemalla Suorita.
  • Pysäytä: Lopettaa käynnissä olevan ohjelmaan suorituksen. Ei voida jatkaa valitsemalla Suorita, Tämä käynnistää ohjelman uudelleen alusta (ja tekee uudelleen kokoamiseen tarvittaessa).
  • Suoritus parametrit:

Avaa monisivuisen ikkunan, jonka avulla komentorivivalitsimia ja parametrejä välitetään ohjelman suoritettavaksi; mahdollistaa näytön valinnan missä ohjelma ajetaan (esim etäkäyttöinen X-pääte voidaan käyttää Linuxissa); joitakin järjestelmän ympäristömuuttujia voidaan ohittaa. Yksi tärkeä käyttö tässä alivalikossa on aktivoida pääteikkunaa jossa tavanomainen Pascal konsolin (päätteen) input / output näytetään. Jos kehitetään konsoli-tilassa toimivia Pascal ohjelmia (eli sellaisia jotka eivät käytä graafista käyttöliittymää ja sen lomakkeita, painikkeita ja laatikoita) sitten sinun pitäisi tarkistaa valintaruutu "Käytä käynnistävää ohjelmaa". Kun ensimmäisen kerran tehdä tämän ja yrittää "Käännä / Suorita" komentojensarjaa, saanet todennäköisesti "töykeän" viestin:

"xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied".  

Jos näin tapahtuu, niin täytyy muuttaa tiedoston käyttöoikeuksia sopivaksi (esimerkiksi käyttämällä chmod + x tiedostonimi tai Windowsin apuohjelmaa käyttöoikeuksien muuttamista); ehkä tämä täytyy tehdä root oikeuksilla. Tämän jälkeen joka kerta kun käynnistää ohjelman, konsoli aukeaa ja kaikki teksti I / O (readln, writeln ym) ilmestyy siihen. Kun ohjelma on päättynyt suorituksen, viesti "Press Enter" ilmestyy näyttöön. Niinpä mikä tahansa ohjelmalla luotu ulostulo pysyy näytöllä, kunnes olet ehtinyt lukea sen; kun painat Enter niin konsoli-ikkuna sulkeutuu. Katso erillinen opetusohjelma Pascal ohjelmointi päätetilassa.

  • Nollaa virheenjäljitin: Palauttaa virheenjäjittimen alkuperäiseen tilaansa, niin että raja-arvot ja muuttujien arvot jne unohdetaan.
  • Kokoa tiedosto: Kokoaa tiedoston, joka on editorissa avoinna.
  • Suorita tiedosto: Kääntää, linkittää ja ajaa tiedoston, joka on editorissa avoinna.
  • Konfiguroi kokoa + Suorita tiedosto: Avaa monisivuisen välilehtiä sisältävän ikkunan jossa on vaihtoehtoja, joita käytetään kun valitaan kokoa tiedosto tai suorita tiedosto valinta. Muun muuassa mahdollistaa työkansion valinnan, voidaan käyttää erilaisia makroja jne. Sitten rakentaa ja suorittaa tiedosto .

Näillä kolmella viimeisellä vaihtoehdon avulla voidaan avata (ja ylläpitää) testausprojektia. Käytä Tiedosto -> Avaa avata .lpr tiedosto painamalla peru ja seuraava dialogi avaa tiedoston "normaalina" lähdekooditiedostona.

  • Tutki...: Tutkii arvon, kun ohjelma on keskeytetty.
  • Arvioi/Muuta...: Arvioi tai muuttaa lausekkeen tai arvon, kun ohjelma on keskeytetty.
  • Lisää vahti...: Lisää muuttuja tarkkailuluetteloon.
  • Lisää keskeytyskohta...: Lisää keskeytyskohdan, joka keskeyttää ohjelman suorituksen kyseisellä koodirivillä.

Paketti-valikko

PackageMenu.jpg
  • Uusi paketti...: Luo uuden paketin.
  • Avaa jo ladattu paketti...: Avaa yhden valitun paketin tiedostot.
  • Avaa pakettitiedosto (.lpk)...:Avaa valitun pakettitiedoston (.lpk) ja siirtyy Pakettimuokkaimeen
  • Avaa aktiivisen käännösyksikön paketti:Avaa aktiivisen käännösyksikön paketin ja siirtyy Pakettimuokkaimeen.
  • Avaa esillä ollut paketti: Avaa paketin joka avattiin hiljattain.
  • Lisää aktiivinen tiedosto pakettiin...: Aseta tiedosto (joka on tällä hetkellä editorissa) pakettiin.
  • Uusi Komponentti: Luo uuden komponentin.
  • Pakettikuvaaja...: Näyttää osoittaen pakkausten suhteet jotka ovat tällä hetkellä käytössä (jos et käytä muita paketteja, Lazarus paketti ja FCL sekä LCL näytetään).
  • Asenna/Poista Paketteja...: Asentaa/Poistaa yhden tai useamman paketin.

Työkalut-valikko

ToolsMenu.jpg
  • Asetukset...: Näyttää ja muuttaa eri vaihtoehtoja ja asetuksia Lazarus kehitysympäristössä.
  • Lue uudelleen FPC-lähdekoodit käy uudelleen hakemiston lävitse. Lazarus käyttää FPC lähdekoodia tuottaakseen oikeat tapahtumankäsittelijät ja etsiessään määrittelyitä. Jos joku muuttaa hakemistoa käyttöympäristöasetuksissa, niin tämä hakemisto on skannattava uudelleen, varmistamaab että Lazarus käyttää sitä versiota jota säilytetään kyseisessä paikassa. Mutta jos tämä hakemisto on muuttunut ilman että Lazarus huomaa sen, niin voidaan saada joitakin virheitä suunniteltaessa lomakkeita tai tehtäessä "Etsi määrittely" etsintä. Jos tulee tällainen virhe niin voidaan tehdä kaksi asiaa:
    1. Tarkistaa FPC lähdehakemisto asetus käyttöympäristöasetuksissa.
    2. Lue uudelleen FPC-lähdekoodit.
  • Koodimallit...: Näyttää koodimalleja, jotka ovat käytettävissä.
  • CodeTools määritysten muokkain...: Muokkaa CodeTools määrityksiä.
  • Project templates options...: Asettaa project templates vaihtoehdot.
  • [[IDE_Window:_External_Tools|Muokkaa ulkoisia työkaluja: Käyttäjä voi lisätä erilaisia ulkoisia työkaluja (yleensä makroja)
  • Esimerkki projektit...: Näyttää esimerkki projektit, jotka ovat käytettävissä.
  • Vertaa tiedostoja: Mahdollistaa kahden tiedoston vertailun (tai, tavallisesti, kahta eri versiota samasta tiedostosta) jotta nähdään niiden erot. Vaihtoehtoina on mmm jättää huomioimatta erilaiset välilyöntien määrät rivin alussa tai lopussa tai rivin päättymisen eroista: CR + LF vs. LF. Hyödyllinen kun tarkistaa, jos on tapahtunut muutoksia viime versiohallinnan päivityksen jälkeen jne.
  • Muunna projektin/ paketin merkistökoodaus...:
  • Tarkista edistorissa oleva LFM tiedosto: Mahdollistaa tarkastaa LFM tiedosto, joka sisältää asetuksia, jotka määritelty nyt valitulla lomakkeella.
  • Delphi muunnos: sisältää alivalikon. Katso Lazarus For Delphi Users ja Code Conversion Guide.
    • Muunna Delphi käännösyksikkö Lazarukselle
    • Muunna Delphi projekti Lazarukselle
    • Muunna Delphi Paketti Lazarukselle:
    • Muunna binaarinen DFM-tiedosto teksti-LFM:ksi ja tarkista kielioppi
  • Kokoa Lazarus käyttäen profiilia: Normaali IDE: Aloittaa uudelleen rakentamaan Lasaruksen viimeksi ladatuista tai päivitetyistä SVN tiedostoista. Paina nappia ja istu katsomaan mitä tapahtuu! (prosessin seuraaminen onnistuu Viestit-ikkunassa).
  • Konfiguroi "Lazaruksen kokoaminen": Sallii käyttäjän määrittää, mitkä Lazarus osat uudelleen rakennetaan ja miten. Esimerkiksi, voidaan valita että vain LCL uudelleen rakennetaan, tai rakennetaan kaikki paitsi esimerkkit; voidaan valita mitä rajapintaa LCL käyttää (eli mitä joukkoa widgettejä) ja voidaan valita kohde käyttöjärjestelmä ja määrittää eri kohdekansio.

Ikkunat-valikko

WindowMenu.jpg

Sisältää luettelon tällä hetkellä avattujen tiedostojen ja käytettävissä olevia ikkunoita kuten lähekoodieditori, komponenttimuokkain ja projektin hallinta. Klikkaamalla yhden ikkunan nimeä niin tuo sen edustalle ja laittaa sen aktiiviseksi.

Ohje-valikko

HelpMenu.jpg
  • Mukana oleva avustus joka nykyisin avaa selainikkunan, joka sisältää kuvan juoksevasta gepardista ja muutamia linkkejä Lazarus, Free Pascal ja Wiki sivustoille
  • Virheen raportointi Avaa wiki sivun, joka kuvaa kuinka tehdään virheraportointi
  • Tietoja Lazaruksesta Näyttää ikkunassa joitakin tietoja Lazaruksesta mm. kertoo mikä versio on kyseessä.