Main menu/fr

From Lazarus wiki
Jump to navigationJump to search

Deutsch (de) English (en) español (es) suomi (fi) français (fr) magyar (hu) italiano (it) 日本語 (ja) македонски (mk) Nederlands (nl) português (pt) русский (ru) slovenčina (sk) shqip (sq) 中文(中国大陆)‎ (zh_CN) 中文(台灣)‎ (zh_TW)

Le menu principal contient les entrées suivantes : Fichier Edition Cercher Voir Project Exécuter Composants Outils Configuration Fenêtres Aide

Comme d'habitude, les options peuvent êtres sélectionnées soit en cliquant directement dessus à l'aide du bouton gauche de la souris, soit en tapant au clavier :

  • Alt,
  • la lettre correspondante au menu voulu (par exemple F),
  • Entrée.


Sous-menu Fichier

SousMenuFichierFr.png
  • Nouvelle unité : crée une nouvelle unité (Source Pascal) ;
  • Nouvelle fiche : crée une nouvelle fiche, et l'unité Pascal associée ;
  • Nouveau... : affiche un menu surgissant (capture d'écran) proposant une variété de documents à créer ;
  • Ouvrir... : affiche une boîte de dialogue permettant ne naviguer dans le système de fichier et de choisir une fichier existant à ouvrir ;
  • Restaurer : abandonne les modifications effectuées et restaure les fichiers dans leurs états d'origine ;
  • Réouvrir... : propose la liste des fichiers récemment ouverts, avec la possibilité d'en sélectionner un et de l'ouvrir ;
  • Enregistrer : sauvegarde le fichier courant, en utilisant son nom d'origine. S'il n'a pas de nom, le système vous en demandera un (de la même manière qu'enregistrer sous) ;
  • Enregistrer sous... : affiche une boîte de dialogue qui vous permet de choisir un nom de fichier et un répertoire pour sauvegarder le fichier courant ;
  • Fermer : ferme le fichier en cours, après avoir demandé la sauvegarde des modifications effectuées ;
  • Fermer tous les fichiers : ferme tout les fichiers en cours et ouvre l'éditeur. Demande si vous souhaitez sauvegarder (si vous avez effectué des modifications) ;
  • Nettoyer un répertoire... : affiche une boîte de dialogue avec une série de filtres éditables pour supprimer les fichiers correspondants de votre répertoire en cours. Utile pour supprimer les fichiers .bak et les restes des anciens projets de Delphi ;
  • Print... : imprime la page sélectionnée de l'éditeur de sources ;
  • Redémarrer : redémarre Lazarus, ce qui est utile lorsque les fichiers sont trop désorganisés ;
  • Quitter : sort de Lazarus, après avoir demandé la sauvegarde des fichiers modifiés.

Sous-menu Edition

SousMenuEditionFr.png
  • Défaire : défait la dernière action effectuée.
  • Refaire : refait la dernière action annulée par Défaire ;
  • Couper : supprime le texte sélectionné et le copie en mémoire ;
  • Copier : fait une copie en mémoire du texte sélectionné, en laissant l'original en place ;
  • Coller : place le contenu de la mémoire à l'emplacement du curseur. S'il y a du texte sélectionné à l'emplacement du curseur, il sera remplacé par le contenu de la mémoire ;
  • Indenter la sélection : déplace le texte sélectionné vers la droite en fonction de ce qui est spécifié dans : Configuration -> Options... -> Editeur -> Général -> Indentation de bloc. Cette fonctionnalité est utile pour formater votre code source Pascal de manière à mettre en évidence sa structure ;
  • Désindenter la sélection : supprime un niveau d'indentation, déplace le texte vers la gauche en fonction de ce qui est spécifié dans Indentation de bloc ;
  • Entourer la sélection... : affiche un menu pop-up avec plusieurs options pouvant logiquement entourer le texte sélectionné (begin ... end; try ... except; try ... finally; repeat ... until; { ... } etc) ;
  • Sélection en commentaire : commente le texte sélectionné en insérant // sur chaque ligne ;
  • Décommenter la sélection : supprime les marqueurs de commentaire du texte sélectionné ;
  • Insérer $IFDEF... : insère la directive de compilation $IFDEF qui permet de compiler le code en fonction du système d'exploitation. Une boîte de dialogue propose différentes valeurs possible ;
  • Trier la sélection... : trie les lignes, les mots ou les paragraphes dans l'ordre alphabétique ; incluant des option croissantes, décroissantes, ou la sensibilité à la casse. Ceci n'a évidemment aucun sens au beau milieu du code source, mais si vous avez une liste à trier, cette fonctionnalité fera l'affaire ;
  • Mettre la sélection en majuscules : convertit le texte sélectionné en majuscules ;
  • Mettre la sélection en minuscules : convertit le texte sélectionné en minuscules ;
  • Remplacer les tabulations par des espaces dans la sélection : convertit chaque tabulation dans le texte sélectionné par le nombre d'espaces spécifié dans Configuration -> Options -> Editeur -> Général -> Largeur de tabulation. Le nombre d'espaces n'est pas fixe, mais correspond au nombre nécessaire pour remplacer la largeur de la tabulation ;
  • Couper les lignes dans la sélection : si une ligne de la sélection fait plus de 80 caractères de long ou plus que le nombre spécifié dans Configuration -> Options -> Editeur -> Affichage -> Marge droite, alors cette ligne sera coupée au niveau de la borne limite et continuera sur la ligne suivante ;
  • Sélectionner : permet de sélectionner un bloc de texte. Les options possibles sont : Tout sélectionner, Ancrer la sélection, Sélectionner le bloc de code, Sélectionner la ligne et Sélectionner le paragraphe ;
  • Insérer depuis la table des caractères : permet l'insertion de symboles qui ne figurent pas sur le clavier, une fenêtre s'affiche vous proposant diverses possibilités ;
  • Insérer un texte : affiche un sous-menu permettant d'insérer du texte comme des mots clefs CVS (Author, Date, Header etc) ou une note GPL, LGPL, l'utilisateur courant, la date et l'heure courante, etc. ;
  • Compléter le code : complète le code à l'emplacement du curseur. Il est sensible au contexte et vous fera gagner beaucoup de temps. Par exemple : il complète les classes, en ajoutant les variables privées, les méthodes d'accès aux propriétés Get et Set ainsi que le corps des méthodes. Lors de l'assignation d'une variable (ex : i:=3;) il ajoute la déclaration de la variable. Lors de la définition de procédures forward, il ajoute le corps des procédures. Lors de l'assignation d'événement (OnClick:=), il ajoute la définition et le corps de la méthode. Voir les outils de l'EDI Lazarus ;
  • Extraire procédure... : utilise le texte sélectionné (une déclaration ou une série de déclarations) pour créer une nouvelle procédure.

Sous-menu Chercher

SousMenuChercherFr.png
  • Chercher... : similaire à la fonction équivalente de la plupart des éditeurs de texte : une boîte de dialogue s'affiche vous permettant de saisir une chaîne de texte à rechercher, les options de sensibilité de casse, mot entier, direction de recherche, etc. sont également disponibles ;
  • Chercher l'occurrence suivante, Chercher l'occurrence précédente : cherche l'occurrence suivante (resp. précédente) de la chaîne entrée précédemment, dans la direction spécifiée ;
  • Chercher dans les fichiers... : chercher une chaîne de caractères dans un fichier : boîte de dialogue avec la possibilité de chercher dans tous les fichiers du projet, tous les fichiers ouverts, ou dans les répertoires ; masque les possibilités en fonction du type de fichier sélectionné ;
  • Remplacer... : similaire à Chercher ; affiche une boîte de dialogue avec la possibilité d'entrer le texte à chercher et le texte à remplacer, ainsi que les options de sensibilité de casse, de direction, etc. ;
  • Recherche incrémentale : cherche la chaîne de caractères que vous entrez au clavier. Exemple : après avoir choisi "Recherche incrémentale" si vous appuyez sur la touche "l" le premier "l" après la position en cours du curseur sera surligné. Si vous appuyez sur la touche "a", l'éditeur cherchera le "la" suivant et ainsi de suite ;
  • Aller à la ligne... : déplace le curseur à la ligne spécifiée ;
  • En arrière : se déplace vers le signet précédant (Ajouter le point de saut à l'historique doit avoir été utilisé au préalable). Se déplacera vers d'autres fichiers ouvert dans l'éditeur.
  • En avant : se déplace vers le signet suivant ;
  • Ajouter le point de saut à l'historique : ajoute des points de saut ou des signets au fichier ;
  • Afficher l'historique des déplacements... : affiche au moins un point de saut dans le fichier : Pas encore implémenté ! ;
  • Erreur suivante, Erreur précédente : se déplace dans le fichier source, à la position de l'erreur suivante (resp. précédente) ;
  • Mettre un signet libre : marque la ligne courante (où se trouve le curseur, donc) d'un signet affecté du prochain numéro de signet libre, et l'ajoute à la liste des signets. Notez qu'un clic droit sur une ligne appropriée du fichier source, ouvre un menu pop-up proposant un choix plus étendu d'options de gestion des signets, permettant de spécifier un numéro de signet, ou à se déplacer jusqu'à un signet donné (et pas seulement vers le prochain ou le précédent) ; Attention, en 0.9.028.2, l'option du menu ne fonctionne pas et les traductions françaises dans le pop-up sont identiques pour des fonctions différentes : l'une gère le déplacement vers les signets, l'autre gère la mise en place et le déplacement des signets eux-mêmes !
  • Aller au prochain signet, Aller au précédent signet : se déplace au prochain (resp. précédent) signet, dans l'ordre numérique des signets (i.e. pas forcément dans l'ordre des lignes).
  • Chercher la fin du bloc de code : si vous êtes positionné sur begin, cherche le end correspondant ou vice versa ;
  • Chercher le début du bloc de code : se déplace sur le begin de la procédure ou de la fonction dans laquelle le curseur et positionné ;
  • Rechercher la déclaration sous le curseur : trouve l'endroit où est déclaré l'identifiant choisi. Celui-ci peut être dans le même fichier ou dans un autre fichier déjà ouvert dans l'éditeur ; si le fichier n'est pas ouvert, il le sera (si une procédure ou une fonction et déclarée, par exemple, dans classesh.inc, cela l'ouvrira dans l'éditeur) ;
  • Ouvrir le fichier sous le curseur : ouvre le fichier correspondant au nom sélectionné sous le curseur. Utile pour ouvrir des fichiers Include ou des fichiers contenant d'autres Unités utilisées dans le projet ;
  • Aller à la directive "include" : si le curseur est positionné dans un fichier Inclus dans un autre fichier, va à la position de la directive d'Inclusion dans cet autre fichier ;
  • Trouver les références à l'identifiant... : affiche une liste de toutes les lignes où l'identifiant recherché apparaît, dans le fichier courant, le projet courant ou tous les fichiers dépendants ;
  • Renommer l'identifiant... : permet de renommer un identifiant partout où il est utilisé. Une boîte de dialogue permet de préciser s'il faut renommer l'identifiant uniquement dans le fichier courant, dans tout le projet, ou dans tous les fichiers ouverts ou dépendants, etc. Vous pouvez même renommer les occurrences de l'identifiant apparaissant dans les commentaires. Vous utiliserez cette fonctionnalité notamment lorsque le compilateur vous indiquera qu'un identifiant existe déjà, auquel cas vous aurez besoin d'un nouveau nom ;
  • Liste de procédures... : ouvre une boîte de dialogue présentant une liste filtrable de toutes les procédures et fonctions du fichier courant, avec le numéro de ligne de leur définition.

Sous-menu Voir

SousMenuVoirFr.png

Il permet le contrôle de l'affichage de différentes fenêtres sur l'écran.

  • Inspecteur d'Objets : C'est la fenêtre qui occupe généralement le côté gauche du bureau, et qui montre les éléments de la Fiche (Form) qui se trouve sur le bureau. En cliquant avec la souris sur un composant de cette fiche, le détail du composant s'affiche dans l'inspecteur d'objets. Le haut de l'inspecteur d'objet montre l'arborescence du projet courant, et les composants de la fiche peuvent éventuellement y être sélectionnés : ceci entraînant l'affichage des détails correspondant dans l'inspecteur d'objet. Le bas de l'inspecteur d'objet est composé de plusieurs onglets qui permettent la sélection des propriétés : PropertyPage, des événements : EventPage ou des éléments que vous avez consulté : Favorites. La sélection de l'onglet PropertyPage permet d'afficher les propriétés telles que Name, Color, Caption, Font, Size etc. : La colonne de gauche représentant la propriété par son nom, la colonne de droite montrant la valeur qui lui est associée. La sélection de l'onglet Events montre aussi deux colonnes : celle de gauche montre les événements possibles tels que MouseClick ou KeyDown associés à ce composant, et celle de droite montre l'action associée à cet événement. S'il n'y a pas encore d'action définie pour cet événement, il suffit de cliquer dans le champ correspondant ou le bouton
    ...
    pour que dans l'éditeur de sources, le curseur se place dans la procédure créée automatiquement, attendant que vous y tapiez le code associé.
  • Editeur de Source : C'est la fenêtre principale dans laquelle le code source est édité. Il réagit comme la plupart des éditeur de texte, on peut y déplacer le curseur à la souris, un clic gauche maintenu plus déplacement permet de sélectionner une partie du texte. Le clic droit fait apparaître un menu popup comprenant les actions d'édition classique (Couper, Copier, Coller...), Chercher la Déclaration et Ouvrir le fichier sous le curseur. En haut de la fenêtre de l'éditeur de sources se trouvent un certain nombre d'onglets qui correspondent aux fichiers ouverts dans le projet courant ; en cliquant sur l'un d'entre eux, le fichier correspondant est affiché, vous pouvez ainsi naviguer facilement de fichier en fichier, effectuer des copier/coller et autres travaux d'édition entre eux. L'éditeur de source est équipé de la coloration syntaxique de code, avec différents coloris pour les marques de ponctuation, les commentaires, les chaînes de caractères, les constantes etc... Il conserve aussi l'indentation du code de ligne en ligne au fur et à mesure de votre frappe, jusqu'à ce que vous modifiez celle-ci. L'apparence et les options de l'éditeur de code sont entièrement configurables depuis le menu principal en sélectionnant Configuration -> Options de l'éditeur puis en sélectionnant l'un des onglet dans la fenêtre de dialogue.
  • Explorateur de code : Affiche une fenêtre qui se place habituellement à droite du plan de travail, elle affiche sous forme arborescente la structure du code dans l'unité ou le programme actuel. Elle s'ouvre normalement avec les sections Unit, Interface, Implementation et Initialization affichées, mais un clique sur le bouton [+] à gauche de la branche, ouvrira ses sous-branches, affichant de plus en plus de détails jusqu'à ce que les constantes, types et variables soient affichées, de même que les déclarations de procédure et fonction. Si vous changez les fichiers affichés dans l'éditeur de source, vous devrez cliquer sur le bouton Rafraîchir pour afficher la structure du nouveau fichier dans l'Explorateur de Code.
  • Editeur LazDoc :
  • Navigateur de code :
  • Unités... : Ouvre une boîte de dialogue listant les Unités du projet en cours. Pour sélectionner les fichiers cliquez dessus ; cela ouvrira le fichier dans l'éditeur de sources. Si vous cochez la case "Multi sélection" vous pourrez sélectionner plusieurs fichiers à la simultanément, et ils seront tous ouverts dans l'éditeur de Sources (mais un seul sera affiché à la fois). Ce menu est comparable à l'option Projet -> Inspecteur de Projet, mais affiche uniquement la liste des fichiers d'unités et permet de les ouvrir.
  • Fiches... : Ouvre une boîte de dialogue listant les Fiches du projet en cours, et permettant la sélection d'une ou plusieurs d'entre elles de manière à les afficher.
  • Dépendances d'unités : Ouvre une boîte de dialogue qui affiche, de façons arborescente, la structure des Dépendances de l'unité en ouverte. La plupart des fichiers listés comme dépendance auront leur propre boîte [+], chacune autorise l'exploration des dépendances de chaque fichiers, y compris de façon récursive.
  • Informations de l'unité : Donne des informations sur l'onglet d'unité sélectionné dans l'éditeur de sources.
  • Commutation fiche/Unité : Bascule entre l'éditeur de sources et la Fiche active. Si l'éditeur de sources et actif, vous pouvez éditer le code source ; si la Fiche est active, vous pouvez manipuler les composants et modifier l'apparence de la fiche. La façon la plus simple de basculer entre l'éditeur et la Fiche est d'utiliser le raccourci clavier F12, vous obtiendrez le même résultat en cliquant "Commutation fiche/Unité" dans le menu principal.
  • Messages : Une fenêtre qui affiche les messages du compilateur, montre la progression de la compilation ou liste les erreurs trouvées.
  • Résultats de la recherche : Une fenêtre qui affiche les résultats de Chercher -> Chercher dans les fichiers.
  • Afficher l'éditeur d'ancres :
  • Voir la palette des composants :
  • Voir les boutons rapides de l'IDE :
  • Fenêtres de débogage : Ouvre un menu surgissant avec plusieurs options pour le fonctionnement et la configuration du débogueur. Voir le débogueur plus bas.

Sous-menu Projet

SousMenuProjetFr.png
  • Nouveau Projet... : Crée un nouveau projet. Une boîte de dialogue s'affiche permettant de choisir entre différents types de projets.
  • Nouveau projet depuis le fichier... : Une fenêtre permettant d'ouvrir un fichier qui servira de point de départ à un nouveau projet.
  • Ouvrir un projet... : Ouvre un projet déjà créé. Une fenêtre de navigation listant les fichiers de projet au format Lazarus (.lpi ou Lazarus Project Information) s'affiche, permettant de sélectionner le projet à ouvrir.
  • Réouvrir un projet... : Affiche une liste des projets récemment ouvert, permettant de les sélectionner pour les ouvrir.
  • Fermer le projet :
  • Enregistrer le projet : équivalent de "Fichier -> Enregistrer". Enregistre tout les fichiers du projet en cours ; s'ils n'ont pas déjà été enregistré, un message apparaît demandant le(s) nom(s) du/des fichier(s) de la même manière que "Fichier -> Enregistrer sous".
  • Enregistrer le projet sous... : Demande l'emplacement et le nom de fichier du projet. Par défaut, le nom de fichier est Project1.lpi, mais il est recommandé d'en choisir un autre. Lazarus ne vous permettra pas d'utiliser le même nom de fichier pour votre Projet et pour le fichier de l'unité (Unit) (voir plus bas).
  • Publier le projet... : Crée une copie de tout le projet. Si vous voulez envoyer les sources du projet à quelqu'un, ainsi que les options de compilation, cette fonction est faite pour vous. Un dossier classique d'un projet contient beaucoup d'informations, et la plupart d'entre elles ne sont pas utiles : le fichier .lpi contient des informations de session (comme la position des fenêtres et les fiches ouvertes) et le dossier du projet contient beaucoup de fichiers .ppu, .o et l'exécutable. Pour créer un fichier .lpi avec uniquement l'information de base et seulement les sources avec tous les sous répertoires, utilisez "Publier le Projet". Dans la fenêtre de paramétrage, vous pouvez mettre un filtre d'exclusion / inclusion, et avec la commande "after" vous pouvez compresser le tout dans un fichier archive. Voir les outils de l'EDI Lazarus
  • Inspecteur de projet : Ouvre une boîte de dialogue, représentant les fichiers du projet en cours sous forme arborescente. Vous pouvez ajouter, supprimer, ou ouvrir les fichiers sélectionnés, ou changer les options du projet.
  • Options du projet... : Ouvre une boîte de dialogue contenant plusieurs onglets permettant d'accéder aux divers options de paramétrage de l'application (Titre, Fichier de destination), Fiches (permettant de sélectionner les fiches disponibles, de manière à les créer automatiquement au lancement de l'application), Divers, LazDoc et Session (spécifie quelles informations l'éditeur doit sauvegarder lors de la fermeture des fichiers, ou uniquement les fichiers projet).
  • Option du compilateur... : Ouvre une fenêtre à onglets permettant la configuration du compilateur. Les onglets incluent Chemins qui permet la définition de chemin de recherche pour les unités, les fichiers d'inclusion, bibliothèques etc., de même que permettre le type de composant pour les fiches (gtk, gnome, win32) ; Analyse qui autorise le choix des règles d'analyse des sources du programme, Code qui autorise le chois d'optimisation pour des programmes plus rapides ou plus petits, choix de la plateforme cible, types de contrôles, taille de la pile etc. ; Edition des liens permet de choisir le débogueur à utiliser, les bibliothèques static ou dynamic, et la possibilité de passer des option à l'éditeur de liens ; Messages définie quel genre de messages doivent être générés durant la compilation ; Autre permet de choisir d'utiliser le fichier de configuration par défaut (fpc.cfg) ou un autre fichier ; Hérité montre sous forme arborescente qu'elle options ont étés héritées des unités déjà incorporées ; Compilation permet de définir les appels qui doivent êtres exécutés avant ou après que la compilation soit lancée, et permet également de créer un Makefile.
  • Afficher la liste des ToDo... : Ouvre une boîte de dialogue affichant la liste des choses à faire "ToDo" associées au projet. Ces ToDo sont de simples lignes de commentaire commençant par //TODO. Il sera nécessaire de réactualiser cette liste après sauvegarde pour que les nouveaux ToDo apparaissent dans la liste. La première colonne de la liste des ToDo contiens le numéro que vous avez alloué à votre ligne de commentaire ; un simple //TODO apparaîtra comme zéro, mais un commentaire comme //TODO999 (par exemple) apparaîtra au numéro 999 dans la première colonne. Souvenez vous bien qu'il n'y a pas d'espaces sur la ligne avant //TODO et que les ToDo ajoutés après la dernière sauvegarde ne seront pas affichés !
  • Ajouter le fichier de l'éditeur au projet : Ajouter au projet le fichier en cours d'édition.
  • Retirer du projet... : Affiche une liste des fichiers pouvant être supprimés du projet.
  • Afficher le source : Affiche le code source principal (fichier .lpr ou .pas s'il n'existe pas de fichier .lpr) du programme en cours.

Sous-menu Exécuter

SousMenuExecuterFr.png
  • Construire : Lazarus construit (par exemple Compiler) chaque fichier du projet ayant été modifié depuis la dernière construction.
  • Construire tout : Construit tout les fichiers du projet, y compris ceux qui n'ont subis aucune modification.
  • Construire vite :
  • Arrêter le construction : Stop la construction (par exemple Compilation) en cours – sois vous vous apercevez que vous avez commis une erreur et souhaitez arrêter la construction, sois le système semble prendre trop de temps ce qui laisse penser qu'il y a forcément une erreur.
  • Exécuter : C'est la solution habituelle pour lancer une compilation et, si la compilation réussie, démarre l'exécution de l'application. Normalement, Lazarus sauvegarde une copie de vos fichiers, ensuite il compile et link, finalement lance l'exécution du fichier binaire créé.
  • Pause : Arrête le programme en cours d'exécution. Cela permet de consulter les sorties générées ; l'exécution peut être reprise en cliquant une nouvelle fois sur Exécuter.
  • Pas à pas approfondi : Utiliser en conjonction avec le débogueur, entraîne l'exécution du programme une ligne à la fois en passant par toute les unités déclarées.
  • Pas à pas : Entraîne l'exécution par étape du programme, l'exécution peut être reprise à vitesse normale à n'importe quel moment. Utile pour essayer d'isoler une erreur de logique dans le code.
  • Exécuter jusqu'au curseur : Exécute le programme avec son déroulement normal (ie NON pas à pas) jusqu'à la position en cours du curseur ; et s'arrête. Reprendre l'exécution à sa vitesse normale en sélectionnant Exécuter. (NDT : Cette fonction semble identique à exécuter dans la version 2.1 de Lazarus.)
  • Arrêter : Cesse l'exécution du programme en cours. A la différence de Pause l'exécution ne peut pas être reprise en cliquant sur Exécuter ; le programme sera redémarré depuis le début il sera recompilé si nécessaire.
  • Paramètres d'exécution... : Ouvre une fenêtre à onglet qui vous permette d'entrer des options et paramètres en ligne de commande d'exécution du programme ; autorise la sélection de l'écran de démarrage du programme (eg un terminal X peut être utilisé sous Linux) ; certaines variables d'environnement peuvent être "écrasées".
Une utilisation très importante de ce sous-menu est la possibilité d'activer une fenêtre de terminal dans le mode console du Pascal. Si vous développez une application Pascal en mode console (ie qui n'utilise pas d'interface graphique avec formulaires, boutons et boîtes) vous devriez cocher la case "Utiliser une application de démarrage". La première fois que vous l'activerez et essaierez de Compiler/Exécuter, vous rencontrerez probablement un message un peu brutal
"xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied".  
Si cela arrive, vous devrez changer les permissions dans le fichier approprié (par exemple en utilisant chmod +x nomfichier, ou en utilisant un utilitaire Windows pour changer les permissions) ; vous devrez faire cela en tant que root. Après, chaque fois que vous lancerez le programme, un fenêtre en mode console apparaîtra et tous votre texte d'entrées/sorties (readln, writeln etc.) apparaîtra à l'intérieur.
Après que votre programme est fini de s'exécuter, le message "Press enter" apparaît à l'écran. Ceci vous permet de lire toutes les sorties générées par votre programme ; après vous pouvez appuyer sur 'entrer' la fenêtre de la console se fermera.
Voir le tutoriel : programmation Pascal en Mode Console.
  • Réinitialiser le débogueur : Restaure le débogueur à son état original, par conséquent les points d'arrêts, les valeurs de variables etc. sont ignorées.
  • Construire le fichier : Compile (construit) uniquement le fichier ouvert dans l'éditeur.
  • Exécuter le fichier : Compile, link et exécute le fichier ouvert dans l'éditeur.
  • Configurer construire + Exécuter le fichier... : Ouvre une fenêtre à onglets permettant d'accéder aux options de construction du fichier en cours lorsque Build Project est sélectionné, autorise la sélection du répertoire de travail, l'utilisation de divers Macros, etc. Construit et Exécute le fichier.
Ces trois dernières options vous permettent d'ouvrir (et de maintenir) un projet test. Utilisez Fichier -> Ouvrir pour ouvrir un fichier .lpr, appuyez sur Annuler sur la boîte de dialogue suivante pour ouvrir ce fichier comme un fichier "source normal".
  • Inspecter... :
  • Evaluer/Modifier.. :
  • Ajouter un suivi... :
  • Ajouter un point d'arrêt :

Sous-menu Composants

SousMenuComposantsFr.png
  • Ouvrir un paquet chargé... : Affiche une liste des paquets installés, vous invitant à en ouvrir un ou plusieurs d'entre eux, ou vous permettant de sélectionner différentes options générales ou de compilation.
  • Ouvrir un fichier paquet (.lpk)... : Ouvre un ou plusieurs fichiers du paquet sélectionné.
  • Ouvrir le paquet de l'unité courante : Ouvre un paquet utilisé récemment.
  • Ouvrir un paquet récent... :
  • Ajouter l'unité active au projet : Place le fichier de l'unité (en cours d'édition) dans un package.
  • Graphique des paquets... : Affiche un graphique montrant les relations des packages actuellement en cours d'utilisation (si vous n'utilisez pas d'autres packages, le package Lazarus de la FCL et de la LCL seront affichés).
  • Configurer les paquets installés... : Si vous avez créé vos propres composants, vous permet de les configurer.

Sous-menu Outils

SousMenuOutilsFr.png
  • Configurer les outils personnalisés... : Autorise l'utilisateur à ajouter différents outils externe (habituellement des macros).
  • Project templates options : Permet définir le répertoire des modèles par défaut.
  • Vérification rapide de la syntaxe : Effectue un contrôle rapide de la syntaxe dans votre fichier source sans rien compiler. C'est une étape essentielle dans le développement d'un programme long et compliqué, si vous ne voulez pas perdre votre temps avec du code erroné.
  • Identifier les blocs non terminés : Utilitaire pratique si vous avez un bloc imbriqué de structures complexes et que vous avez oublié un 'end' quelque part.
  • Identifier les IFDEF/ENDIF mal placés : Pratique si vous avec un bloc imbriqué de structures complexes de macro et que vous pensez avoir oublié une directive ENDIF.
  • Construire une chaîne ressource... : Transforme la chaîne sélectionnée en chaîne ressource en la plaçant dans une section resourcestrings. L'avantage de la chaîne ressource est que vous pouvez la changer sans avoir besoin de recompiler votre projet !
  • Différences : Permet la comparaison entre deux fichiers (ou, habituellement, deux versions d'un même fichier) pour trouver leurs différences. Des options permettent d'ignorer les espaces blancs au début ou à la fin ou les lignes ou les différence de code de retour à la ligne : CR+LF contre LF). Pratique pour contrôler s'il y a un changement depuis la dernière mise à jour du CVS etc.
  • Vérifier le fichier LFM dans l'éditeur : Permet l'inspection du fichier LFM contenant les paramètres décrivant le formulaire en cours.
  • Convertir une unité Delphi en unité Lazarus... : Aide au portage des applications Delphi vers Lazarus ; fait les changements nécessaires dans le fichier source. Voir Lazarus For Delphi Users et Code Conversion Guide.
  • Convertir un projet Delphi en projet Lazarus... :
  • Convertir une paquet Delphi en paquet Lazarus... :
  • Convertir un fichier DFM en LFM... : Permet de porter les applications Delphi vers Lazarus : convertis les fichiers de descriptions de Form de Delphi vers Lazarus. Voir Lazarus For Delphi Users et Code Conversion Guide.
  • Construire Lazarus : Lance la reconstruction de Lazarus pour les téléchargements les plus récents ou les fichiers CVS mis à jour. Appuyez sur le bouton et asseyez vous en regardant ce qui se passe ! (suivez le processus dans votre fenêtre de Messages).
  • Configure "Build Lazarus"...: Permet à l'utilisateur de choisir quel partie de Lazarus doit être re-construite, et de quelle manière. Par exemple, vous pouvez sélectionner uniquement le re-contruction de la LCL, ou tout excepté les exemples ; vous pouvez sélectionner quelle interface de la LCL vous voulez utiliser (ie quel jeu de composants), et vous pouvez sélectionner quel système d'exploitation cible et spécifier les différents répertoires de destination.

Sous-menu Configuration

SousMenuConfigurationFr.png
  • Options... :
    • ... de l'Environnement :
      • Fichier - autorise l'utilisateur à spécifier le chemin du répertoire par défaut, compiler, définir le répertoire des sources et le répertoire temporaire pour la compilation ;
      • Bureau - options de Langue, comportement de l'enregistrement automatique, l'enregistrement des paramètres de bureau, les conseils pour les principaux boutons rapides (Ouvrir, Enregistrer,...) ;
      • Fenêtres - autorise la spécification de la taille et le comportement des différentes fenêtres ;
      • Editeur de fiches - pour choisir les couleurs et différentes options de l'éditeur de fiches ;
      • Inspecteur d'objets - pour choisir la couleur et la hauteur des éléments, et différentes options ;
      • Sauvegarde - spécifie de quelle manière la sauvegarde doit fonctionner au moment de l'édition ;
      • Nommage - spécifie quelles extensions à utiliser pour les noms des fichiers Pascal ('.pp' or '.pas'). Il est possible de paramétrer les actions à effectuer pour les fichiers litigieux ainsi que la casse des fichiers enregistrés ;
      • Editeur FPDoc - permet d'indiquer les chemins pour FPDoc.
    • ... de l'Editeur :
      • Général - détermines les comportements comme l'indentation automatique, la mise en évidence des parenthèses, l'affichage des conseils de défilement, la mise en évidence de la syntaxe, l'édition par glisser-déposer, la taille du bloc d'indentation et de tabulation, le nombre d'annuler possibles, etc. ;
      • Affichage - options permettant d'afficher ou non les numéros de ligne, la présence de gouttières, la taille et le type de la police de l'éditeur. Contient un panneau d'aperçu montrant les différentes syntaxes et leur apparence dans l'éditeur, directives, ponctuation, erreurs et les points d'arrêts ;
      • Assignation des touches - options pour sélectionner les raccourcis clavier de Lazarus, Turbo Pascal ou ses propres raccourcis clavier ;
      • Souris - options de comportement de la souris et de son pointeur ;
      • Couleurs - permet de paramétrer la coloration syntaxique de l'éditeur, pour un certain nombre de langages comme : Pascal objet, C++, Perl, HTML, XML et scripts. Propose un aperçu pour chaque langage sélectionné ;
      • Audit de code - permet la sélection des fonctionnalités comme le complément d'identifiant, les outils des symboles ToolTip, les paramètres du code, et l'évaluation d'expression ToolTip ;
      • Repliage de code - options de pliage de code.
    • ... des Outils de code :
      • Général - permet d'entrer un chemin de recherche de fichiers source, spécification de la méthode de saut ;
      • Complétion de classe - options de complétion des classes,et de leurs méthodes et propriétés ;
      • Création de code - détermine comment le code ajouté et créé après l'activation de certaines fonctionnalités ;
      • Mots - détermine la casse des mots clefs Pascal lorsqu'ils sont intégrés au code ;
      • Coupure de ligne - détermine les règles selon lesquelles les lignes se coupent (avant ou après la ponctuation, après des mots clefs etc.) ;
      • Espace - indique de quel manière un espace peut être ajouté automatiquement avant ou après certaines syntaxes comme des mots clefs ou des marques de ponctuation ;
      • Compléter l'identifiant - options de complétion des identifiants.
    • ... de l'Explorateur de code :
      • Mise à jour - options de rafraîchissement ;
      • Catégories - catégories à explorer ;
      • Code Observer - paramètres d'analyse du code.
    • ... du Debugger :
      • Général - choisi le débogueur : none, GNU debugger (gdb) ou gdb through SSH, spécifie le chemin de recherches pour les débogueurs, et les options spécifique au débogueur choisi ;
      • Journal des événements - spécifie comment nettoyer le log au au démarrage, et quels messages doivent être affichés ;
      • Exceptions de langue - sélectionne quels exceptions peuvent être ignorées ;
      • Exceptions du système d'exploitation - autorise l'utilisateur à ajouter certains signaux à appliquer au système d'exploitation actuel (pas encore implémenté).
    • ... de l'Aide : permet de paramétrer le chemin, le visualiseur et les bases de données de l'aide.


  • Modèles de code : affiche une boîte de dialogue permettant d'indiquer le fichier contenant les modèles de code, de modifier les modèles existants ou d'en ajouter. Permet également d'autoriser et d'insérer des macros, et de paramétrer l'auto-complétion.


  • Editeur des directives des outils de code : vous pouvez voir ici toutes les définitions internes que l'EDI utilise pour analyser les sources. Vous verrez toutes les définitions, unités, sources, chemins d'inclusion pour tous les répertoires. Cela commence avec le paramétrage courant de FPC, les définitions du répertoire de sources de Lazarus, tous les répertoires de paquets et les répertoires de projets.

La plupart des ses paramètres son générés automatiquement et sont en lecture seule.


  • Reparcourir le répertoire des sources FPC : déclenche une nouvelle consultation des répertoires. Lazarus utilise les sources de FPC pour générer des événements corrects tout en recherchant les déclarations. Si quelqu'un change le répertoire dans les options d'environnement, ce répertoire est reparcouru, pour être certain que Lazarus utilise la version stockée à cet endroit. Mais si ce répertoire a changé sans que Lazarus en soit averti, alors vous aurez quelques erreurs au moment de travailler sur une fiche ou en faisant Chercher la déclaration. Si vous obtenez une telle erreur vous pouvez faire deux choses :
    1. contrôlez le paramètre du répertoire de sources FPC dans les Options de l'Environnement ;
    2. Reparcourir le répertoire des sources FPC.

Sous-menu Fenêtres

SousMenuFenetreFr.png

Contient une liste des fichiers actuellement ouverts et des fenêtres disponibles comme Editeur de sources Lazarus, Inspecteur d'objets et Messages. Cliquer sur le nom d'une des fenêtres la placera au premier plan et lui donnera le focus.

Sous-menu Aide

  • Aide en ligne : ouvre le navigateur internet et affiche un guépard en train de courir et quelques liens vers les site Lazarus, FreePascal et le Wiki
  • Configurer l'aide : ouvre une fenêtre avec des options pour sélectionner les Visualiseurs et les bases de données à partir desquelles lire les informations d'Aide. Cette option autorise l'utilisateur à spécifier où se trouve une section de la documentation en ligne du site Lazarus-CCR, ou d'un quelconque autre site contenant des documents, ou une documentation stockée localement (cela pourra éventuellement être l'option par défaut, lorsque le système d'Aide sera complètement développé).

Si vous placez le curseur de l'éditeur au dessus d'un mot clef de la FeePascal Components Library (FCL) ou de la RunTime Library (RTL), mais pas de la Lazarus Components Library (LCL) et appuyez sur <<F1>> vous serez emmené vers la définition appropriée sur le site Internet. CETTE SECTION EST TOUJOURS EN COURS D'ELABORATION

  • A propos de Lazarus : affiche une fenêtre avec quelques informations sur Lazarus.

À terme, cela deviendra un service complet d'aide en ligne, avec des informations sur la syntaxe Pascal, l'utilisation de l'EDI, la modification ou la création de composants, et des astuces sur la façon d'exécuter certaines tâches. Cette partie de la section de la Documentation (celle que vous êtes en train de lire) représente le début de ce processus. Nous avons besoin des contributions de quiconque se sent capable d'en fournir : le Wiki est très facile à modifier.