Main menu/nl

From Free Pascal wiki
Jump to navigationJump to search

Deutsch (de) English (en) español (es) suomi (fi) français (fr) magyar (hu) italiano (it) 日本語 (ja) македонски (mk) Nederlands (nl) português (pt) русский (ru) slovenčina (sk) shqip (sq) 中文(中国大陆)‎ (zh_CN) 中文(台灣)‎ (zh_TW)

Het Hoofdmenu

Het hoofdmenu bevat de volgende keuzes: File Edit Search View Project Run Components Tools Environment Windows Help

De keuzes kunnen op de bekende manieren geselecteerd worden, door een klik met de muis of door het gebruik van de Alt toets in combinatie met de onderstreepte latter. De F10 toets zorgt er ook voor dat het menu actief wordt.

Het File menu

  • New Unit: Maakt een nieuwe Unit file aan zonder form (Pascal Source).
  • New Form: Maakt een nieuw Form: Zowel het zichtbare form als de bijbehorende Pascal source file.
  • New ...: Laat een pop-up scherm zien keuzes van verschillende nieuw te maken documenten.
  • Open: Opent een "Open bestand" dialoog om een bestaand document te openen.
  • Revert: Maakt alle wijzigingen ongedaan en keert terug naar de laatst opgeslagen versie van het bestand.
  • Open recent: Geeft uit keuze uit de laatst geopende bestanden.
  • Save: Slaat het huidige bestand op onder de bekende naam. Als er nog geen naam bekend is, zal het systeem hier om vragen. (net als 'Save As').
  • Save As: Stelt je in staat om de file onder een andere naam en of in een andere directory op te slaan.
  • Close: Sluit de huidige file, en vraagt indien nodig of de wijzigingen moeten worden opgeslagen.
  • Close all editor files: Sluit alle files in de editor en vraagt eventueel of de wijzigingen moeten worden opgeslagen.
  • Clean directory: Toont een dialoog waarin een serie van wijzigbare filters getoond worden voor het verwijderen van bepaalde bestanden in de huidige directory. Dit is handig voor het verwijderen van backup files en overblijfselen van oude Delphi projecten.
  • Quit: Sluit Lazarus af, eventueel na het vragen of wijzigingen moeten worden opgeslagen.

Het Editmenu

  • Undo: Draait de laatste actie terug.
  • Redo: Voert de laatste actie die was terug gedraaid opnieuw uit.
  • Cut: Verwijdert de geselecteerde tekst en plaatst dit op het Clipboard.
  • Copy: Plaatst een kopie van de geselecteerde tekst op het Clipboard.
  • Paste: Plaatst de inhoud van het Clipboard op de cursor positie. Als er tekst is geselecteerd wordt deze tekst vervangen door de tekst op het clipboard.
  • Indent selection: Laat de geselecteerde tekst naar een aantal posities inspringen. Het aantal posities kun je instellen via Environment -> Editor options -> General -> Block indent. Dit is een handig tooltje bij het formateren van je broncode.
  • Unindent selection: Het tegengestelde van de vorige menukeuze. Het verlaagt het aantal positie dat de geselecteerde tekst is ingesprongen.
  • Enclose selection: Laat een pop-up schermpje zien waarin een keuze gemaakt kan worden voor een bepaalde blok structuur, zoals bijv.begin ... end; try ... except; en nog een aantal. De geselecteerde tekst wordt dan in de gekozen structuur opgenomen.
  • Uppercase selection: Zet de geselecteerde tekst om naar uppercase.
  • Lowercase selection: Zet de geselecteerde tekst om naar lowercase.
  • Tabs to spaces in selection: Zet tabs om naar spatie in de geselecteerde tekst. Het aantal spaties wordt bepaald in Environment -> Editor options -> General -> Tab widths.
  • Break lines in selection: Als er regels in de geselecteerde tekst langer zijn dan in Environment -> Editor options -> Display -> Right Margin is ingesteld, worden deze regels afgebroken op een woord grens en vervolgd op de volgende regel.
  • Comment selection: Maakt van de geseleteerde tekst commentaar door iedere regel te laten beginnen met //.
  • Uncomment selection: Verwijdert de commentaar markeringen.
  • Sort selection: Sorteert lijnen (of woorden of paragrafen) alphabetisch, hierbij zijn opties voor oplopend of aflopend, hoofdlettergevoelig of niet.
  • Select: Hierbij kunnen bepaalde blokken tekst geselecteerd worden. Mogelijkheden hierbij zijn bijvoorbeeld select all, select to brace, select paragraph or line etc.
  • Insert from character map: Maakt het mogelijk om bijvoorbeeld diakritisch tekens in te voeren, door ze in een popup schermpje te kiezen.
  • Insert text: Geeft een popup menu voor het invoeren van bepaalde standaard teksten zoals CVS sleutelwoorden (Author, Date, Header etc) of GPL notitie, de gebruikersnaam of de huidige datum en tijd.
  • Complete code: Complementeert de code waar de cursor staat. Dit is redelijk intelligent en kan je een hoop tijd besparen. Het kan bijvoorbeeld classes complementeren door het toevoeging van "private" variabelen, Getters en Setters en het toevoegen van method bodies. Zie ook Lazarus IDE Tools.
  • Extract procedure: Van de geselecteerde tekst wordt een nieuwe procedure gemaakt.

Het Searchmenu

  • Find: Net als bij alle andere tekstverwerkers, krijg je een popup te zien waarin je zoekcriteria kunt invullen.
  • Find Next, Find previous: Voert de vorige zoekaktie opnieuw uit in de aangegeven richting. (Next zoekt naar het eind, Previous naar het bein.)
  • Find in files: Het zelfde als Find maar nu kun je ook laten zoeken in alle files van het project of alle bestanden in een directorie.
  • Replace: Vervangt een bepaalde tekst door een andere.
  • Incremental find: Een zoek functionaliteit die werkt terwijl je de zoekstring invult. Bijvoorbeeld: Nadat je "Incremental Find" hebt gekozen en je typt een "l" zal de eerste "l" worden gehighlight. Typ je daarna een "a" dan zal de eerste "la" getoond worden, etc.
  • Goto line: Hiermee gaat de cursor naar de aangegeven regel in de file.
  • Jump back: Gaat terug naar het vorige Bookmark. Dit Bookmark moet eerst met Add jump point to history gezet zijn. Dit werkt door alle in de editor geopende bestanden.
  • Jump forward: Ga naar het volgende Bookmark.
  • Add jump point to history: Plaats een bookmark of "spring"punt.
  • View Jump-History: Dit moet een lijst van bookmarks laten zien. Maar is helaas Not implemented yet.
  • Find other end of code block: Als de cursor bij een begin staat, springt deze naar de bijbehorende end of vice versa.
  • Find code block start: Springt naar het begin van de procedure of functie.
  • Find Declaration at cursor: Toont de plaats waar een identifier is gedeclareerd. Dit kan in dezelfde file zijn, maar ook in een andere file. Als deze file nog niet in de editor geopend is, zal dat automatisch gebeuren. Als de cursor bijvoorbeeld in TButton staat, zal de file buttons.pp geopend worden. (Dezelfde functionaliteit krijg je met een ctrl + muisklik.
  • Open filename at cursor: Opent de file waarvan de naam onder de cursor staat. Kun je bijvoorbeeld gebruiken voor het zoeken van Include files.
  • Goto include directive: Als het actieve bestand ge-include wordt in een ander bestand, wordt dit andere bestand geopend, met de cursor op de plaats van het include directive.

Het View menu

Geeft je de controle over welk van de verschillende schermen op je desktop actief wordt.

  • Object Inspector: Standaard staat dit scherm aan de linkerkant van de desktop. Het toont de eigenschappen van het control dat op dat moment geselecteerd is. Als je dus op een component op je form klikt worden de eigenschappen (properties) daarvan in de object inspector getoond. Bovenin de object inspector zie je een boom-structuur waarin de componenten van het actieve form te zien zijn. Je kunt ook in deze boom-structuur klikken om de eigenschappen van een bepaald component te laten zien. Het onderste deel van de Object Inspector heeft twee tabs. De eerste bevat alle Properties en de tweede alle Events. Onder Properties vinden we de eigenschappen zoals name, colour, caption, font, size.Er zijn twee kolommen. In de linker kolom staat de naam van het property, in de rechter kolom wordt de toegekende waarde getoond. Ook de Events-tab kent twee kolommen. De linker kolom toont de verschillende events die het component kent en de tweede de naam van de aan dat event toegekende procedure. Als er nog geen procedure aan een event is toegekend, kun je dat doen door in het bijbehorende vakje te klikken en dan op de
    ...
    knop te klikken. Je komt dan in de code-editor terecht en is er een basis declaratie voor de procedure gemaakt.
  • Source Editor: In dit scherm kun je de broncode bewerken. Het werkt in principe net als iedere andere tekstverwerker. De muis kan de cursor overal in de tekst plaatsen en met het links klikken en bewegen van de muis kun je tekst selecteren. Een rechter muisklik geeft een popup-menu. Het popup menu ziet er echter anders uit dan het normale Knip, Kopie en Plak menu dat je gewend bent. Je ziet echter wel opties als Find Declaration en Open File at Cursor. Aan de bovenkant van de source editor zie je een aantal tabs, een voor iedere file die je geopend hebt. Het klikken op zo'n tab maakt de bijbehorende file de actieve file. Je kunt natuurlijk tussen de verschillende files ook knippen en plakken. Je zult zien dat de editor "Syntax highlighting" kent, met instelbare kleuren voor "keywords", commentaar, strings etc etc. Het niveau van inspringen wordt net zolang vastgehouden totdat je dit zelf wijzigt. Het gedrag en uiterlijk van de Source Editor kun je instellen via Environment -> Editor options. Je ziet dan een dialoog met verschillende tabs waarop je verschillende instellingen kunt doen.
  • Code Explorer: Een handig scherm waarmee je snel naar bepaalde punten in je code kunt springen. Dit scherm wordt standaard aan de rechterkant van je desktop getoond. Dit scherm toont in een boomstructuur de code van het in de source-editor actieve bestand. Als het geopend wordt toont het alleen de naam van de unit en takken voor de interface en implementatie secties van de file, maar als je klikt op
    +
    knop aan de linkerkant van een tak, zal deze uitklappen. Hierdoor worden meer details getoond totdat iedere individueele constante, variabele, procedure en functie decleratie worden getoond. Als je de file in de editor wijzigt moet je op refresh klikken om de code explorer de nieuwe stand van zaken te laten weergeven.
  • Units...: Opent een popupvenster met een lijst van alle bestanden in het project. Als je op een bestandsnaam klikt wordt deze geopend en getoond in de Source-editor. Je kunt ook meerdere bestande selecteren, dan worden alle gekozen bestanden in de source editor geopend. Via Project -> Project Inspector option kun je ook een lijst krijgen, maar dit zijn alleen source bestanden.
  • Forms...: Hiermee wordt een pop-upvenster getoond met alle forms in het project. Klik op een form en het wordt actief gemaakt, zodat je het kunt wijzigingen.
  • View Unit Dependencies: Laat een scherm zien met een boomstructuur die per unit de afhankelijkheden van die unit laat zien. The meeste bestanden die als afhankelijkheid worden getoond zullen zelf ook weer een
    +
    box hebben, waardoor je steeds dieper meer afhankelijkheden ziet, vaak in recursie.
  • Toggle form / unit view F12: Schakelt heen en weer tussen de source-editor en het formulier dat bij de bewerkte unit hoort. Als de focus op de Source Editor ligt, kun je de source-code aanpassen. Heeft het formulier ontwerpfocus, dan kun je daar wijzigingen in aanbrengen. De makkelijkste manier om te schakelik tussen Source Editor en Form is de F12 toets.
  • Messages: Laat het Messages-scherm zien. In dit scherm worden de compiler berichten getoond.
  • Search Results: Een scherm dat de resultaten toont van het zoeken in bestanden.
  • Debug windows: Hiermee wordt een submenu getoond waarin je de verschillende debug-schermen kunt oproepen. Hieronder wordt de debugger beschreven.

Het Project menu

  • New Project: Maakt een nieuw project. Er verschijnt eerst een dialog scherm waarin de keuze voor het type project gemaakt moet worden.
  • New Project from file: Er wordt een open bestand dialoog getoond waarmee naar een bestand ge"browsed" kan worden waarvan een nieuw project gemaakt wordt.
  • Open Project Er wordt een open bestand dialoog getoond waarmee je een Lazarus Project Information (.lpi) file kunt aangeven, zodat er een bestaand project geopend kan worden.
  • Open Recent Project: Geeft een pop-up menu met de laatst geopende projecten.
  • Save Project: Vergelijkbaar met File -> Save all: alle bestanden van het huidige project worden opgeslagen. Als er nog geen filenaam bekend is van een file dan wordt hier omgevraagd.
  • Save Project As...: Vraagt om een naam voor het project. Bij een nieuw project wordt de default Project1.lpi aangeboden. Je kunt niet dezelfde naam gebruiken voor het project als voor een bestand / unit in dit project. (Zie ook below).
  • Publish Project: Maakt een kopie van alle tot het project behorende bestanden. Ideaal voor het versturen van de source van je project naar een collega. In een project directory staan een aantal bestanden die niet noodakelijk zijn. De .lpi file bijvoorbeeld bevat informatie over de sessie, zoals bookmarks, de plaats van de cursor etc. Tevens staan er een aantal .ppu, .o bestanden de executable in de directory. Zie ook Lazarus IDE Tools
  • Project Inspector: Opent een scherm met een boomstructuur waarin de bestanden van het huidige project getoond worden. Je kunt hier bestanden toevoegen, verwijderen en openen en bepaalde opties voor het project wijzigen.
  • Project Options...: Opent een dialoog scherm met een aantal tabs om bepaalde opties te zetten voor de Applicatie (Titel, Doelbestandsnaam), Forms (hier kun je aangeven welk formulier het "mainform" is en welke forms automatisch gemaakt moeten worden) and Info (waarin ondermeer aangegeven kan worden of de editor informatie, zoals cursorpositie, alleen voor de project files moet worden opgeslagen of voor alle geopende bestanden).
  • Compiler options ...: Opent een dialoog scherm met een aantal tabs om de compiler te kunnen configureren. Tabs zijn ondermeer Paths, om zoekpaden naar units, include-bestanden en dergelijke aan te geven; Parsing voor het aangeven van een aantal "Parse" opties; Code om optimalisatie opties te kiezen; Linking met keuzes met betrekking tot debugging, statisch of dynamisch geladen libraries, en of deze opties doorgegeven moeten worden aan de linker; Messages definieert de meldingen die de compiler genereerd; Other hier kun je aangeven dat er een andere cfg-file gebruyikt moet worden, dan de standaard fpc.cfg; Inherited laat zien welke opties worden overgenomen van andere units; Compilation hier kunnen opdrachten opgegeven worden die voor of na de compilatie uitgevoerd moeten worden.
  • Add editor file to Project: Voegt het bestand dat in de editor actief is, aan het projet toe.
  • Remove from Project: Toont een lijst met bestanden die deel uitmaken van het project zodat je aan kunt geven welk bestand verwijderd kan worden.
  • View Source: Laat het "hoofd"bestand van het programma zien. Dit is meestal het project bestand (.lpr).
  • View ToDo List: Laat een lijst met "ToDo" dingen zien. de lijst wordt opgebouwd uit de commentaar regels die met //TODO beginnen. Je kunt zelf de items nummere door achter //TODO een volgnummer te zetten. Let op: Als de //TODO regel met een spatie begint, wordt deze niet getoond. Je moet na het oproepen van dit scherm eerst op de refresh pijl klikken. Alleen de TODO-items die ook zijn opgeslagen worden getoond.

Het Run menu

  • Build: Hiermee worden alle bestanden in het project die sinds de laatste compilatie zijn gewijzigd gecompileerd.
  • Build all: Hiermee worden alle bestanden in het project gecopileerd ook degene die niet gewijzigd zijn.
  • Abort build: Onderbreekt het compileren - Kan handig zijn als je je realiseert iets stoms gedaan te hebben of als het compileren te lang duurt en er dus echt iets mis moet zijn.
  • Run: Dit is de manier om de compilatie te starten en als dat goed gegaan is het programma te starten. Lazarus zal eerst de bestanden opslaan, dan het projet compileren en linken voordat het programma wordt uitgevoerd.
  • Pause: Pauzeert de uitvoering van het programma. Hierdoor kan eventuele uitvoer gecontroleerd worden. Het pauzeren wordt opgeheven door weer op Run te klikken.
  • Step into: Wordt gebruikt in samenhang met de debugger, hiermee wordt het programma statement voor statement uitgevoerd. Is een bepaald statement een procedure of wordt er een functie in aangeroepen dan zal de debugger deze functie of procedure ook statement voor statement uitvoeren.
  • Step over: Voert een bepaald statement in een keer uit. Als er dus een functie of procedure in het statement staat wordt die als "een stap" uitgevoerd.
  • Run to cursor: Het programma wordt uitgevoerd tot het de regel code bereikt waar de cursor staat. Op dat moment stop het en kun je met Step into, Step over of Run het programma verder uit voeren.
  • Stop: Stopt de uitvoering van het programma. Het programma kan dan niet vervolgt worden, maar zal bij een Run weer opnieuw gecompileerd worden en vanaf begin af worden uitgevoerd.
  • Run Parameters: Laat een popup scherm zien met een tweetal tabs. Op de eerste tab kun je parameters opgeven die aan het programma worden meegegeven. Onder Linux kun je ook opgeven op welk display (scherm en desktop) het programma getoond moet worden. Op de tweede tab kunnen de systeem variabelen bekeken worden en eventueel voor het programma overschreven.
Een belangrijk gebruik hiervan is het activeren van een terminal scherm waarin de consol invoer en uitvoer kan worden getoond. Als je een terminal programma (console-mode) ontwikkeld, dan moet je het vinkje zetten bij "Use launching application". Een eerste keer hun je een foutmelding krijgen als:
"xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied".  
Dit betekent dat je de rechten voor dit bestand even goed moet zetten (bijv. met chmod +x filename). Hierna zal er als het programma gestart wordt, een terminal scherm openen waarin alle invoer en uitvoer (readln, writeln) getoond zal worden.
Nadat het programma is afgesloten verschijnt in de schermpje een "Press enter" bericht, zodat je na afloop van het programma nog de tijd hebt om de in- en uitvoer na te lezen.
Zie ook de lessen voor Console Mode Pascal-programmeren.
  • Reset debugger: Hiermee wordt de debugger in de originele stand terug gebracht. Alle breakpoints en waarden van variabelen worden weggegooid.
  • Build file: Compileerd het bestand dat op dat moment actief is in de source editor.
  • Run file: Compileert, linkt en voert alleen het huidige actieve bestand uit.
  • Configure Build + Run File: Hiermee wordt een popup scherm getoond waarin bepaalde opties gezet kunnen worden. Daarna wordt de betreffende file gecompileerd, gelinkt en uitgevoerd.
Deze laatste drie opties maken het je dus mogelijk om een klein testprojectje te laden en dat uit te voeren. Open het de project file (.lpr) dan wel als "normal source" door op "Cancel" te klikken als Lazarus deze vraag toont.

Het Components-menu

  • Open Package: Opent een lijst met de geinstalleerde packages, met de mogelijkheid om een of meer packages te openen.
  • Open Package File: Toont een Open bestand dialoog waarmee een package geopende kan worden.
  • Open Recent Package: Geeft een submenu met onlangs geopende packages.
  • Add Active Unit to Package: Voegt het bestand dat in de editor actoef is toe aan een package.
  • Package Graph: Toont een boomstructuur die de relaties tussen de geínstalleerd packages laat zien.

Het Tools-menu

  • Configure custom tools: Hiermee kunnen externe tools aan het menu toegevoegd worden. Je zou bijvoorbeeld een programma om bitmaps te wijzigen aan het Tools-menu kunnen toevoegen.
  • Quick syntax check: Voert een syntax check uit. Er wordt dus alleen gekeken of er geen fouten in de sources zitten, zonder dat het programma wordt gecompileerd. Een syntax check gaat sneller dan het compileren en linken van je programma.
  • Guess unclosed block: Laat zien welk begin-statement geen end-statement heeft door er in de broncode naar toe te springen.
  • guess misplaced IFDEF/ENDIF: Laat zien of er een IFDEF directive is zonder bij behorend ENDIF directive.
  • Make resource string: Zet de geselecteerde string in de resourcestring van het project. Het voordeel is dat deze string vervangen kunnen worden zonder dat het hele programma opnieuw gecompileerd moet worden.
  • Diff: Vergelijkt twee bestanden and laat de verschillen zien. Er zijn een aantal opties, bijv. spaties aan het begin of eind van een regel, verschillen in regeleinden.
  • Check LFM file in editor: Laat de form definitie in tekstvorm in de editor zien. (Nog niet geïmplementeerd.)
  • Convert Delphi unit to Lazarus unit: Importeert en converteert een Delphi-unit naar Lazarus, dit is een hulp middeltje om je Delphi projecten over te zetten. Een aantal benodigde wijzigingen worden dan automatisch in de source aangebracht. Zie ook Lazarus For Delphi Users en Code Conversion Guide.
  • Convert DFM file to LFM: Dit converteert de Delphi-form bestanden (.dfm) naar het Lazarus equivalent. Zie ook Lazarus For Delphi Users en Code Conversion Guide.
  • Build Lazarus: Zorgt er voor dat Lazarus opnieuw gecompileerd wordt. Dit kun je gebruiken na het downloaden van een nieuwe CVS versie of nadat je componenten hebt geïnstalleerd. (Doe het eens en zie wat er gebeurt in het Messages Scherm!).
  • Configure "Build Lazarus": Hiermee wordt bepaald hoe Lazarus gebuild wordt. Je kunt bijvoorbeeld slechts een bepaald onderdeel opnieuw laten "builden" of je kunt Lazarus met een andere widget set compileren. Je kunt ook een andere doel (target) directory opgeven.

Het Environment-menu

  • Environment options: Toont een dialog scherm met tabs voor
    • Files - hier kan de standaard directory, compiler, sourcedirectory and temporary directory voor de compilatie ingesteld worden;
    • Desktop - bevat opties voor de taal, het automatisch opslaan, het opslaan van de desktop, hints van de component pallet en de speedbuttons;
    • Windows, hiermee kan aangegeven worden waar de verschillende schermen geplaatst moeten worden;
    • Form Editor - het instellen van de gebruikte kleuren in de form editor;
    • Object Inspector - het instellen van de kleur en itemhoogte van de Object Inspector;
    • Backup - het instellen van hoe de veiligheids kopien van de bewerkte bestanden worden gemaakt;
    • Naming - het specificeren van de gebruikte extensie voor de pascal files ('.pp' or '.pas'), of alle bestandnamen worden omgezet in kleine letters en of er automatisch hernoemd of verwijderd moet worden.
  • Editor options: Toont een dialoog scherm met tabs voor
    • General - het instellen van zaken als automatisch inspringen, het "highlighten" van haakjes, drag-drop acties, scrollen, het "highlighten" van de syntax, het laten zien van hints, grootte van het inspringen van tekstblokken en tabs, aantal malen "Undo";
    • Display - het instellen van het tonen van regelnummers, de aanwezigheid van "gutters", de grootte en het type van het font in de editor. Het bevat een preview panel waarin de verschillende ingestelde kleuren getoond worden;
    • Key Mappings - de keuze tusen de Lazarus of Turbo Pascal schema of het volledig naar eigen wens instellen van;
    • Color - de keuze van een kleuren schema voor een aantal talen zoals: Object Pascal, C++, Perl, HTML, XML and shell scripts. Ook hier een preview panel die toont hoe de kleuren ingesteld zijn;
    • Code Tools - het instellen van het completeren van Identifiers, tooltips, template file names en aanvullingen op de code completion.
  • Debugger Options: Toont een dialoog scherm met tabs voor
    • General - het kiezen van de debugger: geen, GNU debugger (gdb) of gdb via SSH, het opgeven van het zoek pad voor debuggers en het instellen opties voor de gekozen debugger;
    • Event log - instellen of the log wordt gewist voor het uitvoeren van het programma en welke berichten getoond moeten worden;
    • Language Exceptions - het aangeven welke fouten genegeerd kunnen worden;
    • OS Exceptions - het instellen van OS-specifieke berichten (signals) (nog niet geïmplementeerd).
  • Code Tool Options: Toont een dialoog scherm met tabs voor
    • General - het toevoegen van additionele zoek paden en het instellen van een aantal opties voor "Method Jumping";
    • Code Creation - het instellen van een aantal opties voor het automatisch aanmaken van code;
    • Words - het instellen van hoe Pascal keywords worden geschreven, in Hoofdletters of kleine letters, de eerste letter als hoofdletter en de rest klein;
    • Line Splitting - het bepalen van hoe de source regels afgebroken moeten worden;
    • Space - het bepalen of er achter bepaalde syntax onderdelen automaitsch een spatie geplaatst moet worden.
  • Code Tools Defines Editor: Misschien kan iemand anders dit onderdeel uitleggen?


  • Re-scan FPC Source directory Dit zorgt ervoor dat de FPC source directory opnieuw doorzocht wordt. Lazarus gebruikt de fpc sources om de juiste event handlers aan te maken en als er naar declaraties gezocht wordt. Als met behulp van de environment options deze directory gewijzigd wordt, zal Lazarus deze automatisch controleren. Maar als dit buiten Lazarus om is gebeurt of je krijgt foutmeldingen als je "Find Declaration" gebruikt dan moet je twee dingen doen:
  1. Controleren of het pad van de fpc source directory nog goed staat in de environment opties.
  2. Re-scan FPC source directory.

The Windows sub-menu

Geeft een lijst van geopende schermen zoals de Source Editor, Object Inspector en Project Inspector. Het klikken op de naam van een van deze schermen brengt dit scherm naar de voorgrond.

Het Help menu

Op dit moment zijn er drie keuzes:

  • Online Help opent in de in Configure Help opgegeven browser een pagina van de Lazarus documentatie.
  • Configure Help Opent een dialoog scherm met de mogelijkheid om het pad naar de browser in te voeren en de URL's naar de lazarus documentatie. Uiteindelijk zal dit wijzen naar een locale directory als het help-systeem volledig is geïmplementeerd.
  • About Lazarus Laat het bekende About-scherm zien..

Het is de bedoeling dat er uiteindelijk een volledige Help zal zijn, met informatie over de Pascal syntax, het gebruik van de IDE etc etc. Het huidige document zal daar een onderdeel van zijn, dus: We need contributions from anyone who feels able to provide them: the WiKi is very easy to edit. oftewel: We kunnen de hulp van iedereen gebruiken die denkt te kunnen helpen: de WiKi kun je eenvoudig aanpassen!